summaryrefslogtreecommitdiffstats
path: root/kmymoney2/widgets/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kmymoney2/widgets/Makefile.am')
-rw-r--r--kmymoney2/widgets/Makefile.am15
1 files changed, 10 insertions, 5 deletions
diff --git a/kmymoney2/widgets/Makefile.am b/kmymoney2/widgets/Makefile.am
index d6c91e9..e27f2b0 100644
--- a/kmymoney2/widgets/Makefile.am
+++ b/kmymoney2/widgets/Makefile.am
@@ -23,18 +23,18 @@ EXTRA_DIST = kmymoney.widgets kmymoneygpgconfigdecl.ui kmymoneyonlinequoteconfig
# but the file is included in the tar-ball. See also the separate target
# $(top_builddir)/kmymoney/xxx.h further down and the BUILT_SOURCES target.
instdir=$(includedir)/kmymoney
-inst_HEADERS = kmymoneydateinput.h kmymoneyedit.h kmymoneytitlelabel.h kmymoneyaccountselector.h kmymoneycategory.h kmymoneyaccounttreebase.h kmymoneyaccounttree.h kmymoneycurrencyselector.h kguiutils.h kmymoneywizard.h kmymoneyaccounttreebudget.h kmymoneyaccounttreeforecast.h kmymoneyaccountcombo.h register.h registeritem.h transaction.h scheduledtransaction.h stdtransactiondownloaded.h stdtransactionmatched.h selectedtransaction.h transactionform.h transactioneditorcontainer.h kmymoneylineedit.h kmymoneychecklistitem.h kmymoneylistviewitem.h kmymoneyforecastlistviewitem.h kmymoneyselector.h kmymoneyaccountcompletion.h kmymoneycompletion.h kmymoneycombo.h kbudgetvalues.h kaccounttemplateselector.h \
+inst_HEADERS = kmymoneydateinput.h kmymoneyedit.h kmymoneytitlelabel.h kmymoneyaccountselector.h kmymoneycategory.h kmymoneyaccounttreebase.h kmymoneyaccounttree.h kmymoneycurrencyselector.h kguiutils.h kmymoneywizard.h kmymoneyaccounttreebudget.h kmymoneyaccounttreeforecast.h kmymoneyaccountcombo.h register.h registeritem.h transaction.h scheduledtransaction.h stdtransactiondownloaded.h stdtransactionmatched.h selectedtransaction.h transactionform.h transactioneditorcontainer.h kmymoneylineedit.h kmymoneychecklistitem.h kmymoneylistviewitem.h kmymoneyforecastlistviewitem.h kmymoneyselector.h kmymoneyaccountcompletion.h kmymoneycompletion.h kmymoneycombo.h kbudgetvalues.h kbudgetvaluesdecl.h kaccounttemplateselector.h \
transactionsortoption.h
# include the widgets that are only available to KMyMoney here
-noinst_HEADERS = kbudgetvalues.h tdelistviewsearchline.h kmymoneyaccounttree.h \
- kmymoneyaccounttreebudget.h kmymoneyaccounttreeforecast.h kmymoneybriefschedule.h kmymoneycalculator.h kmymoneycalendar.h \
- kmymoneycategory.h kmymoneydatetbl.h kmymoneygpgconfig.h kmymoneyonlinequoteconfig.h \
+noinst_HEADERS = tdelistviewsearchline.h \
+ kmymoneybriefschedule.h kmymoneycalculator.h kmymoneycalendar.h \
+ kmymoneydatetbl.h kmymoneygpgconfig.h kmymoneyonlinequoteconfig.h \
kmymoneypriceview.h kmymoneyscheduledcalendar.h kmymoneyscheduleddatetbl.h \
kmymoneywizard_p.h registersearchline.h
# make sure, automatically generated files exist
-BUILT_SOURCES = settings $(top_builddir)/kmymoney/transactionsortoption.h mocs dialogs transactionsortoption.cpp kbudgetvaluesdecl.h kaccounttemplateselectordecl.h libkmymoney.la kmmwidgets.cpp
+BUILT_SOURCES = settings $(top_builddir)/kmymoney/transactionsortoption.h mocs dialogs transactionsortoption.cpp $(top_builddir)/kmymoney/kbudgetvaluesdecl.h kaccounttemplateselectordecl.h libkmymoney.la kmmwidgets.cpp
CLEANFILES = kmmwidgets.cpp
@@ -50,6 +50,10 @@ $(top_builddir)/kmymoney/transactionsortoption.h: transactionsortoption.h
if test -h $@; then rm $@; fi
ln -s `pwd`/transactionsortoption.h $@
+$(top_builddir)/kmymoney/kbudgetvaluesdecl.h: kbudgetvaluesdecl.h
+ if test -h $@; then rm $@; fi
+ ln -s `pwd`/kbudgetvaluesdecl.h $@
+
PICS_DIR=kmymoney2/pics
libkmymoney_la_SOURCES = kmmwidgets.cpp ../kmymoneysettings.cpp kmymoneycompletion.cpp kmymoneyaccountcombo.cpp kmymoneyaccountcompletion.cpp kmymoneycurrencyselector.cpp kmymoneyaccountselector.cpp kmymoneydatetbl.cpp kmymoneycalculator.cpp kmymoneycategory.cpp kmymoneycombo.cpp kmymoneylineedit.cpp kmymoneyedit.cpp kmymoneydateinput.cpp kmymoneyaccounttree.cpp kmymoneytitlelabel.cpp kguiutils.cpp kmymoneyaccounttreebase.cpp kmymoneyaccounttreebudget.cpp kmymoneyaccounttreeforecast.cpp register.cpp registeritem.cpp transaction.cpp scheduledtransaction.cpp stdtransactiondownloaded.cpp stdtransactionmatched.cpp transactionform.cpp kmymoneychecklistitem.cpp kmymoneylistviewitem.cpp kmymoneyselector.cpp transactionsortoption.cpp kbudgetvalues.cpp kbudgetvaluesdecl.cpp kaccounttemplateselector.cpp kaccounttemplateselectordecl.cpp
@@ -88,6 +92,7 @@ endif
dist-hook:
-rm -rf $(distdir)/transactionsortoption.h
-rm -rf $(distdir)/transactionsortoption.cpp
+ -rm -rf $(distdir)/kbudgetvaluesdecl.h
-rm -rf $(distdir)/kmmwidgets.cpp
messages: rc.cpp