summaryrefslogtreecommitdiffstats
path: root/src/kcm/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/kcm/Makefile.am')
-rw-r--r--src/kcm/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/kcm/Makefile.am b/src/kcm/Makefile.am
new file mode 100644
index 0000000..15440a0
--- /dev/null
+++ b/src/kcm/Makefile.am
@@ -0,0 +1,28 @@
+## Makefile.am for kcm_knemo
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kcm_knemo.pot
+
+# this is the program that gets installed. it's name is used for all
+# of the other Makefile.am variables
+kde_module_LTLIBRARIES = kcm_knemo.la
+
+# set the include path for X, qt and KDE
+INCLUDES = -I$(srcdir)/../common -I$(srcdir)/../knemod/backends $(all_includes)
+
+# the library search path.
+kcm_knemo_la_LDFLAGS = -module -avoid-version $(all_libraries)
+
+# the libraries to link against.
+kcm_knemo_la_LIBADD = $(LIB_KDEUI)
+
+# which sources should be compiled for knemo
+kcm_knemo_la_SOURCES = configdialog.cpp configdlg.ui
+
+# these are the headers for your project
+noinst_HEADERS = configdialog.h
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+xdg_apps_DATA = kcm_knemo.desktop