summaryrefslogtreecommitdiffstats
path: root/src/knemod/backends/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/knemod/backends/Makefile.am')
-rw-r--r--src/knemod/backends/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/src/knemod/backends/Makefile.am b/src/knemod/backends/Makefile.am
new file mode 100644
index 0000000..aab0fd0
--- /dev/null
+++ b/src/knemod/backends/Makefile.am
@@ -0,0 +1,22 @@
+## Makefile.am for knemo backends
+
+noinst_LTLIBRARIES = libknemo_backends.la
+
+# set the include path for X, qt and KDE
+INCLUDES = -I$(srcdir)/.. -I$(srcdir)/../../common $(all_includes)
+
+# the library search path.
+libknemo_backends_la_LDFLAGS = -module -avoid-version $(all_libraries)
+
+# the libraries to link against.
+libknemo_backends_la_LIBADD = $(LIB_KIO) $(LIB_KUTILS)
+
+# which sources should be compiled as backends
+libknemo_backends_la_SOURCES = backendbase.cpp nettoolsbackend.cpp sysbackend.cpp
+
+# the headers of the backends
+noinst_HEADERS = backendbase.h nettoolsbackend.h sysbackend.h
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+