summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 00718bc..938bb69 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -68,9 +68,19 @@ set( CMAKE_MODULE_LINKER_FLAGS "-Wl,--no-undefined" )
##### directories
add_subdirectory( src )
+add_subdirectory( icons )
+tde_conditional_add_subdirectory( BUILD_DOC doc )
tde_conditional_add_subdirectory( BUILD_TRANSLATIONS translations )
##### write configure files
configure_file( config.h.cmake config.h @ONLY )
+
+
+##### other data
+
+install(
+ FILES ${PROJECT_NAME}.desktop
+ DESTINATION ${XDG_APPS_INSTALL_DIR}
+)