summaryrefslogtreecommitdiffstats
path: root/knights/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-04-29 23:37:22 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-04-29 23:37:22 +0200
commitf35662989b7ee4c17166a4d17059d1c18eb1ad61 (patch)
tree00af3329f80d19c51b1b10c48f9c03f80b17dffe /knights/CMakeLists.txt
parent0494ba0588177e8f3b96b0ca757302735d43821e (diff)
downloadknights-f35662989b7ee4c17166a4d17059d1c18eb1ad61.tar.gz
knights-f35662989b7ee4c17166a4d17059d1c18eb1ad61.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'knights/CMakeLists.txt')
-rw-r--r--knights/CMakeLists.txt12
1 files changed, 5 insertions, 7 deletions
diff --git a/knights/CMakeLists.txt b/knights/CMakeLists.txt
index e3239d9..9e7b739 100644
--- a/knights/CMakeLists.txt
+++ b/knights/CMakeLists.txt
@@ -44,12 +44,10 @@ tde_add_executable( ${PROJECT_NAME} AUTOMOC
##### other data
-install(
- FILES pgn.desktop
- DESTINATION ${MIME_INSTALL_DIR}/application
-)
+tde_create_translated_desktop( ${PROJECT_NAME}.desktop )
-install(
- FILES ${PROJECT_NAME}.desktop
- DESTINATION ${APPS_INSTALL_DIR}/Games/Board
+tde_create_translated_desktop(
+ SOURCE pgn.desktop
+ DESTINATION ${MIME_INSTALL_DIR}/application
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/pgn-mimetype
)