summaryrefslogtreecommitdiffstats
path: root/knights/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'knights/Makefile.am')
-rw-r--r--knights/Makefile.am61
1 files changed, 0 insertions, 61 deletions
diff --git a/knights/Makefile.am b/knights/Makefile.am
deleted file mode 100644
index 32b7155..0000000
--- a/knights/Makefile.am
+++ /dev/null
@@ -1,61 +0,0 @@
-####### tdevelop will overwrite this part!!! (begin)##########
-bin_PROGRAMS = knights
-
-## INCLUDES were found outside tdevelop specific part
-
-knights_SOURCES = board_2d.cpp board_base.cpp setpagedisplay.cpp proto_xboard.cpp dlg_selectengine.cpp thinbuttons.cpp pgn.cpp io_engine.cpp dlg_challenge.cpp idmanager.cpp challenge_graph.cpp dlg_login.cpp tabgrip.cpp tabpage.cpp tab_seeklist.cpp dlg_engine.cpp setpageaudio.cpp proto_base.cpp dlg_server.cpp core.cpp match_param.cpp knightspixcache.cpp dlg_settings.cpp console.cpp match.cpp setpagegeneral.cpp splash.cpp audio.cpp main.cpp logic.cpp list_pgn.cpp challenge_graph_view.cpp accel.cpp dlg_selectemail.cpp challenge_rectangle.cpp knightstextview.cpp tabmanager.cpp command.cpp dlg_newmatch.cpp chessclock.cpp dlg_promote.cpp resource.cpp tabbox.cpp io_internet.cpp challenge_game.cpp knights.cpp tab_pgnview.cpp io_base.cpp wiz_setup.cpp setpageservers.cpp proto_uci.cpp setpageengines.cpp
-knights_LDADD = $(LIB_TQT) -lartskde -ltdeio -ltdeprint -ltdeui -ltdecore $(LIBSOCKET) -lsoundserver_idl -lkmedia2_idl -lartsflow_idl -lmcop
-
-EXTRA_DIST = setpageengines.cpp proto_uci.cpp setpageservers.cpp wiz_setup.cpp setpageengines.h io_base.cpp knightsmap.h tab_pgnview.cpp knights.cpp challenge_game.cpp io_internet.cpp challenge_graph_view.h resource.h tabbox.cpp resource.cpp dlg_promote.cpp dlg_server.h pgn.h chessclock.cpp dlg_newmatch.cpp command.h io_internet.h challenge_rectangle.h command.cpp tabmanager.cpp dlg_promote.h definitions.h knightstextview.cpp challenge_rectangle.cpp dlg_selectemail.cpp splash.h list_pgn.h accel.cpp tabmanager.h match.h setpagedisplay.h challenge_graph_view.cpp list_pgn.cpp logic.h logic.cpp knightstextview.h main.cpp audio.cpp splash.cpp setpagegeneral.cpp match.cpp io_base.h console.h idmanager.h dlg_selectemail.h console.cpp tab_pgnview.h knights.h dlg_settings.cpp core.h knightspixcache.cpp thinbuttons.h dlg_settings.h setpageservers.h tab_seeklist.h match_param.cpp core.cpp match_param.h dlg_server.cpp pgn.desktop tabbox.h accel.h io_engine.h proto_base.cpp setpageaudio.cpp dlg_engine.cpp tab_seeklist.cpp tabpage.cpp challenge_graph.h tabgrip.cpp dlg_login.cpp challenge_graph.cpp proto_uci.h setpageaudio.h proto_base.h chessclock.h setpagegeneral.h idmanager.cpp dlg_challenge.cpp io_engine.cpp audio.h dlg_newmatch.h pgn.cpp dlg_engine.h thinbuttons.cpp wiz_setup.h dlg_selectengine.cpp challenge_game.h proto_xboard.cpp knightspixcache.h setpagedisplay.cpp tabgrip.h knights.desktop dlg_login.h proto_xboard.h dlg_challenge.h dlg_selectengine.h tabpage.h board_base.cpp board_base.h board_2d.cpp board_2d.h Makefile.am
-
-install-data-local:
- $(mkinstalldirs) $(kde_mimedir)/application/
- $(INSTALL_DATA) $(srcdir)/pgn.desktop $(kde_mimedir)/application/pgn.desktop
- $(mkinstalldirs) $(kde_appsdir)/Games/Board/
- $(INSTALL_DATA) $(srcdir)/knights.desktop $(kde_appsdir)/Games/Board/knights.desktop
-
-uninstall-local:
- -rm -f $(kde_mimedir)/application/pgn.desktop
- -rm -f $(kde_appsdir)/Games/Board/knights.desktop
-
-####### tdevelop will overwrite this part!!! (end)############
-# this 10 paths are KDE specific. Use them:
-# kde_htmldir Where your docs should go to. (contains lang subdirs)
-# kde_appsdir Where your application file (.kdelnk) should go to.
-# kde_icondir Where your icon should go to.
-# kde_minidir Where your mini icon should go to.
-# kde_datadir Where you install application data. (Use a subdir)
-# kde_locale Where translation files should go to.(contains lang subdirs)
-# kde_cgidir Where cgi-bin executables should go to.
-# kde_confdir Where config files should go to.
-# kde_mimedir Where mimetypes should go to.
-# kde_toolbardir Where general toolbar icons should go to.
-# kde_wallpaperdir Where general wallpapers should go to.
-
-# set the include path for X, qt and KDE
-INCLUDES= $(all_includes)
-
-METASOURCES = AUTO
-
-# the library search path.
-knights_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_TQT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx $(LIB_TDEIO) -ltdetexteditor -lartskde -lsoundserver_idl -lkmedia2_idl -lartsflow_idl -lmcop
-
-# Uncomment the following two lines if you add a ui.rc file for your application to make use of
-# KDE´s XML GUI builing
-#rcdir = $(kde_datadir)/knights
-#rc_DATA = knightsui.rc
-
-#WARNING: if you use a ui.rc file above, use:
-
-# messages: rc.cpp
-
-# instead of
-
-# messages:
-
-messages:
- LIST=`find $(srcdir) -name \*.h -o -name \*.hh -o -name \*.H -o -name \*.hxx -o -name \*.hpp -o -name \*.cpp -o -name \*.cc -o -name \*.cxx -o -name \*.ecpp -o -name \*.C`; \
- if test -n "$$LIST"; then \
- $(XGETTEXT) $$LIST -o $(podir)/knights.pot; \
- fi
-