summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-07-24 11:29:03 -0500
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-07-24 11:29:03 -0500
commit066bae76e94c21604fe4132c4ca26e5b2f0c6375 (patch)
tree64cd6638d6f513ef8ddb094f9437467c0a810d86 /src/Makefile.am
downloadknmap-066bae76e94c21604fe4132c4ca26e5b2f0c6375.tar.gz
knmap-066bae76e94c21604fe4132c4ca26e5b2f0c6375.zip
Initial import of knmap 2.1 sources
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am46
1 files changed, 46 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..6a38c98
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,46 @@
+# set the include path for X, qt and KDE
+INCLUDES = $(all_includes)
+
+# these are the headers for your project
+noinst_HEADERS = knmap.h global.h mainwidget.h outputwidget.h commonwidget.h \
+ timingwidget.h compoundwidget.h htmlwidget.h stylesheetdialog.h profiledialog.h \
+ loggingoptions.h simpleoptions.h pandsoptions.h whatsthis.h tabwidgetptrlist.h \
+ tabwidgetdata.h scanwidget.h indexwidget.h scannamedialog.h scanstack.h scanmonitor.h \
+ scanmonitorevent.h nmapoutputbuffer.h
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+messages: rc.cpp
+ $(EXTRACTRC) `find . -name \*.ui -o -name \*.rc` > rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/knmap.pot
+
+KDE_ICON = AUTO
+
+#########################################################################
+# APPLICATION SECTION
+#########################################################################
+# this is the program that gets installed. it's name is used for all
+# of the other Makefile.am variables
+bin_PROGRAMS = knmap
+
+# the application source, library search path, and link libraries
+knmap_SOURCES = main.cpp knmap.cpp mainwidget.cpp outputwidget.cpp \
+ commonwidget.cpp timingwidget.cpp compoundwidget.cpp htmlwidget.cpp stylesheetdialog.cpp \
+ profiledialog.cpp loggingoptions.cpp simpleoptions.cpp pandsoptions.cpp whatsthis.cpp \
+ tabwidgetptrlist.cpp tabwidgetdata.cpp scanwidget.cpp indexwidget.cpp scannamedialog.cpp \
+ scanstack.cpp scanmonitor.cpp scanmonitorevent.cpp nmapoutputbuffer.cpp
+knmap_LDFLAGS = $(KDE_RPATH) $(all_libraries)
+knmap_LDADD = $(LIB_KIO) $(LIB_KHTML)
+
+# this is where the desktop file will go
+shelldesktopdir = $(kde_appsdir)/Utilities
+shelldesktop_DATA = knmap.desktop
+
+# this is where the shell's XML-GUI resource file goes
+shellrcdir = $(kde_datadir)/knmap
+shellrc_DATA = knmapui.rc nmap_manpage.html nmap_manpage.html.diff
+
+kde_icon_KDEICON = hi16-app-scanclose.png hi32-app-scanclose.png \
+ hi16-app-scannew.png hi32-app-scannew.png hi16-app-scanrename.png hi32-app-scanrename.png \
+ hi16-app-scanduplicate.png hi32-app-scanduplicate.png hi16-app-manpage.png hi32-app-manpage.png