summaryrefslogtreecommitdiffstats
path: root/koshell/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-01-20 01:29:50 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-01-20 01:29:50 +0000
commit8362bf63dea22bbf6736609b0f49c152f975eb63 (patch)
tree0eea3928e39e50fae91d4e68b21b1e6cbae25604 /koshell/Makefile.am
downloadkoffice-8362bf63dea22bbf6736609b0f49c152f975eb63.tar.gz
koffice-8362bf63dea22bbf6736609b0f49c152f975eb63.zip
Added old abandoned KDE3 version of koffice
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/applications/koffice@1077364 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'koshell/Makefile.am')
-rw-r--r--koshell/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/koshell/Makefile.am b/koshell/Makefile.am
new file mode 100644
index 000000000..e6dceac41
--- /dev/null
+++ b/koshell/Makefile.am
@@ -0,0 +1,25 @@
+
+INCLUDES = $(KOFFICE_INCLUDES) $(all_includes)
+
+## The kdeinit loadable module and executable
+lib_LTLIBRARIES =
+kdeinit_LTLIBRARIES = koshell.la
+bin_PROGRAMS =
+koshell_la_SOURCES = koshell_main.cc koshell_shell.cc iconsidepane.cpp koshellsettings.kcfgc
+koshell_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+koshell_la_LIBADD = $(LIB_KOFFICEUI)
+kde_kcfg_DATA = koshell.kcfg
+
+METASOURCES = AUTO
+
+KDE_ICON=AUTO
+
+rcdir = $(kde_datadir)/koshell
+rc_DATA = koshellui.rc
+
+xdg_apps_DATA = koshell.desktop
+
+messages: rc.cpp
+ $(XGETTEXT) rc.cpp *.cc *.cpp -o $(podir)/koshell.pot
+
+include $(top_srcdir)/admin/Doxyfile.am