summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-02-19 18:38:42 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-02-19 18:38:42 +0000
commit498ff4e365566b987d2c7a1e54065e0e126556f7 (patch)
treec283921daac735696d642ba121c9e14152e00215 /src/Makefile.am
downloadkopete-otr-498ff4e365566b987d2c7a1e54065e0e126556f7.tar.gz
kopete-otr-498ff4e365566b987d2c7a1e54065e0e126556f7.zip
Added abandoned KDE3 version of kopete-otr
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/applications/kopete-otr@1092925 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am48
1 files changed, 48 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..f168bd9
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,48 @@
+METASOURCES = AUTO
+
+messages:
+ extractrc `find . -name \*.ui -o -name \*.rc` > rc.cpp
+ $(XGETTEXT) --keyword=i18n *.cpp -o $(top_srcdir)/po/kopete_otr.pot
+
+INCLUDES = $(all_includes) -I$(kde_includes)/kopete -I$(kde_includes)/kopete/ui
+
+kde_module_LTLIBRARIES = kcm_kopete_otr.la kopete_otr.la
+
+kopete_otr_la_SOURCES = kopete_otr.kcfgc otrguiclient.cpp otrplugin.cpp
+
+
+kopete_otr_la_LDFLAGS = -module -no-undefined $(KDE_PLUGIN) $(all_libraries) \
+ -lkopete
+
+kcm_kopete_otr_la_SOURCES = kopete_otr.kcfgc otrpreferences.cpp otrprefs.ui
+
+kcm_kopete_otr_la_LDFLAGS = -module -no-undefined $(KDE_PLUGIN) \
+ $(all_libraries) -lkopete
+kcm_kopete_otr_la_LIBADD = libkotr.la -lotr $(LIB_KUTILS)
+
+service_DATA = kopete_otr.desktop
+servicedir = $(kde_servicesdir)
+
+kde_kcfg_DATA = kopete_otr.kcfg
+
+kcm_DATA = kopete_otr_config.desktop
+kcmdir = $(kde_servicesdir)/kconfiguredialog
+
+kopete_otr_la_LIBADD = libkotr.la -lotr
+
+noinst_HEADERS = otrguiclient.h otrlchatinterface.h otrlconfinterface.h \
+ otrplugin.h otrpreferences.h otrprefs.h privkeypopup.h smppopup.h verifypopup.h
+
+
+rcdir = $(kde_datadir)/kopete_otr
+rc_DATA = otrchatui.rc otrui.rc
+
+lib_LTLIBRARIES = libkotr.la
+libkotr_la_LDFLAGS = $(all_libraries)
+libkotr_la_SOURCES = otrlchatinterface.cpp otrlconfinterface.cpp \
+ privkeypopup.cpp privkeypopupui.ui smppopup.cpp smppopupui.ui verifypopup.cpp \
+ verifypopupui.ui
+libkotr_la_LIBADD = -lotr
+
+SUBDIRS = pics
+