summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-06-23 17:21:16 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-06-23 19:16:05 +0200
commit8403288e0159dbe377403e5f089072685a9d94f3 (patch)
treea9d67abfdfe66d86d58a6009852d497ee56795a8 /src/Makefile.am
parent541bc109cb8ee0ffd9ae8fd7df9bff715c0ef0d9 (diff)
downloadkopete-otr-8403288e0159dbe377403e5f089072685a9d94f3.tar.gz
kopete-otr-8403288e0159dbe377403e5f089072685a9d94f3.zip
Separate OTRPlugin object code from the OTRPluginFactory definition.
This resolves bug 1153. Fix support for GCC hidden visibility. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 4795dae..496be34 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -8,8 +8,8 @@ INCLUDES = $(all_includes) -I$(kde_includes)/kopete -I$(kde_includes)/tde/kopete
kde_module_LTLIBRARIES = kcm_kopete_otr.la kopete_otr.la
-kopete_otr_la_SOURCES = kopete_otr.kcfgc otrguiclient.cpp otrplugin.cpp
-
+kopete_otr_la_SOURCES = otrplugin-factory.cpp
+
kopete_otr_la_LDFLAGS = -module -no-undefined $(KDE_PLUGIN) $(all_libraries) $(LIB_TQT) $(LIB_TDECORE) $(LIB_TDEUI) \
-lkopete
@@ -39,7 +39,9 @@ rc_DATA = otrchatui.rc otrui.rc
lib_LTLIBRARIES = libkotr.la
libkotr_la_LDFLAGS = $(all_libraries) $(LIB_TQT) $(LIB_TDECORE) $(LIB_TDEUI)
-libkotr_la_SOURCES = otrlchatinterface.cpp otrlconfinterface.cpp \
+libkotr_la_SOURCES = \
+ kopete_otr.kcfgc otrguiclient.cpp otrplugin.cpp \
+ otrlchatinterface.cpp otrlconfinterface.cpp \
privkeypopup.cpp privkeypopupui.ui smppopup.cpp smppopupui.ui verifypopup.cpp \
verifypopupui.ui
libkotr_la_LIBADD = -lotr