summaryrefslogtreecommitdiffstats
path: root/conduits/malconduit/CMakeLists.txt
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-02-16 20:17:18 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-02-16 20:17:18 +0000
commitcb7eddb91455a69cf66fcd717e91a51ca5e2cfef (patch)
treecf5546e4d7c44370fbe9ca2be937bd254f30ebaa /conduits/malconduit/CMakeLists.txt
downloadkpilot-cb7eddb91455a69cf66fcd717e91a51ca5e2cfef.tar.gz
kpilot-cb7eddb91455a69cf66fcd717e91a51ca5e2cfef.zip
Moved kpilot from kdepim to applications, as the core Trinity libraries should not contain hardware-dependent software
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/applications/kpilot@1221127 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'conduits/malconduit/CMakeLists.txt')
-rw-r--r--conduits/malconduit/CMakeLists.txt48
1 files changed, 48 insertions, 0 deletions
diff --git a/conduits/malconduit/CMakeLists.txt b/conduits/malconduit/CMakeLists.txt
new file mode 100644
index 0000000..092f340
--- /dev/null
+++ b/conduits/malconduit/CMakeLists.txt
@@ -0,0 +1,48 @@
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${MAL_INCLUDE_DIR}
+)
+
+set(conduit_mal_SRCS
+ mal-factory.cc
+ mal-setup.cc
+ mal-conduit.cc
+)
+
+set(conduit_mal_UIS
+ mal-setup_dialog.ui
+)
+
+set(conduit_mal_KCFGS
+ malconduitSettings.kcfgc
+)
+
+kde3_add_kcfg_files(conduit_mal_SRCS ${conduit_mal_KCFGS})
+kde3_add_ui_files(conduit_mal_SRCS ${conduit_mal_UIS})
+kde3_automoc(${conduit_mal_SRCS})
+add_library(conduit_mal SHARED ${conduit_mal_SRCS})
+target_link_libraries(conduit_mal ${MAL_LIBRARY})
+
+set_target_properties(
+ conduit_mal PROPERTIES
+ LOCATION ${KDE3_PLUGIN_INSTALL_DIR}
+ PREFIX ""
+ INSTALL_RPATH "${MAL_LIBRARY}"
+ INSTALL_RPATH_USE_LINK_PATH true
+)
+
+kde3_install_libtool_file(conduit_mal)
+
+install(
+ TARGETS conduit_mal
+ LIBRARY DESTINATION ${KDE3_PLUGIN_INSTALL_DIR}
+)
+
+install(
+ FILES mal_conduit.desktop DESTINATION ${KDE3_SERVICES_DIR}
+)
+
+install(
+ FILES malconduit.kcfg DESTINATION ${KDE3_KCFG_DIR}
+)
+