summaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt16
1 files changed, 8 insertions, 8 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index f27f41a..6dfe070 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -29,50 +29,50 @@ link_directories(
set(EXECUTABLE_OUTPUT_PATH ${CMAKE_CURRENT_BINARY_DIR} )
tde_add_check_executable( testconstants
- SOURCES testconstants.cc
+ SOURCES testconstants.cpp
LINK kpilot-shared ${TQT_LIBRARIES}
TEST
)
tde_add_check_executable( testcategories
- SOURCES testcategories.cc
+ SOURCES testcategories.cpp
LINK kpilot-shared ${TQT_LIBRARIES}
TEST
)
tde_add_check_executable( testaddresses
- SOURCES testaddress.cc
+ SOURCES testaddress.cpp
LINK kpilot-shared ${TQT_LIBRARIES}
TEST
)
tde_add_check_executable( testdatebook
- SOURCES testdatebook.cc
+ SOURCES testdatebook.cpp
LINK kpilot-shared ${TQT_LIBRARIES}
TEST
)
tde_add_check_executable( importaddresses
- SOURCES importaddresses.cc
+ SOURCES importaddresses.cpp
LINK kpilot-shared tdeabc-shared tdeabc_file-shared ${TQT_LIBRARIES}
)
add_test(importaddresses ${EXECUTABLE_OUTPUT_PATH}/importaddresses --data-dir "${CMAKE_CURRENT_BINARY_DIR}" --address-file "${CMAKE_CURRENT_SOURCE_DIR}/data/AddressDB.pdb")
if (HAVE_CALENDARLOCAL_H)
tde_add_check_executable( importdatebook
- SOURCES importdatebook.cc
+ SOURCES importdatebook.cpp
LINK kpilot-shared kcal-shared ${TQT_LIBRARIES}
TEST
)
tde_add_check_executable( exportdatebook
- SOURCES exportdatebook.cc
+ SOURCES exportdatebook.cpp
LINK kpilot-shared kcal-shared ${TQT_LIBRARIES}
TEST
)
tde_add_check_executable( mergecalendars
- SOURCES mergecalendars.cc
+ SOURCES mergecalendars.cpp
LINK kpilot-shared kcal-shared ${TQT_LIBRARIES}
TEST
)