summaryrefslogtreecommitdiffstats
path: root/krename/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'krename/Makefile.am')
-rw-r--r--krename/Makefile.am49
1 files changed, 49 insertions, 0 deletions
diff --git a/krename/Makefile.am b/krename/Makefile.am
new file mode 100644
index 0000000..5d1503f
--- /dev/null
+++ b/krename/Makefile.am
@@ -0,0 +1,49 @@
+## Makefile.am for KRename
+
+# set the include path for X, qt and KDE
+INCLUDES = -I$(top_srcdir)/src $(all_includes)
+
+# these are the headers for your project
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+KDE_ICON = AUTO
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kdedcoptest.pot
+
+# this is the program that gets installed. it's name is used for all
+# of the other Makefile.am variables
+bin_PROGRAMS = krename
+
+# the application source, library search path, and link libraries
+
+krename_LDFLAGS = $(KDE_RPATH) $(all_libraries)
+krename_LDADD =$(LIB_KPARTS) $(LIB_KFILE) $(LIB_KDEUI) $(LIB_KDECORE) $(LIB_QT) $(LIBSOCKET)
+
+noinst_HEADERS = ProgressDialog.h dateplugin.h fileplugin.h kmylistbox.h krenameimpl.h \
+ pictureplugin.h tabs.h batchrenamer.h datetime.h firststartdlg.h \
+ kmylistview.h mydirplugin.h plugin.h threadedlister.h commandplugin.h \
+ dsdirselectdialog.h guimodeselector.h krecursivelister.h myinputdialog.h \
+ pluginloader.h translitplugin.h confdialog.h encodingplugin.h helpdialog.h \
+ krename.h numberdialog.h profiledlg.h undodialog.h coorddialog.h \
+ fileoperation.h kmyhistorycombo.h krenamedcop.h permission.h replacedialog.h \
+ wizard.h
+
+krename_SOURCES = guimodeselector.cpp firststartdlg.cpp tabs.cpp \
+ krenameimpl.cpp numberdialog.cpp coorddialog.cpp commandplugin.cpp helpdialog.cpp \
+ pictureplugin.cpp mydirplugin.cpp datetime.cpp permission.cpp fileplugin.cpp \
+ undodialog.cpp myinputdialog.cpp kmylistview.cpp wizard.cpp replacedialog.cpp \
+ pluginloader.cpp plugin.cpp kmylistbox.cpp kmyhistorycombo.cpp fileoperation.cpp \
+ confdialog.cpp batchrenamer.cpp ProgressDialog.cpp main.cpp krecursivelister.cpp \
+ dsdirselectdialog.cpp krenamedcop.skel dateplugin.cpp encodingplugin.cpp profiledlg.cpp \
+ threadedlister.cpp translitplugin.cpp
+
+
+xdg_apps_DATA = krename.desktop
+
+krenameservice_DATA = krenameservicemenu.desktop krename_dir.desktop
+krenameservicedir = $(kde_datadir)/konqueror/servicemenus
+
+datafiles_DATA = logo.png krename_system_default_tabbed.xml krename_system_default_wizard.xml
+datafilesdir = $(kde_datadir)/krename