summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2024-03-15 10:52:33 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2024-03-17 11:13:15 +0900
commitc684f019a81c828e8fbdfa8f2e7bbf545315057b (patch)
tree130ab8b9ed868d209b830746857c4e18a0a5d0e3 /CMakeLists.txt
parent7b0ba5b4ec0e6a41689f294d68c64f5631d8f733 (diff)
downloadkscope-c684f019a81c828e8fbdfa8f2e7bbf545315057b.tar.gz
kscope-c684f019a81c828e8fbdfa8f2e7bbf545315057b.zip
Use centralized cmake version
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 5 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4ae23d4..67bc53d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,7 +7,11 @@
############################################
-cmake_minimum_required( VERSION 3.5 )
+##### set project version ########################
+
+include( TDEVersion )
+cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
+tde_set_project_version( )
#### general package setup
@@ -32,11 +36,6 @@ include( CheckCXXSourceCompiles )
include( TDEMacros )
-##### set version number ########################
-
-tde_set_project_version( )
-
-
##### setup install paths
include( TDESetupPaths )