summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2013-10-08 04:35:35 +0200
committerSlávek Banko <slavek.banko@axis.cz>2013-10-08 05:14:53 +0200
commit57d8bb3d12aed373eee08915f0ff19f5233aabe3 (patch)
treed7d3cb303f1a2257497e47a09da9062b3fdd9727 /src/Makefile.am
parent3d4505d268fc776309324d98c6a793053e368d92 (diff)
downloadkscope-57d8bb3d12aed373eee08915f0ff19f5233aabe3.tar.gz
kscope-57d8bb3d12aed373eee08915f0ff19f5233aabe3.zip
Fix FTBFS with automake >= 1.12
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 3e6d3ec..a1d6d4f 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -33,7 +33,7 @@ bin_PROGRAMS = kscope
kscope_SOURCES = autocompletionlayout.ui bookmarksdlg.cpp bookmarkslayout.ui \
calltreedlg.cpp calltreelayout.ui calltreemanager.cpp configfrontend.cpp \
cscopefrontend.cpp cscopemsgdlg.cpp cscopemsglayout.ui ctagsfrontend.cpp ctagslist.cpp \
- dirscanner.cpp dotfrontend.cpp dotparse.ypp dotscan.lpp editormanager.cpp \
+ dirscanner.cpp dotfrontend.cpp dotparse.cpp dotscan.lpp editormanager.cpp \
editorpage.cpp editortabs.cpp encoder.cpp filelist.cpp fileview.cpp fileviewlayout.ui \
frontend.cpp graphedge.cpp graphnode.cpp graphprefdlg.cpp graphpreflayout.ui \
graphwidget.cpp historypage.cpp historyview.cpp kscope.cpp kscopeactions.cpp \
@@ -64,5 +64,13 @@ pics_DATA = file_ro.png file_rw.png file_save.png query_locked.png \
query_unlocked.png tab_list.png call_graph.png called_tree.png calling_tree.png \
bookmark.png
-BUILT_SOURCES = dotparse.h
+# automake <=1.11 and automake >=1.12 have different conventions for naming C++ header files
+# made by yacc. To work with both, we write our own rule rather than using automake's.
+# When (if) we require automake >=1.12 in configure.ac, this can be removed, and we can use
+# the automake rule.
+dotparse.cpp dotparse.hpp: dotparse.ypp
+ $(AM_V_GEN) $(YACC) -v --output dotparse.cpp --defines=dotparse.hpp $<
+
+BUILT_SOURCES = dotparse.hpp
+DISTCLEANFILES = dotparse.cpp
AM_YFLAGS = -d