summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2016-01-22 02:06:59 +0100
committerSlávek Banko <slavek.banko@axis.cz>2016-01-22 02:06:59 +0100
commitb62b2d3a077be091b693fecb52f65cbc1ac2681e (patch)
tree2d444960da8fc9070018398a225bc8af5c21523e /src/Makefile.am
parentea5e81fbea7b7e5f8fbc9c0603be329d0d7322e9 (diff)
downloadksensors-b62b2d3a077be091b693fecb52f65cbc1ac2681e.tar.gz
ksensors-b62b2d3a077be091b693fecb52f65cbc1ac2681e.zip
Strictly use autostart-enabled .desktop
This resolves Bug 2577 Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 8128f46..7c17c10 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -45,10 +45,14 @@ ksensors_SOURCES = main.cpp ksensors.cpp aboutcfgdesign.ui \
ksensors_LDFLAGS = $(TDE_RPATH) $(all_libraries)
ksensors_LDADD = $(LIB_TDEUI) $(LIB_TDECORE) $(LIB_QT) -lsensors -lm
-# this is where the desktop file will go
+# this is where the desktop file will go
shelldesktopdir = $(kde_appsdir)/System
shelldesktop_DATA = ksensors.desktop
+# and for autostart
+autostartdir = $(prefix)/share/autostart
+autostart_DATA = ksensors.desktop
+
# this is where the shell's XML-GUI resource file goes
shellrcdir = $(kde_datadir)/ksensors
shellrc_DATA = ksensorsui.rc