summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-07-22 12:21:45 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-07-22 12:21:45 +0200
commit9f1147122934ad21ab862468d4163b90be15c9fa (patch)
tree484c42f5309c2cafa5863dd04a03ae7ed90b544f /CMakeLists.txt
parent0c7071878e893e6ce98cc46427dea4c780fa72b7 (diff)
downloadkshowmail-9f1147122934ad21ab862468d4163b90be15c9fa.tar.gz
kshowmail-9f1147122934ad21ab862468d4163b90be15c9fa.zip
Use common rules for build and install documentation and translations.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f58f0ea..987e350 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -71,8 +71,12 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
add_subdirectory( pics )
add_subdirectory( sounds )
add_subdirectory( ${PROJECT_NAME} )
-tde_conditional_add_subdirectory( BUILD_DOC doc )
-tde_conditional_add_subdirectory( BUILD_TRANSLATIONS translations )
+
+
+##### other data ################################
+
+tde_conditional_add_project_docs( BUILD_DOC )
+tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
##### write configure files