summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-05-03 02:39:22 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-05-03 02:41:07 +0200
commiteb2422ab08ebe4d975a8d8a387d2371089b4e5b5 (patch)
tree1236539c5cbd17f40a6d4f1166c3e44ae8e8e253 /CMakeLists.txt
parent54c0aa6024b24fc0adfbc0b16d127a40c0583cda (diff)
downloadksplash-engine-moodin-eb2422ab08ebe4d975a8d8a387d2371089b4e5b5.tar.gz
ksplash-engine-moodin-eb2422ab08ebe4d975a8d8a387d2371089b4e5b5.zip
Add the ability to translate:
+ Catalog for strings in the plugin. + Desktop file translations. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 460b0273772f313ff533ba655ccaa11cf7acef5c)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9fd0397..a8b120d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -47,7 +47,9 @@ option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden"
##### user requested modules
-option( BUILD_ALL "Build all" ON )
+option( BUILD_ALL "Build all" ON )
+option( BUILD_THEMES "Build themes" ${BUILD_ALL} )
+option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
##### configure checks
@@ -67,6 +69,7 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### directories
add_subdirectory( src )
+tde_conditional_add_subdirectory( BUILD_TRANSLATIONS translations )
##### write configure files