summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4ad489b..bf760dd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -689,6 +689,22 @@ if test ! -z "$MINGW"; then
fi
AC_SUBST(WSOCKLIB)
+# Check for libgcrypt
+AH_TEMPLATE(WITH_CLIENT_GCRYPT, [Enable support for libgcrypt in libvncclient])
+AC_ARG_WITH(gcrypt,
+[ --without-gcrypt disable support for gcrypt],,)
+AC_ARG_WITH(client-gcrypt,
+[ --without-client-gcrypt disable support for gcrypt in libvncclient],,)
+
+if test "x$with_gcrypt" != "xno"; then
+ AM_PATH_LIBGCRYPT(1.4.0, , with_client_gcrypt=no)
+ CFLAGS="$CFLAGS $LIBGCRYPT_CFLAGS"
+ LIBS="$LIBS $LIBGCRYPT_LIBS"
+ if test "x$with_client_gcrypt" != "xno"; then
+ AC_DEFINE(WITH_CLIENT_GCRYPT)
+ fi
+fi
+
# Checks for GnuTLS
AH_TEMPLATE(WITH_CLIENT_TLS, [Enable support for gnutls in libvncclient])
AC_ARG_WITH(gnutls,