summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2024-03-15 10:54:32 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2024-03-17 11:15:27 +0900
commitaf39fe61484fac44a487c9403988360c9fadfc20 (patch)
tree525dce48977d619401a81ee03dae152dfe640a8f /CMakeLists.txt
parentda959f72f9d98c7e4edaa504781668e0b0066e2b (diff)
downloadpotracegui-af39fe61484fac44a487c9403988360c9fadfc20.tar.gz
potracegui-af39fe61484fac44a487c9403988360c9fadfc20.zip
Use centralized cmake version
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 5 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6763af4..4010ba2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,7 +7,11 @@
############################################
-cmake_minimum_required( VERSION 3.5 )
+##### set project version ########################
+
+include( TDEVersion )
+cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
+tde_set_project_version( )
#### general package setup
@@ -31,11 +35,6 @@ include( CheckCXXSourceCompiles )
include( TDEMacros )
-##### set version number ########################
-
-tde_set_project_version( )
-
-
##### setup install paths
include( TDESetupPaths )