summaryrefslogtreecommitdiffstats
path: root/src/metadata/mp4/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/metadata/mp4/Makefile.am')
-rw-r--r--src/metadata/mp4/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/metadata/mp4/Makefile.am b/src/metadata/mp4/Makefile.am
new file mode 100644
index 0000000..e0779c6
--- /dev/null
+++ b/src/metadata/mp4/Makefile.am
@@ -0,0 +1,18 @@
+SUBDIRS =
+
+INCLUDES = $(all_includes) $(MP4V2_INCLUDES) $(taglib_includes)
+METASOURCES = AUTO
+libtagmp4_la_LDFLAGS = $(all_libraries) $(MP4V2_LIBS)
+noinst_LTLIBRARIES = libtagmp4.la
+
+libtagmp4_la_SOURCES = \
+ mp4properties.cpp \
+ mp4tag.cpp \
+ mp4file.cpp \
+ taglib_mp4filetyperesolver.cpp
+
+noinst_HEADERS = \
+ mp4properties.h \
+ mp4tag.h \
+ mp4file.h \
+ taglib_mp4filetyperesolver.h