summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris <xchrisx@uber.space>2020-01-25 03:37:43 +0100
committerTDE Gitea <gitea@mirror.git.trinitydesktop.org>2020-01-26 02:21:07 +0000
commit1872d122256f687184e07c66511ae0c20499c3c2 (patch)
tree33815a3e0c1c859515da343075266ba50fd712af
parent20729147d9e0bc250848772633cc2b311a4a2fa0 (diff)
downloadtde-packaging-gentoo-1872d122256f687184e07c66511ae0c20499c3c2.tar.gz
tde-packaging-gentoo-1872d122256f687184e07c66511ae0c20499c3c2.zip
Live ebuilds: Add preliminary Kima ebuild.
Signed-off-by: Chris <xchrisx@uber.space>
-rw-r--r--trinity-apps/kima/kima-9999.ebuild32
-rw-r--r--trinity-apps/kima/metadata.xml7
2 files changed, 39 insertions, 0 deletions
diff --git a/trinity-apps/kima/kima-9999.ebuild b/trinity-apps/kima/kima-9999.ebuild
new file mode 100644
index 00000000..dc83d335
--- /dev/null
+++ b/trinity-apps/kima/kima-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI="7"
+TRINITY_MODULE_TYPE="applications"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="de es et hu id nl sv tr"
+
+inherit trinity-base-2
+
+DESCRIPTION="A Kicker monitoring applet"
+HOMEPAGE="http://trinitydesktop.org/"
+LICENSE="|| ( GPL-2 GPL-3 )"
+
+need-trinity 14.1.0
+
+SLOT="${TRINITY_VER}"
+
+# NVControl support needs the nvidia-settings package,
+# which isn't in the portage tree anymore. So if there
+# is interest, it could be imported to the overlay maybe.
+
+src_configure() {
+ mycmakeargs=(
+ -DWITH_NVCONTROL=OFF
+ )
+
+ trinity-base-2_src_configure
+} \ No newline at end of file
diff --git a/trinity-apps/kima/metadata.xml b/trinity-apps/kima/metadata.xml
new file mode 100644
index 00000000..61b4108b
--- /dev/null
+++ b/trinity-apps/kima/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Chris</name>
+ </maintainer>
+</pkgmetadata>