summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris <xchrisx@uber.space>2020-01-07 20:10:11 +0100
committerTDE Gitea <gitea@mirror.git.trinitydesktop.org>2020-01-18 16:11:06 +0000
commit355b84074a0e6e5fa5fcd666917c6799b0805af4 (patch)
tree57fe5bfc606eb573075273c89254ac3f3cc2b10c
parent3de8a3c7c50cfcaf9334ee8a538998fd4763bcf5 (diff)
downloadtde-packaging-gentoo-355b84074a0e6e5fa5fcd666917c6799b0805af4.tar.gz
tde-packaging-gentoo-355b84074a0e6e5fa5fcd666917c6799b0805af4.zip
Live ebuilds: Cleanup and EAPI7 bump of tdelibs and tqt.
Also fix the building segfault, caused by building without tdehwlib. Use of hwlib only pulls in additional dependencies at the moment. Signed-off-by: Chris <xchrisx@uber.space>
-rw-r--r--dev-tqt/tqt/tqt-9999.ebuild25
-rw-r--r--trinity-base/tdelibs/tdelibs-9999.ebuild45
2 files changed, 32 insertions, 38 deletions
diff --git a/dev-tqt/tqt/tqt-9999.ebuild b/dev-tqt/tqt/tqt-9999.ebuild
index 48444b81..4e759d13 100644
--- a/dev-tqt/tqt/tqt-9999.ebuild
+++ b/dev-tqt/tqt/tqt-9999.ebuild
@@ -3,26 +3,24 @@
# $Id$
EAPI=7
-inherit eutils git-r3 flag-o-matic toolchain-funcs
+inherit eutils git-r3 toolchain-funcs
SRCTYPE="free"
DESCRIPTION="Trinity's Qt toolkit fork."
HOMEPAGE="http://trinitydesktop.org/"
-#SRC_URI="http://www.mirrorservice.org/sites/trinitydesktop.org/trinity/releases/R${PV}/main/dependencies/tqt3-trinity-${PV}.tar.xz"
EGIT_REPO_URI="https://mirror.git.trinitydesktop.org/gitea/TDE/tqt3"
LICENSE="|| ( GPL-2 GPL-3 )"
SLOT="3.5"
KEYWORDS=
IUSE="cups debug doc examples firebird ipv6 mysql nas nis opengl postgres sqlite xinerama"
-# no odbc, immtqt and immtqt-bc support anymore.
# TODO: optional support for xrender and xrandr
RDEPEND="
virtual/jpeg:=
- >=media-libs/freetype-2
- >=media-libs/libmng-1.0.9
+ media-libs/freetype
+ media-libs/libmng
media-libs/libpng:=
sys-libs/zlib
x11-libs/libXft
@@ -33,12 +31,10 @@ RDEPEND="
cups? ( net-print/cups )
firebird? ( dev-db/firebird )
mysql? ( virtual/mysql )
- nas? ( >=media-libs/nas-1.5 )
+ nas? ( media-libs/nas )
opengl? ( virtual/opengl virtual/glu )
postgres? ( dev-db/postgresql:= )
- xinerama? ( x11-libs/libXinerama )
- !dev-qt/qt:3
- !dev-qt/qt-meta:3"
+ xinerama? ( x11-libs/libXinerama )"
DEPEND="${RDEPEND}
x11-base/xorg-proto"
@@ -82,13 +78,10 @@ src_prepare() {
# Apply user-provided patches
eapply_user
- # Do not link with -rpath. See bug #75181.
+ # Do not link with -rpath. See Gentoo bug #75181.
find "${S}"/mkspecs -name qmake.conf | xargs \
sed -i -e 's:QMAKE_RPATH.*:QMAKE_RPATH =:'
- # set c/xxflags and ldflags
- strip-flags
-
sed -i -e "s:QMAKE_CFLAGS_RELEASE.*=.*:QMAKE_CFLAGS_RELEASE=${CFLAGS}:" \
-e "s:QMAKE_CXXFLAGS_RELEASE.*=.*:QMAKE_CXXFLAGS_RELEASE=${CXXFLAGS}:" \
-e "s:QMAKE_LFLAGS_RELEASE.*=.*:QMAKE_LFLAGS_RELEASE=${LDFLAGS}:" \
@@ -116,8 +109,8 @@ src_prepare() {
src_configure() {
export SYSCONF="${D}${TQTBASE}"/etc/settings
- # Let's just allow writing to these directories during Qt emerge
- # as it makes TQt much happier.
+ # Let's just allow writing to these directories
+ # during emerge as it makes TQt much happier.
addwrite "${TQTBASE}/etc/settings"
addwrite "${HOME}/.qt"
addwrite "${HOME}/.tqt"
@@ -252,6 +245,6 @@ pkg_postinst() {
elog "occurs you should recompile the packages providing these plugins,"
elog "and you should also make sure that TQt and its plugins were compiled with the"
elog "same version of GCC. Packages that may need to be rebuilt are, for instance,"
- elog "tde-base/tdelibs, tde-base/tdeartwork and tde-base/tdeartwork-styles."
+ elog "trinity-base/tdelibs and trinity-base/tdeartwork-styles."
echo
}
diff --git a/trinity-base/tdelibs/tdelibs-9999.ebuild b/trinity-base/tdelibs/tdelibs-9999.ebuild
index 94729ca8..5c8153d4 100644
--- a/trinity-base/tdelibs/tdelibs-9999.ebuild
+++ b/trinity-base/tdelibs/tdelibs-9999.ebuild
@@ -2,10 +2,10 @@
# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="7"
TRINITY_MODULE_NAME="tdelibs"
-inherit trinity-base multilib
+inherit trinity-base-2 multilib
set-trinityver
@@ -13,46 +13,47 @@ need-arts optional
DESCRIPTION="Trinity libraries needed by all TDE programs."
HOMEPAGE="http://www.trinitydesktop.org/"
-LICENSE="GPL-2 LGPL-2"
+LICENSE="|| ( GPL-2 GPL-3 )"
+
SLOT="${TRINITY_VER}"
-KEYWORDS=
-IUSE+=" alsa avahi cups consolekit cryptsetup fam hwlib jpeg2k lua
+
+IUSE+=" alsa avahi cups consolekit cryptsetup fam jpeg2k lua
lzma networkmanager openexr pcsc-lite spell sudo tiff
- utempter upower xcomposite +xrandr"
+ utempter upower xcomposite hwlib +xrandr "
MY_DEPEND="=dev-tqt/tqtinterface-${PV}
- >=dev-libs/libxslt-1.1.16
- >=dev-libs/libxml2-2.6.6
- >=dev-libs/libpcre-6.6
+ dev-libs/libxslt
+ dev-libs/libxml2
+ dev-libs/libpcre
net-dns/libidn
app-text/ghostscript-gpl
- >=dev-libs/openssl-0.9.7d:=
+ dev-libs/openssl:=
media-libs/fontconfig
media-libs/freetype:2
media-libs/libart_lgpl
sys-apps/dbus
- dev-libs/dbus-1-tqt
+ =dev-libs/dbus-1-tqt-${PV}
x11-libs/libXcursor
x11-libs/libXrender
alsa? ( media-libs/alsa-lib )
avahi? ( net-dns/avahi )
cryptsetup? ( sys-fs/cryptsetup )
- cups? ( >=net-print/cups-1.1.19 )
+ cups? ( net-print/cups )
fam? ( virtual/fam )
jpeg2k? ( media-libs/jasper )
lua? ( dev-lang/lua:* )
- openexr? ( >=media-libs/openexr-1.2.2-r2 )
+ openexr? ( media-libs/openexr )
pcsc-lite? ( sys-apps/pcsc-lite )
- spell? ( >=app-dicts/aspell-en-6.0.0 >=app-text/aspell-0.60.5 )
+ spell? ( app-dicts/aspell-en app-text/aspell )
sudo? ( app-admin/sudo )
tiff? ( media-libs/tiff:= )
utempter? ( sys-libs/libutempter )
networkmanager? ( net-misc/networkmanager )
lzma? ( app-arch/xz-utils )
- xrandr? ( >=x11-libs/libXrandr-1.2 )
+ xrandr? ( x11-libs/libXrandr )
xcomposite? ( x11-libs/libXcomposite )"
-# NOTE: upstream lacks avahi support, so the use flag is currenly masked
# TODO: add elfres support via libr (not in portage now)
+# NOTE: Building without tdehwlib segfaults, so no choice until fixed.
DEPEND+=" ${MY_DEPEND}"
RDEPEND+=" ${MY_DEPEND}
consolekit? ( sys-auth/consolekit )
@@ -68,8 +69,8 @@ src_configure() {
-DWITH_PCRE=ON
-DWITH_HSPELL=OFF
-DWITH_PKCS=OFF
- -DWITH_TDEHWLIB="$(usex hwlib)"
- -DWITH_TDEHWLIB_DAEMONS="$(usex hwlib)"
+ -DWITH_TDEHWLIB=ON
+ -DWITH_TDEHWLIB_DAEMONS=ON
-DWITH_ARTS=OFF
-DWITH_ALSA="$(usex alsa)"
-DWITH_AVAHI="$(usex avahi)"
@@ -93,11 +94,11 @@ src_configure() {
-DWITH_SUDO_TDESU_BACKEND="$(usex sudo)"
)
- trinity-base_src_configure
+ trinity-base-2_src_configure
}
src_install() {
- trinity-base_src_install
+ trinity-base-2_src_install
dodir /etc/env.d
# TDE expects that the install path is listed first in TDEDIRS and the user
@@ -129,8 +130,8 @@ cat <<EOF >"${D}/etc/revdep-rebuild/50-trinity-${SLOT}"
SEARCH_DIRS="${TDEDIR}/bin ${TDEDIR}/lib*"
EOF
- trinity-base_create_tmp_docfiles
- trinity-base_install_docfiles
+ trinity-base-2_create_tmp_docfiles
+ trinity-base-2_install_docfiles
}
pkg_postinst () {