summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2023-04-25 14:44:32 +0300
committerormorph <roma251078@mail.ru>2023-04-25 15:31:45 +0300
commit48e81b686bc71329df6a9e9dcd001badd6e8c4e2 (patch)
tree70d68123b3c6eda9a4746b497080e3bb05ae6dfa
parentd61b990d16400a990fcc10f6b8b251f84a98479a (diff)
downloadtde-packaging-gentoo-48e81b686bc71329df6a9e9dcd001badd6e8c4e2.tar.gz
tde-packaging-gentoo-48e81b686bc71329df6a9e9dcd001badd6e8c4e2.zip
Added new ebuilds: polkit-tqt, polkit-agent-tde, tdebluez, tdesshaskpass, tdeio-appinfo, tdepacman, kompose, mathemagics, twin-style-machbuntr14.1.0
Signed-off-by: ormorph <roma251078@mail.ru>
-rw-r--r--trinity-apps/kompose/Manifest1
-rw-r--r--trinity-apps/kompose/kompose-14.1.0.ebuild36
-rw-r--r--trinity-apps/kompose/kompose-9999.ebuild36
-rw-r--r--trinity-apps/kompose/metadata.xml8
-rw-r--r--trinity-apps/mathemagics/Manifest1
-rw-r--r--trinity-apps/mathemagics/mathemagics-14.1.0.ebuild30
-rw-r--r--trinity-apps/mathemagics/mathemagics-9999.ebuild30
-rw-r--r--trinity-apps/mathemagics/metadata.xml8
-rw-r--r--trinity-apps/polkit-agent-tde/Manifest1
-rw-r--r--trinity-apps/polkit-agent-tde/metadata.xml8
-rw-r--r--trinity-apps/polkit-agent-tde/polkit-agent-tde-14.1.0.ebuild33
-rw-r--r--trinity-apps/polkit-agent-tde/polkit-agent-tde-9999.ebuild33
-rw-r--r--trinity-apps/tdebluez/Manifest1
-rw-r--r--trinity-apps/tdebluez/metadata.xml8
-rw-r--r--trinity-apps/tdebluez/tdebluez-14.1.0.ebuild32
-rw-r--r--trinity-apps/tdebluez/tdebluez-9999.ebuild32
-rw-r--r--trinity-apps/tdeio-appinfo/Manifest1
-rw-r--r--trinity-apps/tdeio-appinfo/metadata.xml8
-rw-r--r--trinity-apps/tdeio-appinfo/tdeio-appinfo-14.1.0.ebuild17
-rw-r--r--trinity-apps/tdeio-appinfo/tdeio-appinfo-9999.ebuild17
-rw-r--r--trinity-apps/tdepacman/Manifest1
-rw-r--r--trinity-apps/tdepacman/metadata.xml8
-rw-r--r--trinity-apps/tdepacman/tdepacman-14.1.0.ebuild31
-rw-r--r--trinity-apps/tdepacman/tdepacman-9999.ebuild31
-rw-r--r--trinity-apps/tdesshaskpass/Manifest1
-rw-r--r--trinity-apps/tdesshaskpass/metadata.xml8
-rw-r--r--trinity-apps/tdesshaskpass/tdesshaskpass-14.1.0.ebuild34
-rw-r--r--trinity-apps/tdesshaskpass/tdesshaskpass-9999.ebuild34
-rw-r--r--trinity-apps/twin-style-machbunt/Manifest1
-rw-r--r--trinity-apps/twin-style-machbunt/metadata.xml8
-rw-r--r--trinity-apps/twin-style-machbunt/twin-style-machbunt-14.1.0.ebuild31
-rw-r--r--trinity-apps/twin-style-machbunt/twin-style-machbunt-9999.ebuild31
-rw-r--r--trinity-base/polkit-tqt/Manifest1
-rw-r--r--trinity-base/polkit-tqt/metadata.xml8
-rw-r--r--trinity-base/polkit-tqt/polkit-tqt-14.1.0.ebuild21
-rw-r--r--trinity-base/polkit-tqt/polkit-tqt-9999.ebuild21
36 files changed, 611 insertions, 0 deletions
diff --git a/trinity-apps/kompose/Manifest b/trinity-apps/kompose/Manifest
new file mode 100644
index 00000000..19a292cd
--- /dev/null
+++ b/trinity-apps/kompose/Manifest
@@ -0,0 +1 @@
+DIST kompose-trinity-14.1.0.tar.xz 76396 BLAKE2B f666c3798a0c556966c48891538ab93ca6005e111f4c9f3fd639005d7d174084553cf59e0764480d3ec186ac41dcbb8572aa70962279c3b2dcaf75827644d819 SHA512 6c8e5c8e8541c20ab738820a0a86b307e4e6b5243824a564609b119b40a94f42c99ca4a0f27f8c5c430b266b7f283b32cbbf63c6d676b5a8f7be298b114f4e05
diff --git a/trinity-apps/kompose/kompose-14.1.0.ebuild b/trinity-apps/kompose/kompose-14.1.0.ebuild
new file mode 100644
index 00000000..f9636d72
--- /dev/null
+++ b/trinity-apps/kompose/kompose-14.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="never"
+
+TRINITY_LANGS="da de el es fr it"
+
+TRINITY_MODULE_TYPE="applications/utilities"
+inherit trinity-base-2
+
+DESCRIPTION="Full-Screen Task Manager for TDE"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE="xcomposite"
+
+DEPEND="media-libs/imlib2
+ xcomposite? ( x11-libs/libXcomposite
+ x11-libs/libXdamage )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ -DWITH_XCOMPOSITE="$(usex xcomposite)"
+ )
+ trinity-base-2_src_configure
+}
diff --git a/trinity-apps/kompose/kompose-9999.ebuild b/trinity-apps/kompose/kompose-9999.ebuild
new file mode 100644
index 00000000..d4ace5ad
--- /dev/null
+++ b/trinity-apps/kompose/kompose-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="never"
+
+TRINITY_LANGS="da de el es fr it"
+
+TRINITY_MODULE_TYPE="applications/utilities"
+inherit trinity-base-2
+
+DESCRIPTION="Full-Screen Task Manager for TDE"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~x86"
+fi
+IUSE="xcomposite"
+
+DEPEND="media-libs/imlib2
+ xcomposite? ( x11-libs/libXcomposite
+ x11-libs/libXdamage )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ -DWITH_XCOMPOSITE="$(usex xcomposite)"
+ )
+ trinity-base-2_src_configure
+}
diff --git a/trinity-apps/kompose/metadata.xml b/trinity-apps/kompose/metadata.xml
new file mode 100644
index 00000000..689e1534
--- /dev/null
+++ b/trinity-apps/kompose/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>team-gentoo@trinitydesktop.org</email>
+ <name>Trinity Gentoo ebuilds project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/trinity-apps/mathemagics/Manifest b/trinity-apps/mathemagics/Manifest
new file mode 100644
index 00000000..941db5b4
--- /dev/null
+++ b/trinity-apps/mathemagics/Manifest
@@ -0,0 +1 @@
+DIST mathemagics-trinity-14.1.0.tar.xz 32780 BLAKE2B a0cf58571307e778e5b363e521768ee84c52afda38460e0912532db3b6be9c99b6bcdff84ab38af8333366034624923ef0daab6ad980cd3628c024c4531698a3 SHA512 2629aa096d87b8e6c654320b51a1bf46200ad0ef033b43058b995b02904cb3976a1a90e17de309835d65235a9d73514ab6294de8d22c2c579ef598e5764e2265
diff --git a/trinity-apps/mathemagics/mathemagics-14.1.0.ebuild b/trinity-apps/mathemagics/mathemagics-14.1.0.ebuild
new file mode 100644
index 00000000..2ed80f7a
--- /dev/null
+++ b/trinity-apps/mathemagics/mathemagics-14.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="never"
+
+TRINITY_LANGS="af az bg bs ca cs da de el es et eu fi fr he hr hu is it ja \
+ lt lv mt nl nn pl pt_BR pt ro ru sk sl sr@Latn sr sv ta th \
+ tr uk wa xh zh_CN zh_TW zu"
+
+TRINITY_MODULE_TYPE="applications/utilities"
+inherit trinity-base-2
+
+DESCRIPTION="Mathemagics is a RPN Calculator"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+ trinity-base-2_src_configure
+}
diff --git a/trinity-apps/mathemagics/mathemagics-9999.ebuild b/trinity-apps/mathemagics/mathemagics-9999.ebuild
new file mode 100644
index 00000000..0cc608fb
--- /dev/null
+++ b/trinity-apps/mathemagics/mathemagics-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="never"
+
+TRINITY_LANGS="af az bg bs ca cs da de el es et eu fi fr he hr hu is it ja \
+ lt lv mt nl nn pl pt_BR pt ro ru sk sl sr@Latn sr sv ta th \
+ tr uk wa xh zh_CN zh_TW zu"
+
+TRINITY_MODULE_TYPE="applications/utilities"
+inherit trinity-base-2
+
+DESCRIPTION="Mathemagics is a RPN Calculator"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~x86"
+fi
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+ trinity-base-2_src_configure
+}
diff --git a/trinity-apps/mathemagics/metadata.xml b/trinity-apps/mathemagics/metadata.xml
new file mode 100644
index 00000000..689e1534
--- /dev/null
+++ b/trinity-apps/mathemagics/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>team-gentoo@trinitydesktop.org</email>
+ <name>Trinity Gentoo ebuilds project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/trinity-apps/polkit-agent-tde/Manifest b/trinity-apps/polkit-agent-tde/Manifest
new file mode 100644
index 00000000..ba92ac31
--- /dev/null
+++ b/trinity-apps/polkit-agent-tde/Manifest
@@ -0,0 +1 @@
+DIST polkit-agent-tde-trinity-14.1.0.tar.xz 32632 BLAKE2B 5b320345ab3a7ac2f3f23e3f537f38a10916208551cc95f60a01d51a423450bdb2e975c88ae9fb4c79aeebe8d3e08995c3a10ead67047cf4807a3b7ca43e6409 SHA512 448f026ebf6631e0679fb354e219a7287907796ab9507df9f1f83fe418a2974d7716f5107298ae8edfe38bfab46cbf7903e3ff4beb62fd7e6b00af115e5f1e9e
diff --git a/trinity-apps/polkit-agent-tde/metadata.xml b/trinity-apps/polkit-agent-tde/metadata.xml
new file mode 100644
index 00000000..689e1534
--- /dev/null
+++ b/trinity-apps/polkit-agent-tde/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>team-gentoo@trinitydesktop.org</email>
+ <name>Trinity Gentoo ebuilds project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/trinity-apps/polkit-agent-tde/polkit-agent-tde-14.1.0.ebuild b/trinity-apps/polkit-agent-tde/polkit-agent-tde-14.1.0.ebuild
new file mode 100644
index 00000000..1265d313
--- /dev/null
+++ b/trinity-apps/polkit-agent-tde/polkit-agent-tde-14.1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="never"
+
+TRINITY_LANGS="ar bs ca ca@valencia cs da de el en_GB eo es et fi fr ga gl hr \
+ hu is it ja kk km lt mai mr ms nb nds nl pa pl pt_BR pt ro ru \
+ sk sl sr sv th tr ug uk vi zh_CN zh_TW"
+
+TRINITY_MODULE_TYPE="applications/system"
+inherit trinity-base-2
+
+DESCRIPTION="TDE dialogs for PolicyKit"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DEPEND="~trinity-base/polkit-tqt-${PV}"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+ trinity-base-2_src_configure
+}
diff --git a/trinity-apps/polkit-agent-tde/polkit-agent-tde-9999.ebuild b/trinity-apps/polkit-agent-tde/polkit-agent-tde-9999.ebuild
new file mode 100644
index 00000000..f6859101
--- /dev/null
+++ b/trinity-apps/polkit-agent-tde/polkit-agent-tde-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="never"
+
+TRINITY_LANGS="ar bs ca ca@valencia cs da de el en_GB eo es et fi fr ga gl hr \
+ hu is it ja kk km lt mai mr ms nb nds nl pa pl pt_BR pt ro ru \
+ sk sl sr sv th tr ug uk vi zh_CN zh_TW"
+
+TRINITY_MODULE_TYPE="applications/system"
+inherit trinity-base-2
+
+DESCRIPTION="TDE dialogs for PolicyKit"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DEPEND="~trinity-base/polkit-tqt-${PV}"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+ trinity-base-2_src_configure
+}
diff --git a/trinity-apps/tdebluez/Manifest b/trinity-apps/tdebluez/Manifest
new file mode 100644
index 00000000..1adcc06c
--- /dev/null
+++ b/trinity-apps/tdebluez/Manifest
@@ -0,0 +1 @@
+DIST tdebluez-trinity-14.1.0.tar.xz 345396 BLAKE2B a495ed4f65d2a86e38852ca0d4fbb543f8d986967532df22c3381d4c3f52a0f1617407752def428201fbe8ba0db05d2a9cc424f417a45dd351443edf46ebec80 SHA512 d6337469300339254c56eebb90080fd7eea217e1d4c931819155c8617bb7a3fa9da583f715c2abf2f7bdae1ab0af900dae70a7730d725b1f17490a41aa97cccf
diff --git a/trinity-apps/tdebluez/metadata.xml b/trinity-apps/tdebluez/metadata.xml
new file mode 100644
index 00000000..689e1534
--- /dev/null
+++ b/trinity-apps/tdebluez/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>team-gentoo@trinitydesktop.org</email>
+ <name>Trinity Gentoo ebuilds project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/trinity-apps/tdebluez/tdebluez-14.1.0.ebuild b/trinity-apps/tdebluez/tdebluez-14.1.0.ebuild
new file mode 100644
index 00000000..537e5780
--- /dev/null
+++ b/trinity-apps/tdebluez/tdebluez-14.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="never"
+
+TRINITY_LANGS="bg cs pl"
+
+TRINITY_MODULE_TYPE="applications/system"
+inherit trinity-base-2
+
+DESCRIPTION="Bluetooth control for TDE"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DEPEND="net-wireless/bluez
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+ trinity-base-2_src_configure
+}
diff --git a/trinity-apps/tdebluez/tdebluez-9999.ebuild b/trinity-apps/tdebluez/tdebluez-9999.ebuild
new file mode 100644
index 00000000..f06cb8ba
--- /dev/null
+++ b/trinity-apps/tdebluez/tdebluez-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="never"
+
+TRINITY_LANGS="bg cs pl"
+
+TRINITY_MODULE_TYPE="applications/system"
+inherit trinity-base-2
+
+DESCRIPTION="Bluetooth control for TDE"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DEPEND="net-wireless/bluez
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+ trinity-base-2_src_configure
+}
diff --git a/trinity-apps/tdeio-appinfo/Manifest b/trinity-apps/tdeio-appinfo/Manifest
new file mode 100644
index 00000000..8140153c
--- /dev/null
+++ b/trinity-apps/tdeio-appinfo/Manifest
@@ -0,0 +1 @@
+DIST tdeio-appinfo-trinity-14.1.0.tar.xz 13688 BLAKE2B 21c7e5d1df955387990da3d4595bdba3d10533f9d737055060496e969c078d442f3623633351a6a71c4c0e23b9fe54fa8c7146ab36c3094ae950c5c2212a5791 SHA512 19137110916e2efab9148bc1b2513a41c645113327b1d1a3c59cb444596622335604f0408b7dc71e714b0ab6e8b5c91d70d1496759aa7e92d8361cebfbaf21f3
diff --git a/trinity-apps/tdeio-appinfo/metadata.xml b/trinity-apps/tdeio-appinfo/metadata.xml
new file mode 100644
index 00000000..689e1534
--- /dev/null
+++ b/trinity-apps/tdeio-appinfo/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>team-gentoo@trinitydesktop.org</email>
+ <name>Trinity Gentoo ebuilds project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/trinity-apps/tdeio-appinfo/tdeio-appinfo-14.1.0.ebuild b/trinity-apps/tdeio-appinfo/tdeio-appinfo-14.1.0.ebuild
new file mode 100644
index 00000000..4c181d4a
--- /dev/null
+++ b/trinity-apps/tdeio-appinfo/tdeio-appinfo-14.1.0.ebuild
@@ -0,0 +1,17 @@
+# Copyright 2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_TYPE="applications/tdeio"
+inherit trinity-base-2
+
+DESCRIPTION="TDEIO slave for the appinfo protocol"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE=""
diff --git a/trinity-apps/tdeio-appinfo/tdeio-appinfo-9999.ebuild b/trinity-apps/tdeio-appinfo/tdeio-appinfo-9999.ebuild
new file mode 100644
index 00000000..37d468e5
--- /dev/null
+++ b/trinity-apps/tdeio-appinfo/tdeio-appinfo-9999.ebuild
@@ -0,0 +1,17 @@
+# Copyright 2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_TYPE="applications/tdeio"
+inherit trinity-base-2
+
+DESCRIPTION="TDEIO slave for the appinfo protocol"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~x86"
+fi
+IUSE=""
diff --git a/trinity-apps/tdepacman/Manifest b/trinity-apps/tdepacman/Manifest
new file mode 100644
index 00000000..7bd5dbaf
--- /dev/null
+++ b/trinity-apps/tdepacman/Manifest
@@ -0,0 +1 @@
+DIST tdepacman-trinity-14.1.0.tar.xz 109488 BLAKE2B 1198aec2d20b52ffddcb488587d0bdabe1273d6a76dc8a22a9573432d94bdfe0b78ffe7d7bda739f91a0b74035c8f8fdbbc89ec15bc7a3a670ebfc764419d77b SHA512 20ec80e10a38a94bf65fc859e8b89141ece5e494a08f78d62fa59c601a8ee2b81b3a15aaa84844a01794bbb51750672ab1f29bbe2b05c4051a63bb1282895bc7
diff --git a/trinity-apps/tdepacman/metadata.xml b/trinity-apps/tdepacman/metadata.xml
new file mode 100644
index 00000000..689e1534
--- /dev/null
+++ b/trinity-apps/tdepacman/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>team-gentoo@trinitydesktop.org</email>
+ <name>Trinity Gentoo ebuilds project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/trinity-apps/tdepacman/tdepacman-14.1.0.ebuild b/trinity-apps/tdepacman/tdepacman-14.1.0.ebuild
new file mode 100644
index 00000000..1d903e2d
--- /dev/null
+++ b/trinity-apps/tdepacman/tdepacman-14.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="de es he pt sv"
+TRINITY_MODULE_TYPE="applications/games"
+inherit trinity-base-2
+
+DESCRIPTION="A pacman game for the Trinity Desktop"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DEPEND="~trinity-base/libtdegames-${PV}"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+
+ trinity-base-2_src_configure
+}
diff --git a/trinity-apps/tdepacman/tdepacman-9999.ebuild b/trinity-apps/tdepacman/tdepacman-9999.ebuild
new file mode 100644
index 00000000..3e167f47
--- /dev/null
+++ b/trinity-apps/tdepacman/tdepacman-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="de es he pt sv"
+TRINITY_MODULE_TYPE="applications/games"
+inherit trinity-base-2
+
+DESCRIPTION="A pacman game for the Trinity Desktop"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DEPEND="~trinity-base/libtdegames-${PV}"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+
+ trinity-base-2_src_configure
+}
diff --git a/trinity-apps/tdesshaskpass/Manifest b/trinity-apps/tdesshaskpass/Manifest
new file mode 100644
index 00000000..30fa91d3
--- /dev/null
+++ b/trinity-apps/tdesshaskpass/Manifest
@@ -0,0 +1 @@
+DIST tdesshaskpass-trinity-14.1.0.tar.xz 11152 BLAKE2B 8b85338b7e303a313c98445c3e9757f9c65c1c4ebe6886dca002be5540943fe05a2ab3a68d2ecd587d8301b4c5f20601cc8dce656f01f120ba45e00727c16501 SHA512 8c25827da3070c9e0d7677b935030da64369a62d9d6c88f29e3b58952b3f8998d2ce8c1bdf8668d332778933d94e155f77af7e7a80cddd9c52795fdcc4cf3f28
diff --git a/trinity-apps/tdesshaskpass/metadata.xml b/trinity-apps/tdesshaskpass/metadata.xml
new file mode 100644
index 00000000..689e1534
--- /dev/null
+++ b/trinity-apps/tdesshaskpass/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>team-gentoo@trinitydesktop.org</email>
+ <name>Trinity Gentoo ebuilds project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/trinity-apps/tdesshaskpass/tdesshaskpass-14.1.0.ebuild b/trinity-apps/tdesshaskpass/tdesshaskpass-14.1.0.ebuild
new file mode 100644
index 00000000..d09dcee8
--- /dev/null
+++ b/trinity-apps/tdesshaskpass/tdesshaskpass-14.1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="never"
+
+TRINITY_LANGS=""
+
+TRINITY_MODULE_TYPE="applications/system"
+inherit trinity-base-2
+
+DESCRIPTION="Interactively prompt users for a passphrase for ssh-add"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DEPEND="dev-libs/openssl
+ net-dns/libidn
+ sys-apps/acl
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+ trinity-base-2_src_configure
+}
diff --git a/trinity-apps/tdesshaskpass/tdesshaskpass-9999.ebuild b/trinity-apps/tdesshaskpass/tdesshaskpass-9999.ebuild
new file mode 100644
index 00000000..1b80941f
--- /dev/null
+++ b/trinity-apps/tdesshaskpass/tdesshaskpass-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="never"
+
+TRINITY_LANGS=""
+
+TRINITY_MODULE_TYPE="applications/system"
+inherit trinity-base-2
+
+DESCRIPTION="Interactively prompt users for a passphrase for ssh-add"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DEPEND="dev-libs/openssl
+ net-dns/libidn
+ sys-apps/acl
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+ trinity-base-2_src_configure
+}
diff --git a/trinity-apps/twin-style-machbunt/Manifest b/trinity-apps/twin-style-machbunt/Manifest
new file mode 100644
index 00000000..c235c00c
--- /dev/null
+++ b/trinity-apps/twin-style-machbunt/Manifest
@@ -0,0 +1 @@
+DIST twin-style-machbunt-trinity-14.1.0.tar.xz 25340 BLAKE2B 86de62cc0257881b9f006e93e5dce8ade38231a89ebd0972b843f5360acc55c477019ddcec3440f1374b95d8d0ac61b1d9c58d5b8fecf567b0877bf18e7828b2 SHA512 26aba2882e5b81cb6a14e6f4f2c6fbbcb092040a92a86861bc0dbec86c0a1dc03f62bd1d316337b511fd0f4ccaaeb834b3552f6bb32c9ca2c54cbc6c1e7df1a3
diff --git a/trinity-apps/twin-style-machbunt/metadata.xml b/trinity-apps/twin-style-machbunt/metadata.xml
new file mode 100644
index 00000000..689e1534
--- /dev/null
+++ b/trinity-apps/twin-style-machbunt/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>team-gentoo@trinitydesktop.org</email>
+ <name>Trinity Gentoo ebuilds project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/trinity-apps/twin-style-machbunt/twin-style-machbunt-14.1.0.ebuild b/trinity-apps/twin-style-machbunt/twin-style-machbunt-14.1.0.ebuild
new file mode 100644
index 00000000..42c89967
--- /dev/null
+++ b/trinity-apps/twin-style-machbunt/twin-style-machbunt-14.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="never"
+
+TRINITY_LANGS=""
+
+TRINITY_MODULE_TYPE="applications/themes"
+inherit trinity-base-2
+
+DESCRIPTION="TWin decoration theme - machbunt"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DEPEND="~trinity-base/twin-${PV}"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+ trinity-base-2_src_configure
+}
diff --git a/trinity-apps/twin-style-machbunt/twin-style-machbunt-9999.ebuild b/trinity-apps/twin-style-machbunt/twin-style-machbunt-9999.ebuild
new file mode 100644
index 00000000..bb75ad60
--- /dev/null
+++ b/trinity-apps/twin-style-machbunt/twin-style-machbunt-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="never"
+
+TRINITY_LANGS=""
+
+TRINITY_MODULE_TYPE="applications/themes"
+inherit trinity-base-2
+
+DESCRIPTION="TWin decoration theme - machbunt"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DEPEND="~trinity-base/twin-${PV}"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+ trinity-base-2_src_configure
+}
diff --git a/trinity-base/polkit-tqt/Manifest b/trinity-base/polkit-tqt/Manifest
new file mode 100644
index 00000000..7a7fc82d
--- /dev/null
+++ b/trinity-base/polkit-tqt/Manifest
@@ -0,0 +1 @@
+DIST polkit-tqt-trinity-14.1.0.tar.xz 54156 BLAKE2B 3bc1506a8111fc91275f0b487bf0ee27d60cb9ce254083eae992dec6847caeb0b5fcdaac26a245602111467f22ddc32e2b6524ddebda819dea08e2086335fc3c SHA512 c10ccf7ed154209a434df9de66dac3ce95c1cc9a3255f082e66f506a665d0996adfab88c2daaad98cc68c9711e7e8b4577480d550a33e52136ceb7b83d05c1a2
diff --git a/trinity-base/polkit-tqt/metadata.xml b/trinity-base/polkit-tqt/metadata.xml
new file mode 100644
index 00000000..689e1534
--- /dev/null
+++ b/trinity-base/polkit-tqt/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>team-gentoo@trinitydesktop.org</email>
+ <name>Trinity Gentoo ebuilds project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/trinity-base/polkit-tqt/polkit-tqt-14.1.0.ebuild b/trinity-base/polkit-tqt/polkit-tqt-14.1.0.ebuild
new file mode 100644
index 00000000..c1fe1833
--- /dev/null
+++ b/trinity-base/polkit-tqt/polkit-tqt-14.1.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_TYPE="dependencies"
+inherit trinity-base-2
+
+DESCRIPTION="PolicyKit-tqt library"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE=""
+
+DEPEND="~dev-tqt/tqtinterface-${PV}
+"
+RDEPEND="${DEPEND}"
diff --git a/trinity-base/polkit-tqt/polkit-tqt-9999.ebuild b/trinity-base/polkit-tqt/polkit-tqt-9999.ebuild
new file mode 100644
index 00000000..943c1c09
--- /dev/null
+++ b/trinity-base/polkit-tqt/polkit-tqt-9999.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_TYPE="dependencies"
+inherit trinity-base-2
+
+DESCRIPTION="PolicyKit-tqt library"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~x86"
+fi
+IUSE=""
+
+DEPEND="~dev-tqt/tqtinterface-${PV}
+"
+RDEPEND="${DEPEND}"