summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2023-06-25 07:06:52 +0300
committerormorph <roma251078@mail.ru>2023-07-05 05:11:58 +0300
commitc704aa006b666ca063b57756e9111f238f5a21fa (patch)
tree16fd951f417e45f73d4a68194101c93239e91c0a
parentddec2f3c25dfb9858854be4d00ab63720442427a (diff)
downloadtde-packaging-gentoo-c704aa006b666ca063b57756e9111f238f5a21fa.tar.gz
tde-packaging-gentoo-c704aa006b666ca063b57756e9111f238f5a21fa.zip
Adding patches for ksysguard, kcheckpass and tdm for stable ebuilds, fix issue #299
This resolves FTBFS - see issue TDE/tde-packaging-gentoo#299. Adds detection and optionally a prototype for strlcat and strlcpy for ksysguard and kcheckpass. It also adds an include <sys/ioctl.h> for the ioctl() prototype in tdm. The absence of these prototypes results in a build error with some compilers. Signed-off-by: ormorph <roma251078@mail.ru>
-rw-r--r--trinity-base/kcheckpass/files/kcheckpass-strlcpy-14.0.13.patch54
-rw-r--r--trinity-base/kcheckpass/files/kcheckpass-strlcpy-14.1.0.patch54
-rw-r--r--trinity-base/kcheckpass/kcheckpass-14.0.13.ebuild5
-rw-r--r--trinity-base/kcheckpass/kcheckpass-14.1.0.ebuild5
-rw-r--r--trinity-base/ksysguard/files/ksysguard-strlcpy-14.0.13.patch54
-rw-r--r--trinity-base/ksysguard/files/ksysguard-strlcpy-14.1.0.patch54
-rw-r--r--trinity-base/ksysguard/ksysguard-14.0.13.ebuild5
-rw-r--r--trinity-base/ksysguard/ksysguard-14.1.0.ebuild5
-rw-r--r--trinity-base/tdm/files/tdm-ioctl.patch10
-rw-r--r--trinity-base/tdm/tdm-14.0.13.ebuild5
-rw-r--r--trinity-base/tdm/tdm-14.1.0.ebuild5
11 files changed, 256 insertions, 0 deletions
diff --git a/trinity-base/kcheckpass/files/kcheckpass-strlcpy-14.0.13.patch b/trinity-base/kcheckpass/files/kcheckpass-strlcpy-14.0.13.patch
new file mode 100644
index 00000000..c65d198e
--- /dev/null
+++ b/trinity-base/kcheckpass/files/kcheckpass-strlcpy-14.0.13.patch
@@ -0,0 +1,54 @@
+--- a/config.h.cmake 2023-07-04 20:26:16.401274149 +0300
++++ b/config.h.cmake 2023-07-04 20:29:24.692279031 +0300
+@@ -136,6 +136,33 @@
+ // kcontrol/input
+ #cmakedefine HAVE_LIBUSB 1
+
++// ksysguard, kcheckpass
++#cmakedefine HAVE_STRLCAT 1
++#cmakedefine HAVE_STRLCAT_PROTO 1
++#cmakedefine HAVE_STRLCPY 1
++#cmakedefine HAVE_STRLCPY_PROTO 1
++
++#if !defined(HAVE_STRLCAT_PROTO)
++#ifdef __cplusplus
++extern "C" {
++#endif
++unsigned long strlcat(char*, const char*, unsigned long);
++#ifdef __cplusplus
++}
++#endif
++#endif
++
++#if !defined(HAVE_STRLCPY_PROTO)
++#ifdef __cplusplus
++extern "C" {
++#endif
++unsigned long strlcpy(char*, const char*, unsigned long);
++#ifdef __cplusplus
++}
++#endif
++#endif
++
++
+ // tdeprint
+ #cmakedefine HAVE_SIGACTION 1
+ #cmakedefine HAVE_SIGSET 1
+--- a/ConfigureChecks.cmake 2023-07-04 20:26:16.400274149 +0300
++++ b/ConfigureChecks.cmake 2023-07-04 20:28:16.349277259 +0300
+@@ -389,6 +389,15 @@
+ endif( )
+
+
++# strlcat, strlcpy
++if( BUILD_KSYSGUARD OR BUILD_KCHECKPASS )
++ check_function_exists( strlcat HAVE_STRLCAT )
++ check_symbol_exists( strlcat "string.h" HAVE_STRLCAT_PROTO )
++ check_function_exists( strlcpy HAVE_STRLCPY )
++ check_symbol_exists( strlcpy "string.h" HAVE_STRLCPY_PROTO )
++endif( )
++
++
+ # getifaddrs (kcontrol, tdm)
+ if( BUILD_KCONTROL OR BUILD_TDM )
+ check_function_exists( getifaddrs HAVE_GETIFADDRS )
diff --git a/trinity-base/kcheckpass/files/kcheckpass-strlcpy-14.1.0.patch b/trinity-base/kcheckpass/files/kcheckpass-strlcpy-14.1.0.patch
new file mode 100644
index 00000000..8901b1b2
--- /dev/null
+++ b/trinity-base/kcheckpass/files/kcheckpass-strlcpy-14.1.0.patch
@@ -0,0 +1,54 @@
+--- a/config.h.cmake 2023-07-04 20:10:53.550250219 +0300
++++ b/config.h.cmake 2023-07-04 20:18:18.312261752 +0300
+@@ -130,6 +130,33 @@
+ // kcontrol/input
+ #cmakedefine HAVE_LIBUSB 1
+
++// ksysguard, kcheckpass
++#cmakedefine HAVE_STRLCAT 1
++#cmakedefine HAVE_STRLCAT_PROTO 1
++#cmakedefine HAVE_STRLCPY 1
++#cmakedefine HAVE_STRLCPY_PROTO 1
++
++#if !defined(HAVE_STRLCAT_PROTO)
++#ifdef __cplusplus
++extern "C" {
++#endif
++unsigned long strlcat(char*, const char*, unsigned long);
++#ifdef __cplusplus
++}
++#endif
++#endif
++
++#if !defined(HAVE_STRLCPY_PROTO)
++#ifdef __cplusplus
++extern "C" {
++#endif
++unsigned long strlcpy(char*, const char*, unsigned long);
++#ifdef __cplusplus
++}
++#endif
++#endif
++
++
+ // tdeprint
+ #cmakedefine HAVE_SIGACTION 1
+ #cmakedefine HAVE_SIGSET 1
+--- a/ConfigureChecks.cmake 2023-07-04 20:10:53.550250219 +0300
++++ b/ConfigureChecks.cmake 2023-07-04 20:16:46.905259381 +0300
+@@ -381,6 +381,15 @@
+ endif( )
+
+
++# strlcat, strlcpy
++if( BUILD_KSYSGUARD OR BUILD_KCHECKPASS )
++ check_function_exists( strlcat HAVE_STRLCAT )
++ check_symbol_exists( strlcat "string.h" HAVE_STRLCAT_PROTO )
++ check_function_exists( strlcpy HAVE_STRLCPY )
++ check_symbol_exists( strlcpy "string.h" HAVE_STRLCPY_PROTO )
++endif( )
++
++
+ # getifaddrs (kcontrol, tdm)
+ if( BUILD_KCONTROL OR BUILD_TDM )
+ check_function_exists( getifaddrs HAVE_GETIFADDRS )
diff --git a/trinity-base/kcheckpass/kcheckpass-14.0.13.ebuild b/trinity-base/kcheckpass/kcheckpass-14.0.13.ebuild
index 3cc6d933..16d0b919 100644
--- a/trinity-base/kcheckpass/kcheckpass-14.0.13.ebuild
+++ b/trinity-base/kcheckpass/kcheckpass-14.0.13.ebuild
@@ -17,6 +17,11 @@ IUSE="pam"
RDEPEND="pam? ( trinity-base/tdebase-pam )"
DEPEND="${RDEPEND}"
+src_prepare() {
+ eapply "${FILESDIR}/${PN}-strlcpy-${PV}.patch"
+ trinity-meta-2_src_prepare
+}
+
src_configure() {
local mycmakeargs=(
-DWITH_SHADOW=ON
diff --git a/trinity-base/kcheckpass/kcheckpass-14.1.0.ebuild b/trinity-base/kcheckpass/kcheckpass-14.1.0.ebuild
index 314c95bb..5dc52356 100644
--- a/trinity-base/kcheckpass/kcheckpass-14.1.0.ebuild
+++ b/trinity-base/kcheckpass/kcheckpass-14.1.0.ebuild
@@ -17,6 +17,11 @@ IUSE="pam"
RDEPEND="pam? ( trinity-base/tdebase-pam )"
DEPEND="${RDEPEND}"
+src_prepare() {
+ eapply "${FILESDIR}/${PN}-strlcpy-${PV}.patch"
+ trinity-meta-2_src_prepare
+}
+
src_configure() {
local mycmakeargs=(
-DWITH_SHADOW=ON
diff --git a/trinity-base/ksysguard/files/ksysguard-strlcpy-14.0.13.patch b/trinity-base/ksysguard/files/ksysguard-strlcpy-14.0.13.patch
new file mode 100644
index 00000000..c65d198e
--- /dev/null
+++ b/trinity-base/ksysguard/files/ksysguard-strlcpy-14.0.13.patch
@@ -0,0 +1,54 @@
+--- a/config.h.cmake 2023-07-04 20:26:16.401274149 +0300
++++ b/config.h.cmake 2023-07-04 20:29:24.692279031 +0300
+@@ -136,6 +136,33 @@
+ // kcontrol/input
+ #cmakedefine HAVE_LIBUSB 1
+
++// ksysguard, kcheckpass
++#cmakedefine HAVE_STRLCAT 1
++#cmakedefine HAVE_STRLCAT_PROTO 1
++#cmakedefine HAVE_STRLCPY 1
++#cmakedefine HAVE_STRLCPY_PROTO 1
++
++#if !defined(HAVE_STRLCAT_PROTO)
++#ifdef __cplusplus
++extern "C" {
++#endif
++unsigned long strlcat(char*, const char*, unsigned long);
++#ifdef __cplusplus
++}
++#endif
++#endif
++
++#if !defined(HAVE_STRLCPY_PROTO)
++#ifdef __cplusplus
++extern "C" {
++#endif
++unsigned long strlcpy(char*, const char*, unsigned long);
++#ifdef __cplusplus
++}
++#endif
++#endif
++
++
+ // tdeprint
+ #cmakedefine HAVE_SIGACTION 1
+ #cmakedefine HAVE_SIGSET 1
+--- a/ConfigureChecks.cmake 2023-07-04 20:26:16.400274149 +0300
++++ b/ConfigureChecks.cmake 2023-07-04 20:28:16.349277259 +0300
+@@ -389,6 +389,15 @@
+ endif( )
+
+
++# strlcat, strlcpy
++if( BUILD_KSYSGUARD OR BUILD_KCHECKPASS )
++ check_function_exists( strlcat HAVE_STRLCAT )
++ check_symbol_exists( strlcat "string.h" HAVE_STRLCAT_PROTO )
++ check_function_exists( strlcpy HAVE_STRLCPY )
++ check_symbol_exists( strlcpy "string.h" HAVE_STRLCPY_PROTO )
++endif( )
++
++
+ # getifaddrs (kcontrol, tdm)
+ if( BUILD_KCONTROL OR BUILD_TDM )
+ check_function_exists( getifaddrs HAVE_GETIFADDRS )
diff --git a/trinity-base/ksysguard/files/ksysguard-strlcpy-14.1.0.patch b/trinity-base/ksysguard/files/ksysguard-strlcpy-14.1.0.patch
new file mode 100644
index 00000000..8901b1b2
--- /dev/null
+++ b/trinity-base/ksysguard/files/ksysguard-strlcpy-14.1.0.patch
@@ -0,0 +1,54 @@
+--- a/config.h.cmake 2023-07-04 20:10:53.550250219 +0300
++++ b/config.h.cmake 2023-07-04 20:18:18.312261752 +0300
+@@ -130,6 +130,33 @@
+ // kcontrol/input
+ #cmakedefine HAVE_LIBUSB 1
+
++// ksysguard, kcheckpass
++#cmakedefine HAVE_STRLCAT 1
++#cmakedefine HAVE_STRLCAT_PROTO 1
++#cmakedefine HAVE_STRLCPY 1
++#cmakedefine HAVE_STRLCPY_PROTO 1
++
++#if !defined(HAVE_STRLCAT_PROTO)
++#ifdef __cplusplus
++extern "C" {
++#endif
++unsigned long strlcat(char*, const char*, unsigned long);
++#ifdef __cplusplus
++}
++#endif
++#endif
++
++#if !defined(HAVE_STRLCPY_PROTO)
++#ifdef __cplusplus
++extern "C" {
++#endif
++unsigned long strlcpy(char*, const char*, unsigned long);
++#ifdef __cplusplus
++}
++#endif
++#endif
++
++
+ // tdeprint
+ #cmakedefine HAVE_SIGACTION 1
+ #cmakedefine HAVE_SIGSET 1
+--- a/ConfigureChecks.cmake 2023-07-04 20:10:53.550250219 +0300
++++ b/ConfigureChecks.cmake 2023-07-04 20:16:46.905259381 +0300
+@@ -381,6 +381,15 @@
+ endif( )
+
+
++# strlcat, strlcpy
++if( BUILD_KSYSGUARD OR BUILD_KCHECKPASS )
++ check_function_exists( strlcat HAVE_STRLCAT )
++ check_symbol_exists( strlcat "string.h" HAVE_STRLCAT_PROTO )
++ check_function_exists( strlcpy HAVE_STRLCPY )
++ check_symbol_exists( strlcpy "string.h" HAVE_STRLCPY_PROTO )
++endif( )
++
++
+ # getifaddrs (kcontrol, tdm)
+ if( BUILD_KCONTROL OR BUILD_TDM )
+ check_function_exists( getifaddrs HAVE_GETIFADDRS )
diff --git a/trinity-base/ksysguard/ksysguard-14.0.13.ebuild b/trinity-base/ksysguard/ksysguard-14.0.13.ebuild
index 9c4f996e..77fcea3f 100644
--- a/trinity-base/ksysguard/ksysguard-14.0.13.ebuild
+++ b/trinity-base/ksysguard/ksysguard-14.0.13.ebuild
@@ -18,6 +18,11 @@ IUSE="dell-laptop lm-sensors"
DEPEND="lm-sensors? ( sys-apps/lm-sensors )"
RDEPEND="${DEPEND}"
+src_prepare() {
+ eapply "${FILESDIR}/${PN}-strlcpy-${PV}.patch"
+ trinity-meta-2_src_prepare
+}
+
src_configure() {
local mycmakeargs=(
-DWITH_I8K="$(usex dell-laptop)"
diff --git a/trinity-base/ksysguard/ksysguard-14.1.0.ebuild b/trinity-base/ksysguard/ksysguard-14.1.0.ebuild
index 6a47f295..5f6561d3 100644
--- a/trinity-base/ksysguard/ksysguard-14.1.0.ebuild
+++ b/trinity-base/ksysguard/ksysguard-14.1.0.ebuild
@@ -18,6 +18,11 @@ IUSE="dell-laptop lm-sensors"
DEPEND="lm-sensors? ( sys-apps/lm-sensors )"
RDEPEND="${DEPEND}"
+src_prepare() {
+ eapply "${FILESDIR}/${PN}-strlcpy-${PV}.patch"
+ trinity-meta-2_src_prepare
+}
+
src_configure() {
local mycmakeargs=(
-DWITH_I8K="$(usex dell-laptop)"
diff --git a/trinity-base/tdm/files/tdm-ioctl.patch b/trinity-base/tdm/files/tdm-ioctl.patch
new file mode 100644
index 00000000..3ca1a9ac
--- /dev/null
+++ b/trinity-base/tdm/files/tdm-ioctl.patch
@@ -0,0 +1,10 @@
+--- a/tdm/backend/ctrl.c 2023-07-04 20:45:46.142304481 +0300
++++ b/tdm/backend/ctrl.c 2023-07-04 20:46:57.086306320 +0300
+@@ -41,6 +41,7 @@
+ #include <string.h>
+ #include <signal.h>
+ #include <pwd.h>
++#include <sys/ioctl.h>
+ #include <sys/stat.h>
+
+ #ifdef __linux__
diff --git a/trinity-base/tdm/tdm-14.0.13.ebuild b/trinity-base/tdm/tdm-14.0.13.ebuild
index a8e8a3a2..6816b720 100644
--- a/trinity-base/tdm/tdm-14.0.13.ebuild
+++ b/trinity-base/tdm/tdm-14.0.13.ebuild
@@ -35,6 +35,11 @@ pkg_setup() {
use sak && TRINITY_SUBMODULE+=" tsak"
}
+src_prepare() {
+ eapply "${FILESDIR}/${PN}-ioctl.patch"
+ trinity-meta-2_src_prepare
+}
+
src_configure() {
local mycmakeargs=(
-DWITH_XTEST=ON
diff --git a/trinity-base/tdm/tdm-14.1.0.ebuild b/trinity-base/tdm/tdm-14.1.0.ebuild
index 1787b8af..7cdadc93 100644
--- a/trinity-base/tdm/tdm-14.1.0.ebuild
+++ b/trinity-base/tdm/tdm-14.1.0.ebuild
@@ -35,6 +35,11 @@ pkg_setup() {
use sak && TRINITY_SUBMODULE+=" tsak"
}
+src_prepare() {
+ eapply "${FILESDIR}/${PN}-ioctl.patch"
+ trinity-meta-2_src_prepare
+}
+
src_configure() {
local mycmakeargs=(
-DWITH_XTEST=ON