summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2023-04-16 22:32:33 +0300
committerormorph <roma251078@mail.ru>2023-04-16 22:32:33 +0300
commiteecab8428fd5b221de1aba5f79e0007e34483b43 (patch)
treebdfa0a9f4b1c70433dd8c6800e0bdfcf47865fed
parente4d748ee9352b89c4a3aed71273bf468156a760d (diff)
downloadtde-packaging-gentoo-eecab8428fd5b221de1aba5f79e0007e34483b43.tar.gz
tde-packaging-gentoo-eecab8428fd5b221de1aba5f79e0007e34483b43.zip
Fix shortcomings in dev-python/* ebuilds
Signed-off-by: ormorph <roma251078@mail.ru>
-rw-r--r--dev-python/pytde/pytde-9999.ebuild2
-rw-r--r--dev-python/python-tqt/python-tqt-14.0.13.ebuild2
-rw-r--r--dev-python/pytqt/pytqt-9999.ebuild2
-rw-r--r--dev-python/sip4-tqt/sip4-tqt-14.0.13.ebuild2
-rw-r--r--dev-python/sip4-tqt/sip4-tqt-9999.ebuild2
5 files changed, 10 insertions, 0 deletions
diff --git a/dev-python/pytde/pytde-9999.ebuild b/dev-python/pytde/pytde-9999.ebuild
index 87fcaebf..152b3517 100644
--- a/dev-python/pytde/pytde-9999.ebuild
+++ b/dev-python/pytde/pytde-9999.ebuild
@@ -9,12 +9,14 @@ PYTHON_COMPAT=( python3_{8..11} )
inherit trinity-base-2 python-single-r1
DESCRIPTION="Trinity bindings for Python - Development files and scripts"
+HOMEPAGE="https://trinitydesktop.org/"
LICENSE="GPL-2"
SLOT="0"
if [[ ${PV} != *9999* ]] ; then
KEYWORDS="~amd64 ~x86"
fi
IUSE="examples"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
DEPEND="${PYTHON_DEPS}
~dev-python/sip4-tqt-${PV}
diff --git a/dev-python/python-tqt/python-tqt-14.0.13.ebuild b/dev-python/python-tqt/python-tqt-14.0.13.ebuild
index deebd107..53c461c9 100644
--- a/dev-python/python-tqt/python-tqt-14.0.13.ebuild
+++ b/dev-python/python-tqt/python-tqt-14.0.13.ebuild
@@ -9,12 +9,14 @@ PYTHON_COMPAT=( python3_{8..11} )
inherit trinity-base-2 python-single-r1 flag-o-matic
DESCRIPTION="TQt bindings for Python"
+HOMEPAGE="https://trinitydesktop.org/"
LICENSE="GPL-2"
SLOT="0"
if [[ ${PV} != *9999* ]] ; then
KEYWORDS="~amd64 ~arm64 ~x86"
fi
IUSE="examples"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
DEPEND="${PYTHON_DEPS}
~dev-python/sip4-tqt-${PV}
diff --git a/dev-python/pytqt/pytqt-9999.ebuild b/dev-python/pytqt/pytqt-9999.ebuild
index ec7efe7b..be01e8c4 100644
--- a/dev-python/pytqt/pytqt-9999.ebuild
+++ b/dev-python/pytqt/pytqt-9999.ebuild
@@ -9,12 +9,14 @@ PYTHON_COMPAT=( python3_{8..11} )
inherit trinity-base-2 python-single-r1 flag-o-matic
DESCRIPTION="TQt bindings for Python"
+HOMEPAGE="https://trinitydesktop.org/"
LICENSE="GPL-2"
SLOT="0"
if [[ ${PV} != *9999* ]] ; then
KEYWORDS="~amd64 ~x86"
fi
IUSE="examples"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
DEPEND="${PYTHON_DEPS}
~dev-python/sip4-tqt-${PV}
diff --git a/dev-python/sip4-tqt/sip4-tqt-14.0.13.ebuild b/dev-python/sip4-tqt/sip4-tqt-14.0.13.ebuild
index 76339130..acef063a 100644
--- a/dev-python/sip4-tqt/sip4-tqt-14.0.13.ebuild
+++ b/dev-python/sip4-tqt/sip4-tqt-14.0.13.ebuild
@@ -9,12 +9,14 @@ PYTHON_COMPAT=( python3_{8..11} )
inherit trinity-base-2 python-single-r1 flag-o-matic
DESCRIPTION="Python/C++ bindings generator runtime library"
+HOMEPAGE="https://trinitydesktop.org"
LICENSE="|| ( GPL-2 GPL-3 SIP )"
SLOT="0"
if [[ ${PV} != *9999* ]] ; then
KEYWORDS="~amd64 ~arm64 ~x86"
fi
IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
DEPEND="${PYTHON_DEPS}
~x11-libs/tqscintilla-${PV}
diff --git a/dev-python/sip4-tqt/sip4-tqt-9999.ebuild b/dev-python/sip4-tqt/sip4-tqt-9999.ebuild
index 135d69d8..ae738967 100644
--- a/dev-python/sip4-tqt/sip4-tqt-9999.ebuild
+++ b/dev-python/sip4-tqt/sip4-tqt-9999.ebuild
@@ -9,12 +9,14 @@ PYTHON_COMPAT=( python3_{8..11} )
inherit trinity-base-2 python-single-r1 flag-o-matic
DESCRIPTION="Python/C++ bindings generator runtime library"
+HOMEPAGE="https://trinitydesktop.org"
LICENSE="|| ( GPL-2 GPL-3 SIP )"
SLOT="0"
if [[ ${PV} != *9999* ]] ; then
KEYWORDS="~amd64 ~x86"
fi
IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
DEPEND="${PYTHON_DEPS}
~x11-libs/tqscintilla-${PV}