summaryrefslogtreecommitdiffstats
path: root/trinity-apps
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2022-10-17 22:04:09 +0200
committerormorph <roma251078@mail.ru>2022-10-17 22:04:09 +0200
commit2dd5194acb3ed913442d970adb429b7fe98ece85 (patch)
tree27dd952ea9566f7f5125563bb4435bbdf6dca2cc /trinity-apps
parente33e21af26d64f01f1c47242e5654e5649e2a670 (diff)
downloadtde-packaging-gentoo-2dd5194acb3ed913442d970adb429b7fe98ece85.tar.gz
tde-packaging-gentoo-2dd5194acb3ed913442d970adb429b7fe98ece85.zip
Fixed koffice-i18n live build
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-apps')
-rw-r--r--trinity-apps/koffice-i18n/koffice-i18n-9999.ebuild32
1 files changed, 13 insertions, 19 deletions
diff --git a/trinity-apps/koffice-i18n/koffice-i18n-9999.ebuild b/trinity-apps/koffice-i18n/koffice-i18n-9999.ebuild
index 783a5f38..f3b7f5f8 100644
--- a/trinity-apps/koffice-i18n/koffice-i18n-9999.ebuild
+++ b/trinity-apps/koffice-i18n/koffice-i18n-9999.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
-# Copyright 2021 The Trinity Desktop Project
+# Copyright 1999-2022 Gentoo Authors
+# Copyright 2021-2022 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
EAPI="8"
TRINITY_MODULE_TYPE="applications/office"
-TRINITY_BUILD_ADMIN="yes"
inherit trinity-base-2
@@ -32,30 +31,25 @@ DEPEND="
"
RDEPEND="${DEPEND}"
-run_phase() {
- local lang dir phase;
- phase=${1}
- lang=${2}
+LINGUAS="en"
- dir="koffice-i18n-${lang}"
- pushd "${S}/${dir}" || die "No such dir: ${dir}"
- trinity-base-2_${phase}
- popd
+find_lang() {
+ local lang
+ lang=${1}
+ LINGUAS+=" ${lang}"
}
src_prepare() {
- trinity_l10n_for_each_locale_do run_phase src_prepare
- eapply_user
+ trinity_l10n_for_each_locale_do find_lang
+ trinity-base-2_src_prepare
}
src_configure() {
- trinity_l10n_for_each_locale_do run_phase src_configure
-}
-
-src_compile() {
- trinity_l10n_for_each_locale_do run_phase src_compile
+ local mycmakeargs=( -DBUILD_ALL=ON )
+ trinity-base-2_src_configure
}
src_install() {
- trinity_l10n_for_each_locale_do run_phase src_install
+ [[ "${LINGUAS}" == "en" ]] && return 0
+ trinity-base-2_src_install
}