summaryrefslogtreecommitdiffstats
path: root/trinity-base/kate
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2024-02-02 12:45:45 +0300
committerormorph <roma251078@mail.ru>2024-02-02 15:40:58 +0300
commitbbd4b5275b35a40309b56170bb9cccc7287dc164 (patch)
treef50db917c15e4ba6b8b4aee76ff1db35997d97d8 /trinity-base/kate
parenta196fb18265bf2648d4a81119de2b97260912ee2 (diff)
downloadtde-packaging-gentoo-bbd4b5275b35a40309b56170bb9cccc7287dc164.tar.gz
tde-packaging-gentoo-bbd4b5275b35a40309b56170bb9cccc7287dc164.zip
Added patches for compatibility with glibc-2.38
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-base/kate')
-rw-r--r--trinity-base/kate/files/tdebase-strlcpy.patch29
-rw-r--r--trinity-base/kate/kate-14.1.1.ebuild5
2 files changed, 34 insertions, 0 deletions
diff --git a/trinity-base/kate/files/tdebase-strlcpy.patch b/trinity-base/kate/files/tdebase-strlcpy.patch
new file mode 100644
index 00000000..c117154d
--- /dev/null
+++ b/trinity-base/kate/files/tdebase-strlcpy.patch
@@ -0,0 +1,29 @@
+--- a/ConfigureChecks.cmake 2023-11-13 20:24:40.136525876 +0300
++++ b/ConfigureChecks.cmake 2023-11-13 20:30:04.069534276 +0300
+@@ -23,6 +23,10 @@
+ find_package( TQt )
+ find_package( TDE )
+
++check_function_exists( strlcat HAVE_STRLCAT )
++check_symbol_exists( strlcat "string.h" HAVE_STRLCAT_PROTO )
++check_function_exists( strlcpy HAVE_STRLCPY )
++check_symbol_exists( strlcpy "string.h" HAVE_STRLCPY_PROTO )
+
+ ##### look for the usb.ids file, Its location can be set EG: -DWITH_USBIDS="/opt/share/misc/usb.ids"
+
+@@ -387,15 +391,6 @@
+ endif( )
+
+
+-# strlcat, strlcpy
+-if( BUILD_KSYSGUARD OR BUILD_KCHECKPASS )
+- check_function_exists( strlcat HAVE_STRLCAT )
+- check_symbol_exists( strlcat "string.h" HAVE_STRLCAT_PROTO )
+- check_function_exists( strlcpy HAVE_STRLCPY )
+- check_symbol_exists( strlcpy "string.h" HAVE_STRLCPY_PROTO )
+-endif( )
+-
+-
+ # getifaddrs (kcontrol, tdm)
+ if( BUILD_KCONTROL OR BUILD_TDM )
+ check_function_exists( getifaddrs HAVE_GETIFADDRS )
diff --git a/trinity-base/kate/kate-14.1.1.ebuild b/trinity-base/kate/kate-14.1.1.ebuild
index b2e2d532..40f26be1 100644
--- a/trinity-base/kate/kate-14.1.1.ebuild
+++ b/trinity-base/kate/kate-14.1.1.ebuild
@@ -12,3 +12,8 @@ DESCRIPTION="Kate is an MDI texteditor"
if [[ ${PV} != *9999* ]] ; then
KEYWORDS="~amd64 ~arm64 ~x86"
fi
+
+src_prepare() {
+ eapply "${FILESDIR}/tdebase-strlcpy.patch"
+ trinity-meta-2_src_prepare
+}