summaryrefslogtreecommitdiffstats
path: root/trinity-base/kturtle
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2023-10-27 13:50:17 +0300
committerormorph <roma251078@mail.ru>2023-10-27 13:50:17 +0300
commit18d39ed9f062321b596258a9137f10b3e93b71e0 (patch)
treefe24a566266198330ff71db390413fdf7a9d63af /trinity-base/kturtle
parentcd2192fbe2c90ea734db5bc716740b7dded481b6 (diff)
downloadtde-packaging-gentoo-18d39ed9f062321b596258a9137f10b3e93b71e0.tar.gz
tde-packaging-gentoo-18d39ed9f062321b596258a9137f10b3e93b71e0.zip
Release R14.1.1 added
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-base/kturtle')
-rw-r--r--trinity-base/kturtle/Manifest1
-rw-r--r--trinity-base/kturtle/kturtle-14.1.1.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/trinity-base/kturtle/Manifest b/trinity-base/kturtle/Manifest
index feb0e189..80b7129f 100644
--- a/trinity-base/kturtle/Manifest
+++ b/trinity-base/kturtle/Manifest
@@ -1 +1,2 @@
DIST tdeedu-trinity-14.1.0.tar.xz 24697508 BLAKE2B fa3002581d37481b9c7e55a83ac934988b04d9164992d96e3576498af2c3e402b9b917e3e55f74a9db7d356c8c7b101fd6185916aef54b75d0c6b9eb98f2f341 SHA512 eaeacde4ed27f455faaa42d730477e4ef94d02b9902efbd86aee3ff921fc7bf2069f60c63db7ce57b5c188308745ba449f711eafe466af3b00734fd176b4a57e
+DIST tdeedu-trinity-14.1.1.tar.xz 24697532 BLAKE2B 8a516c18a1dddc6a3fae01ad96df006fe60ad22515802ffc351fbc11fcc2cc9c347877b60790d44f538f5dc167a7b491f4083b1b2350489882f83676eb4a1cac SHA512 4216fdb31db332872bc09619feb9127944092495be4cc586d4e33d0df34d06658f3ba47b8baafd33c08f8f1a752ba6c8c828f16e1569a0b5b658477328cd28f2
diff --git a/trinity-base/kturtle/kturtle-14.1.1.ebuild b/trinity-base/kturtle/kturtle-14.1.1.ebuild
new file mode 100644
index 00000000..5fb21aa4
--- /dev/null
+++ b/trinity-base/kturtle/kturtle-14.1.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2022-2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_NAME="tdeedu"
+TRINITY_MODULE_TYPE="core"
+TRINITY_HANDBOOK="optional"
+TSM_EXTRACT_ALSO="translations"
+inherit trinity-meta-2
+
+DESCRIPTION="Educational Logo programming environment"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+src_prepare() {
+ sed -i -e '/add_subdirectory( applnk )/d' \
+ -e '/add_subdirectory( libtdeedu )/d' "${S}/CMakeLists.txt" || die
+ trinity-meta-2_src_prepare
+}