summaryrefslogtreecommitdiffstats
path: root/trinity-base/kwifimanager
diff options
context:
space:
mode:
authorChris <xchrisx@uber.space>2019-12-31 17:21:13 +0100
committerChris <xchrisx@uber.space>2019-12-31 17:21:13 +0100
commit55d2aaa4eb5201ac97e269fc141e4ee1778379b8 (patch)
tree810ece5e004aa9e97e26a1ad988ed52552175fb6 /trinity-base/kwifimanager
parent644110a847c5911c2eb04eb53c93031740561efc (diff)
downloadtde-packaging-gentoo-55d2aaa4eb5201ac97e269fc141e4ee1778379b8.tar.gz
tde-packaging-gentoo-55d2aaa4eb5201ac97e269fc141e4ee1778379b8.zip
Clean up and fix TDE Gentoo overlay.
- Remove old v3.5.13 ebuilds and eclasses - Change repo URL to official TGW - Remove old HAL and traces (TDEHW is used now) - Make split between TDE applications and tdebase consistent - Move TQt into own category (for users filtering dev-qt/ out) - Change to new TQTDIR var - Move away from virtual/pam dependency - Change to use new xorg-proto dependency - Some cosmetic fixes and removal of unneeded files - Remove some now obsolete patches - Change to clean 9999 naming scheme for anything - Add some potential workaround for newer portage versions - Add own README ... thanks to Aggi from IRC for some fixes too. Signed-off-by: Chris <xchrisx@uber.space>
Diffstat (limited to 'trinity-base/kwifimanager')
-rw-r--r--trinity-base/kwifimanager/Manifest1
-rw-r--r--trinity-base/kwifimanager/files/kwifimanager-fix-3.5.13.1.patch25
-rw-r--r--trinity-base/kwifimanager/kwifimanager-3.5.13.1.ebuild26
3 files changed, 0 insertions, 52 deletions
diff --git a/trinity-base/kwifimanager/Manifest b/trinity-base/kwifimanager/Manifest
deleted file mode 100644
index 1d49700d..00000000
--- a/trinity-base/kwifimanager/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST kdenetwork-3.5.13.1.tar.gz 8794225 SHA256 21e69e8cb2550561c26913a5cccdc376115f50cffd43f9a94f7a660a303f46f9 SHA512 b3189a9f5e9cddd130b24a82b95ef90db1ec3c7afa280a46101ba7cbf6f9d92f60a536401f648a96459ba87f70ede5f7ae4affe894515a8e858b40ee79cb1b69 WHIRLPOOL de678ab30e3aa8dc3068c895fd000fdab1bc046e272273bf44196a198210efab82ddde3c5e0ffaa863061e9c56e3a8a68ca2f8f03cd77136755f66688f878c65
diff --git a/trinity-base/kwifimanager/files/kwifimanager-fix-3.5.13.1.patch b/trinity-base/kwifimanager/files/kwifimanager-fix-3.5.13.1.patch
deleted file mode 100644
index 9e66af37..00000000
--- a/trinity-base/kwifimanager/files/kwifimanager-fix-3.5.13.1.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-diff --git a/wifi/ConfigureChecks.cmake b/wifi/ConfigureChecks.cmake
-index f3a7ddb..0d2972b 100644
---- a/wifi/ConfigureChecks.cmake
-+++ b/wifi/ConfigureChecks.cmake
-@@ -21,7 +21,9 @@ endif( )
-
-
- # check for wireless tools
-+set( CMAKE_REQUIRED_FLAGS "-lm" )
- check_library_exists( iw iw_get_stats "" HAVE_IW )
-+set( CMAKE_REQUIRED_FLAGS )
- if( HAVE_IW )
- check_include_file( iwlib.h HAVE_IWLIB_H )
- # we need at least wireless tools >= 27
-diff --git a/wifi/kwireless/CMakeLists.txt b/wifi/kwireless/CMakeLists.txt
-index 5acfb5a..3707722 100644
---- a/wifi/kwireless/CMakeLists.txt
-+++ b/wifi/kwireless/CMakeLists.txt
-@@ -33,5 +33,5 @@ tde_add_kpart( libkwireless AUTOMOC
- kwireless.cpp kwirelesswidget.cpp linuxwirelesswidget.cpp
- propertytablebase.ui propertytable.cpp
- LINK kdeui-shared ${IW_LIBRARY}
-- DESTINATION ${PLUGIN_INSTALL_DIR}
-+ DESTINATION ${LIB_INSTALL_DIR}
- )
diff --git a/trinity-base/kwifimanager/kwifimanager-3.5.13.1.ebuild b/trinity-base/kwifimanager/kwifimanager-3.5.13.1.ebuild
deleted file mode 100644
index ec388986..00000000
--- a/trinity-base/kwifimanager/kwifimanager-3.5.13.1.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-EAPI="5"
-TRINITY_MODULE_NAME="kdenetwork"
-TRINITY_SUBMODULE="wifi"
-inherit trinity-meta
-
-DESCRIPTION="Trinity wifi (wireless network) gui"
-KEYWORDS="amd64 x86"
-IUSE="arts"
-
-DEPEND="
- net-wireless/wireless-tools
- arts? ( trinity-base/arts )"
-RDEPEND="${DEPEND}"
-
-PATCHES=( "${FILESDIR}/kwifimanager-fix-3.5.13.1.patch" )
-
-src_configure() {
- mycmakeargs=(
- $(cmake-utils_use_with arts ARTS)
- )
-
- trinity-meta_src_configure
-}