summaryrefslogtreecommitdiffstats
path: root/trinity-base/tdegames-doc
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-11-28 02:34:44 +0100
committerSlávek Banko <slavek.banko@axis.cz>2019-11-28 02:34:44 +0100
commit644110a847c5911c2eb04eb53c93031740561efc (patch)
tree9658dde1cc70b52b233957b7852f87d997e98156 /trinity-base/tdegames-doc
downloadtde-packaging-gentoo-644110a847c5911c2eb04eb53c93031740561efc.tar.gz
tde-packaging-gentoo-644110a847c5911c2eb04eb53c93031740561efc.zip
Initial import of an ebuilds tree
from Fat-Zer's (Alexander Golubev) repository. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'trinity-base/tdegames-doc')
-rw-r--r--trinity-base/tdegames-doc/metadata.xml8
-rw-r--r--trinity-base/tdegames-doc/tdegames-doc-9999.ebuild27
2 files changed, 35 insertions, 0 deletions
diff --git a/trinity-base/tdegames-doc/metadata.xml b/trinity-base/tdegames-doc/metadata.xml
new file mode 100644
index 00000000..6e9f5e4a
--- /dev/null
+++ b/trinity-base/tdegames-doc/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>fatzer2@gmail.com</email>
+ <name>Alexander Golubev</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/trinity-base/tdegames-doc/tdegames-doc-9999.ebuild b/trinity-base/tdegames-doc/tdegames-doc-9999.ebuild
new file mode 100644
index 00000000..36295dd4
--- /dev/null
+++ b/trinity-base/tdegames-doc/tdegames-doc-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI="5"
+TRINITY_MODULE_NAME="tdegames"
+
+inherit trinity-meta
+
+DESCRIPTION="Documentaion for tdegames-derived packages"
+KEYWORDS=""
+IUSE+=""
+RDEPEND="
+ >=trinity-base/khelpcenter-${PV}:${SLOT}"
+
+pkg_setup() {
+ # we should reduce MAKEOPTS -j parametr to no more than 4
+ local makeopts_j
+ makeopts_j="$(echo "$MAKEOPTS" | sed -n 's/\(^\|.*\s\)\(-j\s*[0-9]\+\)\(\s.*\|$\)/\2/p')"
+ if [ -n "$makeopts_j" -a "$makeopts_j" > 4 ]; then
+ export MAKEOPTS="${MAKEOPTS//"${makeopts_j}"/-j4}"
+
+ ewarn "This ebuild needs huge amoumt of memmory to compile in highly parallel"
+ ewarn "mode so it can chew it all. MAKEOPTS are reduced to \"$MAKEOPTS\"."
+ fi
+
+ trinity-meta_pkg_setup
+}