summaryrefslogtreecommitdiffstats
path: root/trinity-base/tdelibs
diff options
context:
space:
mode:
authorChris <xchrisx@uber.space>2020-01-07 01:39:50 +0100
committerChris <xchrisx@uber.space>2020-01-07 01:39:50 +0100
commitc7cffbb46b70e1e148ffdc9a8cc90828e2139d9e (patch)
treea9c049298bea3c48ae999236dbfcc70889f1f1ae /trinity-base/tdelibs
parentb78e6201f889e463a82ab2ab8f6d1423a9b7c7f0 (diff)
downloadtde-packaging-gentoo-c7cffbb46b70e1e148ffdc9a8cc90828e2139d9e.tar.gz
tde-packaging-gentoo-c7cffbb46b70e1e148ffdc9a8cc90828e2139d9e.zip
Set back tdelibs live ebuild to EAPI5.
Signed-off-by: Chris <xchrisx@uber.space>
Diffstat (limited to 'trinity-base/tdelibs')
-rw-r--r--trinity-base/tdelibs/tdelibs-9999.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/trinity-base/tdelibs/tdelibs-9999.ebuild b/trinity-base/tdelibs/tdelibs-9999.ebuild
index d95ea4f5..94729ca8 100644
--- a/trinity-base/tdelibs/tdelibs-9999.ebuild
+++ b/trinity-base/tdelibs/tdelibs-9999.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="7"
-TRINITY_MODULE_NAME="$PN"
+EAPI="5"
+TRINITY_MODULE_NAME="tdelibs"
-inherit trinity-base-2 multilib
+inherit trinity-base multilib
set-trinityver
@@ -60,7 +61,7 @@ RDEPEND+=" ${MY_DEPEND}
src_configure() {
mycmakeargs=(
- -TDE_DMALLOC_FULL=ON
+ -DTDE_MALLOC_FULL=ON
-DWITH_LIBIDN=ON
-DWITH_SSL=ON
-DWITH_LIBART=ON
@@ -92,9 +93,6 @@ src_configure() {
-DWITH_SUDO_TDESU_BACKEND="$(usex sudo)"
)
-# -DWITH_XCURSOR=ON
-# -DKDE4_DEFAULT_HOME=.kde4
-
trinity-base_src_configure
}