summaryrefslogtreecommitdiffstats
path: root/trinity-base/tdepim-tdeioslaves/tdepim-tdeioslaves-9999.ebuild
diff options
context:
space:
mode:
authorChris <xchrisx@uber.space>2020-04-24 00:37:28 +0200
committerChris <xchrisx@uber.space>2020-04-24 00:37:28 +0200
commit55787e8078d5d241d95cf251fda8fff5b88164ae (patch)
tree23e3d4f7ea1daf613bd93012a1588921a4a0d617 /trinity-base/tdepim-tdeioslaves/tdepim-tdeioslaves-9999.ebuild
parent912f40ace9505c591e61e02a47e101c864c98bca (diff)
downloadtde-packaging-gentoo-55787e8078d5d241d95cf251fda8fff5b88164ae.tar.gz
tde-packaging-gentoo-55787e8078d5d241d95cf251fda8fff5b88164ae.zip
Live ebuilds: Add `KMail` and depending ebuilds.
- `libkpgp` - `libksieve` - `tdepim-tdeioslaves` Signed-off-by: Chris <xchrisx@uber.space>
Diffstat (limited to 'trinity-base/tdepim-tdeioslaves/tdepim-tdeioslaves-9999.ebuild')
-rw-r--r--trinity-base/tdepim-tdeioslaves/tdepim-tdeioslaves-9999.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/trinity-base/tdepim-tdeioslaves/tdepim-tdeioslaves-9999.ebuild b/trinity-base/tdepim-tdeioslaves/tdepim-tdeioslaves-9999.ebuild
new file mode 100644
index 00000000..828ac432
--- /dev/null
+++ b/trinity-base/tdepim-tdeioslaves/tdepim-tdeioslaves-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+TRINITY_MODULE_NAME="tdepim"
+
+inherit trinity-meta-2
+
+TSM_EXTRACT="tdeioslave"
+TRINITY_SUBMODULE="tdeioslave"
+
+DESCRIPTION="PIM Trinity TDEIOslaves"
+
+IUSE="sasl sieve"
+
+# The Sieve TDEIOslave won't build without SASL and
+# the IMAP4 TDEIOslave will lose the ability of SASL
+# authentification. To fulfill any expectation of users,
+# we offer two USE flags, which depend on each other.
+
+REQUIRED_USE="
+ sasl? ( sieve )
+ sieve? ( sasl )
+"
+
+DEPEND="
+ net-libs/libtirpc
+ trinity-base/libkmime
+ sasl? ( dev-libs/cyrus-sasl )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ -DWITH_SASL=$(usex sieve)
+ )
+
+ trinity-meta-2_src_configure
+}