summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xtrinity-base/tdelibs/files/tdelibs-malloc.patch11
-rw-r--r--trinity-base/tdelibs/tdelibs-14.0.13.ebuild3
2 files changed, 13 insertions, 1 deletions
diff --git a/trinity-base/tdelibs/files/tdelibs-malloc.patch b/trinity-base/tdelibs/files/tdelibs-malloc.patch
new file mode 100755
index 00000000..9e4ebeb5
--- /dev/null
+++ b/trinity-base/tdelibs/files/tdelibs-malloc.patch
@@ -0,0 +1,11 @@
+--- a/tdecore/malloc/malloc.c
++++ b/tdecore/malloc/malloc.c
+@@ -4306,7 +4306,7 @@
+ remainder_size = chunksize(p);
+
+ if (opts & 0x2) { /* optionally clear the elements */
+- memset(mem, 0, remainder_size - SIZE_SZ - array_size)
++ memset(mem, 0, remainder_size - SIZE_SZ - array_size);
+ }
+
+ /* If not provided, allocate the pointer array as final part of chunk */
diff --git a/trinity-base/tdelibs/tdelibs-14.0.13.ebuild b/trinity-base/tdelibs/tdelibs-14.0.13.ebuild
index fb4abe4b..df291768 100644
--- a/trinity-base/tdelibs/tdelibs-14.0.13.ebuild
+++ b/trinity-base/tdelibs/tdelibs-14.0.13.ebuild
@@ -78,7 +78,8 @@ RDEPEND="${DEPEND}
"
PATCHES=(
- "${FILESDIR}/tdelibs-backtrace.patch"
+ "${FILESDIR}/${PN}-backtrace.patch"
+ "${FILESDIR}/${PN}-malloc.patch"
)
src_configure() {