summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kima/kima-14.1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/kima/kima-14.1.1.ebuild')
-rw-r--r--trinity-apps/kima/kima-14.1.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/trinity-apps/kima/kima-14.1.1.ebuild b/trinity-apps/kima/kima-14.1.1.ebuild
new file mode 100644
index 00000000..3252a2e6
--- /dev/null
+++ b/trinity-apps/kima/kima-14.1.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Copyright 2020-2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="de es et hu id nl sv tr"
+TRINITY_MODULE_TYPE="applications/settings"
+inherit trinity-base-2
+
+DESCRIPTION="A Kicker monitoring applet"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+# NVControl support needs the nvidia-settings package,
+# which isn't in the Portage tree anymore. So if there
+# is interest, it could be imported to the overlay maybe.
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ -DWITH_NVCONTROL=OFF
+ )
+
+ trinity-base-2_src_configure
+}