summaryrefslogtreecommitdiffstats
path: root/trinity-base/kfax/kfax-14.1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-base/kfax/kfax-14.1.1.ebuild')
-rw-r--r--trinity-base/kfax/kfax-14.1.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/trinity-base/kfax/kfax-14.1.1.ebuild b/trinity-base/kfax/kfax-14.1.1.ebuild
new file mode 100644
index 00000000..b6f7f080
--- /dev/null
+++ b/trinity-base/kfax/kfax-14.1.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Copyright 2020-2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_NAME="tdegraphics"
+TRINITY_MODULE_TYPE="core"
+TRINITY_SUBMODULE="kfax kfaxview"
+TRINITY_HANDBOOK="optional"
+TSM_EXTRACT_ALSO="kviewshell"
+inherit trinity-meta-2
+
+DESCRIPTION="Trinity G3/G4 fax viewer"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DEPEND="~trinity-base/kviewshell-${PV}"
+RDEPEND="${DEPEND}"
+
+src_prepare(){
+ sed -i "s/BUILD_KVIEWSHELL OR BUILD_KDVI OR BUILD_KFAX/BUILD_KVIEWSHELL/" "${S}/doc/man/CMakeLists.txt" || die
+ trinity-meta-2_src_prepare
+}