summaryrefslogtreecommitdiffstats
path: root/trinity-base/ksysguard
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-base/ksysguard')
-rw-r--r--trinity-base/ksysguard/files/ksysguard-strlcpy-14.0.13.patch54
-rw-r--r--trinity-base/ksysguard/files/ksysguard-strlcpy-14.1.0.patch54
-rw-r--r--trinity-base/ksysguard/ksysguard-14.0.13.ebuild5
-rw-r--r--trinity-base/ksysguard/ksysguard-14.1.0.ebuild5
4 files changed, 118 insertions, 0 deletions
diff --git a/trinity-base/ksysguard/files/ksysguard-strlcpy-14.0.13.patch b/trinity-base/ksysguard/files/ksysguard-strlcpy-14.0.13.patch
new file mode 100644
index 00000000..c65d198e
--- /dev/null
+++ b/trinity-base/ksysguard/files/ksysguard-strlcpy-14.0.13.patch
@@ -0,0 +1,54 @@
+--- a/config.h.cmake 2023-07-04 20:26:16.401274149 +0300
++++ b/config.h.cmake 2023-07-04 20:29:24.692279031 +0300
+@@ -136,6 +136,33 @@
+ // kcontrol/input
+ #cmakedefine HAVE_LIBUSB 1
+
++// ksysguard, kcheckpass
++#cmakedefine HAVE_STRLCAT 1
++#cmakedefine HAVE_STRLCAT_PROTO 1
++#cmakedefine HAVE_STRLCPY 1
++#cmakedefine HAVE_STRLCPY_PROTO 1
++
++#if !defined(HAVE_STRLCAT_PROTO)
++#ifdef __cplusplus
++extern "C" {
++#endif
++unsigned long strlcat(char*, const char*, unsigned long);
++#ifdef __cplusplus
++}
++#endif
++#endif
++
++#if !defined(HAVE_STRLCPY_PROTO)
++#ifdef __cplusplus
++extern "C" {
++#endif
++unsigned long strlcpy(char*, const char*, unsigned long);
++#ifdef __cplusplus
++}
++#endif
++#endif
++
++
+ // tdeprint
+ #cmakedefine HAVE_SIGACTION 1
+ #cmakedefine HAVE_SIGSET 1
+--- a/ConfigureChecks.cmake 2023-07-04 20:26:16.400274149 +0300
++++ b/ConfigureChecks.cmake 2023-07-04 20:28:16.349277259 +0300
+@@ -389,6 +389,15 @@
+ endif( )
+
+
++# strlcat, strlcpy
++if( BUILD_KSYSGUARD OR BUILD_KCHECKPASS )
++ check_function_exists( strlcat HAVE_STRLCAT )
++ check_symbol_exists( strlcat "string.h" HAVE_STRLCAT_PROTO )
++ check_function_exists( strlcpy HAVE_STRLCPY )
++ check_symbol_exists( strlcpy "string.h" HAVE_STRLCPY_PROTO )
++endif( )
++
++
+ # getifaddrs (kcontrol, tdm)
+ if( BUILD_KCONTROL OR BUILD_TDM )
+ check_function_exists( getifaddrs HAVE_GETIFADDRS )
diff --git a/trinity-base/ksysguard/files/ksysguard-strlcpy-14.1.0.patch b/trinity-base/ksysguard/files/ksysguard-strlcpy-14.1.0.patch
new file mode 100644
index 00000000..8901b1b2
--- /dev/null
+++ b/trinity-base/ksysguard/files/ksysguard-strlcpy-14.1.0.patch
@@ -0,0 +1,54 @@
+--- a/config.h.cmake 2023-07-04 20:10:53.550250219 +0300
++++ b/config.h.cmake 2023-07-04 20:18:18.312261752 +0300
+@@ -130,6 +130,33 @@
+ // kcontrol/input
+ #cmakedefine HAVE_LIBUSB 1
+
++// ksysguard, kcheckpass
++#cmakedefine HAVE_STRLCAT 1
++#cmakedefine HAVE_STRLCAT_PROTO 1
++#cmakedefine HAVE_STRLCPY 1
++#cmakedefine HAVE_STRLCPY_PROTO 1
++
++#if !defined(HAVE_STRLCAT_PROTO)
++#ifdef __cplusplus
++extern "C" {
++#endif
++unsigned long strlcat(char*, const char*, unsigned long);
++#ifdef __cplusplus
++}
++#endif
++#endif
++
++#if !defined(HAVE_STRLCPY_PROTO)
++#ifdef __cplusplus
++extern "C" {
++#endif
++unsigned long strlcpy(char*, const char*, unsigned long);
++#ifdef __cplusplus
++}
++#endif
++#endif
++
++
+ // tdeprint
+ #cmakedefine HAVE_SIGACTION 1
+ #cmakedefine HAVE_SIGSET 1
+--- a/ConfigureChecks.cmake 2023-07-04 20:10:53.550250219 +0300
++++ b/ConfigureChecks.cmake 2023-07-04 20:16:46.905259381 +0300
+@@ -381,6 +381,15 @@
+ endif( )
+
+
++# strlcat, strlcpy
++if( BUILD_KSYSGUARD OR BUILD_KCHECKPASS )
++ check_function_exists( strlcat HAVE_STRLCAT )
++ check_symbol_exists( strlcat "string.h" HAVE_STRLCAT_PROTO )
++ check_function_exists( strlcpy HAVE_STRLCPY )
++ check_symbol_exists( strlcpy "string.h" HAVE_STRLCPY_PROTO )
++endif( )
++
++
+ # getifaddrs (kcontrol, tdm)
+ if( BUILD_KCONTROL OR BUILD_TDM )
+ check_function_exists( getifaddrs HAVE_GETIFADDRS )
diff --git a/trinity-base/ksysguard/ksysguard-14.0.13.ebuild b/trinity-base/ksysguard/ksysguard-14.0.13.ebuild
index 9c4f996e..77fcea3f 100644
--- a/trinity-base/ksysguard/ksysguard-14.0.13.ebuild
+++ b/trinity-base/ksysguard/ksysguard-14.0.13.ebuild
@@ -18,6 +18,11 @@ IUSE="dell-laptop lm-sensors"
DEPEND="lm-sensors? ( sys-apps/lm-sensors )"
RDEPEND="${DEPEND}"
+src_prepare() {
+ eapply "${FILESDIR}/${PN}-strlcpy-${PV}.patch"
+ trinity-meta-2_src_prepare
+}
+
src_configure() {
local mycmakeargs=(
-DWITH_I8K="$(usex dell-laptop)"
diff --git a/trinity-base/ksysguard/ksysguard-14.1.0.ebuild b/trinity-base/ksysguard/ksysguard-14.1.0.ebuild
index 6a47f295..5f6561d3 100644
--- a/trinity-base/ksysguard/ksysguard-14.1.0.ebuild
+++ b/trinity-base/ksysguard/ksysguard-14.1.0.ebuild
@@ -18,6 +18,11 @@ IUSE="dell-laptop lm-sensors"
DEPEND="lm-sensors? ( sys-apps/lm-sensors )"
RDEPEND="${DEPEND}"
+src_prepare() {
+ eapply "${FILESDIR}/${PN}-strlcpy-${PV}.patch"
+ trinity-meta-2_src_prepare
+}
+
src_configure() {
local mycmakeargs=(
-DWITH_I8K="$(usex dell-laptop)"