summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFran├žois Andriot <albator78@libertysurf.fr>2013-09-11 21:42:05 +0200
committerFran├žois Andriot <albator78@libertysurf.fr>2013-09-11 21:42:05 +0200
commitd8260a6ce3beb4f6aa74e66f9f9b56995a36d79e (patch)
treec9ce19741b0d33903ac7e6e267c5bcdeab17da8f
parentd27e5e6838cded96c7f11370af49a74f5bab0aa8 (diff)
parente52ee671cbb3dfd521892b659f54cb4e647aca3d (diff)
downloadtde-packaging-d8260a6ce3beb4f6aa74e66f9f9b56995a36d79e.tar.gz
tde-packaging-d8260a6ce3beb4f6aa74e66f9f9b56995a36d79e.zip
Merge branch 'master' of http://scm.trinitydesktop.org/scm/git/tde-packaging
-rwxr-xr-xdebian/lenny/applications/kcpuload/debian/rules9
-rw-r--r--debian/lenny/applications/koffice/debian/control28
-rw-r--r--debian/lenny/dependencies/arts/debian/patches/12_cleanup_artsc-config.diff4
-rwxr-xr-xdebian/lenny/dependencies/arts/debian/rules2
-rw-r--r--debian/lenny/dependencies/libcaldav/debian/source/format1
-rw-r--r--debian/lenny/dependencies/libcaldav/debian/source/options6
-rw-r--r--debian/lenny/dependencies/libcarddav/debian/source/format1
-rw-r--r--debian/lenny/dependencies/libcarddav/debian/source/options6
-rw-r--r--debian/lenny/dependencies/qt3/debian/control2
-rw-r--r--debian/lenny/dependencies/qt3/debian/patches/06_disable_rpath.diff12
-rw-r--r--debian/lenny/dependencies/tqt3/debian/control2
-rw-r--r--debian/lenny/dependencies/tqt3/debian/patches/06_disable_rpath.diff12
-rw-r--r--debian/lenny/libraries/python-trinity/debian/control6
-rw-r--r--debian/lenny/libraries/python-trinity/debian/pycompat1
-rwxr-xr-xdebian/lenny/libraries/python-trinity/debian/rules10
-rw-r--r--debian/lenny/tdebase/debian/control12
-rw-r--r--debian/lenny/tdebindings/debian/control8
-rw-r--r--debian/lenny/tdeedu/debian/control38
-rw-r--r--debian/lenny/tdegraphics/debian/control2
-rwxr-xr-xdebian/squeeze/applications/kcpuload/debian/rules9
-rw-r--r--debian/squeeze/applications/koffice/debian/control28
-rw-r--r--debian/squeeze/dependencies/arts/debian/patches/12_cleanup_artsc-config.diff4
-rwxr-xr-xdebian/squeeze/dependencies/arts/debian/rules2
-rw-r--r--debian/squeeze/dependencies/libcaldav/debian/source/format1
-rw-r--r--debian/squeeze/dependencies/libcaldav/debian/source/options6
-rw-r--r--debian/squeeze/dependencies/libcarddav/debian/source/format1
-rw-r--r--debian/squeeze/dependencies/libcarddav/debian/source/options6
-rw-r--r--debian/squeeze/dependencies/qt3/debian/control2
-rw-r--r--debian/squeeze/dependencies/qt3/debian/patches/06_disable_rpath.diff12
-rw-r--r--debian/squeeze/dependencies/tqt3/debian/control2
-rw-r--r--debian/squeeze/dependencies/tqt3/debian/patches/06_disable_rpath.diff12
-rw-r--r--debian/squeeze/libraries/python-trinity/debian/control6
-rw-r--r--debian/squeeze/libraries/python-trinity/debian/pycompat1
-rwxr-xr-xdebian/squeeze/libraries/python-trinity/debian/rules10
-rw-r--r--debian/squeeze/tdebase/debian/control12
-rw-r--r--debian/squeeze/tdebindings/debian/control8
-rw-r--r--debian/squeeze/tdeedu/debian/control38
-rw-r--r--debian/squeeze/tdegraphics/debian/control2
-rwxr-xr-xdebian/wheezy/applications/kcpuload/debian/rules9
-rw-r--r--debian/wheezy/applications/koffice/debian/control28
-rw-r--r--debian/wheezy/dependencies/arts/debian/patches/12_cleanup_artsc-config.diff4
-rwxr-xr-xdebian/wheezy/dependencies/arts/debian/rules2
-rw-r--r--debian/wheezy/dependencies/libcaldav/debian/source/format1
-rw-r--r--debian/wheezy/dependencies/libcaldav/debian/source/options6
-rw-r--r--debian/wheezy/dependencies/libcarddav/debian/source/format1
-rw-r--r--debian/wheezy/dependencies/libcarddav/debian/source/options6
-rw-r--r--debian/wheezy/dependencies/qt3/debian/control2
-rw-r--r--debian/wheezy/dependencies/qt3/debian/patches/06_disable_rpath.diff12
-rw-r--r--debian/wheezy/dependencies/tqt3/debian/control2
-rw-r--r--debian/wheezy/dependencies/tqt3/debian/patches/06_disable_rpath.diff12
-rw-r--r--debian/wheezy/libraries/python-trinity/debian/control6
-rw-r--r--debian/wheezy/libraries/python-trinity/debian/pycompat1
-rwxr-xr-xdebian/wheezy/libraries/python-trinity/debian/rules10
-rw-r--r--debian/wheezy/tdebase/debian/control12
-rw-r--r--debian/wheezy/tdebindings/debian/control8
-rw-r--r--debian/wheezy/tdeedu/debian/control38
-rw-r--r--debian/wheezy/tdegraphics/debian/control2
-rwxr-xr-xubuntu/maverick/applications/kcpuload/debian/rules9
-rw-r--r--ubuntu/maverick/applications/koffice/debian/control28
-rw-r--r--ubuntu/maverick/dependencies/arts/debian/patches/12_cleanup_artsc-config.diff4
-rwxr-xr-xubuntu/maverick/dependencies/arts/debian/rules2
-rw-r--r--ubuntu/maverick/dependencies/libcaldav/debian/source/format1
-rw-r--r--ubuntu/maverick/dependencies/libcaldav/debian/source/options6
-rw-r--r--ubuntu/maverick/dependencies/libcarddav/debian/source/format1
-rw-r--r--ubuntu/maverick/dependencies/libcarddav/debian/source/options6
-rw-r--r--ubuntu/maverick/dependencies/qt3/debian/control2
-rw-r--r--ubuntu/maverick/dependencies/qt3/debian/patches/06_disable_rpath.diff12
-rw-r--r--ubuntu/maverick/dependencies/tqt3/debian/control2
-rw-r--r--ubuntu/maverick/dependencies/tqt3/debian/patches/06_disable_rpath.diff12
-rw-r--r--ubuntu/maverick/libraries/python-trinity/debian/control6
-rw-r--r--ubuntu/maverick/libraries/python-trinity/debian/pycompat1
-rwxr-xr-xubuntu/maverick/libraries/python-trinity/debian/rules10
-rw-r--r--ubuntu/maverick/tdebase/debian/control12
-rw-r--r--ubuntu/maverick/tdebindings/debian/control8
-rw-r--r--ubuntu/maverick/tdeedu/debian/control38
-rw-r--r--ubuntu/maverick/tdegraphics/debian/control2
-rwxr-xr-xubuntu/precise/applications/kcpuload/debian/rules9
-rw-r--r--ubuntu/precise/applications/koffice/debian/control28
-rw-r--r--ubuntu/precise/dependencies/arts/debian/patches/12_cleanup_artsc-config.diff4
-rwxr-xr-xubuntu/precise/dependencies/arts/debian/rules2
-rw-r--r--ubuntu/precise/dependencies/libcaldav/debian/source/format1
-rw-r--r--ubuntu/precise/dependencies/libcaldav/debian/source/options6
-rw-r--r--ubuntu/precise/dependencies/libcarddav/debian/source/format1
-rw-r--r--ubuntu/precise/dependencies/libcarddav/debian/source/options6
-rw-r--r--ubuntu/precise/dependencies/qt3/debian/control2
-rw-r--r--ubuntu/precise/dependencies/qt3/debian/patches/06_disable_rpath.diff12
-rw-r--r--ubuntu/precise/dependencies/tqt3/debian/control2
-rw-r--r--ubuntu/precise/dependencies/tqt3/debian/patches/06_disable_rpath.diff12
-rw-r--r--ubuntu/precise/libraries/python-trinity/debian/control6
-rw-r--r--ubuntu/precise/libraries/python-trinity/debian/pycompat1
-rwxr-xr-xubuntu/precise/libraries/python-trinity/debian/rules10
-rw-r--r--ubuntu/precise/tdebase/debian/control12
-rw-r--r--ubuntu/precise/tdebindings/debian/control8
-rw-r--r--ubuntu/precise/tdeedu/debian/control38
-rw-r--r--ubuntu/precise/tdegraphics/debian/control2
-rwxr-xr-xubuntu/raring/applications/kcpuload/debian/rules9
-rw-r--r--ubuntu/raring/applications/koffice/debian/control28
-rw-r--r--ubuntu/raring/dependencies/arts/debian/patches/12_cleanup_artsc-config.diff4
-rwxr-xr-xubuntu/raring/dependencies/arts/debian/rules2
-rw-r--r--ubuntu/raring/dependencies/libcaldav/debian/source/format1
-rw-r--r--ubuntu/raring/dependencies/libcaldav/debian/source/options6
-rw-r--r--ubuntu/raring/dependencies/libcarddav/debian/source/format1
-rw-r--r--ubuntu/raring/dependencies/libcarddav/debian/source/options6
-rw-r--r--ubuntu/raring/dependencies/qt3/debian/control2
-rw-r--r--ubuntu/raring/dependencies/qt3/debian/patches/06_disable_rpath.diff12
-rw-r--r--ubuntu/raring/dependencies/tqt3/debian/control2
-rw-r--r--ubuntu/raring/dependencies/tqt3/debian/patches/06_disable_rpath.diff12
-rw-r--r--ubuntu/raring/libraries/python-trinity/debian/control6
-rw-r--r--ubuntu/raring/libraries/python-trinity/debian/pycompat1
-rwxr-xr-xubuntu/raring/libraries/python-trinity/debian/rules10
-rw-r--r--ubuntu/raring/tdebase/debian/control12
-rw-r--r--ubuntu/raring/tdebindings/debian/control8
-rw-r--r--ubuntu/raring/tdeedu/debian/control38
-rw-r--r--ubuntu/raring/tdegraphics/debian/control2
114 files changed, 516 insertions, 456 deletions
diff --git a/debian/lenny/applications/kcpuload/debian/rules b/debian/lenny/applications/kcpuload/debian/rules
index 20eca167c..385c24313 100755
--- a/debian/lenny/applications/kcpuload/debian/rules
+++ b/debian/lenny/applications/kcpuload/debian/rules
@@ -45,11 +45,6 @@ ifeq ($(DEB_BUILD_GNU_TYPE),i386-linux)
#export CXXFLAGS=-O3 -march=i686 -ffast-math -finline-functions
endif
--include debian/debiandirs
-
-debian/debiandirs: admin/debianrules
- perl -w admin/debianrules echodirs > debian/debiandirs
-
configure: configure-stamp
configure-stamp:
dh_testdir
@@ -104,7 +99,7 @@ debian-clean:
clean:
dh_testdir
dh_testroot
- rm -f build-stamp configure-stamp debian/debiandirs
+ rm -f build-stamp configure-stamp
# Remove Debian specific patches
if test -f patch-stamp; then \
@@ -169,8 +164,6 @@ binary-common:
dh_testroot
dh_installchangelogs kcpuload/ChangeLog
dh_installdocs
- mkdir debian/kcpuload-trinity/opt/trinity/share/doc
- mv debian/kcpuload-trinity/usr/share/doc/tde debian/kcpuload-trinity/opt/trinity/share/doc/
rm -fr debian/kcpuload-trinity/usr/share/doc-base
dh_installexamples
dh_installmanpages
diff --git a/debian/lenny/applications/koffice/debian/control b/debian/lenny/applications/koffice/debian/control
index f4000d836..ed66aecc6 100644
--- a/debian/lenny/applications/koffice/debian/control
+++ b/debian/lenny/applications/koffice/debian/control
@@ -61,7 +61,7 @@ Architecture: any
Section: graphics
Replaces: karbon-trinity (<< 4:14.0.0)
Breaks: karbon-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Description: a vector graphics application for the KDE Office Suite
Karbon is a vector graphics application.
.
@@ -72,7 +72,7 @@ Architecture: any
Section: tde
Replaces: kchart-trinity (<< 4:14.0.0)
Breaks: kchart-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: a chart drawing program for the KDE Office Suite [Trinity]
KChart is a chart drawing application. It can be used to embed charts
@@ -85,7 +85,7 @@ Architecture: any
Section: tde
Replaces: kexi-trinity (<< 4:14.0.0)
Breaks: kexi-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Suggests: kexi-mdb-plugin-trinity
Description: integrated database environment for the KDE Office Suite [Trinity]
Kexi is an integrated data management application. It can be used for
@@ -107,7 +107,7 @@ Architecture: any
Section: tde
Replaces: kformula-trinity (<< 4:14.0.0)
Breaks: kformula-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: a formula editor for the KDE Office Suite [Trinity]
KFormula is a formula editor that provides the basic input facilities
@@ -124,7 +124,7 @@ Architecture: any
Section: graphics
Replaces: kivio-trinity (<< 4:14.0.0)
Breaks: kivio-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, kivio-data-trinity (>> 1:1.4.90.2-1), kivio-data-trinity (>> ${KDE-Version3}), kivio-data-trinity (<< ${KDE-Next-Version3}), koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, kivio-data-trinity (>> 1:1.4.90.2-1), kivio-data-trinity (>> ${KDE-Version3}~), kivio-data-trinity (<< ${KDE-Next-Version3}~), koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Description: a flowcharting program for the KDE Office Suite [Trinity]
Kivio is a flowcharting program that offers basic flowcharting abilities,
but with a twist. Objects are scriptable, and a backend plugin system
@@ -150,7 +150,7 @@ Architecture: any
Section: tde
Replaces: koshell-trinity (<< 4:14.0.0)
Breaks: koshell-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: koffice-trinity, khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: the KDE Office Suite workspace [Trinity]
The KOffice workspace is a desktop with easy one-click launchers for
@@ -163,7 +163,7 @@ Architecture: any
Section: tde
Replaces: kplato-trinity (<< 4:14.0.0)
Breaks: kplato-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: an integrated project management and planning tool [Trinity]
KPlato is a project management application, allowing for the planning and
@@ -177,7 +177,7 @@ Architecture: any
Section: tde
Replaces: kpresenter-trinity (<< 4:14.0.0)
Breaks: kpresenter-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, ${perl:Depends}, kpresenter-data-trinity (>> ${KDE-Version3}), kpresenter-data-trinity (<< ${KDE-Next-Version3}), koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, ${perl:Depends}, kpresenter-data-trinity (>> ${KDE-Version3}~), kpresenter-data-trinity (<< ${KDE-Next-Version3}~), koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: a presentation program for the KDE Office Suite [Trinity]
KPresenter is a fully-featured presentation program. Presentations can
@@ -204,7 +204,7 @@ Architecture: any
Section: tde
Replaces: krita-trinity (<< 4:14.0.0), chalk-trinity (<< 4:14.0.0)
Breaks: krita-trinity (<< 4:14.0.0), chalk-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, chalk-data-trinity (>> ${KDE-Version3}), chalk-data-trinity (<< ${KDE-Next-Version3}), koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, chalk-data-trinity (>> ${KDE-Version3}~), chalk-data-trinity (<< ${KDE-Next-Version3}~), koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: dcraw, khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: a pixel-based image manipulation program for the KDE Office Suite [Trinity]
Chalk is a painting and image editing application for KOffice. Chalk contains
@@ -230,7 +230,7 @@ Architecture: any
Section: tde
Replaces: kspread-trinity (<< 4:14.0.0)
Breaks: kspread-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: a spreadsheet for the KDE Office Suite [Trinity]
KSpread is a powerful spreadsheet application. It is scriptable and
@@ -244,7 +244,7 @@ Architecture: any
Section: tde
Replaces: kugar-trinity (<< 4:14.0.0)
Breaks: kugar-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: a business report maker for the KDE Office Suite [Trinity]
Kugar is a tool for generating business quality reports that can
@@ -260,7 +260,7 @@ Architecture: any
Section: tde
Replaces: kword-trinity (<< 4:14.0.0)
Breaks: kword-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, kword-data-trinity (>> ${KDE-Version3}), kword-data-trinity (<< ${KDE-Next-Version3}), koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, kword-data-trinity (>> ${KDE-Version3}~), kword-data-trinity (<< ${KDE-Next-Version3}~), koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: a word processor for the KDE Office Suite [Trinity]
KWord is a FrameMaker-like word processing and desktop publishing
@@ -288,7 +288,7 @@ Architecture: any
Section: tde
Replaces: kthesaurus-trinity (<< 4:14.0.0)
Breaks: kthesaurus-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: thesaurus for the KDE Office Suite [Trinity]
KThesaurus lists words related to a given term and offers a user interface
@@ -302,7 +302,7 @@ Architecture: any
Section: libs
Replaces: koffice-libs-trinity (<< 4:14.0.0)
Breaks: koffice-libs-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-data-trinity (>> ${KDE-Version3}), koffice-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-data-trinity (>> ${KDE-Version3}~), koffice-data-trinity (<< ${KDE-Next-Version3}~)
Recommends: latex-xft-fonts, ruby, python
Suggests: wordnet, texlive-base
Description: common libraries and binaries for the KDE Office Suite [Trinity]
diff --git a/debian/lenny/dependencies/arts/debian/patches/12_cleanup_artsc-config.diff b/debian/lenny/dependencies/arts/debian/patches/12_cleanup_artsc-config.diff
index 603ffdf37..57a8122f9 100644
--- a/debian/lenny/dependencies/arts/debian/patches/12_cleanup_artsc-config.diff
+++ b/debian/lenny/dependencies/arts/debian/patches/12_cleanup_artsc-config.diff
@@ -1,3 +1,5 @@
+Index: b/artsc/artsc-config.in
+===================================================================
--- a/artsc/artsc-config.in
+++ b/artsc/artsc-config.in
@@ -27,7 +27,7 @@
@@ -8,4 +10,4 @@
+ flags="$flags -L$libdir -lartsc"
;;
--cflags)
- flags="$flags -I$includedir/artsc @GLIB_CFLAGS@"
+ flags="$flags -I$includedir @GLIB_CFLAGS@"
diff --git a/debian/lenny/dependencies/arts/debian/rules b/debian/lenny/dependencies/arts/debian/rules
index 9c9730bda..1b4911297 100755
--- a/debian/lenny/dependencies/arts/debian/rules
+++ b/debian/lenny/dependencies/arts/debian/rules
@@ -41,6 +41,6 @@ DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
binary-predeb/libarts1-trinity-dev::
ifeq (linux,$(DEB_HOST_ARCH_OS))
- echo "libasound2-trinity-dev=libasound2-trinity-dev" >> debian/libarts1-dev.substvars
+ echo "libasound2-dev=libasound2-dev" >> debian/libarts1-trinity-dev.substvars
endif
diff --git a/debian/lenny/dependencies/libcaldav/debian/source/format b/debian/lenny/dependencies/libcaldav/debian/source/format
new file mode 100644
index 000000000..89ae9db8f
--- /dev/null
+++ b/debian/lenny/dependencies/libcaldav/debian/source/format
@@ -0,0 +1 @@
+3.0 (native)
diff --git a/debian/lenny/dependencies/libcaldav/debian/source/options b/debian/lenny/dependencies/libcaldav/debian/source/options
new file mode 100644
index 000000000..72f1f5450
--- /dev/null
+++ b/debian/lenny/dependencies/libcaldav/debian/source/options
@@ -0,0 +1,6 @@
+# Use xz instead of gzip
+compression = "xz"
+compression-level = 9
+
+# Don't run differences
+diff-ignore = .*
diff --git a/debian/lenny/dependencies/libcarddav/debian/source/format b/debian/lenny/dependencies/libcarddav/debian/source/format
new file mode 100644
index 000000000..89ae9db8f
--- /dev/null
+++ b/debian/lenny/dependencies/libcarddav/debian/source/format
@@ -0,0 +1 @@
+3.0 (native)
diff --git a/debian/lenny/dependencies/libcarddav/debian/source/options b/debian/lenny/dependencies/libcarddav/debian/source/options
new file mode 100644
index 000000000..72f1f5450
--- /dev/null
+++ b/debian/lenny/dependencies/libcarddav/debian/source/options
@@ -0,0 +1,6 @@
+# Use xz instead of gzip
+compression = "xz"
+compression-level = 9
+
+# Don't run differences
+diff-ignore = .*
diff --git a/debian/lenny/dependencies/qt3/debian/control b/debian/lenny/dependencies/qt3/debian/control
index e10fbcab1..cf10bbb50 100644
--- a/debian/lenny/dependencies/qt3/debian/control
+++ b/debian/lenny/dependencies/qt3/debian/control
@@ -11,7 +11,7 @@ Build-Depends: debhelper (>= 5.0.31), quilt, cpio, libxext-dev (>= 4.3.0.dfsg.1-
libfreetype6-dev, libxft-dev, unixodbc-dev, uuid-dev, libglib2.0-dev,
libmysqlclient-dev, flex, libpq-dev, libaudio-dev, libcups2-dev,
libgl1-mesa-dev | libgl-dev, libglu1-mesa-dev | libglu-dev, libsqlite3-dev,
- firebird2.1-dev [i386 kfreebsd-i386 kfreebsd-amd64 knetbsd-i386 netbsd-i386 amd64 sparc powerpc] | firebird2-dev [i386 amd64]
+ firebird-dev | firebird2.1-dev [i386 kfreebsd-i386 kfreebsd-amd64 knetbsd-i386 netbsd-i386 amd64 sparc powerpc] | firebird2-dev [i386 amd64]
Section: libs
Priority: optional
Standards-Version: 3.8.4
diff --git a/debian/lenny/dependencies/qt3/debian/patches/06_disable_rpath.diff b/debian/lenny/dependencies/qt3/debian/patches/06_disable_rpath.diff
index 27fc1426c..a3d74ffce 100644
--- a/debian/lenny/dependencies/qt3/debian/patches/06_disable_rpath.diff
+++ b/debian/lenny/dependencies/qt3/debian/patches/06_disable_rpath.diff
@@ -2,25 +2,29 @@ author: Martin Loschwitz <madkiss@madkiss.org>
Disables the rpath settings in qmake.conf
+Index: b/mkspecs/linux-g++/qmake.conf
+===================================================================
--- a/mkspecs/linux-g++/qmake.conf
+++ b/mkspecs/linux-g++/qmake.conf
-@@ -55,7 +55,7 @@ QMAKE_LFLAGS_SHLIB = -shared
+@@ -55,7 +55,7 @@
QMAKE_LFLAGS_PLUGIN = $$QMAKE_LFLAGS_SHLIB
QMAKE_LFLAGS_SONAME = -Wl,-soname,
QMAKE_LFLAGS_THREAD =
-QMAKE_RPATH = -Wl,-rpath,
+QMAKE_RPATH =
- QMAKE_LIBS =
+ QMAKE_LIBS = -luuid
QMAKE_LIBS_DYNLOAD = -ldl
+Index: b/mkspecs/linux-g++-64/qmake.conf
+===================================================================
--- a/mkspecs/linux-g++-64/qmake.conf
+++ b/mkspecs/linux-g++-64/qmake.conf
-@@ -58,7 +58,7 @@ QMAKE_LFLAGS_SHLIB = -shared
+@@ -58,7 +58,7 @@
QMAKE_LFLAGS_PLUGIN = $$QMAKE_LFLAGS_SHLIB
QMAKE_LFLAGS_SONAME = -Wl,-soname,
QMAKE_LFLAGS_THREAD =
-QMAKE_RPATH = -Wl,-rpath,
+QMAKE_RPATH =
- QMAKE_LIBS =
+ QMAKE_LIBS = -luuid
QMAKE_LIBS_DYNLOAD = -ldl
diff --git a/debian/lenny/dependencies/tqt3/debian/control b/debian/lenny/dependencies/tqt3/debian/control
index 75c905a54..25b539b6b 100644
--- a/debian/lenny/dependencies/tqt3/debian/control
+++ b/debian/lenny/dependencies/tqt3/debian/control
@@ -11,7 +11,7 @@ Build-Depends: debhelper (>= 5.0.31), quilt, cpio, libxext-dev (>= 4.3.0.dfsg.1-
libfreetype6-dev, libxft-dev, unixodbc-dev, uuid-dev, libglib2.0-dev,
libmysqlclient-dev, flex, libpq-dev, libaudio-dev, libcups2-dev,
libgl1-mesa-dev | libgl-dev, libglu1-mesa-dev | libglu-dev, libsqlite3-dev,
- firebird2.1-dev [i386 kfreebsd-i386 kfreebsd-amd64 knetbsd-i386 netbsd-i386 amd64 sparc powerpc] | firebird2-dev [i386 amd64]
+ firebird-dev | firebird2.1-dev [i386 kfreebsd-i386 kfreebsd-amd64 knetbsd-i386 netbsd-i386 amd64 sparc powerpc] | firebird2-dev [i386 amd64]
Section: libs
Priority: optional
Standards-Version: 3.8.4
diff --git a/debian/lenny/dependencies/tqt3/debian/patches/06_disable_rpath.diff b/debian/lenny/dependencies/tqt3/debian/patches/06_disable_rpath.diff
index 27fc1426c..a3d74ffce 100644
--- a/debian/lenny/dependencies/tqt3/debian/patches/06_disable_rpath.diff
+++ b/debian/lenny/dependencies/tqt3/debian/patches/06_disable_rpath.diff
@@ -2,25 +2,29 @@ author: Martin Loschwitz <madkiss@madkiss.org>
Disables the rpath settings in qmake.conf
+Index: b/mkspecs/linux-g++/qmake.conf
+===================================================================
--- a/mkspecs/linux-g++/qmake.conf
+++ b/mkspecs/linux-g++/qmake.conf
-@@ -55,7 +55,7 @@ QMAKE_LFLAGS_SHLIB = -shared
+@@ -55,7 +55,7 @@
QMAKE_LFLAGS_PLUGIN = $$QMAKE_LFLAGS_SHLIB
QMAKE_LFLAGS_SONAME = -Wl,-soname,
QMAKE_LFLAGS_THREAD =
-QMAKE_RPATH = -Wl,-rpath,
+QMAKE_RPATH =
- QMAKE_LIBS =
+ QMAKE_LIBS = -luuid
QMAKE_LIBS_DYNLOAD = -ldl
+Index: b/mkspecs/linux-g++-64/qmake.conf
+===================================================================
--- a/mkspecs/linux-g++-64/qmake.conf
+++ b/mkspecs/linux-g++-64/qmake.conf
-@@ -58,7 +58,7 @@ QMAKE_LFLAGS_SHLIB = -shared
+@@ -58,7 +58,7 @@
QMAKE_LFLAGS_PLUGIN = $$QMAKE_LFLAGS_SHLIB
QMAKE_LFLAGS_SONAME = -Wl,-soname,
QMAKE_LFLAGS_THREAD =
-QMAKE_RPATH = -Wl,-rpath,
+QMAKE_RPATH =
- QMAKE_LIBS =
+ QMAKE_LIBS = -luuid
QMAKE_LIBS_DYNLOAD = -ldl
diff --git a/debian/lenny/libraries/python-trinity/debian/control b/debian/lenny/libraries/python-trinity/debian/control
index ef0d3115a..c69bdc5ea 100644
--- a/debian/lenny/libraries/python-trinity/debian/control
+++ b/debian/lenny/libraries/python-trinity/debian/control
@@ -4,17 +4,15 @@ Priority: optional
Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
XSBC-Original-Maintainer: Ricardo Javier Cardenes Medina <rcardenes@debian.org>
Uploaders: Torsten Marek <shlomme@debian.org>, Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
-Build-Depends: debhelper (>= 5.0.38), libtqtinterface-dev, python, python-all-dev, python-all-dbg, sip4 (>= 4.10), python-sip4-dev (>= 4.10), python-tqt-dev, tdelibs14-trinity-dev, python-support (>= 0.6) | python-dev (>= 2.6.6-3~), dpatch, python-sip4, python-sip4-dbg, python-sip4-dev
+Build-Depends: debhelper (>= 5.0.38), libtqtinterface-dev, python, python-all-dev, python-all-dbg, sip4 (>= 4.10), python-sip4-dev (>= 4.10), python-tqt-dev, tdelibs14-trinity-dev, python-sip4, python-sip4-dbg, python-sip4-dev
Standards-Version: 3.8.4
Homepage: http://www.riverbankcomputing.co.uk/pytde/index.php
-XS-Python-Version: all
Package: python-trinity-trinity
Architecture: any
Depends: ${shlibs:Depends}, ${python:Depends}, python-tqt
Replaces: python-trinity-trinity (<< 4:14.0.0)
Breaks: python-trinity-trinity (<< 4:14.0.0)
-XB-Python-Version: ${python:Versions}
Provides: ${python:Provides}
Conflicts: python-trinity-trinity
Description: Trinity bindings for Python [Trinity]
@@ -28,7 +26,6 @@ Architecture: any
Replaces: python-trinity-trinity-dbg (<< 4:14.0.0)
Breaks: python-trinity-trinity-dbg (<< 4:14.0.0)
Depends: python-trinity-trinity (= ${binary:Version}), python-dbg, python-tqt-dbg, ${shlibs:Depends}
-XB-Python-Version: ${python:Versions}
Description: Trinity bindings for Python (debug extensions) [Trinity]
Python binding module that provides wide access to the Trinity API,
also known as PyKDE. Using this, you'll get (for example) classes
@@ -42,7 +39,6 @@ Architecture: all
Replaces: python-trinity-trinity-dev (<< 4:14.0.0)
Breaks: python-trinity-trinity-dev (<< 4:14.0.0)
Depends: pytqt-tools, ${python:Depends}
-XB-Python-Version: ${python:Versions}
Description: Trinity bindings for Python - Development files and scripts [Trinity]
Development .sip files with definitions of PyKDE classes. They
are needed to build PyKDE, but also as building blocks of other
diff --git a/debian/lenny/libraries/python-trinity/debian/pycompat b/debian/lenny/libraries/python-trinity/debian/pycompat
deleted file mode 100644
index 0cfbf0888..000000000
--- a/debian/lenny/libraries/python-trinity/debian/pycompat
+++ /dev/null
@@ -1 +0,0 @@
-2
diff --git a/debian/lenny/libraries/python-trinity/debian/rules b/debian/lenny/libraries/python-trinity/debian/rules
index d4dac70f3..473caac7d 100755
--- a/debian/lenny/libraries/python-trinity/debian/rules
+++ b/debian/lenny/libraries/python-trinity/debian/rules
@@ -14,7 +14,6 @@ cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xine
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
-include /usr/share/dpatch/dpatch.make
# This has to be exported to make some magic below work.
export DH_OPTIONS
export QTDIR=/usr/share/qt3
@@ -31,8 +30,7 @@ endif
PYTHONS := $(shell pyversions -vr debian/control)
DBG_PYTHONS := $(shell pyversions -vd)
-DEB_PYTHON_SYSTEM = $(if $(wildcard /usr/bin/dh_python2),,pysupport)
-DH_PYTHON2 = $(if $(wildcard /usr/bin/dh_python2),dh_python2,dh_pysupport)
+DH_PYTHON2 = $(if $(wildcard /usr/bin/dh_python2),dh_python2,dh_python)
GCCVER := $(shell gcc --version | sed -n '/^gcc (GCC)/s/.*(GCC) \(...\).*/\1/p')
ifneq (,$(filter $(GCCVER),4.2 4.3))
@@ -45,7 +43,7 @@ endif
configure: $(PYTHONS:%=build-%/configure-stamp) $(DBG_PYTHONS:%=dbg-build-%/configure-stamp)
-build-%/configure-stamp: patch-stamp
+build-%/configure-stamp:
dh_testdir
mkdir -p build-$*
cd build-$* && python$* ../configure.py \
@@ -53,7 +51,7 @@ build-%/configure-stamp: patch-stamp
-v /opt/trinity/share/sip/trinity -j $(SPLIT)
touch $@
-dbg-build-%/configure-stamp: patch-stamp
+dbg-build-%/configure-stamp:
dh_testdir
mkdir -p dbg-build-$*
cd dbg-build-$* && python$*-dbg ../configure.py \
@@ -73,7 +71,7 @@ dbg-build-%/build-stamp: dbg-build-%/configure-stamp
$(MAKE) -C dbg-build-$*
touch $@
-clean: unpatch
+clean:
dh_testdir
dh_testroot
rm -f *-stamp
diff --git a/debian/lenny/tdebase/debian/control b/debian/lenny/tdebase/debian/control
index 42a65d9e3..51d256bed 100644
--- a/debian/lenny/tdebase/debian/control
+++ b/debian/lenny/tdebase/debian/control
@@ -88,7 +88,7 @@ Section: tde
Architecture: any
Replaces: kcontrol-trinity (<< 4:14.0.0)
Breaks: kcontrol-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdebase-data-trinity (>> ${KDE-Version3}), tdebase-data-trinity (<< ${KDE-Next-Version3}), usbutils
+Depends: ${shlibs:Depends}, tdebase-data-trinity (>> ${KDE-Version3}~), tdebase-data-trinity (<< ${KDE-Next-Version3}~), usbutils
Recommends: udev
Suggests: khelpcenter-trinity, ntpdate | ntp-simple
Conflicts: tdebase-libs-trinity (<< 4:3.0.0)
@@ -254,7 +254,7 @@ Section: tde
Architecture: any
Replaces: kdm-trinity (<< 4:14.0.0)
Breaks: kdm-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdebase-trinity-bin (= ${Source-Version}), tdebase-data-trinity (>> ${KDE-Version3}), tdebase-data-trinity (<< ${KDE-Next-Version3}), debconf (>= 1.2.9) | debconf-2.0, libpam-runtime (>= 0.76-14), xbase-clients
+Depends: ${shlibs:Depends}, tdebase-trinity-bin (= ${Source-Version}), tdebase-data-trinity (>> ${KDE-Version3}~), tdebase-data-trinity (<< ${KDE-Next-Version3}~), debconf (>= 1.2.9) | debconf-2.0, libpam-runtime (>= 0.76-14), xbase-clients
Recommends: logrotate, xserver-xorg
Suggests: khelpcenter-trinity, ksmserver-trinity (= ${Source-Version}), tdepasswd-trinity (= ${Source-Version}), menu
Provides: x-display-manager
@@ -313,7 +313,7 @@ Section: tde
Architecture: any
Replaces: kicker-trinity (<< 4:14.0.0)
Breaks: kicker-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdebase-data-trinity (>> ${KDE-Version3}), tdebase-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdebase-data-trinity (>> ${KDE-Version3}~), tdebase-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, kicker-applets-trinity, menu
Conflicts: tdebase-libs-trinity (<< 4:3.0.0)
Description: desktop panel for KDE
@@ -446,7 +446,7 @@ Section: tde
Architecture: any
Replaces: kpersonalizer-trinity (<< 4:14.0.0)
Breaks: kpersonalizer-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdebase-data-trinity (>> ${KDE-Version3}), tdebase-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdebase-data-trinity (>> ${KDE-Version3}~), tdebase-data-trinity (<< ${KDE-Next-Version3}~)
Description: installation personalizer for KDE
KDE Personalizer is the application that configures the KDE desktop for you.
It's a very useful wizard that allows you to quickly change the KDE desktop to
@@ -483,7 +483,7 @@ Section: tde
Architecture: any
Replaces: ksplash-trinity (<< 4:14.0.0)
Breaks: ksplash-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdebase-data-trinity (>> ${KDE-Version3}), tdebase-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdebase-data-trinity (>> ${KDE-Version3}~), tdebase-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity
Description: the KDE splash screen
This package includes the KDE Splash screen, which is seen when
@@ -540,7 +540,7 @@ Replaces: kwin-trinity (<< 4:14.0.0)
Breaks: kwin-trinity (<< 4:14.0.0)
Depends: ${shlibs:Depends}
Provides: x-window-manager
-Suggests: tdebase-trinity-bin (= ${Source-Version}), tdebase-data-trinity (>> ${KDE-Version3}), tdebase-data-trinity (<< ${KDE-Next-Version3}), kdesktop-trinity (= ${Source-Version}), kicker-trinity (= ${Source-Version}), kpager-trinity (= ${Source-Version}), kpersonalizer-trinity (= ${Source-Version}), ksmserver-trinity (= ${Source-Version}), ksplash-trinity (= ${Source-Version})
+Suggests: tdebase-trinity-bin (= ${Source-Version}), tdebase-data-trinity (>> ${KDE-Version3}~), tdebase-data-trinity (<< ${KDE-Next-Version3}~), kdesktop-trinity (= ${Source-Version}), kicker-trinity (= ${Source-Version}), kpager-trinity (= ${Source-Version}), kpersonalizer-trinity (= ${Source-Version}), ksmserver-trinity (= ${Source-Version}), ksplash-trinity (= ${Source-Version})
Conflicts: kde-window-manager-trinity (<< 7:3.5.0)
Description: the KDE window manager
This package contains the default X window manager for KDE.
diff --git a/debian/lenny/tdebindings/debian/control b/debian/lenny/tdebindings/debian/control
index 0bb4c4a0a..c561fffb0 100644
--- a/debian/lenny/tdebindings/debian/control
+++ b/debian/lenny/tdebindings/debian/control
@@ -29,7 +29,7 @@ Architecture: all
Section: libs
Replaces: libdcop3-java-trinity (<< 4:14.0.0)
Breaks: libdcop3-java-trinity (<< 4:14.0.0)
-Depends: libdcop3-jni-trinity (>> ${KDE-Version3}), libdcop3-jni-trinity (<< ${KDE-Next-Version3}), gij | java1-runtime | java2-runtime
+Depends: libdcop3-jni-trinity (>> ${KDE-Version3}~), libdcop3-jni-trinity (<< ${KDE-Next-Version3}~), gij | java1-runtime | java2-runtime
Description: DCOP bindings for Java [Trinity]
This package contains the Java classes necessary to run Java programs
using the Java DCOP bindings. DCOP is the TDE Desktop COmmunications
@@ -56,7 +56,7 @@ Architecture: amd64 i386 ia64 powerpc s390 sparc
Section: libdevel
Replaces: libdcop3-java-trinity-dev (<< 4:14.0.0)
Breaks: libdcop3-java-trinity-dev (<< 4:14.0.0)
-Depends: libdcop3-java-trinity (>> ${KDE-Version3}), libdcop3-java-trinity (<< ${KDE-Next-Version3})
+Depends: libdcop3-java-trinity (>> ${KDE-Version3}~), libdcop3-java-trinity (<< ${KDE-Next-Version3}~)
Description: DCOP bindings for Java (dcopidl2java program) [Trinity]
This package contains the dcopidl2java program which generates Java
stubs from DCOP IDL files, necessary to do development with the DCOP Java
@@ -70,7 +70,7 @@ Architecture: all
Section: libs
Replaces: libqt3-java-trinity (<< 4:14.0.0)
Breaks: libqt3-java-trinity (<< 4:14.0.0)
-Depends: libqt3-jni-trinity (>> ${KDE-Version3}), libqt3-jni-trinity (<< ${KDE-Next-Version3}), gij | java1-runtime | java2-runtime
+Depends: libqt3-jni-trinity (>> ${KDE-Version3}~), libqt3-jni-trinity (<< ${KDE-Next-Version3}~), gij | java1-runtime | java2-runtime
Suggests: juic-trinity
Description: Java bindings for Qt [Trinity]
This package contains the Java classes necessary to run Java programs
@@ -100,7 +100,7 @@ Architecture: all
Section: libs
Replaces: libtrinity-java-trinity (<< 4:14.0.0)
Breaks: libtrinity-java-trinity (<< 4:14.0.0)
-Depends: libtrinity-jni-trinity (>> ${KDE-Version3}), libtrinity-jni-trinity (<< ${KDE-Next-Version3}), gij | java1-runtime | java2-runtime
+Depends: libtrinity-jni-trinity (>> ${KDE-Version3}~), libtrinity-jni-trinity (<< ${KDE-Next-Version3}~), gij | java1-runtime | java2-runtime
Description: tdelibs bindings for Java [Trinity]
This package contains the Java classes necessary to run Java programs
using the Java tdelibs bindings. TDE is the Trinity Desktop Environment, a
diff --git a/debian/lenny/tdeedu/debian/control b/debian/lenny/tdeedu/debian/control
index b8323cf70..9b00cc54f 100644
--- a/debian/lenny/tdeedu/debian/control
+++ b/debian/lenny/tdeedu/debian/control
@@ -74,7 +74,7 @@ Architecture: any
Section: games
Replaces: blinken-trinity (<< 4:14.0.0)
Breaks: blinken-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, ttf-sjfonts, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, ttf-sjfonts, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: Trinity version of the Simon Says electronic memory game
Blinken is based on an electronic game released in 1978, which
@@ -94,7 +94,7 @@ Architecture: any
Section: science
Replaces: kalzium-trinity (<< 4:14.0.0)
Breaks: kalzium-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, kalzium-data-trinity (>> ${KDE-Version3}), kalzium-data-trinity (<< ${KDE-Next-Version3}), tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, kalzium-data-trinity (>> ${KDE-Version3}~), kalzium-data-trinity (<< ${KDE-Next-Version3}~), tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: chemistry teaching tool for Trinity
Kalzium is a program which shows you the Periodic System of Elements
@@ -137,7 +137,7 @@ Architecture: any
Section: games
Replaces: kanagram-trinity (<< 4:14.0.0)
Breaks: kanagram-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: letter order game for Trinity
KAnagram is a game that is based on the word/letter puzzles that the
@@ -160,7 +160,7 @@ Architecture: any
Section: math
Replaces: kbruch-trinity (<< 4:14.0.0)
Breaks: kbruch-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: fraction calculation teaching tool for Trinity
KBruch is a small program to practice calculating with fractions.
@@ -175,7 +175,7 @@ Architecture: any
Section: tde
Replaces: keduca-trinity (<< 4:14.0.0)
Breaks: keduca-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: interactive form-based tests for Trinity
KEduca is a flash-card application which allows you to make
@@ -189,7 +189,7 @@ Architecture: any
Section: tde
Replaces: kgeography-trinity (<< 4:14.0.0)
Breaks: kgeography-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, kgeography-data-trinity (>> ${KDE-Version3}), kgeography-data-trinity (<< ${KDE-Next-Version3}), tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, kgeography-data-trinity (>> ${KDE-Version3}~), kgeography-data-trinity (<< ${KDE-Next-Version3}~), tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: Geography learning tool for Trinity
KGeography contains maps allowing you to learn various countries or
@@ -220,7 +220,7 @@ Architecture: any
Section: games
Replaces: khangman-trinity (<< 4:14.0.0)
Breaks: khangman-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, ttf-dustin, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, ttf-dustin, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: the classical hangman game for Trinity
KHangMan is a game based on the well known hangman game. It is aimed
@@ -240,7 +240,7 @@ Architecture: any
Section: math
Replaces: kig-trinity (<< 4:14.0.0)
Breaks: kig-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: interactive geometry program for KDE
Kig is an application for interactive geometry. It is intended to
@@ -268,7 +268,7 @@ Architecture: any
Section: tde
Replaces: kiten-trinity (<< 4:14.0.0)
Breaks: kiten-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3}), ttf-kochi-gothic | ttf-kochi-mincho
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~), ttf-kochi-gothic | ttf-kochi-mincho
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: Japanese reference/study tool for Trinity
Kiten is a Japanese reference and study tool for KDE. It is an
@@ -285,7 +285,7 @@ Architecture: any
Section: tde
Replaces: klatin-trinity (<< 4:14.0.0)
Breaks: klatin-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: application to help revise/teach Latin
KLatin is a program to help revise Latin. There are three "sections"
@@ -310,7 +310,7 @@ Architecture: any
Section: tde
Replaces: klettres-trinity (<< 4:14.0.0)
Breaks: klettres-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, klettres-data-trinity (>> ${KDE-Version3}), klettres-data-trinity (<< ${KDE-Next-Version3}), tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, klettres-data-trinity (>> ${KDE-Version3}~), klettres-data-trinity (<< ${KDE-Next-Version3}~), tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: foreign alphabet tutor for Trinity
KLettres is an application specially designed to help the user to
@@ -344,7 +344,7 @@ Architecture: any
Section: math
Replaces: kmplot-trinity (<< 4:14.0.0)
Breaks: kmplot-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: mathematical function plotter for Trinity
KmPlot is a mathematical function plotter for KDE. It has a powerful
@@ -368,7 +368,7 @@ Architecture: any
Section: math
Replaces: kpercentage-trinity (<< 4:14.0.0)
Breaks: kpercentage-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: percentage calculation teaching tool for Trinity
KPercentage is a small math application that will help pupils to
@@ -386,7 +386,7 @@ Architecture: any
Section: science
Replaces: kstars-trinity (<< 4:14.0.0)
Breaks: kstars-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, kstars-data-trinity (>> ${KDE-Version3}), kstars-data-trinity (<< ${KDE-Next-Version3}), tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3}), indi-trinity (= ${Source-Version})
+Depends: ${shlibs:Depends}, kstars-data-trinity (>> ${KDE-Version3}~), kstars-data-trinity (<< ${KDE-Next-Version3}~), tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~), indi-trinity (= ${Source-Version})
Suggests: konqueror-trinity, khelpcenter-trinity, tdeedu-trinity-doc-html
Description: desktop planetarium for Trinity
KStars is a graphical desktop planetarium for KDE. It depicts an
@@ -424,7 +424,7 @@ Architecture: any
Section: tde
Replaces: ktouch-trinity (<< 4:14.0.0)
Breaks: ktouch-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: touch typing tutor for Trinity
KTouch is a program for learning touch typing - it helps you learn to
@@ -444,7 +444,7 @@ Architecture: any
Section: devel
Replaces: kturtle-trinity (<< 4:14.0.0)
Breaks: kturtle-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: educational Logo programming environment
KTurtle is an educational programming environment using the Logo
@@ -472,7 +472,7 @@ Architecture: any
Section: tde
Replaces: kverbos-trinity (<< 4:14.0.0)
Breaks: kverbos-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: Spanish verb form study application for Trinity
Kverbos allows the user to learn the forms of Spanish verbs. The
@@ -491,7 +491,7 @@ Architecture: any
Section: tde
Replaces: kvoctrain-trinity (<< 4:14.0.0)
Breaks: kvoctrain-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, ${perl:Depends}, libwww-perl, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, ${perl:Depends}, libwww-perl, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: vocabulary trainer for Trinity
KVocTrain is a little utility to help you train your vocabulary when
@@ -517,7 +517,7 @@ Architecture: any
Section: tde
Replaces: kwordquiz-trinity (<< 4:14.0.0)
Breaks: kwordquiz-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: flashcard and vocabulary learning program for Trinity
KWordQuiz is a flashcard-based tool that helps you to master new
diff --git a/debian/lenny/tdegraphics/debian/control b/debian/lenny/tdegraphics/debian/control
index db36d2eea..ea835feac 100644
--- a/debian/lenny/tdegraphics/debian/control
+++ b/debian/lenny/tdegraphics/debian/control
@@ -4,7 +4,7 @@ Priority: optional
Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
XSBC-Original-Maintainer: Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
Uploaders: Ana Beatriz Guerrero Lopez <ana@debian.org>, Francesco Pedrini <francesco.pedrini@gmail.com>, Josh Metzler <joshdeb@metzlers.org>, Sune Vuorela <debian@pusling.com>
-Build-Depends: imlib11-dev, cdbs (>= 0.4.39-0.1), debhelper (>= 5.0.31), autotools-dev, gawk, gettext, tdelibs14-trinity-dev, libexif-dev (>= 0.6.9-1), libfribidi-dev, freeglut3-dev, libgphoto2-2-dev, libopenexr-dev (>= 1.2.1), libpaper-dev, libpoppler-dev, libsane-dev (>> 1.0.15), libtiff-dev, libtiff-tools, libusb-dev, sharutils, libxxf86vm-dev, chrpath [powerpc], cmake, libtool, libltdl-dev
+Build-Depends: imlib11-dev, cdbs (>= 0.4.39-0.1), debhelper (>= 5.0.31), autotools-dev, gawk, gettext, tdelibs14-trinity-dev, libexif-dev (>= 0.6.9-1), libfribidi-dev, freeglut3-dev, libgphoto2-6-dev | libgphoto2-2-dev, libopenexr-dev (>= 1.2.1), libpaper-dev, libpoppler-private-dev | libpoppler-dev (<< 0.18.4-3), libpoppler-dev, libsane-dev (>> 1.0.15), libtiff-dev, libtiff-tools, libusb-dev, sharutils, libxxf86vm-dev, chrpath [powerpc], cmake, libtool, libltdl-dev
Standards-Version: 3.8.4
Package: tdegraphics-trinity
diff --git a/debian/squeeze/applications/kcpuload/debian/rules b/debian/squeeze/applications/kcpuload/debian/rules
index 20eca167c..385c24313 100755
--- a/debian/squeeze/applications/kcpuload/debian/rules
+++ b/debian/squeeze/applications/kcpuload/debian/rules
@@ -45,11 +45,6 @@ ifeq ($(DEB_BUILD_GNU_TYPE),i386-linux)
#export CXXFLAGS=-O3 -march=i686 -ffast-math -finline-functions
endif
--include debian/debiandirs
-
-debian/debiandirs: admin/debianrules
- perl -w admin/debianrules echodirs > debian/debiandirs
-
configure: configure-stamp
configure-stamp:
dh_testdir
@@ -104,7 +99,7 @@ debian-clean:
clean:
dh_testdir
dh_testroot
- rm -f build-stamp configure-stamp debian/debiandirs
+ rm -f build-stamp configure-stamp
# Remove Debian specific patches
if test -f patch-stamp; then \
@@ -169,8 +164,6 @@ binary-common:
dh_testroot
dh_installchangelogs kcpuload/ChangeLog
dh_installdocs
- mkdir debian/kcpuload-trinity/opt/trinity/share/doc
- mv debian/kcpuload-trinity/usr/share/doc/tde debian/kcpuload-trinity/opt/trinity/share/doc/
rm -fr debian/kcpuload-trinity/usr/share/doc-base
dh_installexamples
dh_installmanpages
diff --git a/debian/squeeze/applications/koffice/debian/control b/debian/squeeze/applications/koffice/debian/control
index f4000d836..ed66aecc6 100644
--- a/debian/squeeze/applications/koffice/debian/control
+++ b/debian/squeeze/applications/koffice/debian/control
@@ -61,7 +61,7 @@ Architecture: any
Section: graphics
Replaces: karbon-trinity (<< 4:14.0.0)
Breaks: karbon-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Description: a vector graphics application for the KDE Office Suite
Karbon is a vector graphics application.
.
@@ -72,7 +72,7 @@ Architecture: any
Section: tde
Replaces: kchart-trinity (<< 4:14.0.0)
Breaks: kchart-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: a chart drawing program for the KDE Office Suite [Trinity]
KChart is a chart drawing application. It can be used to embed charts
@@ -85,7 +85,7 @@ Architecture: any
Section: tde
Replaces: kexi-trinity (<< 4:14.0.0)
Breaks: kexi-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Suggests: kexi-mdb-plugin-trinity
Description: integrated database environment for the KDE Office Suite [Trinity]
Kexi is an integrated data management application. It can be used for
@@ -107,7 +107,7 @@ Architecture: any
Section: tde
Replaces: kformula-trinity (<< 4:14.0.0)
Breaks: kformula-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: a formula editor for the KDE Office Suite [Trinity]
KFormula is a formula editor that provides the basic input facilities
@@ -124,7 +124,7 @@ Architecture: any
Section: graphics
Replaces: kivio-trinity (<< 4:14.0.0)
Breaks: kivio-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, kivio-data-trinity (>> 1:1.4.90.2-1), kivio-data-trinity (>> ${KDE-Version3}), kivio-data-trinity (<< ${KDE-Next-Version3}), koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, kivio-data-trinity (>> 1:1.4.90.2-1), kivio-data-trinity (>> ${KDE-Version3}~), kivio-data-trinity (<< ${KDE-Next-Version3}~), koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Description: a flowcharting program for the KDE Office Suite [Trinity]
Kivio is a flowcharting program that offers basic flowcharting abilities,
but with a twist. Objects are scriptable, and a backend plugin system
@@ -150,7 +150,7 @@ Architecture: any
Section: tde
Replaces: koshell-trinity (<< 4:14.0.0)
Breaks: koshell-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: koffice-trinity, khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: the KDE Office Suite workspace [Trinity]
The KOffice workspace is a desktop with easy one-click launchers for
@@ -163,7 +163,7 @@ Architecture: any
Section: tde
Replaces: kplato-trinity (<< 4:14.0.0)
Breaks: kplato-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: an integrated project management and planning tool [Trinity]
KPlato is a project management application, allowing for the planning and
@@ -177,7 +177,7 @@ Architecture: any
Section: tde
Replaces: kpresenter-trinity (<< 4:14.0.0)
Breaks: kpresenter-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, ${perl:Depends}, kpresenter-data-trinity (>> ${KDE-Version3}), kpresenter-data-trinity (<< ${KDE-Next-Version3}), koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, ${perl:Depends}, kpresenter-data-trinity (>> ${KDE-Version3}~), kpresenter-data-trinity (<< ${KDE-Next-Version3}~), koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: a presentation program for the KDE Office Suite [Trinity]
KPresenter is a fully-featured presentation program. Presentations can
@@ -204,7 +204,7 @@ Architecture: any
Section: tde
Replaces: krita-trinity (<< 4:14.0.0), chalk-trinity (<< 4:14.0.0)
Breaks: krita-trinity (<< 4:14.0.0), chalk-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, chalk-data-trinity (>> ${KDE-Version3}), chalk-data-trinity (<< ${KDE-Next-Version3}), koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, chalk-data-trinity (>> ${KDE-Version3}~), chalk-data-trinity (<< ${KDE-Next-Version3}~), koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: dcraw, khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: a pixel-based image manipulation program for the KDE Office Suite [Trinity]
Chalk is a painting and image editing application for KOffice. Chalk contains
@@ -230,7 +230,7 @@ Architecture: any
Section: tde
Replaces: kspread-trinity (<< 4:14.0.0)
Breaks: kspread-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: a spreadsheet for the KDE Office Suite [Trinity]
KSpread is a powerful spreadsheet application. It is scriptable and
@@ -244,7 +244,7 @@ Architecture: any
Section: tde
Replaces: kugar-trinity (<< 4:14.0.0)
Breaks: kugar-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: a business report maker for the KDE Office Suite [Trinity]
Kugar is a tool for generating business quality reports that can
@@ -260,7 +260,7 @@ Architecture: any
Section: tde
Replaces: kword-trinity (<< 4:14.0.0)
Breaks: kword-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, kword-data-trinity (>> ${KDE-Version3}), kword-data-trinity (<< ${KDE-Next-Version3}), koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, kword-data-trinity (>> ${KDE-Version3}~), kword-data-trinity (<< ${KDE-Next-Version3}~), koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: a word processor for the KDE Office Suite [Trinity]
KWord is a FrameMaker-like word processing and desktop publishing
@@ -288,7 +288,7 @@ Architecture: any
Section: tde
Replaces: kthesaurus-trinity (<< 4:14.0.0)
Breaks: kthesaurus-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: thesaurus for the KDE Office Suite [Trinity]
KThesaurus lists words related to a given term and offers a user interface
@@ -302,7 +302,7 @@ Architecture: any
Section: libs
Replaces: koffice-libs-trinity (<< 4:14.0.0)
Breaks: koffice-libs-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-data-trinity (>> ${KDE-Version3}), koffice-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-data-trinity (>> ${KDE-Version3}~), koffice-data-trinity (<< ${KDE-Next-Version3}~)
Recommends: latex-xft-fonts, ruby, python
Suggests: wordnet, texlive-base
Description: common libraries and binaries for the KDE Office Suite [Trinity]
diff --git a/debian/squeeze/dependencies/arts/debian/patches/12_cleanup_artsc-config.diff b/debian/squeeze/dependencies/arts/debian/patches/12_cleanup_artsc-config.diff
index 603ffdf37..57a8122f9 100644
--- a/debian/squeeze/dependencies/arts/debian/patches/12_cleanup_artsc-config.diff
+++ b/debian/squeeze/dependencies/arts/debian/patches/12_cleanup_artsc-config.diff
@@ -1,3 +1,5 @@
+Index: b/artsc/artsc-config.in
+===================================================================
--- a/artsc/artsc-config.in
+++ b/artsc/artsc-config.in
@@ -27,7 +27,7 @@
@@ -8,4 +10,4 @@
+ flags="$flags -L$libdir -lartsc"
;;
--cflags)
- flags="$flags -I$includedir/artsc @GLIB_CFLAGS@"
+ flags="$flags -I$includedir @GLIB_CFLAGS@"
diff --git a/debian/squeeze/dependencies/arts/debian/rules b/debian/squeeze/dependencies/arts/debian/rules
index 9c9730bda..1b4911297 100755
--- a/debian/squeeze/dependencies/arts/debian/rules
+++ b/debian/squeeze/dependencies/arts/debian/rules
@@ -41,6 +41,6 @@ DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
binary-predeb/libarts1-trinity-dev::
ifeq (linux,$(DEB_HOST_ARCH_OS))
- echo "libasound2-trinity-dev=libasound2-trinity-dev" >> debian/libarts1-dev.substvars
+ echo "libasound2-dev=libasound2-dev" >> debian/libarts1-trinity-dev.substvars
endif
diff --git a/debian/squeeze/dependencies/libcaldav/debian/source/format b/debian/squeeze/dependencies/libcaldav/debian/source/format
new file mode 100644
index 000000000..89ae9db8f
--- /dev/null
+++ b/debian/squeeze/dependencies/libcaldav/debian/source/format
@@ -0,0 +1 @@
+3.0 (native)
diff --git a/debian/squeeze/dependencies/libcaldav/debian/source/options b/debian/squeeze/dependencies/libcaldav/debian/source/options
new file mode 100644
index 000000000..72f1f5450
--- /dev/null
+++ b/debian/squeeze/dependencies/libcaldav/debian/source/options
@@ -0,0 +1,6 @@
+# Use xz instead of gzip
+compression = "xz"
+compression-level = 9
+
+# Don't run differences
+diff-ignore = .*
diff --git a/debian/squeeze/dependencies/libcarddav/debian/source/format b/debian/squeeze/dependencies/libcarddav/debian/source/format
new file mode 100644
index 000000000..89ae9db8f
--- /dev/null
+++ b/debian/squeeze/dependencies/libcarddav/debian/source/format
@@ -0,0 +1 @@
+3.0 (native)
diff --git a/debian/squeeze/dependencies/libcarddav/debian/source/options b/debian/squeeze/dependencies/libcarddav/debian/source/options
new file mode 100644
index 000000000..72f1f5450
--- /dev/null
+++ b/debian/squeeze/dependencies/libcarddav/debian/source/options
@@ -0,0 +1,6 @@
+# Use xz instead of gzip
+compression = "xz"
+compression-level = 9
+
+# Don't run differences
+diff-ignore = .*
diff --git a/debian/squeeze/dependencies/qt3/debian/control b/debian/squeeze/dependencies/qt3/debian/control
index e10fbcab1..cf10bbb50 100644
--- a/debian/squeeze/dependencies/qt3/debian/control
+++ b/debian/squeeze/dependencies/qt3/debian/control
@@ -11,7 +11,7 @@ Build-Depends: debhelper (>= 5.0.31), quilt, cpio, libxext-dev (>= 4.3.0.dfsg.1-
libfreetype6-dev, libxft-dev, unixodbc-dev, uuid-dev, libglib2.0-dev,
libmysqlclient-dev, flex, libpq-dev, libaudio-dev, libcups2-dev,
libgl1-mesa-dev | libgl-dev, libglu1-mesa-dev | libglu-dev, libsqlite3-dev,
- firebird2.1-dev [i386 kfreebsd-i386 kfreebsd-amd64 knetbsd-i386 netbsd-i386 amd64 sparc powerpc] | firebird2-dev [i386 amd64]
+ firebird-dev | firebird2.1-dev [i386 kfreebsd-i386 kfreebsd-amd64 knetbsd-i386 netbsd-i386 amd64 sparc powerpc] | firebird2-dev [i386 amd64]
Section: libs
Priority: optional
Standards-Version: 3.8.4
diff --git a/debian/squeeze/dependencies/qt3/debian/patches/06_disable_rpath.diff b/debian/squeeze/dependencies/qt3/debian/patches/06_disable_rpath.diff
index 27fc1426c..a3d74ffce 100644
--- a/debian/squeeze/dependencies/qt3/debian/patches/06_disable_rpath.diff
+++ b/debian/squeeze/dependencies/qt3/debian/patches/06_disable_rpath.diff
@@ -2,25 +2,29 @@ author: Martin Loschwitz <madkiss@madkiss.org>
Disables the rpath settings in qmake.conf
+Index: b/mkspecs/linux-g++/qmake.conf
+===================================================================
--- a/mkspecs/linux-g++/qmake.conf
+++ b/mkspecs/linux-g++/qmake.conf
-@@ -55,7 +55,7 @@ QMAKE_LFLAGS_SHLIB = -shared
+@@ -55,7 +55,7 @@
QMAKE_LFLAGS_PLUGIN = $$QMAKE_LFLAGS_SHLIB
QMAKE_LFLAGS_SONAME = -Wl,-soname,
QMAKE_LFLAGS_THREAD =
-QMAKE_RPATH = -Wl,-rpath,
+QMAKE_RPATH =
- QMAKE_LIBS =
+ QMAKE_LIBS = -luuid
QMAKE_LIBS_DYNLOAD = -ldl
+Index: b/mkspecs/linux-g++-64/qmake.conf
+===================================================================
--- a/mkspecs/linux-g++-64/qmake.conf
+++ b/mkspecs/linux-g++-64/qmake.conf
-@@ -58,7 +58,7 @@ QMAKE_LFLAGS_SHLIB = -shared
+@@ -58,7 +58,7 @@
QMAKE_LFLAGS_PLUGIN = $$QMAKE_LFLAGS_SHLIB
QMAKE_LFLAGS_SONAME = -Wl,-soname,
QMAKE_LFLAGS_THREAD =
-QMAKE_RPATH = -Wl,-rpath,
+QMAKE_RPATH =
- QMAKE_LIBS =
+ QMAKE_LIBS = -luuid
QMAKE_LIBS_DYNLOAD = -ldl
diff --git a/debian/squeeze/dependencies/tqt3/debian/control b/debian/squeeze/dependencies/tqt3/debian/control
index b45983f80..1655a1357 100644
--- a/debian/squeeze/dependencies/tqt3/debian/control
+++ b/debian/squeeze/dependencies/tqt3/debian/control
@@ -11,7 +11,7 @@ Build-Depends: debhelper (>= 5.0.31), quilt, cpio, libxext-dev (>= 4.3.0.dfsg.1-
libfreetype6-dev, libxft-dev, unixodbc-dev, uuid-dev, libglib2.0-dev,
libmysqlclient-dev, flex, libpq-dev, libaudio-dev, libcups2-dev,
libgl1-mesa-dev | libgl-dev, libglu1-mesa-dev | libglu-dev, libsqlite3-dev,
- firebird2.1-dev [i386 kfreebsd-i386 kfreebsd-amd64 knetbsd-i386 netbsd-i386 amd64 sparc powerpc] | firebird2-dev [i386 amd64]
+ firebird-dev | firebird2.1-dev [i386 kfreebsd-i386 kfreebsd-amd64 knetbsd-i386 netbsd-i386 amd64 sparc powerpc] | firebird2-dev [i386 amd64]
Section: libs
Priority: optional
Standards-Version: 3.8.4
diff --git a/debian/squeeze/dependencies/tqt3/debian/patches/06_disable_rpath.diff b/debian/squeeze/dependencies/tqt3/debian/patches/06_disable_rpath.diff
index 27fc1426c..a3d74ffce 100644
--- a/debian/squeeze/dependencies/tqt3/debian/patches/06_disable_rpath.diff
+++ b/debian/squeeze/dependencies/tqt3/debian/patches/06_disable_rpath.diff
@@ -2,25 +2,29 @@ author: Martin Loschwitz <madkiss@madkiss.org>
Disables the rpath settings in qmake.conf
+Index: b/mkspecs/linux-g++/qmake.conf
+===================================================================
--- a/mkspecs/linux-g++/qmake.conf
+++ b/mkspecs/linux-g++/qmake.conf
-@@ -55,7 +55,7 @@ QMAKE_LFLAGS_SHLIB = -shared
+@@ -55,7 +55,7 @@
QMAKE_LFLAGS_PLUGIN = $$QMAKE_LFLAGS_SHLIB
QMAKE_LFLAGS_SONAME = -Wl,-soname,
QMAKE_LFLAGS_THREAD =
-QMAKE_RPATH = -Wl,-rpath,
+QMAKE_RPATH =
- QMAKE_LIBS =
+ QMAKE_LIBS = -luuid
QMAKE_LIBS_DYNLOAD = -ldl
+Index: b/mkspecs/linux-g++-64/qmake.conf
+===================================================================
--- a/mkspecs/linux-g++-64/qmake.conf
+++ b/mkspecs/linux-g++-64/qmake.conf
-@@ -58,7 +58,7 @@ QMAKE_LFLAGS_SHLIB = -shared
+@@ -58,7 +58,7 @@
QMAKE_LFLAGS_PLUGIN = $$QMAKE_LFLAGS_SHLIB
QMAKE_LFLAGS_SONAME = -Wl,-soname,
QMAKE_LFLAGS_THREAD =
-QMAKE_RPATH = -Wl,-rpath,
+QMAKE_RPATH =
- QMAKE_LIBS =
+ QMAKE_LIBS = -luuid
QMAKE_LIBS_DYNLOAD = -ldl
diff --git a/debian/squeeze/libraries/python-trinity/debian/control b/debian/squeeze/libraries/python-trinity/debian/control
index ef0d3115a..c69bdc5ea 100644
--- a/debian/squeeze/libraries/python-trinity/debian/control
+++ b/debian/squeeze/libraries/python-trinity/debian/control
@@ -4,17 +4,15 @@ Priority: optional
Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
XSBC-Original-Maintainer: Ricardo Javier Cardenes Medina <rcardenes@debian.org>
Uploaders: Torsten Marek <shlomme@debian.org>, Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
-Build-Depends: debhelper (>= 5.0.38), libtqtinterface-dev, python, python-all-dev, python-all-dbg, sip4 (>= 4.10), python-sip4-dev (>= 4.10), python-tqt-dev, tdelibs14-trinity-dev, python-support (>= 0.6) | python-dev (>= 2.6.6-3~), dpatch, python-sip4, python-sip4-dbg, python-sip4-dev
+Build-Depends: debhelper (>= 5.0.38), libtqtinterface-dev, python, python-all-dev, python-all-dbg, sip4 (>= 4.10), python-sip4-dev (>= 4.10), python-tqt-dev, tdelibs14-trinity-dev, python-sip4, python-sip4-dbg, python-sip4-dev
Standards-Version: 3.8.4
Homepage: http://www.riverbankcomputing.co.uk/pytde/index.php
-XS-Python-Version: all
Package: python-trinity-trinity
Architecture: any
Depends: ${shlibs:Depends}, ${python:Depends}, python-tqt
Replaces: python-trinity-trinity (<< 4:14.0.0)
Breaks: python-trinity-trinity (<< 4:14.0.0)
-XB-Python-Version: ${python:Versions}
Provides: ${python:Provides}
Conflicts: python-trinity-trinity
Description: Trinity bindings for Python [Trinity]
@@ -28,7 +26,6 @@ Architecture: any
Replaces: python-trinity-trinity-dbg (<< 4:14.0.0)
Breaks: python-trinity-trinity-dbg (<< 4:14.0.0)
Depends: python-trinity-trinity (= ${binary:Version}), python-dbg, python-tqt-dbg, ${shlibs:Depends}
-XB-Python-Version: ${python:Versions}
Description: Trinity bindings for Python (debug extensions) [Trinity]
Python binding module that provides wide access to the Trinity API,
also known as PyKDE. Using this, you'll get (for example) classes
@@ -42,7 +39,6 @@ Architecture: all
Replaces: python-trinity-trinity-dev (<< 4:14.0.0)
Breaks: python-trinity-trinity-dev (<< 4:14.0.0)
Depends: pytqt-tools, ${python:Depends}
-XB-Python-Version: ${python:Versions}
Description: Trinity bindings for Python - Development files and scripts [Trinity]
Development .sip files with definitions of PyKDE classes. They
are needed to build PyKDE, but also as building blocks of other
diff --git a/debian/squeeze/libraries/python-trinity/debian/pycompat b/debian/squeeze/libraries/python-trinity/debian/pycompat
deleted file mode 100644
index 0cfbf0888..000000000
--- a/debian/squeeze/libraries/python-trinity/debian/pycompat
+++ /dev/null
@@ -1 +0,0 @@
-2
diff --git a/debian/squeeze/libraries/python-trinity/debian/rules b/debian/squeeze/libraries/python-trinity/debian/rules
index d4dac70f3..473caac7d 100755
--- a/debian/squeeze/libraries/python-trinity/debian/rules
+++ b/debian/squeeze/libraries/python-trinity/debian/rules
@@ -14,7 +14,6 @@ cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xine
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
-include /usr/share/dpatch/dpatch.make
# This has to be exported to make some magic below work.
export DH_OPTIONS
export QTDIR=/usr/share/qt3
@@ -31,8 +30,7 @@ endif
PYTHONS := $(shell pyversions -vr debian/control)
DBG_PYTHONS := $(shell pyversions -vd)
-DEB_PYTHON_SYSTEM = $(if $(wildcard /usr/bin/dh_python2),,pysupport)
-DH_PYTHON2 = $(if $(wildcard /usr/bin/dh_python2),dh_python2,dh_pysupport)
+DH_PYTHON2 = $(if $(wildcard /usr/bin/dh_python2),dh_python2,dh_python)
GCCVER := $(shell gcc --version | sed -n '/^gcc (GCC)/s/.*(GCC) \(...\).*/\1/p')
ifneq (,$(filter $(GCCVER),4.2 4.3))
@@ -45,7 +43,7 @@ endif
configure: $(PYTHONS:%=build-%/configure-stamp) $(DBG_PYTHONS:%=dbg-build-%/configure-stamp)
-build-%/configure-stamp: patch-stamp
+build-%/configure-stamp:
dh_testdir
mkdir -p build-$*
cd build-$* && python$* ../configure.py \
@@ -53,7 +51,7 @@ build-%/configure-stamp: patch-stamp
-v /opt/trinity/share/sip/trinity -j $(SPLIT)
touch $@
-dbg-build-%/configure-stamp: patch-stamp
+dbg-build-%/configure-stamp:
dh_testdir
mkdir -p dbg-build-$*
cd dbg-build-$* && python$*-dbg ../configure.py \
@@ -73,7 +71,7 @@ dbg-build-%/build-stamp: dbg-build-%/configure-stamp
$(MAKE) -C dbg-build-$*
touch $@
-clean: unpatch
+clean:
dh_testdir
dh_testroot
rm -f *-stamp
diff --git a/debian/squeeze/tdebase/debian/control b/debian/squeeze/tdebase/debian/control
index f6d04d18f..e4874266c 100644
--- a/debian/squeeze/tdebase/debian/control
+++ b/debian/squeeze/tdebase/debian/control
@@ -88,7 +88,7 @@ Section: tde
Architecture: any
Replaces: kcontrol-trinity (<< 4:14.0.0)
Breaks: kcontrol-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdebase-data-trinity (>> ${KDE-Version3}), tdebase-data-trinity (<< ${KDE-Next-Version3}), usbutils
+Depends: ${shlibs:Depends}, tdebase-data-trinity (>> ${KDE-Version3}~), tdebase-data-trinity (<< ${KDE-Next-Version3}~), usbutils
Recommends: udev
Suggests: khelpcenter-trinity, ntpdate | ntp-simple
Conflicts: tdebase-libs-trinity (<< 4:3.0.0)
@@ -254,7 +254,7 @@ Section: tde
Architecture: any
Replaces: kdm-trinity (<< 4:14.0.0)
Breaks: kdm-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdebase-trinity-bin (= ${Source-Version}), tdebase-data-trinity (>> ${KDE-Version3}), tdebase-data-trinity (<< ${KDE-Next-Version3}), debconf (>= 1.2.9) | debconf-2.0, libpam-runtime (>= 0.76-14), xbase-clients
+Depends: ${shlibs:Depends}, tdebase-trinity-bin (= ${Source-Version}), tdebase-data-trinity (>> ${KDE-Version3}~), tdebase-data-trinity (<< ${KDE-Next-Version3}~), debconf (>= 1.2.9) | debconf-2.0, libpam-runtime (>= 0.76-14), xbase-clients
Recommends: logrotate, xserver-xorg
Suggests: khelpcenter-trinity, ksmserver-trinity (= ${Source-Version}), tdepasswd-trinity (= ${Source-Version}), menu
Provides: x-display-manager
@@ -313,7 +313,7 @@ Section: tde
Architecture: any
Replaces: kicker-trinity (<< 4:14.0.0)
Breaks: kicker-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdebase-data-trinity (>> ${KDE-Version3}), tdebase-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdebase-data-trinity (>> ${KDE-Version3}~), tdebase-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, kicker-applets-trinity, menu
Conflicts: tdebase-libs-trinity (<< 4:3.0.0)
Description: desktop panel for KDE
@@ -446,7 +446,7 @@ Section: tde
Architecture: any
Replaces: kpersonalizer-trinity (<< 4:14.0.0)
Breaks: kpersonalizer-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdebase-data-trinity (>> ${KDE-Version3}), tdebase-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdebase-data-trinity (>> ${KDE-Version3}~), tdebase-data-trinity (<< ${KDE-Next-Version3}~)
Description: installation personalizer for KDE
KDE Personalizer is the application that configures the KDE desktop for you.
It's a very useful wizard that allows you to quickly change the KDE desktop to
@@ -483,7 +483,7 @@ Section: tde
Architecture: any
Replaces: ksplash-trinity (<< 4:14.0.0)
Breaks: ksplash-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdebase-data-trinity (>> ${KDE-Version3}), tdebase-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdebase-data-trinity (>> ${KDE-Version3}~), tdebase-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity
Description: the KDE splash screen
This package includes the KDE Splash screen, which is seen when
@@ -540,7 +540,7 @@ Replaces: kwin-trinity (<< 4:14.0.0)
Breaks: kwin-trinity (<< 4:14.0.0)
Depends: ${shlibs:Depends}
Provides: x-window-manager
-Suggests: tdebase-trinity-bin (= ${Source-Version}), tdebase-data-trinity (>> ${KDE-Version3}), tdebase-data-trinity (<< ${KDE-Next-Version3}), kdesktop-trinity (= ${Source-Version}), kicker-trinity (= ${Source-Version}), kpager-trinity (= ${Source-Version}), kpersonalizer-trinity (= ${Source-Version}), ksmserver-trinity (= ${Source-Version}), ksplash-trinity (= ${Source-Version})
+Suggests: tdebase-trinity-bin (= ${Source-Version}), tdebase-data-trinity (>> ${KDE-Version3}~), tdebase-data-trinity (<< ${KDE-Next-Version3}~), kdesktop-trinity (= ${Source-Version}), kicker-trinity (= ${Source-Version}), kpager-trinity (= ${Source-Version}), kpersonalizer-trinity (= ${Source-Version}), ksmserver-trinity (= ${Source-Version}), ksplash-trinity (= ${Source-Version})
Conflicts: kde-window-manager-trinity (<< 7:3.5.0)
Description: the KDE window manager
This package contains the default X window manager for KDE.
diff --git a/debian/squeeze/tdebindings/debian/control b/debian/squeeze/tdebindings/debian/control
index 0bb4c4a0a..c561fffb0 100644
--- a/debian/squeeze/tdebindings/debian/control
+++ b/debian/squeeze/tdebindings/debian/control
@@ -29,7 +29,7 @@ Architecture: all
Section: libs
Replaces: libdcop3-java-trinity (<< 4:14.0.0)
Breaks: libdcop3-java-trinity (<< 4:14.0.0)
-Depends: libdcop3-jni-trinity (>> ${KDE-Version3}), libdcop3-jni-trinity (<< ${KDE-Next-Version3}), gij | java1-runtime | java2-runtime
+Depends: libdcop3-jni-trinity (>> ${KDE-Version3}~), libdcop3-jni-trinity (<< ${KDE-Next-Version3}~), gij | java1-runtime | java2-runtime
Description: DCOP bindings for Java [Trinity]
This package contains the Java classes necessary to run Java programs
using the Java DCOP bindings. DCOP is the TDE Desktop COmmunications
@@ -56,7 +56,7 @@ Architecture: amd64 i386 ia64 powerpc s390 sparc
Section: libdevel
Replaces: libdcop3-java-trinity-dev (<< 4:14.0.0)
Breaks: libdcop3-java-trinity-dev (<< 4:14.0.0)
-Depends: libdcop3-java-trinity (>> ${KDE-Version3}), libdcop3-java-trinity (<< ${KDE-Next-Version3})
+Depends: libdcop3-java-trinity (>> ${KDE-Version3}~), libdcop3-java-trinity (<< ${KDE-Next-Version3}~)
Description: DCOP bindings for Java (dcopidl2java program) [Trinity]
This package contains the dcopidl2java program which generates Java
stubs from DCOP IDL files, necessary to do development with the DCOP Java
@@ -70,7 +70,7 @@ Architecture: all
Section: libs
Replaces: libqt3-java-trinity (<< 4:14.0.0)
Breaks: libqt3-java-trinity (<< 4:14.0.0)
-Depends: libqt3-jni-trinity (>> ${KDE-Version3}), libqt3-jni-trinity (<< ${KDE-Next-Version3}), gij | java1-runtime | java2-runtime
+Depends: libqt3-jni-trinity (>> ${KDE-Version3}~), libqt3-jni-trinity (<< ${KDE-Next-Version3}~), gij | java1-runtime | java2-runtime
Suggests: juic-trinity
Description: Java bindings for Qt [Trinity]
This package contains the Java classes necessary to run Java programs
@@ -100,7 +100,7 @@ Architecture: all
Section: libs
Replaces: libtrinity-java-trinity (<< 4:14.0.0)
Breaks: libtrinity-java-trinity (<< 4:14.0.0)
-Depends: libtrinity-jni-trinity (>> ${KDE-Version3}), libtrinity-jni-trinity (<< ${KDE-Next-Version3}), gij | java1-runtime | java2-runtime
+Depends: libtrinity-jni-trinity (>> ${KDE-Version3}~), libtrinity-jni-trinity (<< ${KDE-Next-Version3}~), gij | java1-runtime | java2-runtime
Description: tdelibs bindings for Java [Trinity]
This package contains the Java classes necessary to run Java programs
using the Java tdelibs bindings. TDE is the Trinity Desktop Environment, a
diff --git a/debian/squeeze/tdeedu/debian/control b/debian/squeeze/tdeedu/debian/control
index b8323cf70..9b00cc54f 100644
--- a/debian/squeeze/tdeedu/debian/control
+++ b/debian/squeeze/tdeedu/debian/control
@@ -74,7 +74,7 @@ Architecture: any
Section: games
Replaces: blinken-trinity (<< 4:14.0.0)
Breaks: blinken-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, ttf-sjfonts, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, ttf-sjfonts, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: Trinity version of the Simon Says electronic memory game
Blinken is based on an electronic game released in 1978, which
@@ -94,7 +94,7 @@ Architecture: any
Section: science
Replaces: kalzium-trinity (<< 4:14.0.0)
Breaks: kalzium-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, kalzium-data-trinity (>> ${KDE-Version3}), kalzium-data-trinity (<< ${KDE-Next-Version3}), tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, kalzium-data-trinity (>> ${KDE-Version3}~), kalzium-data-trinity (<< ${KDE-Next-Version3}~), tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: chemistry teaching tool for Trinity
Kalzium is a program which shows you the Periodic System of Elements
@@ -137,7 +137,7 @@ Architecture: any
Section: games
Replaces: kanagram-trinity (<< 4:14.0.0)
Breaks: kanagram-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: letter order game for Trinity
KAnagram is a game that is based on the word/letter puzzles that the
@@ -160,7 +160,7 @@ Architecture: any
Section: math
Replaces: kbruch-trinity (<< 4:14.0.0)
Breaks: kbruch-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: fraction calculation teaching tool for Trinity
KBruch is a small program to practice calculating with fractions.
@@ -175,7 +175,7 @@ Architecture: any
Section: tde
Replaces: keduca-trinity (<< 4:14.0.0)
Breaks: keduca-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: interactive form-based tests for Trinity
KEduca is a flash-card application which allows you to make
@@ -189,7 +189,7 @@ Architecture: any
Section: tde
Replaces: kgeography-trinity (<< 4:14.0.0)
Breaks: kgeography-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, kgeography-data-trinity (>> ${KDE-Version3}), kgeography-data-trinity (<< ${KDE-Next-Version3}), tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, kgeography-data-trinity (>> ${KDE-Version3}~), kgeography-data-trinity (<< ${KDE-Next-Version3}~), tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: Geography learning tool for Trinity
KGeography contains maps allowing you to learn various countries or
@@ -220,7 +220,7 @@ Architecture: any
Section: games
Replaces: khangman-trinity (<< 4:14.0.0)
Breaks: khangman-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, ttf-dustin, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, ttf-dustin, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: the classical hangman game for Trinity
KHangMan is a game based on the well known hangman game. It is aimed
@@ -240,7 +240,7 @@ Architecture: any
Section: math
Replaces: kig-trinity (<< 4:14.0.0)
Breaks: kig-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: interactive geometry program for KDE
Kig is an application for interactive geometry. It is intended to
@@ -268,7 +268,7 @@ Architecture: any
Section: tde
Replaces: kiten-trinity (<< 4:14.0.0)
Breaks: kiten-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3}), ttf-kochi-gothic | ttf-kochi-mincho
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~), ttf-kochi-gothic | ttf-kochi-mincho
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: Japanese reference/study tool for Trinity
Kiten is a Japanese reference and study tool for KDE. It is an
@@ -285,7 +285,7 @@ Architecture: any
Section: tde
Replaces: klatin-trinity (<< 4:14.0.0)
Breaks: klatin-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: application to help revise/teach Latin
KLatin is a program to help revise Latin. There are three "sections"
@@ -310,7 +310,7 @@ Architecture: any
Section: tde
Replaces: klettres-trinity (<< 4:14.0.0)
Breaks: klettres-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, klettres-data-trinity (>> ${KDE-Version3}), klettres-data-trinity (<< ${KDE-Next-Version3}), tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, klettres-data-trinity (>> ${KDE-Version3}~), klettres-data-trinity (<< ${KDE-Next-Version3}~), tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: foreign alphabet tutor for Trinity
KLettres is an application specially designed to help the user to
@@ -344,7 +344,7 @@ Architecture: any
Section: math
Replaces: kmplot-trinity (<< 4:14.0.0)
Breaks: kmplot-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: mathematical function plotter for Trinity
KmPlot is a mathematical function plotter for KDE. It has a powerful
@@ -368,7 +368,7 @@ Architecture: any
Section: math
Replaces: kpercentage-trinity (<< 4:14.0.0)
Breaks: kpercentage-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: percentage calculation teaching tool for Trinity
KPercentage is a small math application that will help pupils to
@@ -386,7 +386,7 @@ Architecture: any
Section: science
Replaces: kstars-trinity (<< 4:14.0.0)
Breaks: kstars-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, kstars-data-trinity (>> ${KDE-Version3}), kstars-data-trinity (<< ${KDE-Next-Version3}), tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3}), indi-trinity (= ${Source-Version})
+Depends: ${shlibs:Depends}, kstars-data-trinity (>> ${KDE-Version3}~), kstars-data-trinity (<< ${KDE-Next-Version3}~), tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~), indi-trinity (= ${Source-Version})
Suggests: konqueror-trinity, khelpcenter-trinity, tdeedu-trinity-doc-html
Description: desktop planetarium for Trinity
KStars is a graphical desktop planetarium for KDE. It depicts an
@@ -424,7 +424,7 @@ Architecture: any
Section: tde
Replaces: ktouch-trinity (<< 4:14.0.0)
Breaks: ktouch-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: touch typing tutor for Trinity
KTouch is a program for learning touch typing - it helps you learn to
@@ -444,7 +444,7 @@ Architecture: any
Section: devel
Replaces: kturtle-trinity (<< 4:14.0.0)
Breaks: kturtle-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: educational Logo programming environment
KTurtle is an educational programming environment using the Logo
@@ -472,7 +472,7 @@ Architecture: any
Section: tde
Replaces: kverbos-trinity (<< 4:14.0.0)
Breaks: kverbos-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: Spanish verb form study application for Trinity
Kverbos allows the user to learn the forms of Spanish verbs. The
@@ -491,7 +491,7 @@ Architecture: any
Section: tde
Replaces: kvoctrain-trinity (<< 4:14.0.0)
Breaks: kvoctrain-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, ${perl:Depends}, libwww-perl, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, ${perl:Depends}, libwww-perl, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: vocabulary trainer for Trinity
KVocTrain is a little utility to help you train your vocabulary when
@@ -517,7 +517,7 @@ Architecture: any
Section: tde
Replaces: kwordquiz-trinity (<< 4:14.0.0)
Breaks: kwordquiz-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: flashcard and vocabulary learning program for Trinity
KWordQuiz is a flashcard-based tool that helps you to master new
diff --git a/debian/squeeze/tdegraphics/debian/control b/debian/squeeze/tdegraphics/debian/control
index db36d2eea..ea835feac 100644
--- a/debian/squeeze/tdegraphics/debian/control
+++ b/debian/squeeze/tdegraphics/debian/control
@@ -4,7 +4,7 @@ Priority: optional
Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
XSBC-Original-Maintainer: Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
Uploaders: Ana Beatriz Guerrero Lopez <ana@debian.org>, Francesco Pedrini <francesco.pedrini@gmail.com>, Josh Metzler <joshdeb@metzlers.org>, Sune Vuorela <debian@pusling.com>
-Build-Depends: imlib11-dev, cdbs (>= 0.4.39-0.1), debhelper (>= 5.0.31), autotools-dev, gawk, gettext, tdelibs14-trinity-dev, libexif-dev (>= 0.6.9-1), libfribidi-dev, freeglut3-dev, libgphoto2-2-dev, libopenexr-dev (>= 1.2.1), libpaper-dev, libpoppler-dev, libsane-dev (>> 1.0.15), libtiff-dev, libtiff-tools, libusb-dev, sharutils, libxxf86vm-dev, chrpath [powerpc], cmake, libtool, libltdl-dev
+Build-Depends: imlib11-dev, cdbs (>= 0.4.39-0.1), debhelper (>= 5.0.31), autotools-dev, gawk, gettext, tdelibs14-trinity-dev, libexif-dev (>= 0.6.9-1), libfribidi-dev, freeglut3-dev, libgphoto2-6-dev | libgphoto2-2-dev, libopenexr-dev (>= 1.2.1), libpaper-dev, libpoppler-private-dev | libpoppler-dev (<< 0.18.4-3), libpoppler-dev, libsane-dev (>> 1.0.15), libtiff-dev, libtiff-tools, libusb-dev, sharutils, libxxf86vm-dev, chrpath [powerpc], cmake, libtool, libltdl-dev
Standards-Version: 3.8.4
Package: tdegraphics-trinity
diff --git a/debian/wheezy/applications/kcpuload/debian/rules b/debian/wheezy/applications/kcpuload/debian/rules
index 20eca167c..385c24313 100755
--- a/debian/wheezy/applications/kcpuload/debian/rules
+++ b/debian/wheezy/applications/kcpuload/debian/rules
@@ -45,11 +45,6 @@ ifeq ($(DEB_BUILD_GNU_TYPE),i386-linux)
#export CXXFLAGS=-O3 -march=i686 -ffast-math -finline-functions
endif
--include debian/debiandirs
-
-debian/debiandirs: admin/debianrules
- perl -w admin/debianrules echodirs > debian/debiandirs
-
configure: configure-stamp
configure-stamp:
dh_testdir
@@ -104,7 +99,7 @@ debian-clean:
clean:
dh_testdir
dh_testroot
- rm -f build-stamp configure-stamp debian/debiandirs
+ rm -f build-stamp configure-stamp
# Remove Debian specific patches
if test -f patch-stamp; then \
@@ -169,8 +164,6 @@ binary-common:
dh_testroot
dh_installchangelogs kcpuload/ChangeLog
dh_installdocs
- mkdir debian/kcpuload-trinity/opt/trinity/share/doc
- mv debian/kcpuload-trinity/usr/share/doc/tde debian/kcpuload-trinity/opt/trinity/share/doc/
rm -fr debian/kcpuload-trinity/usr/share/doc-base
dh_installexamples
dh_installmanpages
diff --git a/debian/wheezy/applications/koffice/debian/control b/debian/wheezy/applications/koffice/debian/control
index f4000d836..ed66aecc6 100644
--- a/debian/wheezy/applications/koffice/debian/control
+++ b/debian/wheezy/applications/koffice/debian/control
@@ -61,7 +61,7 @@ Architecture: any
Section: graphics
Replaces: karbon-trinity (<< 4:14.0.0)
Breaks: karbon-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Description: a vector graphics application for the KDE Office Suite
Karbon is a vector graphics application.
.
@@ -72,7 +72,7 @@ Architecture: any
Section: tde
Replaces: kchart-trinity (<< 4:14.0.0)
Breaks: kchart-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: a chart drawing program for the KDE Office Suite [Trinity]
KChart is a chart drawing application. It can be used to embed charts
@@ -85,7 +85,7 @@ Architecture: any
Section: tde
Replaces: kexi-trinity (<< 4:14.0.0)
Breaks: kexi-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Suggests: kexi-mdb-plugin-trinity
Description: integrated database environment for the KDE Office Suite [Trinity]
Kexi is an integrated data management application. It can be used for
@@ -107,7 +107,7 @@ Architecture: any
Section: tde
Replaces: kformula-trinity (<< 4:14.0.0)
Breaks: kformula-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: a formula editor for the KDE Office Suite [Trinity]
KFormula is a formula editor that provides the basic input facilities
@@ -124,7 +124,7 @@ Architecture: any
Section: graphics
Replaces: kivio-trinity (<< 4:14.0.0)
Breaks: kivio-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, kivio-data-trinity (>> 1:1.4.90.2-1), kivio-data-trinity (>> ${KDE-Version3}), kivio-data-trinity (<< ${KDE-Next-Version3}), koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, kivio-data-trinity (>> 1:1.4.90.2-1), kivio-data-trinity (>> ${KDE-Version3}~), kivio-data-trinity (<< ${KDE-Next-Version3}~), koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Description: a flowcharting program for the KDE Office Suite [Trinity]
Kivio is a flowcharting program that offers basic flowcharting abilities,
but with a twist. Objects are scriptable, and a backend plugin system
@@ -150,7 +150,7 @@ Architecture: any
Section: tde
Replaces: koshell-trinity (<< 4:14.0.0)
Breaks: koshell-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: koffice-trinity, khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: the KDE Office Suite workspace [Trinity]
The KOffice workspace is a desktop with easy one-click launchers for
@@ -163,7 +163,7 @@ Architecture: any
Section: tde
Replaces: kplato-trinity (<< 4:14.0.0)
Breaks: kplato-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: an integrated project management and planning tool [Trinity]
KPlato is a project management application, allowing for the planning and
@@ -177,7 +177,7 @@ Architecture: any
Section: tde
Replaces: kpresenter-trinity (<< 4:14.0.0)
Breaks: kpresenter-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, ${perl:Depends}, kpresenter-data-trinity (>> ${KDE-Version3}), kpresenter-data-trinity (<< ${KDE-Next-Version3}), koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, ${perl:Depends}, kpresenter-data-trinity (>> ${KDE-Version3}~), kpresenter-data-trinity (<< ${KDE-Next-Version3}~), koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: a presentation program for the KDE Office Suite [Trinity]
KPresenter is a fully-featured presentation program. Presentations can
@@ -204,7 +204,7 @@ Architecture: any
Section: tde
Replaces: krita-trinity (<< 4:14.0.0), chalk-trinity (<< 4:14.0.0)
Breaks: krita-trinity (<< 4:14.0.0), chalk-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, chalk-data-trinity (>> ${KDE-Version3}), chalk-data-trinity (<< ${KDE-Next-Version3}), koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, chalk-data-trinity (>> ${KDE-Version3}~), chalk-data-trinity (<< ${KDE-Next-Version3}~), koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: dcraw, khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: a pixel-based image manipulation program for the KDE Office Suite [Trinity]
Chalk is a painting and image editing application for KOffice. Chalk contains
@@ -230,7 +230,7 @@ Architecture: any
Section: tde
Replaces: kspread-trinity (<< 4:14.0.0)
Breaks: kspread-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: a spreadsheet for the KDE Office Suite [Trinity]
KSpread is a powerful spreadsheet application. It is scriptable and
@@ -244,7 +244,7 @@ Architecture: any
Section: tde
Replaces: kugar-trinity (<< 4:14.0.0)
Breaks: kugar-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: a business report maker for the KDE Office Suite [Trinity]
Kugar is a tool for generating business quality reports that can
@@ -260,7 +260,7 @@ Architecture: any
Section: tde
Replaces: kword-trinity (<< 4:14.0.0)
Breaks: kword-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, kword-data-trinity (>> ${KDE-Version3}), kword-data-trinity (<< ${KDE-Next-Version3}), koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, kword-data-trinity (>> ${KDE-Version3}~), kword-data-trinity (<< ${KDE-Next-Version3}~), koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: a word processor for the KDE Office Suite [Trinity]
KWord is a FrameMaker-like word processing and desktop publishing
@@ -288,7 +288,7 @@ Architecture: any
Section: tde
Replaces: kthesaurus-trinity (<< 4:14.0.0)
Breaks: kthesaurus-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: thesaurus for the KDE Office Suite [Trinity]
KThesaurus lists words related to a given term and offers a user interface
@@ -302,7 +302,7 @@ Architecture: any
Section: libs
Replaces: koffice-libs-trinity (<< 4:14.0.0)
Breaks: koffice-libs-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-data-trinity (>> ${KDE-Version3}), koffice-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-data-trinity (>> ${KDE-Version3}~), koffice-data-trinity (<< ${KDE-Next-Version3}~)
Recommends: latex-xft-fonts, ruby, python
Suggests: wordnet, texlive-base
Description: common libraries and binaries for the KDE Office Suite [Trinity]
diff --git a/debian/wheezy/dependencies/arts/debian/patches/12_cleanup_artsc-config.diff b/debian/wheezy/dependencies/arts/debian/patches/12_cleanup_artsc-config.diff
index 603ffdf37..57a8122f9 100644
--- a/debian/wheezy/dependencies/arts/debian/patches/12_cleanup_artsc-config.diff
+++ b/debian/wheezy/dependencies/arts/debian/patches/12_cleanup_artsc-config.diff
@@ -1,3 +1,5 @@
+Index: b/artsc/artsc-config.in
+===================================================================
--- a/artsc/artsc-config.in
+++ b/artsc/artsc-config.in
@@ -27,7 +27,7 @@
@@ -8,4 +10,4 @@
+ flags="$flags -L$libdir -lartsc"
;;
--cflags)
- flags="$flags -I$includedir/artsc @GLIB_CFLAGS@"
+ flags="$flags -I$includedir @GLIB_CFLAGS@"
diff --git a/debian/wheezy/dependencies/arts/debian/rules b/debian/wheezy/dependencies/arts/debian/rules
index 9c9730bda..1b4911297 100755
--- a/debian/wheezy/dependencies/arts/debian/rules
+++ b/debian/wheezy/dependencies/arts/debian/rules
@@ -41,6 +41,6 @@ DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
binary-predeb/libarts1-trinity-dev::
ifeq (linux,$(DEB_HOST_ARCH_OS))
- echo "libasound2-trinity-dev=libasound2-trinity-dev" >> debian/libarts1-dev.substvars
+ echo "libasound2-dev=libasound2-dev" >> debian/libarts1-trinity-dev.substvars
endif
diff --git a/debian/wheezy/dependencies/libcaldav/debian/source/format b/debian/wheezy/dependencies/libcaldav/debian/source/format
new file mode 100644
index 000000000..89ae9db8f
--- /dev/null
+++ b/debian/wheezy/dependencies/libcaldav/debian/source/format
@@ -0,0 +1 @@
+3.0 (native)
diff --git a/debian/wheezy/dependencies/libcaldav/debian/source/options b/debian/wheezy/dependencies/libcaldav/debian/source/options
new file mode 100644
index 000000000..72f1f5450
--- /dev/null
+++ b/debian/wheezy/dependencies/libcaldav/debian/source/options
@@ -0,0 +1,6 @@
+# Use xz instead of gzip
+compression = "xz"
+compression-level = 9
+
+# Don't run differences
+diff-ignore = .*
diff --git a/debian/wheezy/dependencies/libcarddav/debian/source/format b/debian/wheezy/dependencies/libcarddav/debian/source/format
new file mode 100644
index 000000000..89ae9db8f
--- /dev/null
+++ b/debian/wheezy/dependencies/libcarddav/debian/source/format
@@ -0,0 +1 @@
+3.0 (native)
diff --git a/debian/wheezy/dependencies/libcarddav/debian/source/options b/debian/wheezy/dependencies/libcarddav/debian/source/options
new file mode 100644
index 000000000..72f1f5450
--- /dev/null
+++ b/debian/wheezy/dependencies/libcarddav/debian/source/options
@@ -0,0 +1,6 @@
+# Use xz instead of gzip
+compression = "xz"
+compression-level = 9
+
+# Don't run differences
+diff-ignore = .*
diff --git a/debian/wheezy/dependencies/qt3/debian/control b/debian/wheezy/dependencies/qt3/debian/control
index e10fbcab1..cf10bbb50 100644
--- a/debian/wheezy/dependencies/qt3/debian/control
+++ b/debian/wheezy/dependencies/qt3/debian/control
@@ -11,7 +11,7 @@ Build-Depends: debhelper (>= 5.0.31), quilt, cpio, libxext-dev (>= 4.3.0.dfsg.1-
libfreetype6-dev, libxft-dev, unixodbc-dev, uuid-dev, libglib2.0-dev,
libmysqlclient-dev, flex, libpq-dev, libaudio-dev, libcups2-dev,
libgl1-mesa-dev | libgl-dev, libglu1-mesa-dev | libglu-dev, libsqlite3-dev,
- firebird2.1-dev [i386 kfreebsd-i386 kfreebsd-amd64 knetbsd-i386 netbsd-i386 amd64 sparc powerpc] | firebird2-dev [i386 amd64]
+ firebird-dev | firebird2.1-dev [i386 kfreebsd-i386 kfreebsd-amd64 knetbsd-i386 netbsd-i386 amd64 sparc powerpc] | firebird2-dev [i386 amd64]
Section: libs
Priority: optional
Standards-Version: 3.8.4
diff --git a/debian/wheezy/dependencies/qt3/debian/patches/06_disable_rpath.diff b/debian/wheezy/dependencies/qt3/debian/patches/06_disable_rpath.diff
index 27fc1426c..a3d74ffce 100644
--- a/debian/wheezy/dependencies/qt3/debian/patches/06_disable_rpath.diff
+++ b/debian/wheezy/dependencies/qt3/debian/patches/06_disable_rpath.diff
@@ -2,25 +2,29 @@ author: Martin Loschwitz <madkiss@madkiss.org>
Disables the rpath settings in qmake.conf
+Index: b/mkspecs/linux-g++/qmake.conf
+===================================================================
--- a/mkspecs/linux-g++/qmake.conf
+++ b/mkspecs/linux-g++/qmake.conf
-@@ -55,7 +55,7 @@ QMAKE_LFLAGS_SHLIB = -shared
+@@ -55,7 +55,7 @@
QMAKE_LFLAGS_PLUGIN = $$QMAKE_LFLAGS_SHLIB
QMAKE_LFLAGS_SONAME = -Wl,-soname,
QMAKE_LFLAGS_THREAD =
-QMAKE_RPATH = -Wl,-rpath,
+QMAKE_RPATH =
- QMAKE_LIBS =
+ QMAKE_LIBS = -luuid
QMAKE_LIBS_DYNLOAD = -ldl
+Index: b/mkspecs/linux-g++-64/qmake.conf
+===================================================================
--- a/mkspecs/linux-g++-64/qmake.conf
+++ b/mkspecs/linux-g++-64/qmake.conf
-@@ -58,7 +58,7 @@ QMAKE_LFLAGS_SHLIB = -shared
+@@ -58,7 +58,7 @@
QMAKE_LFLAGS_PLUGIN = $$QMAKE_LFLAGS_SHLIB
QMAKE_LFLAGS_SONAME = -Wl,-soname,
QMAKE_LFLAGS_THREAD =
-QMAKE_RPATH = -Wl,-rpath,
+QMAKE_RPATH =
- QMAKE_LIBS =
+ QMAKE_LIBS = -luuid
QMAKE_LIBS_DYNLOAD = -ldl
diff --git a/debian/wheezy/dependencies/tqt3/debian/control b/debian/wheezy/dependencies/tqt3/debian/control
index b45983f80..1655a1357 100644
--- a/debian/wheezy/dependencies/tqt3/debian/control
+++ b/debian/wheezy/dependencies/tqt3/debian/control
@@ -11,7 +11,7 @@ Build-Depends: debhelper (>= 5.0.31), quilt, cpio, libxext-dev (>= 4.3.0.dfsg.1-
libfreetype6-dev, libxft-dev, unixodbc-dev, uuid-dev, libglib2.0-dev,
libmysqlclient-dev, flex, libpq-dev, libaudio-dev, libcups2-dev,
libgl1-mesa-dev | libgl-dev, libglu1-mesa-dev | libglu-dev, libsqlite3-dev,
- firebird2.1-dev [i386 kfreebsd-i386 kfreebsd-amd64 knetbsd-i386 netbsd-i386 amd64 sparc powerpc] | firebird2-dev [i386 amd64]
+ firebird-dev | firebird2.1-dev [i386 kfreebsd-i386 kfreebsd-amd64 knetbsd-i386 netbsd-i386 amd64 sparc powerpc] | firebird2-dev [i386 amd64]
Section: libs
Priority: optional
Standards-Version: 3.8.4
diff --git a/debian/wheezy/dependencies/tqt3/debian/patches/06_disable_rpath.diff b/debian/wheezy/dependencies/tqt3/debian/patches/06_disable_rpath.diff
index 27fc1426c..a3d74ffce 100644
--- a/debian/wheezy/dependencies/tqt3/debian/patches/06_disable_rpath.diff
+++ b/debian/wheezy/dependencies/tqt3/debian/patches/06_disable_rpath.diff
@@ -2,25 +2,29 @@ author: Martin Loschwitz <madkiss@madkiss.org>
Disables the rpath settings in qmake.conf
+Index: b/mkspecs/linux-g++/qmake.conf
+===================================================================
--- a/mkspecs/linux-g++/qmake.conf
+++ b/mkspecs/linux-g++/qmake.conf
-@@ -55,7 +55,7 @@ QMAKE_LFLAGS_SHLIB = -shared
+@@ -55,7 +55,7 @@
QMAKE_LFLAGS_PLUGIN = $$QMAKE_LFLAGS_SHLIB
QMAKE_LFLAGS_SONAME = -Wl,-soname,
QMAKE_LFLAGS_THREAD =
-QMAKE_RPATH = -Wl,-rpath,
+QMAKE_RPATH =
- QMAKE_LIBS =
+ QMAKE_LIBS = -luuid
QMAKE_LIBS_DYNLOAD = -ldl
+Index: b/mkspecs/linux-g++-64/qmake.conf
+===================================================================
--- a/mkspecs/linux-g++-64/qmake.conf
+++ b/mkspecs/linux-g++-64/qmake.conf
-@@ -58,7 +58,7 @@ QMAKE_LFLAGS_SHLIB = -shared
+@@ -58,7 +58,7 @@
QMAKE_LFLAGS_PLUGIN = $$QMAKE_LFLAGS_SHLIB
QMAKE_LFLAGS_SONAME = -Wl,-soname,
QMAKE_LFLAGS_THREAD =
-QMAKE_RPATH = -Wl,-rpath,
+QMAKE_RPATH =
- QMAKE_LIBS =
+ QMAKE_LIBS = -luuid
QMAKE_LIBS_DYNLOAD = -ldl
diff --git a/debian/wheezy/libraries/python-trinity/debian/control b/debian/wheezy/libraries/python-trinity/debian/control
index ef0d3115a..c69bdc5ea 100644
--- a/debian/wheezy/libraries/python-trinity/debian/control
+++ b/debian/wheezy/libraries/python-trinity/debian/control
@@ -4,17 +4,15 @@ Priority: optional
Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
XSBC-Original-Maintainer: Ricardo Javier Cardenes Medina <rcardenes@debian.org>
Uploaders: Torsten Marek <shlomme@debian.org>, Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
-Build-Depends: debhelper (>= 5.0.38), libtqtinterface-dev, python, python-all-dev, python-all-dbg, sip4 (>= 4.10), python-sip4-dev (>= 4.10), python-tqt-dev, tdelibs14-trinity-dev, python-support (>= 0.6) | python-dev (>= 2.6.6-3~), dpatch, python-sip4, python-sip4-dbg, python-sip4-dev
+Build-Depends: debhelper (>= 5.0.38), libtqtinterface-dev, python, python-all-dev, python-all-dbg, sip4 (>= 4.10), python-sip4-dev (>= 4.10), python-tqt-dev, tdelibs14-trinity-dev, python-sip4, python-sip4-dbg, python-sip4-dev
Standards-Version: 3.8.4
Homepage: http://www.riverbankcomputing.co.uk/pytde/index.php
-XS-Python-Version: all
Package: python-trinity-trinity
Architecture: any
Depends: ${shlibs:Depends}, ${python:Depends}, python-tqt
Replaces: python-trinity-trinity (<< 4:14.0.0)
Breaks: python-trinity-trinity (<< 4:14.0.0)
-XB-Python-Version: ${python:Versions}
Provides: ${python:Provides}
Conflicts: python-trinity-trinity
Description: Trinity bindings for Python [Trinity]
@@ -28,7 +26,6 @@ Architecture: any
Replaces: python-trinity-trinity-dbg (<< 4:14.0.0)
Breaks: python-trinity-trinity-dbg (<< 4:14.0.0)
Depends: python-trinity-trinity (= ${binary:Version}), python-dbg, python-tqt-dbg, ${shlibs:Depends}
-XB-Python-Version: ${python:Versions}
Description: Trinity bindings for Python (debug extensions) [Trinity]
Python binding module that provides wide access to the Trinity API,
also known as PyKDE. Using this, you'll get (for example) classes
@@ -42,7 +39,6 @@ Architecture: all
Replaces: python-trinity-trinity-dev (<< 4:14.0.0)
Breaks: python-trinity-trinity-dev (<< 4:14.0.0)
Depends: pytqt-tools, ${python:Depends}
-XB-Python-Version: ${python:Versions}
Description: Trinity bindings for Python - Development files and scripts [Trinity]
Development .sip files with definitions of PyKDE classes. They
are needed to build PyKDE, but also as building blocks of other
diff --git a/debian/wheezy/libraries/python-trinity/debian/pycompat b/debian/wheezy/libraries/python-trinity/debian/pycompat
deleted file mode 100644
index 0cfbf0888..000000000
--- a/debian/wheezy/libraries/python-trinity/debian/pycompat
+++ /dev/null
@@ -1 +0,0 @@
-2
diff --git a/debian/wheezy/libraries/python-trinity/debian/rules b/debian/wheezy/libraries/python-trinity/debian/rules
index d4dac70f3..473caac7d 100755
--- a/debian/wheezy/libraries/python-trinity/debian/rules
+++ b/debian/wheezy/libraries/python-trinity/debian/rules
@@ -14,7 +14,6 @@ cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xine
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
-include /usr/share/dpatch/dpatch.make
# This has to be exported to make some magic below work.
export DH_OPTIONS
export QTDIR=/usr/share/qt3
@@ -31,8 +30,7 @@ endif
PYTHONS := $(shell pyversions -vr debian/control)
DBG_PYTHONS := $(shell pyversions -vd)
-DEB_PYTHON_SYSTEM = $(if $(wildcard /usr/bin/dh_python2),,pysupport)
-DH_PYTHON2 = $(if $(wildcard /usr/bin/dh_python2),dh_python2,dh_pysupport)
+DH_PYTHON2 = $(if $(wildcard /usr/bin/dh_python2),dh_python2,dh_python)
GCCVER := $(shell gcc --version | sed -n '/^gcc (GCC)/s/.*(GCC) \(...\).*/\1/p')
ifneq (,$(filter $(GCCVER),4.2 4.3))
@@ -45,7 +43,7 @@ endif
configure: $(PYTHONS:%=build-%/configure-stamp) $(DBG_PYTHONS:%=dbg-build-%/configure-stamp)
-build-%/configure-stamp: patch-stamp
+build-%/configure-stamp:
dh_testdir
mkdir -p build-$*
cd build-$* && python$* ../configure.py \
@@ -53,7 +51,7 @@ build-%/configure-stamp: patch-stamp
-v /opt/trinity/share/sip/trinity -j $(SPLIT)
touch $@
-dbg-build-%/configure-stamp: patch-stamp
+dbg-build-%/configure-stamp:
dh_testdir
mkdir -p dbg-build-$*
cd dbg-build-$* && python$*-dbg ../configure.py \
@@ -73,7 +71,7 @@ dbg-build-%/build-stamp: dbg-build-%/configure-stamp
$(MAKE) -C dbg-build-$*
touch $@
-clean: unpatch
+clean:
dh_testdir
dh_testroot
rm -f *-stamp
diff --git a/debian/wheezy/tdebase/debian/control b/debian/wheezy/tdebase/debian/control
index f6d04d18f..e4874266c 100644
--- a/debian/wheezy/tdebase/debian/control
+++ b/debian/wheezy/tdebase/debian/control
@@ -88,7 +88,7 @@ Section: tde
Architecture: any
Replaces: kcontrol-trinity (<< 4:14.0.0)
Breaks: kcontrol-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdebase-data-trinity (>> ${KDE-Version3}), tdebase-data-trinity (<< ${KDE-Next-Version3}), usbutils
+Depends: ${shlibs:Depends}, tdebase-data-trinity (>> ${KDE-Version3}~), tdebase-data-trinity (<< ${KDE-Next-Version3}~), usbutils
Recommends: udev
Suggests: khelpcenter-trinity, ntpdate | ntp-simple
Conflicts: tdebase-libs-trinity (<< 4:3.0.0)
@@ -254,7 +254,7 @@ Section: tde
Architecture: any
Replaces: kdm-trinity (<< 4:14.0.0)
Breaks: kdm-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdebase-trinity-bin (= ${Source-Version}), tdebase-data-trinity (>> ${KDE-Version3}), tdebase-data-trinity (<< ${KDE-Next-Version3}), debconf (>= 1.2.9) | debconf-2.0, libpam-runtime (>= 0.76-14), xbase-clients
+Depends: ${shlibs:Depends}, tdebase-trinity-bin (= ${Source-Version}), tdebase-data-trinity (>> ${KDE-Version3}~), tdebase-data-trinity (<< ${KDE-Next-Version3}~), debconf (>= 1.2.9) | debconf-2.0, libpam-runtime (>= 0.76-14), xbase-clients
Recommends: logrotate, xserver-xorg
Suggests: khelpcenter-trinity, ksmserver-trinity (= ${Source-Version}), tdepasswd-trinity (= ${Source-Version}), menu
Provides: x-display-manager
@@ -313,7 +313,7 @@ Section: tde
Architecture: any
Replaces: kicker-trinity (<< 4:14.0.0)
Breaks: kicker-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdebase-data-trinity (>> ${KDE-Version3}), tdebase-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdebase-data-trinity (>> ${KDE-Version3}~), tdebase-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, kicker-applets-trinity, menu
Conflicts: tdebase-libs-trinity (<< 4:3.0.0)
Description: desktop panel for KDE
@@ -446,7 +446,7 @@ Section: tde
Architecture: any
Replaces: kpersonalizer-trinity (<< 4:14.0.0)
Breaks: kpersonalizer-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdebase-data-trinity (>> ${KDE-Version3}), tdebase-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdebase-data-trinity (>> ${KDE-Version3}~), tdebase-data-trinity (<< ${KDE-Next-Version3}~)
Description: installation personalizer for KDE
KDE Personalizer is the application that configures the KDE desktop for you.
It's a very useful wizard that allows you to quickly change the KDE desktop to
@@ -483,7 +483,7 @@ Section: tde
Architecture: any
Replaces: ksplash-trinity (<< 4:14.0.0)
Breaks: ksplash-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdebase-data-trinity (>> ${KDE-Version3}), tdebase-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdebase-data-trinity (>> ${KDE-Version3}~), tdebase-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity
Description: the KDE splash screen
This package includes the KDE Splash screen, which is seen when
@@ -540,7 +540,7 @@ Replaces: kwin-trinity (<< 4:14.0.0)
Breaks: kwin-trinity (<< 4:14.0.0)
Depends: ${shlibs:Depends}
Provides: x-window-manager
-Suggests: tdebase-trinity-bin (= ${Source-Version}), tdebase-data-trinity (>> ${KDE-Version3}), tdebase-data-trinity (<< ${KDE-Next-Version3}), kdesktop-trinity (= ${Source-Version}), kicker-trinity (= ${Source-Version}), kpager-trinity (= ${Source-Version}), kpersonalizer-trinity (= ${Source-Version}), ksmserver-trinity (= ${Source-Version}), ksplash-trinity (= ${Source-Version})
+Suggests: tdebase-trinity-bin (= ${Source-Version}), tdebase-data-trinity (>> ${KDE-Version3}~), tdebase-data-trinity (<< ${KDE-Next-Version3}~), kdesktop-trinity (= ${Source-Version}), kicker-trinity (= ${Source-Version}), kpager-trinity (= ${Source-Version}), kpersonalizer-trinity (= ${Source-Version}), ksmserver-trinity (= ${Source-Version}), ksplash-trinity (= ${Source-Version})
Conflicts: kde-window-manager-trinity (<< 7:3.5.0)
Description: the KDE window manager
This package contains the default X window manager for KDE.
diff --git a/debian/wheezy/tdebindings/debian/control b/debian/wheezy/tdebindings/debian/control
index 0bb4c4a0a..c561fffb0 100644
--- a/debian/wheezy/tdebindings/debian/control
+++ b/debian/wheezy/tdebindings/debian/control
@@ -29,7 +29,7 @@ Architecture: all
Section: libs
Replaces: libdcop3-java-trinity (<< 4:14.0.0)
Breaks: libdcop3-java-trinity (<< 4:14.0.0)
-Depends: libdcop3-jni-trinity (>> ${KDE-Version3}), libdcop3-jni-trinity (<< ${KDE-Next-Version3}), gij | java1-runtime | java2-runtime
+Depends: libdcop3-jni-trinity (>> ${KDE-Version3}~), libdcop3-jni-trinity (<< ${KDE-Next-Version3}~), gij | java1-runtime | java2-runtime
Description: DCOP bindings for Java [Trinity]
This package contains the Java classes necessary to run Java programs
using the Java DCOP bindings. DCOP is the TDE Desktop COmmunications
@@ -56,7 +56,7 @@ Architecture: amd64 i386 ia64 powerpc s390 sparc
Section: libdevel
Replaces: libdcop3-java-trinity-dev (<< 4:14.0.0)
Breaks: libdcop3-java-trinity-dev (<< 4:14.0.0)
-Depends: libdcop3-java-trinity (>> ${KDE-Version3}), libdcop3-java-trinity (<< ${KDE-Next-Version3})
+Depends: libdcop3-java-trinity (>> ${KDE-Version3}~), libdcop3-java-trinity (<< ${KDE-Next-Version3}~)
Description: DCOP bindings for Java (dcopidl2java program) [Trinity]
This package contains the dcopidl2java program which generates Java
stubs from DCOP IDL files, necessary to do development with the DCOP Java
@@ -70,7 +70,7 @@ Architecture: all
Section: libs
Replaces: libqt3-java-trinity (<< 4:14.0.0)
Breaks: libqt3-java-trinity (<< 4:14.0.0)
-Depends: libqt3-jni-trinity (>> ${KDE-Version3}), libqt3-jni-trinity (<< ${KDE-Next-Version3}), gij | java1-runtime | java2-runtime
+Depends: libqt3-jni-trinity (>> ${KDE-Version3}~), libqt3-jni-trinity (<< ${KDE-Next-Version3}~), gij | java1-runtime | java2-runtime
Suggests: juic-trinity
Description: Java bindings for Qt [Trinity]
This package contains the Java classes necessary to run Java programs
@@ -100,7 +100,7 @@ Architecture: all
Section: libs
Replaces: libtrinity-java-trinity (<< 4:14.0.0)
Breaks: libtrinity-java-trinity (<< 4:14.0.0)
-Depends: libtrinity-jni-trinity (>> ${KDE-Version3}), libtrinity-jni-trinity (<< ${KDE-Next-Version3}), gij | java1-runtime | java2-runtime
+Depends: libtrinity-jni-trinity (>> ${KDE-Version3}~), libtrinity-jni-trinity (<< ${KDE-Next-Version3}~), gij | java1-runtime | java2-runtime
Description: tdelibs bindings for Java [Trinity]
This package contains the Java classes necessary to run Java programs
using the Java tdelibs bindings. TDE is the Trinity Desktop Environment, a
diff --git a/debian/wheezy/tdeedu/debian/control b/debian/wheezy/tdeedu/debian/control
index b8323cf70..9b00cc54f 100644
--- a/debian/wheezy/tdeedu/debian/control
+++ b/debian/wheezy/tdeedu/debian/control
@@ -74,7 +74,7 @@ Architecture: any
Section: games
Replaces: blinken-trinity (<< 4:14.0.0)
Breaks: blinken-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, ttf-sjfonts, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, ttf-sjfonts, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: Trinity version of the Simon Says electronic memory game
Blinken is based on an electronic game released in 1978, which
@@ -94,7 +94,7 @@ Architecture: any
Section: science
Replaces: kalzium-trinity (<< 4:14.0.0)
Breaks: kalzium-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, kalzium-data-trinity (>> ${KDE-Version3}), kalzium-data-trinity (<< ${KDE-Next-Version3}), tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, kalzium-data-trinity (>> ${KDE-Version3}~), kalzium-data-trinity (<< ${KDE-Next-Version3}~), tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: chemistry teaching tool for Trinity
Kalzium is a program which shows you the Periodic System of Elements
@@ -137,7 +137,7 @@ Architecture: any
Section: games
Replaces: kanagram-trinity (<< 4:14.0.0)
Breaks: kanagram-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: letter order game for Trinity
KAnagram is a game that is based on the word/letter puzzles that the
@@ -160,7 +160,7 @@ Architecture: any
Section: math
Replaces: kbruch-trinity (<< 4:14.0.0)
Breaks: kbruch-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: fraction calculation teaching tool for Trinity
KBruch is a small program to practice calculating with fractions.
@@ -175,7 +175,7 @@ Architecture: any
Section: tde
Replaces: keduca-trinity (<< 4:14.0.0)
Breaks: keduca-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: interactive form-based tests for Trinity
KEduca is a flash-card application which allows you to make
@@ -189,7 +189,7 @@ Architecture: any
Section: tde
Replaces: kgeography-trinity (<< 4:14.0.0)
Breaks: kgeography-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, kgeography-data-trinity (>> ${KDE-Version3}), kgeography-data-trinity (<< ${KDE-Next-Version3}), tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, kgeography-data-trinity (>> ${KDE-Version3}~), kgeography-data-trinity (<< ${KDE-Next-Version3}~), tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: Geography learning tool for Trinity
KGeography contains maps allowing you to learn various countries or
@@ -220,7 +220,7 @@ Architecture: any
Section: games
Replaces: khangman-trinity (<< 4:14.0.0)
Breaks: khangman-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, ttf-dustin, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, ttf-dustin, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: the classical hangman game for Trinity
KHangMan is a game based on the well known hangman game. It is aimed
@@ -240,7 +240,7 @@ Architecture: any
Section: math
Replaces: kig-trinity (<< 4:14.0.0)
Breaks: kig-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: interactive geometry program for KDE
Kig is an application for interactive geometry. It is intended to
@@ -268,7 +268,7 @@ Architecture: any
Section: tde
Replaces: kiten-trinity (<< 4:14.0.0)
Breaks: kiten-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3}), ttf-kochi-gothic | ttf-kochi-mincho
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~), ttf-kochi-gothic | ttf-kochi-mincho
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: Japanese reference/study tool for Trinity
Kiten is a Japanese reference and study tool for KDE. It is an
@@ -285,7 +285,7 @@ Architecture: any
Section: tde
Replaces: klatin-trinity (<< 4:14.0.0)
Breaks: klatin-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: application to help revise/teach Latin
KLatin is a program to help revise Latin. There are three "sections"
@@ -310,7 +310,7 @@ Architecture: any
Section: tde
Replaces: klettres-trinity (<< 4:14.0.0)
Breaks: klettres-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, klettres-data-trinity (>> ${KDE-Version3}), klettres-data-trinity (<< ${KDE-Next-Version3}), tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, klettres-data-trinity (>> ${KDE-Version3}~), klettres-data-trinity (<< ${KDE-Next-Version3}~), tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: foreign alphabet tutor for Trinity
KLettres is an application specially designed to help the user to
@@ -344,7 +344,7 @@ Architecture: any
Section: math
Replaces: kmplot-trinity (<< 4:14.0.0)
Breaks: kmplot-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: mathematical function plotter for Trinity
KmPlot is a mathematical function plotter for KDE. It has a powerful
@@ -368,7 +368,7 @@ Architecture: any
Section: math
Replaces: kpercentage-trinity (<< 4:14.0.0)
Breaks: kpercentage-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: percentage calculation teaching tool for Trinity
KPercentage is a small math application that will help pupils to
@@ -386,7 +386,7 @@ Architecture: any
Section: science
Replaces: kstars-trinity (<< 4:14.0.0)
Breaks: kstars-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, kstars-data-trinity (>> ${KDE-Version3}), kstars-data-trinity (<< ${KDE-Next-Version3}), tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3}), indi-trinity (= ${Source-Version})
+Depends: ${shlibs:Depends}, kstars-data-trinity (>> ${KDE-Version3}~), kstars-data-trinity (<< ${KDE-Next-Version3}~), tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~), indi-trinity (= ${Source-Version})
Suggests: konqueror-trinity, khelpcenter-trinity, tdeedu-trinity-doc-html
Description: desktop planetarium for Trinity
KStars is a graphical desktop planetarium for KDE. It depicts an
@@ -424,7 +424,7 @@ Architecture: any
Section: tde
Replaces: ktouch-trinity (<< 4:14.0.0)
Breaks: ktouch-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: touch typing tutor for Trinity
KTouch is a program for learning touch typing - it helps you learn to
@@ -444,7 +444,7 @@ Architecture: any
Section: devel
Replaces: kturtle-trinity (<< 4:14.0.0)
Breaks: kturtle-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: educational Logo programming environment
KTurtle is an educational programming environment using the Logo
@@ -472,7 +472,7 @@ Architecture: any
Section: tde
Replaces: kverbos-trinity (<< 4:14.0.0)
Breaks: kverbos-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: Spanish verb form study application for Trinity
Kverbos allows the user to learn the forms of Spanish verbs. The
@@ -491,7 +491,7 @@ Architecture: any
Section: tde
Replaces: kvoctrain-trinity (<< 4:14.0.0)
Breaks: kvoctrain-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, ${perl:Depends}, libwww-perl, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, ${perl:Depends}, libwww-perl, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: vocabulary trainer for Trinity
KVocTrain is a little utility to help you train your vocabulary when
@@ -517,7 +517,7 @@ Architecture: any
Section: tde
Replaces: kwordquiz-trinity (<< 4:14.0.0)
Breaks: kwordquiz-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: flashcard and vocabulary learning program for Trinity
KWordQuiz is a flashcard-based tool that helps you to master new
diff --git a/debian/wheezy/tdegraphics/debian/control b/debian/wheezy/tdegraphics/debian/control
index 06b3dbe02..ea835feac 100644
--- a/debian/wheezy/tdegraphics/debian/control
+++ b/debian/wheezy/tdegraphics/debian/control
@@ -4,7 +4,7 @@ Priority: optional
Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
XSBC-Original-Maintainer: Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
Uploaders: Ana Beatriz Guerrero Lopez <ana@debian.org>, Francesco Pedrini <francesco.pedrini@gmail.com>, Josh Metzler <joshdeb@metzlers.org>, Sune Vuorela <debian@pusling.com>
-Build-Depends: imlib11-dev, cdbs (>= 0.4.39-0.1), debhelper (>= 5.0.31), autotools-dev, gawk, gettext, tdelibs14-trinity-dev, libexif-dev (>= 0.6.9-1), libfribidi-dev, freeglut3-dev, libgphoto2-2-dev, libopenexr-dev (>= 1.2.1), libpaper-dev, libpoppler-dev, libpoppler-private-dev, libsane-dev (>> 1.0.15), libtiff-dev, libtiff-tools, libusb-dev, sharutils, libxxf86vm-dev, chrpath [powerpc], cmake, libtool, libltdl-dev
+Build-Depends: imlib11-dev, cdbs (>= 0.4.39-0.1), debhelper (>= 5.0.31), autotools-dev, gawk, gettext, tdelibs14-trinity-dev, libexif-dev (>= 0.6.9-1), libfribidi-dev, freeglut3-dev, libgphoto2-6-dev | libgphoto2-2-dev, libopenexr-dev (>= 1.2.1), libpaper-dev, libpoppler-private-dev | libpoppler-dev (<< 0.18.4-3), libpoppler-dev, libsane-dev (>> 1.0.15), libtiff-dev, libtiff-tools, libusb-dev, sharutils, libxxf86vm-dev, chrpath [powerpc], cmake, libtool, libltdl-dev
Standards-Version: 3.8.4
Package: tdegraphics-trinity
diff --git a/ubuntu/maverick/applications/kcpuload/debian/rules b/ubuntu/maverick/applications/kcpuload/debian/rules
index 20eca167c..385c24313 100755
--- a/ubuntu/maverick/applications/kcpuload/debian/rules
+++ b/ubuntu/maverick/applications/kcpuload/debian/rules
@@ -45,11 +45,6 @@ ifeq ($(DEB_BUILD_GNU_TYPE),i386-linux)
#export CXXFLAGS=-O3 -march=i686 -ffast-math -finline-functions
endif
--include debian/debiandirs
-
-debian/debiandirs: admin/debianrules
- perl -w admin/debianrules echodirs > debian/debiandirs
-
configure: configure-stamp
configure-stamp:
dh_testdir
@@ -104,7 +99,7 @@ debian-clean:
clean:
dh_testdir
dh_testroot
- rm -f build-stamp configure-stamp debian/debiandirs
+ rm -f build-stamp configure-stamp
# Remove Debian specific patches
if test -f patch-stamp; then \
@@ -169,8 +164,6 @@ binary-common:
dh_testroot
dh_installchangelogs kcpuload/ChangeLog
dh_installdocs
- mkdir debian/kcpuload-trinity/opt/trinity/share/doc
- mv debian/kcpuload-trinity/usr/share/doc/tde debian/kcpuload-trinity/opt/trinity/share/doc/
rm -fr debian/kcpuload-trinity/usr/share/doc-base
dh_installexamples
dh_installmanpages
diff --git a/ubuntu/maverick/applications/koffice/debian/control b/ubuntu/maverick/applications/koffice/debian/control
index aa5d4cadb..6d2e73b8c 100644
--- a/ubuntu/maverick/applications/koffice/debian/control
+++ b/ubuntu/maverick/applications/koffice/debian/control
@@ -61,7 +61,7 @@ Architecture: any
Section: graphics
Replaces: karbon-kde3 (<< 4:14.0.0), karbon-trinity (<< 4:14.0.0)
Breaks: karbon-kde3 (<< 4:14.0.0), karbon-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Description: a vector graphics application for the KDE Office Suite
Karbon is a vector graphics application.
.
@@ -72,7 +72,7 @@ Architecture: any
Section: tde
Replaces: kchart-kde3 (<< 4:14.0.0), kchart-trinity (<< 4:14.0.0)
Breaks: kchart-kde3 (<< 4:14.0.0), kchart-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: a chart drawing program for the KDE Office Suite [Trinity]
KChart is a chart drawing application. It can be used to embed charts
@@ -85,7 +85,7 @@ Architecture: any
Section: tde
Replaces: kexi-kde3 (<< 4:14.0.0), kexi-trinity (<< 4:14.0.0)
Breaks: kexi-kde3 (<< 4:14.0.0), kexi-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Suggests: kexi-mdb-plugin-trinity
Description: integrated database environment for the KDE Office Suite [Trinity]
Kexi is an integrated data management application. It can be used for
@@ -107,7 +107,7 @@ Architecture: any
Section: tde
Replaces: kformula-kde3 (<< 4:14.0.0), kformula-trinity (<< 4:14.0.0)
Breaks: kformula-kde3 (<< 4:14.0.0), kformula-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: a formula editor for the KDE Office Suite [Trinity]
KFormula is a formula editor that provides the basic input facilities
@@ -124,7 +124,7 @@ Architecture: any
Section: graphics
Replaces: kivio-kde3 (<< 4:14.0.0), kivio-trinity (<< 4:14.0.0)
Breaks: kivio-kde3 (<< 4:14.0.0), kivio-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, kivio-data-trinity (>> 1:1.4.90.2-1), kivio-data-trinity (>> ${KDE-Version3}), kivio-data-trinity (<< ${KDE-Next-Version3}), koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, kivio-data-trinity (>> 1:1.4.90.2-1), kivio-data-trinity (>> ${KDE-Version3}~), kivio-data-trinity (<< ${KDE-Next-Version3}~), koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Description: a flowcharting program for the KDE Office Suite [Trinity]
Kivio is a flowcharting program that offers basic flowcharting abilities,
but with a twist. Objects are scriptable, and a backend plugin system
@@ -150,7 +150,7 @@ Architecture: any
Section: tde
Replaces: koshell-kde3 (<< 4:14.0.0), koshell-trinity (<< 4:14.0.0)
Breaks: koshell-kde3 (<< 4:14.0.0), koshell-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: koffice-trinity, khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: the KDE Office Suite workspace [Trinity]
The KOffice workspace is a desktop with easy one-click launchers for
@@ -163,7 +163,7 @@ Architecture: any
Section: tde
Replaces: kplato-kde3 (<< 4:14.0.0), kplato-trinity (<< 4:14.0.0)
Breaks: kplato-kde3 (<< 4:14.0.0), kplato-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: an integrated project management and planning tool [Trinity]
KPlato is a project management application, allowing for the planning and
@@ -177,7 +177,7 @@ Architecture: any
Section: tde
Replaces: kpresenter-kde3 (<< 4:14.0.0), kpresenter-trinity (<< 4:14.0.0)
Breaks: kpresenter-kde3 (<< 4:14.0.0), kpresenter-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, ${perl:Depends}, kpresenter-data-trinity (>> ${KDE-Version3}), kpresenter-data-trinity (<< ${KDE-Next-Version3}), koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, ${perl:Depends}, kpresenter-data-trinity (>> ${KDE-Version3}~), kpresenter-data-trinity (<< ${KDE-Next-Version3}~), koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: a presentation program for the KDE Office Suite [Trinity]
KPresenter is a fully-featured presentation program. Presentations can
@@ -204,7 +204,7 @@ Architecture: any
Section: tde
Replaces: krita-kde3 (<< 4:14.0.0), chalk-trinity (<< 4:14.0.0)
Breaks: krita-kde3 (<< 4:14.0.0), chalk-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, chalk-data-trinity (>> ${KDE-Version3}), chalk-data-trinity (<< ${KDE-Next-Version3}), koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, chalk-data-trinity (>> ${KDE-Version3}~), chalk-data-trinity (<< ${KDE-Next-Version3}~), koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: dcraw, khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: a pixel-based image manipulation program for the KDE Office Suite [Trinity]
Chalk is a painting and image editing application for KOffice. Chalk contains
@@ -230,7 +230,7 @@ Architecture: any
Section: tde
Replaces: kspread-kde3 (<< 4:14.0.0), kspread-trinity (<< 4:14.0.0)
Breaks: kspread-kde3 (<< 4:14.0.0), kspread-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: a spreadsheet for the KDE Office Suite [Trinity]
KSpread is a powerful spreadsheet application. It is scriptable and
@@ -244,7 +244,7 @@ Architecture: any
Section: tde
Replaces: kugar-kde3 (<< 4:14.0.0), kugar-trinity (<< 4:14.0.0)
Breaks: kugar-kde3 (<< 4:14.0.0), kugar-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: a business report maker for the KDE Office Suite [Trinity]
Kugar is a tool for generating business quality reports that can
@@ -260,7 +260,7 @@ Architecture: any
Section: tde
Replaces: kword-kde3 (<< 4:14.0.0), kword-trinity (<< 4:14.0.0)
Breaks: kword-kde3 (<< 4:14.0.0), kword-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, kword-data-trinity (>> ${KDE-Version3}), kword-data-trinity (<< ${KDE-Next-Version3}), koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, kword-data-trinity (>> ${KDE-Version3}~), kword-data-trinity (<< ${KDE-Next-Version3}~), koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: a word processor for the KDE Office Suite [Trinity]
KWord is a FrameMaker-like word processing and desktop publishing
@@ -288,7 +288,7 @@ Architecture: any
Section: tde
Replaces: kthesaurus-kde3 (<< 4:14.0.0), kthesaurus-trinity (<< 4:14.0.0)
Breaks: kthesaurus-kde3 (<< 4:14.0.0), kthesaurus-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: thesaurus for the KDE Office Suite [Trinity]
KThesaurus lists words related to a given term and offers a user interface
@@ -302,7 +302,7 @@ Architecture: any
Section: libs
Replaces: koffice-libs-kde3 (<< 4:14.0.0), koffice-libs-trinity (<< 4:14.0.0)
Breaks: koffice-libs-kde3 (<< 4:14.0.0), koffice-libs-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-data-trinity (>> ${KDE-Version3}), koffice-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-data-trinity (>> ${KDE-Version3}~), koffice-data-trinity (<< ${KDE-Next-Version3}~)
Recommends: latex-xft-fonts, ruby, python
Suggests: wordnet, texlive-base
Description: common libraries and binaries for the KDE Office Suite [Trinity]
diff --git a/ubuntu/maverick/dependencies/arts/debian/patches/12_cleanup_artsc-config.diff b/ubuntu/maverick/dependencies/arts/debian/patches/12_cleanup_artsc-config.diff
index 603ffdf37..57a8122f9 100644
--- a/ubuntu/maverick/dependencies/arts/debian/patches/12_cleanup_artsc-config.diff
+++ b/ubuntu/maverick/dependencies/arts/debian/patches/12_cleanup_artsc-config.diff
@@ -1,3 +1,5 @@
+Index: b/artsc/artsc-config.in
+===================================================================
--- a/artsc/artsc-config.in
+++ b/artsc/artsc-config.in
@@ -27,7 +27,7 @@
@@ -8,4 +10,4 @@
+ flags="$flags -L$libdir -lartsc"
;;
--cflags)
- flags="$flags -I$includedir/artsc @GLIB_CFLAGS@"
+ flags="$flags -I$includedir @GLIB_CFLAGS@"
diff --git a/ubuntu/maverick/dependencies/arts/debian/rules b/ubuntu/maverick/dependencies/arts/debian/rules
index 9c9730bda..1b4911297 100755
--- a/ubuntu/maverick/dependencies/arts/debian/rules
+++ b/ubuntu/maverick/dependencies/arts/debian/rules
@@ -41,6 +41,6 @@ DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
binary-predeb/libarts1-trinity-dev::
ifeq (linux,$(DEB_HOST_ARCH_OS))
- echo "libasound2-trinity-dev=libasound2-trinity-dev" >> debian/libarts1-dev.substvars
+ echo "libasound2-dev=libasound2-dev" >> debian/libarts1-trinity-dev.substvars
endif
diff --git a/ubuntu/maverick/dependencies/libcaldav/debian/source/format b/ubuntu/maverick/dependencies/libcaldav/debian/source/format
new file mode 100644
index 000000000..89ae9db8f
--- /dev/null
+++ b/ubuntu/maverick/dependencies/libcaldav/debian/source/format
@@ -0,0 +1 @@
+3.0 (native)
diff --git a/ubuntu/maverick/dependencies/libcaldav/debian/source/options b/ubuntu/maverick/dependencies/libcaldav/debian/source/options
new file mode 100644
index 000000000..72f1f5450
--- /dev/null
+++ b/ubuntu/maverick/dependencies/libcaldav/debian/source/options
@@ -0,0 +1,6 @@
+# Use xz instead of gzip
+compression = "xz"
+compression-level = 9
+
+# Don't run differences
+diff-ignore = .*
diff --git a/ubuntu/maverick/dependencies/libcarddav/debian/source/format b/ubuntu/maverick/dependencies/libcarddav/debian/source/format
new file mode 100644
index 000000000..89ae9db8f
--- /dev/null
+++ b/ubuntu/maverick/dependencies/libcarddav/debian/source/format
@@ -0,0 +1 @@
+3.0 (native)
diff --git a/ubuntu/maverick/dependencies/libcarddav/debian/source/options b/ubuntu/maverick/dependencies/libcarddav/debian/source/options
new file mode 100644
index 000000000..72f1f5450
--- /dev/null
+++ b/ubuntu/maverick/dependencies/libcarddav/debian/source/options
@@ -0,0 +1,6 @@
+# Use xz instead of gzip
+compression = "xz"
+compression-level = 9
+
+# Don't run differences
+diff-ignore = .*
diff --git a/ubuntu/maverick/dependencies/qt3/debian/control b/ubuntu/maverick/dependencies/qt3/debian/control
index 4be146e7d..7641cffbf 100644
--- a/ubuntu/maverick/dependencies/qt3/debian/control
+++ b/ubuntu/maverick/dependencies/qt3/debian/control
@@ -11,7 +11,7 @@ Build-Depends: debhelper (>= 5.0.31), quilt, cpio, libxext-dev (>= 4.3.0.dfsg.1-
libfreetype6-dev, libxft-dev, unixodbc-dev, uuid-dev, libglib2.0-dev,
libmysqlclient-dev, flex, libpq-dev, libaudio-dev, libcups2-dev,
libgl1-mesa-dev | libgl-dev, libglu1-mesa-dev | libglu-dev, libsqlite3-dev,
- firebird2.1-dev [i386 kfreebsd-i386 kfreebsd-amd64 knetbsd-i386 netbsd-i386 amd64 sparc powerpc] | firebird2-dev [i386 amd64]
+ firebird-dev | firebird2.1-dev [i386 kfreebsd-i386 kfreebsd-amd64 knetbsd-i386 netbsd-i386 amd64 sparc powerpc] | firebird2-dev [i386 amd64]
Section: libs
Priority: optional
Standards-Version: 3.8.4
diff --git a/ubuntu/maverick/dependencies/qt3/debian/patches/06_disable_rpath.diff b/ubuntu/maverick/dependencies/qt3/debian/patches/06_disable_rpath.diff
index 27fc1426c..a3d74ffce 100644
--- a/ubuntu/maverick/dependencies/qt3/debian/patches/06_disable_rpath.diff
+++ b/ubuntu/maverick/dependencies/qt3/debian/patches/06_disable_rpath.diff
@@ -2,25 +2,29 @@ author: Martin Loschwitz <madkiss@madkiss.org>
Disables the rpath settings in qmake.conf
+Index: b/mkspecs/linux-g++/qmake.conf
+===================================================================
--- a/mkspecs/linux-g++/qmake.conf
+++ b/mkspecs/linux-g++/qmake.conf
-@@ -55,7 +55,7 @@ QMAKE_LFLAGS_SHLIB = -shared
+@@ -55,7 +55,7 @@
QMAKE_LFLAGS_PLUGIN = $$QMAKE_LFLAGS_SHLIB
QMAKE_LFLAGS_SONAME = -Wl,-soname,
QMAKE_LFLAGS_THREAD =
-QMAKE_RPATH = -Wl,-rpath,
+QMAKE_RPATH =
- QMAKE_LIBS =
+ QMAKE_LIBS = -luuid
QMAKE_LIBS_DYNLOAD = -ldl
+Index: b/mkspecs/linux-g++-64/qmake.conf
+===================================================================
--- a/mkspecs/linux-g++-64/qmake.conf
+++ b/mkspecs/linux-g++-64/qmake.conf
-@@ -58,7 +58,7 @@ QMAKE_LFLAGS_SHLIB = -shared
+@@ -58,7 +58,7 @@
QMAKE_LFLAGS_PLUGIN = $$QMAKE_LFLAGS_SHLIB
QMAKE_LFLAGS_SONAME = -Wl,-soname,
QMAKE_LFLAGS_THREAD =
-QMAKE_RPATH = -Wl,-rpath,
+QMAKE_RPATH =
- QMAKE_LIBS =
+ QMAKE_LIBS = -luuid
QMAKE_LIBS_DYNLOAD = -ldl
diff --git a/ubuntu/maverick/dependencies/tqt3/debian/control b/ubuntu/maverick/dependencies/tqt3/debian/control
index b45983f80..1655a1357 100644
--- a/ubuntu/maverick/dependencies/tqt3/debian/control
+++ b/ubuntu/maverick/dependencies/tqt3/debian/control
@@ -11,7 +11,7 @@ Build-Depends: debhelper (>= 5.0.31), quilt, cpio, libxext-dev (>= 4.3.0.dfsg.1-
libfreetype6-dev, libxft-dev, unixodbc-dev, uuid-dev, libglib2.0-dev,
libmysqlclient-dev, flex, libpq-dev, libaudio-dev, libcups2-dev,
libgl1-mesa-dev | libgl-dev, libglu1-mesa-dev | libglu-dev, libsqlite3-dev,
- firebird2.1-dev [i386 kfreebsd-i386 kfreebsd-amd64 knetbsd-i386 netbsd-i386 amd64 sparc powerpc] | firebird2-dev [i386 amd64]
+ firebird-dev | firebird2.1-dev [i386 kfreebsd-i386 kfreebsd-amd64 knetbsd-i386 netbsd-i386 amd64 sparc powerpc] | firebird2-dev [i386 amd64]
Section: libs
Priority: optional
Standards-Version: 3.8.4
diff --git a/ubuntu/maverick/dependencies/tqt3/debian/patches/06_disable_rpath.diff b/ubuntu/maverick/dependencies/tqt3/debian/patches/06_disable_rpath.diff
index 27fc1426c..a3d74ffce 100644
--- a/ubuntu/maverick/dependencies/tqt3/debian/patches/06_disable_rpath.diff
+++ b/ubuntu/maverick/dependencies/tqt3/debian/patches/06_disable_rpath.diff
@@ -2,25 +2,29 @@ author: Martin Loschwitz <madkiss@madkiss.org>
Disables the rpath settings in qmake.conf
+Index: b/mkspecs/linux-g++/qmake.conf
+===================================================================
--- a/mkspecs/linux-g++/qmake.conf
+++ b/mkspecs/linux-g++/qmake.conf
-@@ -55,7 +55,7 @@ QMAKE_LFLAGS_SHLIB = -shared
+@@ -55,7 +55,7 @@
QMAKE_LFLAGS_PLUGIN = $$QMAKE_LFLAGS_SHLIB
QMAKE_LFLAGS_SONAME = -Wl,-soname,
QMAKE_LFLAGS_THREAD =
-QMAKE_RPATH = -Wl,-rpath,
+QMAKE_RPATH =
- QMAKE_LIBS =
+ QMAKE_LIBS = -luuid
QMAKE_LIBS_DYNLOAD = -ldl
+Index: b/mkspecs/linux-g++-64/qmake.conf
+===================================================================
--- a/mkspecs/linux-g++-64/qmake.conf
+++ b/mkspecs/linux-g++-64/qmake.conf
-@@ -58,7 +58,7 @@ QMAKE_LFLAGS_SHLIB = -shared
+@@ -58,7 +58,7 @@
QMAKE_LFLAGS_PLUGIN = $$QMAKE_LFLAGS_SHLIB
QMAKE_LFLAGS_SONAME = -Wl,-soname,
QMAKE_LFLAGS_THREAD =
-QMAKE_RPATH = -Wl,-rpath,
+QMAKE_RPATH =
- QMAKE_LIBS =
+ QMAKE_LIBS = -luuid
QMAKE_LIBS_DYNLOAD = -ldl
diff --git a/ubuntu/maverick/libraries/python-trinity/debian/control b/ubuntu/maverick/libraries/python-trinity/debian/control
index 0da4178e0..44606c723 100644
--- a/ubuntu/maverick/libraries/python-trinity/debian/control
+++ b/ubuntu/maverick/libraries/python-trinity/debian/control
@@ -4,17 +4,15 @@ Priority: optional
Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
XSBC-Original-Maintainer: Ricardo Javier Cardenes Medina <rcardenes@debian.org>
Uploaders: Torsten Marek <shlomme@debian.org>, Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
-Build-Depends: debhelper (>= 5.0.38), libtqtinterface-dev, python, python-all-dev, python-all-dbg, sip4 (>= 4.10), python-sip4-dev (>= 4.10), python-tqt-dev, tdelibs14-trinity-dev, python-support (>= 0.6) | python-dev (>= 2.6.6-3~), dpatch, python-sip4, python-sip4-dbg, python-sip4-dev
+Build-Depends: debhelper (>= 5.0.38), libtqtinterface-dev, python, python-all-dev, python-all-dbg, sip4 (>= 4.10), python-sip4-dev (>= 4.10), python-tqt-dev, tdelibs14-trinity-dev, python-sip4, python-sip4-dbg, python-sip4-dev
Standards-Version: 3.8.4
Homepage: http://www.riverbankcomputing.co.uk/pytde/index.php
-XS-Python-Version: all
Package: python-trinity-trinity
Architecture: any
Depends: ${shlibs:Depends}, ${python:Depends}, python-tqt
Replaces: python-kde3-kde3 (<< 4:14.0.0), python-trinity-trinity (<< 4:14.0.0)
Breaks: python-kde3-kde3 (<< 4:14.0.0), python-trinity-trinity (<< 4:14.0.0)
-XB-Python-Version: ${python:Versions}
Provides: ${python:Provides}
Conflicts: python-trinity-trinity
Description: Trinity bindings for Python [Trinity]
@@ -28,7 +26,6 @@ Architecture: any
Replaces: python-kde3-kde3-dbg (<< 4:14.0.0), python-trinity-trinity-dbg (<< 4:14.0.0)
Breaks: python-kde3-kde3-dbg (<< 4:14.0.0), python-trinity-trinity-dbg (<< 4:14.0.0)
Depends: python-trinity-trinity (= ${binary:Version}), python-dbg, python-tqt-dbg, ${shlibs:Depends}
-XB-Python-Version: ${python:Versions}
Description: Trinity bindings for Python (debug extensions) [Trinity]
Python binding module that provides wide access to the Trinity API,
also known as PyKDE. Using this, you'll get (for example) classes
@@ -42,7 +39,6 @@ Architecture: all
Replaces: python-kde3-kde3-dev (<< 4:14.0.0), python-trinity-trinity-dev (<< 4:14.0.0)
Breaks: python-kde3-kde3-dev (<< 4:14.0.0), python-trinity-trinity-dev (<< 4:14.0.0)
Depends: pytqt-tools, ${python:Depends}
-XB-Python-Version: ${python:Versions}
Description: Trinity bindings for Python - Development files and scripts [Trinity]
Development .sip files with definitions of PyKDE classes. They
are needed to build PyKDE, but also as building blocks of other
diff --git a/ubuntu/maverick/libraries/python-trinity/debian/pycompat b/ubuntu/maverick/libraries/python-trinity/debian/pycompat
deleted file mode 100644
index 0cfbf0888..000000000
--- a/ubuntu/maverick/libraries/python-trinity/debian/pycompat
+++ /dev/null
@@ -1 +0,0 @@
-2
diff --git a/ubuntu/maverick/libraries/python-trinity/debian/rules b/ubuntu/maverick/libraries/python-trinity/debian/rules
index d4dac70f3..473caac7d 100755
--- a/ubuntu/maverick/libraries/python-trinity/debian/rules
+++ b/ubuntu/maverick/libraries/python-trinity/debian/rules
@@ -14,7 +14,6 @@ cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xine
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
-include /usr/share/dpatch/dpatch.make
# This has to be exported to make some magic below work.
export DH_OPTIONS
export QTDIR=/usr/share/qt3
@@ -31,8 +30,7 @@ endif
PYTHONS := $(shell pyversions -vr debian/control)
DBG_PYTHONS := $(shell pyversions -vd)
-DEB_PYTHON_SYSTEM = $(if $(wildcard /usr/bin/dh_python2),,pysupport)
-DH_PYTHON2 = $(if $(wildcard /usr/bin/dh_python2),dh_python2,dh_pysupport)
+DH_PYTHON2 = $(if $(wildcard /usr/bin/dh_python2),dh_python2,dh_python)
GCCVER := $(shell gcc --version | sed -n '/^gcc (GCC)/s/.*(GCC) \(...\).*/\1/p')
ifneq (,$(filter $(GCCVER),4.2 4.3))
@@ -45,7 +43,7 @@ endif
configure: $(PYTHONS:%=build-%/configure-stamp) $(DBG_PYTHONS:%=dbg-build-%/configure-stamp)
-build-%/configure-stamp: patch-stamp
+build-%/configure-stamp:
dh_testdir
mkdir -p build-$*
cd build-$* && python$* ../configure.py \
@@ -53,7 +51,7 @@ build-%/configure-stamp: patch-stamp
-v /opt/trinity/share/sip/trinity -j $(SPLIT)
touch $@
-dbg-build-%/configure-stamp: patch-stamp
+dbg-build-%/configure-stamp:
dh_testdir
mkdir -p dbg-build-$*
cd dbg-build-$* && python$*-dbg ../configure.py \
@@ -73,7 +71,7 @@ dbg-build-%/build-stamp: dbg-build-%/configure-stamp
$(MAKE) -C dbg-build-$*
touch $@
-clean: unpatch
+clean:
dh_testdir
dh_testroot
rm -f *-stamp
diff --git a/ubuntu/maverick/tdebase/debian/control b/ubuntu/maverick/tdebase/debian/control
index b2a891a78..748ea8bf5 100644
--- a/ubuntu/maverick/tdebase/debian/control
+++ b/ubuntu/maverick/tdebase/debian/control
@@ -88,7 +88,7 @@ Section: tde
Architecture: any
Replaces: kcontrol-kde3 (<< 4:14.0.0), kcontrol-trinity (<< 4:14.0.0)
Breaks: kcontrol-kde3 (<< 4:14.0.0), kcontrol-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdebase-data-trinity (>> ${KDE-Version3}), tdebase-data-trinity (<< ${KDE-Next-Version3}), usbutils
+Depends: ${shlibs:Depends}, tdebase-data-trinity (>> ${KDE-Version3}~), tdebase-data-trinity (<< ${KDE-Next-Version3}~), usbutils
Recommends: udev
Suggests: khelpcenter-trinity, ntpdate | ntp-simple
Conflicts: tdebase-libs-trinity (<< 4:3.0.0)
@@ -254,7 +254,7 @@ Section: tde
Architecture: any
Replaces: kdm-kde3 (<< 4:14.0.0), kdm-trinity (<< 4:14.0.0)
Breaks: kdm-kde3 (<< 4:14.0.0), kdm-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdebase-trinity-bin (= ${Source-Version}), tdebase-data-trinity (>> ${KDE-Version3}), tdebase-data-trinity (<< ${KDE-Next-Version3}), debconf (>= 1.2.9) | debconf-2.0, libpam-runtime (>= 0.76-14), xbase-clients
+Depends: ${shlibs:Depends}, tdebase-trinity-bin (= ${Source-Version}), tdebase-data-trinity (>> ${KDE-Version3}~), tdebase-data-trinity (<< ${KDE-Next-Version3}~), debconf (>= 1.2.9) | debconf-2.0, libpam-runtime (>= 0.76-14), xbase-clients
Recommends: logrotate, xserver-xorg
Suggests: khelpcenter-trinity, ksmserver-trinity (= ${Source-Version}), tdepasswd-trinity (= ${Source-Version}), menu
Provides: x-display-manager
@@ -313,7 +313,7 @@ Section: tde
Architecture: any
Replaces: kicker-kde3 (<< 4:14.0.0), kicker-trinity (<< 4:14.0.0)
Breaks: kicker-kde3 (<< 4:14.0.0), kicker-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdebase-data-trinity (>> ${KDE-Version3}), tdebase-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdebase-data-trinity (>> ${KDE-Version3}~), tdebase-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, kicker-applets-trinity, menu
Conflicts: tdebase-libs-trinity (<< 4:3.0.0)
Description: desktop panel for KDE
@@ -446,7 +446,7 @@ Section: tde
Architecture: any
Replaces: kpersonalizer-kde3 (<< 4:14.0.0), kpersonalizer-trinity (<< 4:14.0.0)
Breaks: kpersonalizer-kde3 (<< 4:14.0.0), kpersonalizer-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdebase-data-trinity (>> ${KDE-Version3}), tdebase-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdebase-data-trinity (>> ${KDE-Version3}~), tdebase-data-trinity (<< ${KDE-Next-Version3}~)
Description: installation personalizer for KDE
KDE Personalizer is the application that configures the KDE desktop for you.
It's a very useful wizard that allows you to quickly change the KDE desktop to
@@ -483,7 +483,7 @@ Section: tde
Architecture: any
Replaces: ksplash-kde3 (<< 4:14.0.0), ksplash-trinity (<< 4:14.0.0)
Breaks: ksplash-kde3 (<< 4:14.0.0), ksplash-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdebase-data-trinity (>> ${KDE-Version3}), tdebase-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdebase-data-trinity (>> ${KDE-Version3}~), tdebase-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity
Description: the KDE splash screen
This package includes the KDE Splash screen, which is seen when
@@ -540,7 +540,7 @@ Replaces: kwin-kde3 (<< 4:14.0.0), kwin-trinity (<< 4:14.0.0)
Breaks: kwin-kde3 (<< 4:14.0.0), kwin-trinity (<< 4:14.0.0)
Depends: ${shlibs:Depends}
Provides: x-window-manager
-Suggests: tdebase-trinity-bin (= ${Source-Version}), tdebase-data-trinity (>> ${KDE-Version3}), tdebase-data-trinity (<< ${KDE-Next-Version3}), kdesktop-trinity (= ${Source-Version}), kicker-trinity (= ${Source-Version}), kpager-trinity (= ${Source-Version}), kpersonalizer-trinity (= ${Source-Version}), ksmserver-trinity (= ${Source-Version}), ksplash-trinity (= ${Source-Version})
+Suggests: tdebase-trinity-bin (= ${Source-Version}), tdebase-data-trinity (>> ${KDE-Version3}~), tdebase-data-trinity (<< ${KDE-Next-Version3}~), kdesktop-trinity (= ${Source-Version}), kicker-trinity (= ${Source-Version}), kpager-trinity (= ${Source-Version}), kpersonalizer-trinity (= ${Source-Version}), ksmserver-trinity (= ${Source-Version}), ksplash-trinity (= ${Source-Version})
Conflicts: kde-window-manager-trinity (<< 7:3.5.0)
Description: the KDE window manager
This package contains the default X window manager for KDE.
diff --git a/ubuntu/maverick/tdebindings/debian/control b/ubuntu/maverick/tdebindings/debian/control
index 499a71208..77184243a 100644
--- a/ubuntu/maverick/tdebindings/debian/control
+++ b/ubuntu/maverick/tdebindings/debian/control
@@ -29,7 +29,7 @@ Architecture: all
Section: libs
Replaces: libdcop3-java-kde3 (<< 4:14.0.0), libdcop3-java-trinity (<< 4:14.0.0)
Breaks: libdcop3-java-kde3 (<< 4:14.0.0), libdcop3-java-trinity (<< 4:14.0.0)
-Depends: libdcop3-jni-trinity (>> ${KDE-Version3}), libdcop3-jni-trinity (<< ${KDE-Next-Version3}), gij | java1-runtime | java2-runtime
+Depends: libdcop3-jni-trinity (>> ${KDE-Version3}~), libdcop3-jni-trinity (<< ${KDE-Next-Version3}~), gij | java1-runtime | java2-runtime
Description: DCOP bindings for Java [Trinity]
This package contains the Java classes necessary to run Java programs
using the Java DCOP bindings. DCOP is the TDE Desktop COmmunications
@@ -56,7 +56,7 @@ Architecture: amd64 i386 ia64 powerpc s390 sparc
Section: libdevel
Replaces: libdcop3-java-kde3-dev (<< 4:14.0.0), libdcop3-java-trinity-dev (<< 4:14.0.0)
Breaks: libdcop3-java-kde3-dev (<< 4:14.0.0), libdcop3-java-trinity-dev (<< 4:14.0.0)
-Depends: libdcop3-java-trinity (>> ${KDE-Version3}), libdcop3-java-trinity (<< ${KDE-Next-Version3})
+Depends: libdcop3-java-trinity (>> ${KDE-Version3}~), libdcop3-java-trinity (<< ${KDE-Next-Version3}~)
Description: DCOP bindings for Java (dcopidl2java program) [Trinity]
This package contains the dcopidl2java program which generates Java
stubs from DCOP IDL files, necessary to do development with the DCOP Java
@@ -70,7 +70,7 @@ Architecture: all
Section: libs
Replaces: libqt3-java-kde3 (<< 4:14.0.0), libqt3-java-trinity (<< 4:14.0.0)
Breaks: libqt3-java-kde3 (<< 4:14.0.0), libqt3-java-trinity (<< 4:14.0.0)
-Depends: libqt3-jni-trinity (>> ${KDE-Version3}), libqt3-jni-trinity (<< ${KDE-Next-Version3}), gij | java1-runtime | java2-runtime
+Depends: libqt3-jni-trinity (>> ${KDE-Version3}~), libqt3-jni-trinity (<< ${KDE-Next-Version3}~), gij | java1-runtime | java2-runtime
Suggests: juic-trinity
Description: Java bindings for Qt [Trinity]
This package contains the Java classes necessary to run Java programs
@@ -100,7 +100,7 @@ Architecture: all
Section: libs
Replaces: libtrinity-java-kde3 (<< 4:14.0.0), libtrinity-java-trinity (<< 4:14.0.0)
Breaks: libtrinity-java-kde3 (<< 4:14.0.0), libtrinity-java-trinity (<< 4:14.0.0)
-Depends: libtrinity-jni-trinity (>> ${KDE-Version3}), libtrinity-jni-trinity (<< ${KDE-Next-Version3}), gij | java1-runtime | java2-runtime
+Depends: libtrinity-jni-trinity (>> ${KDE-Version3}~), libtrinity-jni-trinity (<< ${KDE-Next-Version3}~), gij | java1-runtime | java2-runtime
Description: tdelibs bindings for Java [Trinity]
This package contains the Java classes necessary to run Java programs
using the Java tdelibs bindings. TDE is the Trinity Desktop Environment, a
diff --git a/ubuntu/maverick/tdeedu/debian/control b/ubuntu/maverick/tdeedu/debian/control
index 602d933e5..f03b48025 100644
--- a/ubuntu/maverick/tdeedu/debian/control
+++ b/ubuntu/maverick/tdeedu/debian/control
@@ -74,7 +74,7 @@ Architecture: any
Section: games
Replaces: blinken-kde3 (<< 4:14.0.0), blinken-trinity (<< 4:14.0.0)
Breaks: blinken-kde3 (<< 4:14.0.0), blinken-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, ttf-sjfonts, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, ttf-sjfonts, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: Trinity version of the Simon Says electronic memory game
Blinken is based on an electronic game released in 1978, which
@@ -94,7 +94,7 @@ Architecture: any
Section: science
Replaces: kalzium-kde3 (<< 4:14.0.0), kalzium-trinity (<< 4:14.0.0)
Breaks: kalzium-kde3 (<< 4:14.0.0), kalzium-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, kalzium-data-trinity (>> ${KDE-Version3}), kalzium-data-trinity (<< ${KDE-Next-Version3}), tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, kalzium-data-trinity (>> ${KDE-Version3}~), kalzium-data-trinity (<< ${KDE-Next-Version3}~), tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: chemistry teaching tool for Trinity
Kalzium is a program which shows you the Periodic System of Elements
@@ -137,7 +137,7 @@ Architecture: any
Section: games
Replaces: kanagram-kde3 (<< 4:14.0.0), kanagram-trinity (<< 4:14.0.0)
Breaks: kanagram-kde3 (<< 4:14.0.0), kanagram-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: letter order game for Trinity
KAnagram is a game that is based on the word/letter puzzles that the
@@ -160,7 +160,7 @@ Architecture: any
Section: math
Replaces: kbruch-kde3 (<< 4:14.0.0), kbruch-trinity (<< 4:14.0.0)
Breaks: kbruch-kde3 (<< 4:14.0.0), kbruch-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: fraction calculation teaching tool for Trinity
KBruch is a small program to practice calculating with fractions.
@@ -175,7 +175,7 @@ Architecture: any
Section: tde
Replaces: keduca-kde3 (<< 4:14.0.0), keduca-trinity (<< 4:14.0.0)
Breaks: keduca-kde3 (<< 4:14.0.0), keduca-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: interactive form-based tests for Trinity
KEduca is a flash-card application which allows you to make
@@ -189,7 +189,7 @@ Architecture: any
Section: tde
Replaces: kgeography-kde3 (<< 4:14.0.0), kgeography-trinity (<< 4:14.0.0)
Breaks: kgeography-kde3 (<< 4:14.0.0), kgeography-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, kgeography-data-trinity (>> ${KDE-Version3}), kgeography-data-trinity (<< ${KDE-Next-Version3}), tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, kgeography-data-trinity (>> ${KDE-Version3}~), kgeography-data-trinity (<< ${KDE-Next-Version3}~), tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: Geography learning tool for Trinity
KGeography contains maps allowing you to learn various countries or
@@ -220,7 +220,7 @@ Architecture: any
Section: games
Replaces: khangman-kde3 (<< 4:14.0.0), khangman-trinity (<< 4:14.0.0)
Breaks: khangman-kde3 (<< 4:14.0.0), khangman-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, ttf-dustin, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, ttf-dustin, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: the classical hangman game for Trinity
KHangMan is a game based on the well known hangman game. It is aimed
@@ -240,7 +240,7 @@ Architecture: any
Section: math
Replaces: kig-kde3 (<< 4:14.0.0), kig-trinity (<< 4:14.0.0)
Breaks: kig-kde3 (<< 4:14.0.0), kig-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: interactive geometry program for KDE
Kig is an application for interactive geometry. It is intended to
@@ -268,7 +268,7 @@ Architecture: any
Section: tde
Replaces: kiten-kde3 (<< 4:14.0.0), kiten-trinity (<< 4:14.0.0)
Breaks: kiten-kde3 (<< 4:14.0.0), kiten-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3}), ttf-kochi-gothic | ttf-kochi-mincho
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~), ttf-kochi-gothic | ttf-kochi-mincho
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: Japanese reference/study tool for Trinity
Kiten is a Japanese reference and study tool for KDE. It is an
@@ -285,7 +285,7 @@ Architecture: any
Section: tde
Replaces: klatin-kde3 (<< 4:14.0.0), klatin-trinity (<< 4:14.0.0)
Breaks: klatin-kde3 (<< 4:14.0.0), klatin-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: application to help revise/teach Latin
KLatin is a program to help revise Latin. There are three "sections"
@@ -310,7 +310,7 @@ Architecture: any
Section: tde
Replaces: klettres-kde3 (<< 4:14.0.0), klettres-trinity (<< 4:14.0.0)
Breaks: klettres-kde3 (<< 4:14.0.0), klettres-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, klettres-data-trinity (>> ${KDE-Version3}), klettres-data-trinity (<< ${KDE-Next-Version3}), tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, klettres-data-trinity (>> ${KDE-Version3}~), klettres-data-trinity (<< ${KDE-Next-Version3}~), tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: foreign alphabet tutor for Trinity
KLettres is an application specially designed to help the user to
@@ -344,7 +344,7 @@ Architecture: any
Section: math
Replaces: kmplot-kde3 (<< 4:14.0.0), kmplot-trinity (<< 4:14.0.0)
Breaks: kmplot-kde3 (<< 4:14.0.0), kmplot-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: mathematical function plotter for Trinity
KmPlot is a mathematical function plotter for KDE. It has a powerful
@@ -368,7 +368,7 @@ Architecture: any
Section: math
Replaces: kpercentage-kde3 (<< 4:14.0.0), kpercentage-trinity (<< 4:14.0.0)
Breaks: kpercentage-kde3 (<< 4:14.0.0), kpercentage-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: percentage calculation teaching tool for Trinity
KPercentage is a small math application that will help pupils to
@@ -386,7 +386,7 @@ Architecture: any
Section: science
Replaces: kstars-kde3 (<< 4:14.0.0), kstars-trinity (<< 4:14.0.0)
Breaks: kstars-kde3 (<< 4:14.0.0), kstars-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, kstars-data-trinity (>> ${KDE-Version3}), kstars-data-trinity (<< ${KDE-Next-Version3}), tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3}), indi-trinity (= ${Source-Version})
+Depends: ${shlibs:Depends}, kstars-data-trinity (>> ${KDE-Version3}~), kstars-data-trinity (<< ${KDE-Next-Version3}~), tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~), indi-trinity (= ${Source-Version})
Suggests: konqueror-trinity, khelpcenter-trinity, tdeedu-trinity-doc-html
Description: desktop planetarium for Trinity
KStars is a graphical desktop planetarium for KDE. It depicts an
@@ -424,7 +424,7 @@ Architecture: any
Section: tde
Replaces: ktouch-kde3 (<< 4:14.0.0), ktouch-trinity (<< 4:14.0.0)
Breaks: ktouch-kde3 (<< 4:14.0.0), ktouch-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: touch typing tutor for Trinity
KTouch is a program for learning touch typing - it helps you learn to
@@ -444,7 +444,7 @@ Architecture: any
Section: devel
Replaces: kturtle-kde3 (<< 4:14.0.0), kturtle-trinity (<< 4:14.0.0)
Breaks: kturtle-kde3 (<< 4:14.0.0), kturtle-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: educational Logo programming environment
KTurtle is an educational programming environment using the Logo
@@ -472,7 +472,7 @@ Architecture: any
Section: tde
Replaces: kverbos-kde3 (<< 4:14.0.0), kverbos-trinity (<< 4:14.0.0)
Breaks: kverbos-kde3 (<< 4:14.0.0), kverbos-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: Spanish verb form study application for Trinity
Kverbos allows the user to learn the forms of Spanish verbs. The
@@ -491,7 +491,7 @@ Architecture: any
Section: tde
Replaces: kvoctrain-kde3 (<< 4:14.0.0), kvoctrain-trinity (<< 4:14.0.0)
Breaks: kvoctrain-kde3 (<< 4:14.0.0), kvoctrain-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, ${perl:Depends}, libwww-perl, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, ${perl:Depends}, libwww-perl, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: vocabulary trainer for Trinity
KVocTrain is a little utility to help you train your vocabulary when
@@ -517,7 +517,7 @@ Architecture: any
Section: tde
Replaces: kwordquiz-kde3 (<< 4:14.0.0), kwordquiz-trinity (<< 4:14.0.0)
Breaks: kwordquiz-kde3 (<< 4:14.0.0), kwordquiz-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: flashcard and vocabulary learning program for Trinity
KWordQuiz is a flashcard-based tool that helps you to master new
diff --git a/ubuntu/maverick/tdegraphics/debian/control b/ubuntu/maverick/tdegraphics/debian/control
index 9407abe1c..623d2dceb 100644
--- a/ubuntu/maverick/tdegraphics/debian/control
+++ b/ubuntu/maverick/tdegraphics/debian/control
@@ -4,7 +4,7 @@ Priority: optional
Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
XSBC-Original-Maintainer: Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
Uploaders: Ana Beatriz Guerrero Lopez <ana@debian.org>, Francesco Pedrini <francesco.pedrini@gmail.com>, Josh Metzler <joshdeb@metzlers.org>, Sune Vuorela <debian@pusling.com>
-Build-Depends: imlib11-dev, cdbs (>= 0.4.39-0.1), debhelper (>= 5.0.31), autotools-dev, gawk, gettext, tdelibs14-trinity-dev, libexif-dev (>= 0.6.9-1), libfribidi-dev, freeglut3-dev, libgphoto2-2-dev, libopenexr-dev (>= 1.2.1), libpaper-dev, libpoppler-dev, libsane-dev (>> 1.0.15), libtiff-dev, libtiff-tools, libusb-dev, sharutils, libxxf86vm-dev, chrpath [powerpc], cmake, libtool, libltdl-dev
+Build-Depends: imlib11-dev, cdbs (>= 0.4.39-0.1), debhelper (>= 5.0.31), autotools-dev, gawk, gettext, tdelibs14-trinity-dev, libexif-dev (>= 0.6.9-1), libfribidi-dev, freeglut3-dev, libgphoto2-6-dev | libgphoto2-2-dev, libopenexr-dev (>= 1.2.1), libpaper-dev, libpoppler-private-dev | libpoppler-dev (<< 0.18.4-3), libpoppler-dev, libsane-dev (>> 1.0.15), libtiff-dev, libtiff-tools, libusb-dev, sharutils, libxxf86vm-dev, chrpath [powerpc], cmake, libtool, libltdl-dev
Standards-Version: 3.8.4
Package: tdegraphics-trinity
diff --git a/ubuntu/precise/applications/kcpuload/debian/rules b/ubuntu/precise/applications/kcpuload/debian/rules
index 20eca167c..385c24313 100755
--- a/ubuntu/precise/applications/kcpuload/debian/rules
+++ b/ubuntu/precise/applications/kcpuload/debian/rules
@@ -45,11 +45,6 @@ ifeq ($(DEB_BUILD_GNU_TYPE),i386-linux)
#export CXXFLAGS=-O3 -march=i686 -ffast-math -finline-functions
endif
--include debian/debiandirs
-
-debian/debiandirs: admin/debianrules
- perl -w admin/debianrules echodirs > debian/debiandirs
-
configure: configure-stamp
configure-stamp:
dh_testdir
@@ -104,7 +99,7 @@ debian-clean:
clean:
dh_testdir
dh_testroot
- rm -f build-stamp configure-stamp debian/debiandirs
+ rm -f build-stamp configure-stamp
# Remove Debian specific patches
if test -f patch-stamp; then \
@@ -169,8 +164,6 @@ binary-common:
dh_testroot
dh_installchangelogs kcpuload/ChangeLog
dh_installdocs
- mkdir debian/kcpuload-trinity/opt/trinity/share/doc
- mv debian/kcpuload-trinity/usr/share/doc/tde debian/kcpuload-trinity/opt/trinity/share/doc/
rm -fr debian/kcpuload-trinity/usr/share/doc-base
dh_installexamples
dh_installmanpages
diff --git a/ubuntu/precise/applications/koffice/debian/control b/ubuntu/precise/applications/koffice/debian/control
index aa5d4cadb..6d2e73b8c 100644
--- a/ubuntu/precise/applications/koffice/debian/control
+++ b/ubuntu/precise/applications/koffice/debian/control
@@ -61,7 +61,7 @@ Architecture: any
Section: graphics
Replaces: karbon-kde3 (<< 4:14.0.0), karbon-trinity (<< 4:14.0.0)
Breaks: karbon-kde3 (<< 4:14.0.0), karbon-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Description: a vector graphics application for the KDE Office Suite
Karbon is a vector graphics application.
.
@@ -72,7 +72,7 @@ Architecture: any
Section: tde
Replaces: kchart-kde3 (<< 4:14.0.0), kchart-trinity (<< 4:14.0.0)
Breaks: kchart-kde3 (<< 4:14.0.0), kchart-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: a chart drawing program for the KDE Office Suite [Trinity]
KChart is a chart drawing application. It can be used to embed charts
@@ -85,7 +85,7 @@ Architecture: any
Section: tde
Replaces: kexi-kde3 (<< 4:14.0.0), kexi-trinity (<< 4:14.0.0)
Breaks: kexi-kde3 (<< 4:14.0.0), kexi-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Suggests: kexi-mdb-plugin-trinity
Description: integrated database environment for the KDE Office Suite [Trinity]
Kexi is an integrated data management application. It can be used for
@@ -107,7 +107,7 @@ Architecture: any
Section: tde
Replaces: kformula-kde3 (<< 4:14.0.0), kformula-trinity (<< 4:14.0.0)
Breaks: kformula-kde3 (<< 4:14.0.0), kformula-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: a formula editor for the KDE Office Suite [Trinity]
KFormula is a formula editor that provides the basic input facilities
@@ -124,7 +124,7 @@ Architecture: any
Section: graphics
Replaces: kivio-kde3 (<< 4:14.0.0), kivio-trinity (<< 4:14.0.0)
Breaks: kivio-kde3 (<< 4:14.0.0), kivio-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, kivio-data-trinity (>> 1:1.4.90.2-1), kivio-data-trinity (>> ${KDE-Version3}), kivio-data-trinity (<< ${KDE-Next-Version3}), koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, kivio-data-trinity (>> 1:1.4.90.2-1), kivio-data-trinity (>> ${KDE-Version3}~), kivio-data-trinity (<< ${KDE-Next-Version3}~), koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Description: a flowcharting program for the KDE Office Suite [Trinity]
Kivio is a flowcharting program that offers basic flowcharting abilities,
but with a twist. Objects are scriptable, and a backend plugin system
@@ -150,7 +150,7 @@ Architecture: any
Section: tde
Replaces: koshell-kde3 (<< 4:14.0.0), koshell-trinity (<< 4:14.0.0)
Breaks: koshell-kde3 (<< 4:14.0.0), koshell-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: koffice-trinity, khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: the KDE Office Suite workspace [Trinity]
The KOffice workspace is a desktop with easy one-click launchers for
@@ -163,7 +163,7 @@ Architecture: any
Section: tde
Replaces: kplato-kde3 (<< 4:14.0.0), kplato-trinity (<< 4:14.0.0)
Breaks: kplato-kde3 (<< 4:14.0.0), kplato-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: an integrated project management and planning tool [Trinity]
KPlato is a project management application, allowing for the planning and
@@ -177,7 +177,7 @@ Architecture: any
Section: tde
Replaces: kpresenter-kde3 (<< 4:14.0.0), kpresenter-trinity (<< 4:14.0.0)
Breaks: kpresenter-kde3 (<< 4:14.0.0), kpresenter-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, ${perl:Depends}, kpresenter-data-trinity (>> ${KDE-Version3}), kpresenter-data-trinity (<< ${KDE-Next-Version3}), koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, ${perl:Depends}, kpresenter-data-trinity (>> ${KDE-Version3}~), kpresenter-data-trinity (<< ${KDE-Next-Version3}~), koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: a presentation program for the KDE Office Suite [Trinity]
KPresenter is a fully-featured presentation program. Presentations can
@@ -204,7 +204,7 @@ Architecture: any
Section: tde
Replaces: krita-kde3 (<< 4:14.0.0), chalk-trinity (<< 4:14.0.0)
Breaks: krita-kde3 (<< 4:14.0.0), chalk-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, chalk-data-trinity (>> ${KDE-Version3}), chalk-data-trinity (<< ${KDE-Next-Version3}), koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, chalk-data-trinity (>> ${KDE-Version3}~), chalk-data-trinity (<< ${KDE-Next-Version3}~), koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: dcraw, khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: a pixel-based image manipulation program for the KDE Office Suite [Trinity]
Chalk is a painting and image editing application for KOffice. Chalk contains
@@ -230,7 +230,7 @@ Architecture: any
Section: tde
Replaces: kspread-kde3 (<< 4:14.0.0), kspread-trinity (<< 4:14.0.0)
Breaks: kspread-kde3 (<< 4:14.0.0), kspread-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: a spreadsheet for the KDE Office Suite [Trinity]
KSpread is a powerful spreadsheet application. It is scriptable and
@@ -244,7 +244,7 @@ Architecture: any
Section: tde
Replaces: kugar-kde3 (<< 4:14.0.0), kugar-trinity (<< 4:14.0.0)
Breaks: kugar-kde3 (<< 4:14.0.0), kugar-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: a business report maker for the KDE Office Suite [Trinity]
Kugar is a tool for generating business quality reports that can
@@ -260,7 +260,7 @@ Architecture: any
Section: tde
Replaces: kword-kde3 (<< 4:14.0.0), kword-trinity (<< 4:14.0.0)
Breaks: kword-kde3 (<< 4:14.0.0), kword-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, kword-data-trinity (>> ${KDE-Version3}), kword-data-trinity (<< ${KDE-Next-Version3}), koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, kword-data-trinity (>> ${KDE-Version3}~), kword-data-trinity (<< ${KDE-Next-Version3}~), koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: a word processor for the KDE Office Suite [Trinity]
KWord is a FrameMaker-like word processing and desktop publishing
@@ -288,7 +288,7 @@ Architecture: any
Section: tde
Replaces: kthesaurus-kde3 (<< 4:14.0.0), kthesaurus-trinity (<< 4:14.0.0)
Breaks: kthesaurus-kde3 (<< 4:14.0.0), kthesaurus-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: thesaurus for the KDE Office Suite [Trinity]
KThesaurus lists words related to a given term and offers a user interface
@@ -302,7 +302,7 @@ Architecture: any
Section: libs
Replaces: koffice-libs-kde3 (<< 4:14.0.0), koffice-libs-trinity (<< 4:14.0.0)
Breaks: koffice-libs-kde3 (<< 4:14.0.0), koffice-libs-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-data-trinity (>> ${KDE-Version3}), koffice-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-data-trinity (>> ${KDE-Version3}~), koffice-data-trinity (<< ${KDE-Next-Version3}~)
Recommends: latex-xft-fonts, ruby, python
Suggests: wordnet, texlive-base
Description: common libraries and binaries for the KDE Office Suite [Trinity]
diff --git a/ubuntu/precise/dependencies/arts/debian/patches/12_cleanup_artsc-config.diff b/ubuntu/precise/dependencies/arts/debian/patches/12_cleanup_artsc-config.diff
index 603ffdf37..57a8122f9 100644
--- a/ubuntu/precise/dependencies/arts/debian/patches/12_cleanup_artsc-config.diff
+++ b/ubuntu/precise/dependencies/arts/debian/patches/12_cleanup_artsc-config.diff
@@ -1,3 +1,5 @@
+Index: b/artsc/artsc-config.in
+===================================================================
--- a/artsc/artsc-config.in
+++ b/artsc/artsc-config.in
@@ -27,7 +27,7 @@
@@ -8,4 +10,4 @@
+ flags="$flags -L$libdir -lartsc"
;;
--cflags)
- flags="$flags -I$includedir/artsc @GLIB_CFLAGS@"
+ flags="$flags -I$includedir @GLIB_CFLAGS@"
diff --git a/ubuntu/precise/dependencies/arts/debian/rules b/ubuntu/precise/dependencies/arts/debian/rules
index 9c9730bda..1b4911297 100755
--- a/ubuntu/precise/dependencies/arts/debian/rules
+++ b/ubuntu/precise/dependencies/arts/debian/rules
@@ -41,6 +41,6 @@ DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
binary-predeb/libarts1-trinity-dev::
ifeq (linux,$(DEB_HOST_ARCH_OS))
- echo "libasound2-trinity-dev=libasound2-trinity-dev" >> debian/libarts1-dev.substvars
+ echo "libasound2-dev=libasound2-dev" >> debian/libarts1-trinity-dev.substvars
endif
diff --git a/ubuntu/precise/dependencies/libcaldav/debian/source/format b/ubuntu/precise/dependencies/libcaldav/debian/source/format
new file mode 100644
index 000000000..89ae9db8f
--- /dev/null
+++ b/ubuntu/precise/dependencies/libcaldav/debian/source/format
@@ -0,0 +1 @@
+3.0 (native)
diff --git a/ubuntu/precise/dependencies/libcaldav/debian/source/options b/ubuntu/precise/dependencies/libcaldav/debian/source/options
new file mode 100644
index 000000000..72f1f5450
--- /dev/null
+++ b/ubuntu/precise/dependencies/libcaldav/debian/source/options
@@ -0,0 +1,6 @@
+# Use xz instead of gzip
+compression = "xz"
+compression-level = 9
+
+# Don't run differences
+diff-ignore = .*
diff --git a/ubuntu/precise/dependencies/libcarddav/debian/source/format b/ubuntu/precise/dependencies/libcarddav/debian/source/format
new file mode 100644
index 000000000..89ae9db8f
--- /dev/null
+++ b/ubuntu/precise/dependencies/libcarddav/debian/source/format
@@ -0,0 +1 @@
+3.0 (native)
diff --git a/ubuntu/precise/dependencies/libcarddav/debian/source/options b/ubuntu/precise/dependencies/libcarddav/debian/source/options
new file mode 100644
index 000000000..72f1f5450
--- /dev/null
+++ b/ubuntu/precise/dependencies/libcarddav/debian/source/options
@@ -0,0 +1,6 @@
+# Use xz instead of gzip
+compression = "xz"
+compression-level = 9
+
+# Don't run differences
+diff-ignore = .*
diff --git a/ubuntu/precise/dependencies/qt3/debian/control b/ubuntu/precise/dependencies/qt3/debian/control
index 4be146e7d..7641cffbf 100644
--- a/ubuntu/precise/dependencies/qt3/debian/control
+++ b/ubuntu/precise/dependencies/qt3/debian/control
@@ -11,7 +11,7 @@ Build-Depends: debhelper (>= 5.0.31), quilt, cpio, libxext-dev (>= 4.3.0.dfsg.1-
libfreetype6-dev, libxft-dev, unixodbc-dev, uuid-dev, libglib2.0-dev,
libmysqlclient-dev, flex, libpq-dev, libaudio-dev, libcups2-dev,
libgl1-mesa-dev | libgl-dev, libglu1-mesa-dev | libglu-dev, libsqlite3-dev,
- firebird2.1-dev [i386 kfreebsd-i386 kfreebsd-amd64 knetbsd-i386 netbsd-i386 amd64 sparc powerpc] | firebird2-dev [i386 amd64]
+ firebird-dev | firebird2.1-dev [i386 kfreebsd-i386 kfreebsd-amd64 knetbsd-i386 netbsd-i386 amd64 sparc powerpc] | firebird2-dev [i386 amd64]
Section: libs
Priority: optional
Standards-Version: 3.8.4
diff --git a/ubuntu/precise/dependencies/qt3/debian/patches/06_disable_rpath.diff b/ubuntu/precise/dependencies/qt3/debian/patches/06_disable_rpath.diff
index 27fc1426c..a3d74ffce 100644
--- a/ubuntu/precise/dependencies/qt3/debian/patches/06_disable_rpath.diff
+++ b/ubuntu/precise/dependencies/qt3/debian/patches/06_disable_rpath.diff
@@ -2,25 +2,29 @@ author: Martin Loschwitz <madkiss@madkiss.org>
Disables the rpath settings in qmake.conf
+Index: b/mkspecs/linux-g++/qmake.conf
+===================================================================
--- a/mkspecs/linux-g++/qmake.conf
+++ b/mkspecs/linux-g++/qmake.conf
-@@ -55,7 +55,7 @@ QMAKE_LFLAGS_SHLIB = -shared
+@@ -55,7 +55,7 @@
QMAKE_LFLAGS_PLUGIN = $$QMAKE_LFLAGS_SHLIB
QMAKE_LFLAGS_SONAME = -Wl,-soname,
QMAKE_LFLAGS_THREAD =
-QMAKE_RPATH = -Wl,-rpath,
+QMAKE_RPATH =
- QMAKE_LIBS =
+ QMAKE_LIBS = -luuid
QMAKE_LIBS_DYNLOAD = -ldl
+Index: b/mkspecs/linux-g++-64/qmake.conf
+===================================================================
--- a/mkspecs/linux-g++-64/qmake.conf
+++ b/mkspecs/linux-g++-64/qmake.conf
-@@ -58,7 +58,7 @@ QMAKE_LFLAGS_SHLIB = -shared
+@@ -58,7 +58,7 @@
QMAKE_LFLAGS_PLUGIN = $$QMAKE_LFLAGS_SHLIB
QMAKE_LFLAGS_SONAME = -Wl,-soname,
QMAKE_LFLAGS_THREAD =
-QMAKE_RPATH = -Wl,-rpath,
+QMAKE_RPATH =
- QMAKE_LIBS =
+ QMAKE_LIBS = -luuid
QMAKE_LIBS_DYNLOAD = -ldl
diff --git a/ubuntu/precise/dependencies/tqt3/debian/control b/ubuntu/precise/dependencies/tqt3/debian/control
index b45983f80..1655a1357 100644
--- a/ubuntu/precise/dependencies/tqt3/debian/control
+++ b/ubuntu/precise/dependencies/tqt3/debian/control
@@ -11,7 +11,7 @@ Build-Depends: debhelper (>= 5.0.31), quilt, cpio, libxext-dev (>= 4.3.0.dfsg.1-
libfreetype6-dev, libxft-dev, unixodbc-dev, uuid-dev, libglib2.0-dev,
libmysqlclient-dev, flex, libpq-dev, libaudio-dev, libcups2-dev,
libgl1-mesa-dev | libgl-dev, libglu1-mesa-dev | libglu-dev, libsqlite3-dev,
- firebird2.1-dev [i386 kfreebsd-i386 kfreebsd-amd64 knetbsd-i386 netbsd-i386 amd64 sparc powerpc] | firebird2-dev [i386 amd64]
+ firebird-dev | firebird2.1-dev [i386 kfreebsd-i386 kfreebsd-amd64 knetbsd-i386 netbsd-i386 amd64 sparc powerpc] | firebird2-dev [i386 amd64]
Section: libs
Priority: optional
Standards-Version: 3.8.4
diff --git a/ubuntu/precise/dependencies/tqt3/debian/patches/06_disable_rpath.diff b/ubuntu/precise/dependencies/tqt3/debian/patches/06_disable_rpath.diff
index 27fc1426c..a3d74ffce 100644
--- a/ubuntu/precise/dependencies/tqt3/debian/patches/06_disable_rpath.diff
+++ b/ubuntu/precise/dependencies/tqt3/debian/patches/06_disable_rpath.diff
@@ -2,25 +2,29 @@ author: Martin Loschwitz <madkiss@madkiss.org>
Disables the rpath settings in qmake.conf
+Index: b/mkspecs/linux-g++/qmake.conf
+===================================================================
--- a/mkspecs/linux-g++/qmake.conf
+++ b/mkspecs/linux-g++/qmake.conf
-@@ -55,7 +55,7 @@ QMAKE_LFLAGS_SHLIB = -shared
+@@ -55,7 +55,7 @@
QMAKE_LFLAGS_PLUGIN = $$QMAKE_LFLAGS_SHLIB
QMAKE_LFLAGS_SONAME = -Wl,-soname,
QMAKE_LFLAGS_THREAD =
-QMAKE_RPATH = -Wl,-rpath,
+QMAKE_RPATH =
- QMAKE_LIBS =
+ QMAKE_LIBS = -luuid
QMAKE_LIBS_DYNLOAD = -ldl
+Index: b/mkspecs/linux-g++-64/qmake.conf
+===================================================================
--- a/mkspecs/linux-g++-64/qmake.conf
+++ b/mkspecs/linux-g++-64/qmake.conf
-@@ -58,7 +58,7 @@ QMAKE_LFLAGS_SHLIB = -shared
+@@ -58,7 +58,7 @@
QMAKE_LFLAGS_PLUGIN = $$QMAKE_LFLAGS_SHLIB
QMAKE_LFLAGS_SONAME = -Wl,-soname,
QMAKE_LFLAGS_THREAD =
-QMAKE_RPATH = -Wl,-rpath,
+QMAKE_RPATH =
- QMAKE_LIBS =
+ QMAKE_LIBS = -luuid
QMAKE_LIBS_DYNLOAD = -ldl
diff --git a/ubuntu/precise/libraries/python-trinity/debian/control b/ubuntu/precise/libraries/python-trinity/debian/control
index 0da4178e0..44606c723 100644
--- a/ubuntu/precise/libraries/python-trinity/debian/control
+++ b/ubuntu/precise/libraries/python-trinity/debian/control
@@ -4,17 +4,15 @@ Priority: optional
Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
XSBC-Original-Maintainer: Ricardo Javier Cardenes Medina <rcardenes@debian.org>
Uploaders: Torsten Marek <shlomme@debian.org>, Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
-Build-Depends: debhelper (>= 5.0.38), libtqtinterface-dev, python, python-all-dev, python-all-dbg, sip4 (>= 4.10), python-sip4-dev (>= 4.10), python-tqt-dev, tdelibs14-trinity-dev, python-support (>= 0.6) | python-dev (>= 2.6.6-3~), dpatch, python-sip4, python-sip4-dbg, python-sip4-dev
+Build-Depends: debhelper (>= 5.0.38), libtqtinterface-dev, python, python-all-dev, python-all-dbg, sip4 (>= 4.10), python-sip4-dev (>= 4.10), python-tqt-dev, tdelibs14-trinity-dev, python-sip4, python-sip4-dbg, python-sip4-dev
Standards-Version: 3.8.4
Homepage: http://www.riverbankcomputing.co.uk/pytde/index.php
-XS-Python-Version: all
Package: python-trinity-trinity
Architecture: any
Depends: ${shlibs:Depends}, ${python:Depends}, python-tqt
Replaces: python-kde3-kde3 (<< 4:14.0.0), python-trinity-trinity (<< 4:14.0.0)
Breaks: python-kde3-kde3 (<< 4:14.0.0), python-trinity-trinity (<< 4:14.0.0)
-XB-Python-Version: ${python:Versions}
Provides: ${python:Provides}
Conflicts: python-trinity-trinity
Description: Trinity bindings for Python [Trinity]
@@ -28,7 +26,6 @@ Architecture: any
Replaces: python-kde3-kde3-dbg (<< 4:14.0.0), python-trinity-trinity-dbg (<< 4:14.0.0)
Breaks: python-kde3-kde3-dbg (<< 4:14.0.0), python-trinity-trinity-dbg (<< 4:14.0.0)
Depends: python-trinity-trinity (= ${binary:Version}), python-dbg, python-tqt-dbg, ${shlibs:Depends}
-XB-Python-Version: ${python:Versions}
Description: Trinity bindings for Python (debug extensions) [Trinity]
Python binding module that provides wide access to the Trinity API,
also known as PyKDE. Using this, you'll get (for example) classes
@@ -42,7 +39,6 @@ Architecture: all
Replaces: python-kde3-kde3-dev (<< 4:14.0.0), python-trinity-trinity-dev (<< 4:14.0.0)
Breaks: python-kde3-kde3-dev (<< 4:14.0.0), python-trinity-trinity-dev (<< 4:14.0.0)
Depends: pytqt-tools, ${python:Depends}
-XB-Python-Version: ${python:Versions}
Description: Trinity bindings for Python - Development files and scripts [Trinity]
Development .sip files with definitions of PyKDE classes. They
are needed to build PyKDE, but also as building blocks of other
diff --git a/ubuntu/precise/libraries/python-trinity/debian/pycompat b/ubuntu/precise/libraries/python-trinity/debian/pycompat
deleted file mode 100644
index 0cfbf0888..000000000
--- a/ubuntu/precise/libraries/python-trinity/debian/pycompat
+++ /dev/null
@@ -1 +0,0 @@
-2
diff --git a/ubuntu/precise/libraries/python-trinity/debian/rules b/ubuntu/precise/libraries/python-trinity/debian/rules
index d4dac70f3..473caac7d 100755
--- a/ubuntu/precise/libraries/python-trinity/debian/rules
+++ b/ubuntu/precise/libraries/python-trinity/debian/rules
@@ -14,7 +14,6 @@ cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xine
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
-include /usr/share/dpatch/dpatch.make
# This has to be exported to make some magic below work.
export DH_OPTIONS
export QTDIR=/usr/share/qt3
@@ -31,8 +30,7 @@ endif
PYTHONS := $(shell pyversions -vr debian/control)
DBG_PYTHONS := $(shell pyversions -vd)
-DEB_PYTHON_SYSTEM = $(if $(wildcard /usr/bin/dh_python2),,pysupport)
-DH_PYTHON2 = $(if $(wildcard /usr/bin/dh_python2),dh_python2,dh_pysupport)
+DH_PYTHON2 = $(if $(wildcard /usr/bin/dh_python2),dh_python2,dh_python)
GCCVER := $(shell gcc --version | sed -n '/^gcc (GCC)/s/.*(GCC) \(...\).*/\1/p')
ifneq (,$(filter $(GCCVER),4.2 4.3))
@@ -45,7 +43,7 @@ endif
configure: $(PYTHONS:%=build-%/configure-stamp) $(DBG_PYTHONS:%=dbg-build-%/configure-stamp)
-build-%/configure-stamp: patch-stamp
+build-%/configure-stamp:
dh_testdir
mkdir -p build-$*
cd build-$* && python$* ../configure.py \
@@ -53,7 +51,7 @@ build-%/configure-stamp: patch-stamp
-v /opt/trinity/share/sip/trinity -j $(SPLIT)
touch $@
-dbg-build-%/configure-stamp: patch-stamp
+dbg-build-%/configure-stamp:
dh_testdir
mkdir -p dbg-build-$*
cd dbg-build-$* && python$*-dbg ../configure.py \
@@ -73,7 +71,7 @@ dbg-build-%/build-stamp: dbg-build-%/configure-stamp
$(MAKE) -C dbg-build-$*
touch $@
-clean: unpatch
+clean:
dh_testdir
dh_testroot
rm -f *-stamp
diff --git a/ubuntu/precise/tdebase/debian/control b/ubuntu/precise/tdebase/debian/control
index b2a891a78..748ea8bf5 100644
--- a/ubuntu/precise/tdebase/debian/control
+++ b/ubuntu/precise/tdebase/debian/control
@@ -88,7 +88,7 @@ Section: tde
Architecture: any
Replaces: kcontrol-kde3 (<< 4:14.0.0), kcontrol-trinity (<< 4:14.0.0)
Breaks: kcontrol-kde3 (<< 4:14.0.0), kcontrol-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdebase-data-trinity (>> ${KDE-Version3}), tdebase-data-trinity (<< ${KDE-Next-Version3}), usbutils
+Depends: ${shlibs:Depends}, tdebase-data-trinity (>> ${KDE-Version3}~), tdebase-data-trinity (<< ${KDE-Next-Version3}~), usbutils
Recommends: udev
Suggests: khelpcenter-trinity, ntpdate | ntp-simple
Conflicts: tdebase-libs-trinity (<< 4:3.0.0)
@@ -254,7 +254,7 @@ Section: tde
Architecture: any
Replaces: kdm-kde3 (<< 4:14.0.0), kdm-trinity (<< 4:14.0.0)
Breaks: kdm-kde3 (<< 4:14.0.0), kdm-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdebase-trinity-bin (= ${Source-Version}), tdebase-data-trinity (>> ${KDE-Version3}), tdebase-data-trinity (<< ${KDE-Next-Version3}), debconf (>= 1.2.9) | debconf-2.0, libpam-runtime (>= 0.76-14), xbase-clients
+Depends: ${shlibs:Depends}, tdebase-trinity-bin (= ${Source-Version}), tdebase-data-trinity (>> ${KDE-Version3}~), tdebase-data-trinity (<< ${KDE-Next-Version3}~), debconf (>= 1.2.9) | debconf-2.0, libpam-runtime (>= 0.76-14), xbase-clients
Recommends: logrotate, xserver-xorg
Suggests: khelpcenter-trinity, ksmserver-trinity (= ${Source-Version}), tdepasswd-trinity (= ${Source-Version}), menu
Provides: x-display-manager
@@ -313,7 +313,7 @@ Section: tde
Architecture: any
Replaces: kicker-kde3 (<< 4:14.0.0), kicker-trinity (<< 4:14.0.0)
Breaks: kicker-kde3 (<< 4:14.0.0), kicker-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdebase-data-trinity (>> ${KDE-Version3}), tdebase-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdebase-data-trinity (>> ${KDE-Version3}~), tdebase-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, kicker-applets-trinity, menu
Conflicts: tdebase-libs-trinity (<< 4:3.0.0)
Description: desktop panel for KDE
@@ -446,7 +446,7 @@ Section: tde
Architecture: any
Replaces: kpersonalizer-kde3 (<< 4:14.0.0), kpersonalizer-trinity (<< 4:14.0.0)
Breaks: kpersonalizer-kde3 (<< 4:14.0.0), kpersonalizer-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdebase-data-trinity (>> ${KDE-Version3}), tdebase-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdebase-data-trinity (>> ${KDE-Version3}~), tdebase-data-trinity (<< ${KDE-Next-Version3}~)
Description: installation personalizer for KDE
KDE Personalizer is the application that configures the KDE desktop for you.
It's a very useful wizard that allows you to quickly change the KDE desktop to
@@ -483,7 +483,7 @@ Section: tde
Architecture: any
Replaces: ksplash-kde3 (<< 4:14.0.0), ksplash-trinity (<< 4:14.0.0)
Breaks: ksplash-kde3 (<< 4:14.0.0), ksplash-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdebase-data-trinity (>> ${KDE-Version3}), tdebase-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdebase-data-trinity (>> ${KDE-Version3}~), tdebase-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity
Description: the KDE splash screen
This package includes the KDE Splash screen, which is seen when
@@ -540,7 +540,7 @@ Replaces: kwin-kde3 (<< 4:14.0.0), kwin-trinity (<< 4:14.0.0)
Breaks: kwin-kde3 (<< 4:14.0.0), kwin-trinity (<< 4:14.0.0)
Depends: ${shlibs:Depends}
Provides: x-window-manager
-Suggests: tdebase-trinity-bin (= ${Source-Version}), tdebase-data-trinity (>> ${KDE-Version3}), tdebase-data-trinity (<< ${KDE-Next-Version3}), kdesktop-trinity (= ${Source-Version}), kicker-trinity (= ${Source-Version}), kpager-trinity (= ${Source-Version}), kpersonalizer-trinity (= ${Source-Version}), ksmserver-trinity (= ${Source-Version}), ksplash-trinity (= ${Source-Version})
+Suggests: tdebase-trinity-bin (= ${Source-Version}), tdebase-data-trinity (>> ${KDE-Version3}~), tdebase-data-trinity (<< ${KDE-Next-Version3}~), kdesktop-trinity (= ${Source-Version}), kicker-trinity (= ${Source-Version}), kpager-trinity (= ${Source-Version}), kpersonalizer-trinity (= ${Source-Version}), ksmserver-trinity (= ${Source-Version}), ksplash-trinity (= ${Source-Version})
Conflicts: kde-window-manager-trinity (<< 7:3.5.0)
Description: the KDE window manager
This package contains the default X window manager for KDE.
diff --git a/ubuntu/precise/tdebindings/debian/control b/ubuntu/precise/tdebindings/debian/control
index 499a71208..77184243a 100644
--- a/ubuntu/precise/tdebindings/debian/control
+++ b/ubuntu/precise/tdebindings/debian/control
@@ -29,7 +29,7 @@ Architecture: all
Section: libs
Replaces: libdcop3-java-kde3 (<< 4:14.0.0), libdcop3-java-trinity (<< 4:14.0.0)
Breaks: libdcop3-java-kde3 (<< 4:14.0.0), libdcop3-java-trinity (<< 4:14.0.0)
-Depends: libdcop3-jni-trinity (>> ${KDE-Version3}), libdcop3-jni-trinity (<< ${KDE-Next-Version3}), gij | java1-runtime | java2-runtime
+Depends: libdcop3-jni-trinity (>> ${KDE-Version3}~), libdcop3-jni-trinity (<< ${KDE-Next-Version3}~), gij | java1-runtime | java2-runtime
Description: DCOP bindings for Java [Trinity]
This package contains the Java classes necessary to run Java programs
using the Java DCOP bindings. DCOP is the TDE Desktop COmmunications
@@ -56,7 +56,7 @@ Architecture: amd64 i386 ia64 powerpc s390 sparc
Section: libdevel
Replaces: libdcop3-java-kde3-dev (<< 4:14.0.0), libdcop3-java-trinity-dev (<< 4:14.0.0)
Breaks: libdcop3-java-kde3-dev (<< 4:14.0.0), libdcop3-java-trinity-dev (<< 4:14.0.0)
-Depends: libdcop3-java-trinity (>> ${KDE-Version3}), libdcop3-java-trinity (<< ${KDE-Next-Version3})
+Depends: libdcop3-java-trinity (>> ${KDE-Version3}~), libdcop3-java-trinity (<< ${KDE-Next-Version3}~)
Description: DCOP bindings for Java (dcopidl2java program) [Trinity]
This package contains the dcopidl2java program which generates Java
stubs from DCOP IDL files, necessary to do development with the DCOP Java
@@ -70,7 +70,7 @@ Architecture: all
Section: libs
Replaces: libqt3-java-kde3 (<< 4:14.0.0), libqt3-java-trinity (<< 4:14.0.0)
Breaks: libqt3-java-kde3 (<< 4:14.0.0), libqt3-java-trinity (<< 4:14.0.0)
-Depends: libqt3-jni-trinity (>> ${KDE-Version3}), libqt3-jni-trinity (<< ${KDE-Next-Version3}), gij | java1-runtime | java2-runtime
+Depends: libqt3-jni-trinity (>> ${KDE-Version3}~), libqt3-jni-trinity (<< ${KDE-Next-Version3}~), gij | java1-runtime | java2-runtime
Suggests: juic-trinity
Description: Java bindings for Qt [Trinity]
This package contains the Java classes necessary to run Java programs
@@ -100,7 +100,7 @@ Architecture: all
Section: libs
Replaces: libtrinity-java-kde3 (<< 4:14.0.0), libtrinity-java-trinity (<< 4:14.0.0)
Breaks: libtrinity-java-kde3 (<< 4:14.0.0), libtrinity-java-trinity (<< 4:14.0.0)
-Depends: libtrinity-jni-trinity (>> ${KDE-Version3}), libtrinity-jni-trinity (<< ${KDE-Next-Version3}), gij | java1-runtime | java2-runtime
+Depends: libtrinity-jni-trinity (>> ${KDE-Version3}~), libtrinity-jni-trinity (<< ${KDE-Next-Version3}~), gij | java1-runtime | java2-runtime
Description: tdelibs bindings for Java [Trinity]
This package contains the Java classes necessary to run Java programs
using the Java tdelibs bindings. TDE is the Trinity Desktop Environment, a
diff --git a/ubuntu/precise/tdeedu/debian/control b/ubuntu/precise/tdeedu/debian/control
index 602d933e5..f03b48025 100644
--- a/ubuntu/precise/tdeedu/debian/control
+++ b/ubuntu/precise/tdeedu/debian/control
@@ -74,7 +74,7 @@ Architecture: any
Section: games
Replaces: blinken-kde3 (<< 4:14.0.0), blinken-trinity (<< 4:14.0.0)
Breaks: blinken-kde3 (<< 4:14.0.0), blinken-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, ttf-sjfonts, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, ttf-sjfonts, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: Trinity version of the Simon Says electronic memory game
Blinken is based on an electronic game released in 1978, which
@@ -94,7 +94,7 @@ Architecture: any
Section: science
Replaces: kalzium-kde3 (<< 4:14.0.0), kalzium-trinity (<< 4:14.0.0)
Breaks: kalzium-kde3 (<< 4:14.0.0), kalzium-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, kalzium-data-trinity (>> ${KDE-Version3}), kalzium-data-trinity (<< ${KDE-Next-Version3}), tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, kalzium-data-trinity (>> ${KDE-Version3}~), kalzium-data-trinity (<< ${KDE-Next-Version3}~), tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: chemistry teaching tool for Trinity
Kalzium is a program which shows you the Periodic System of Elements
@@ -137,7 +137,7 @@ Architecture: any
Section: games
Replaces: kanagram-kde3 (<< 4:14.0.0), kanagram-trinity (<< 4:14.0.0)
Breaks: kanagram-kde3 (<< 4:14.0.0), kanagram-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: letter order game for Trinity
KAnagram is a game that is based on the word/letter puzzles that the
@@ -160,7 +160,7 @@ Architecture: any
Section: math
Replaces: kbruch-kde3 (<< 4:14.0.0), kbruch-trinity (<< 4:14.0.0)
Breaks: kbruch-kde3 (<< 4:14.0.0), kbruch-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: fraction calculation teaching tool for Trinity
KBruch is a small program to practice calculating with fractions.
@@ -175,7 +175,7 @@ Architecture: any
Section: tde
Replaces: keduca-kde3 (<< 4:14.0.0), keduca-trinity (<< 4:14.0.0)
Breaks: keduca-kde3 (<< 4:14.0.0), keduca-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: interactive form-based tests for Trinity
KEduca is a flash-card application which allows you to make
@@ -189,7 +189,7 @@ Architecture: any
Section: tde
Replaces: kgeography-kde3 (<< 4:14.0.0), kgeography-trinity (<< 4:14.0.0)
Breaks: kgeography-kde3 (<< 4:14.0.0), kgeography-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, kgeography-data-trinity (>> ${KDE-Version3}), kgeography-data-trinity (<< ${KDE-Next-Version3}), tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, kgeography-data-trinity (>> ${KDE-Version3}~), kgeography-data-trinity (<< ${KDE-Next-Version3}~), tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: Geography learning tool for Trinity
KGeography contains maps allowing you to learn various countries or
@@ -220,7 +220,7 @@ Architecture: any
Section: games
Replaces: khangman-kde3 (<< 4:14.0.0), khangman-trinity (<< 4:14.0.0)
Breaks: khangman-kde3 (<< 4:14.0.0), khangman-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, ttf-dustin, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, ttf-dustin, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: the classical hangman game for Trinity
KHangMan is a game based on the well known hangman game. It is aimed
@@ -240,7 +240,7 @@ Architecture: any
Section: math
Replaces: kig-kde3 (<< 4:14.0.0), kig-trinity (<< 4:14.0.0)
Breaks: kig-kde3 (<< 4:14.0.0), kig-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: interactive geometry program for KDE
Kig is an application for interactive geometry. It is intended to
@@ -268,7 +268,7 @@ Architecture: any
Section: tde
Replaces: kiten-kde3 (<< 4:14.0.0), kiten-trinity (<< 4:14.0.0)
Breaks: kiten-kde3 (<< 4:14.0.0), kiten-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3}), ttf-kochi-gothic | ttf-kochi-mincho
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~), ttf-kochi-gothic | ttf-kochi-mincho
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: Japanese reference/study tool for Trinity
Kiten is a Japanese reference and study tool for KDE. It is an
@@ -285,7 +285,7 @@ Architecture: any
Section: tde
Replaces: klatin-kde3 (<< 4:14.0.0), klatin-trinity (<< 4:14.0.0)
Breaks: klatin-kde3 (<< 4:14.0.0), klatin-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: application to help revise/teach Latin
KLatin is a program to help revise Latin. There are three "sections"
@@ -310,7 +310,7 @@ Architecture: any
Section: tde
Replaces: klettres-kde3 (<< 4:14.0.0), klettres-trinity (<< 4:14.0.0)
Breaks: klettres-kde3 (<< 4:14.0.0), klettres-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, klettres-data-trinity (>> ${KDE-Version3}), klettres-data-trinity (<< ${KDE-Next-Version3}), tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, klettres-data-trinity (>> ${KDE-Version3}~), klettres-data-trinity (<< ${KDE-Next-Version3}~), tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: foreign alphabet tutor for Trinity
KLettres is an application specially designed to help the user to
@@ -344,7 +344,7 @@ Architecture: any
Section: math
Replaces: kmplot-kde3 (<< 4:14.0.0), kmplot-trinity (<< 4:14.0.0)
Breaks: kmplot-kde3 (<< 4:14.0.0), kmplot-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: mathematical function plotter for Trinity
KmPlot is a mathematical function plotter for KDE. It has a powerful
@@ -368,7 +368,7 @@ Architecture: any
Section: math
Replaces: kpercentage-kde3 (<< 4:14.0.0), kpercentage-trinity (<< 4:14.0.0)
Breaks: kpercentage-kde3 (<< 4:14.0.0), kpercentage-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: percentage calculation teaching tool for Trinity
KPercentage is a small math application that will help pupils to
@@ -386,7 +386,7 @@ Architecture: any
Section: science
Replaces: kstars-kde3 (<< 4:14.0.0), kstars-trinity (<< 4:14.0.0)
Breaks: kstars-kde3 (<< 4:14.0.0), kstars-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, kstars-data-trinity (>> ${KDE-Version3}), kstars-data-trinity (<< ${KDE-Next-Version3}), tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3}), indi-trinity (= ${Source-Version})
+Depends: ${shlibs:Depends}, kstars-data-trinity (>> ${KDE-Version3}~), kstars-data-trinity (<< ${KDE-Next-Version3}~), tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~), indi-trinity (= ${Source-Version})
Suggests: konqueror-trinity, khelpcenter-trinity, tdeedu-trinity-doc-html
Description: desktop planetarium for Trinity
KStars is a graphical desktop planetarium for KDE. It depicts an
@@ -424,7 +424,7 @@ Architecture: any
Section: tde
Replaces: ktouch-kde3 (<< 4:14.0.0), ktouch-trinity (<< 4:14.0.0)
Breaks: ktouch-kde3 (<< 4:14.0.0), ktouch-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: touch typing tutor for Trinity
KTouch is a program for learning touch typing - it helps you learn to
@@ -444,7 +444,7 @@ Architecture: any
Section: devel
Replaces: kturtle-kde3 (<< 4:14.0.0), kturtle-trinity (<< 4:14.0.0)
Breaks: kturtle-kde3 (<< 4:14.0.0), kturtle-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: educational Logo programming environment
KTurtle is an educational programming environment using the Logo
@@ -472,7 +472,7 @@ Architecture: any
Section: tde
Replaces: kverbos-kde3 (<< 4:14.0.0), kverbos-trinity (<< 4:14.0.0)
Breaks: kverbos-kde3 (<< 4:14.0.0), kverbos-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: Spanish verb form study application for Trinity
Kverbos allows the user to learn the forms of Spanish verbs. The
@@ -491,7 +491,7 @@ Architecture: any
Section: tde
Replaces: kvoctrain-kde3 (<< 4:14.0.0), kvoctrain-trinity (<< 4:14.0.0)
Breaks: kvoctrain-kde3 (<< 4:14.0.0), kvoctrain-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, ${perl:Depends}, libwww-perl, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, ${perl:Depends}, libwww-perl, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: vocabulary trainer for Trinity
KVocTrain is a little utility to help you train your vocabulary when
@@ -517,7 +517,7 @@ Architecture: any
Section: tde
Replaces: kwordquiz-kde3 (<< 4:14.0.0), kwordquiz-trinity (<< 4:14.0.0)
Breaks: kwordquiz-kde3 (<< 4:14.0.0), kwordquiz-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: flashcard and vocabulary learning program for Trinity
KWordQuiz is a flashcard-based tool that helps you to master new
diff --git a/ubuntu/precise/tdegraphics/debian/control b/ubuntu/precise/tdegraphics/debian/control
index 4d9e8fb52..623d2dceb 100644
--- a/ubuntu/precise/tdegraphics/debian/control
+++ b/ubuntu/precise/tdegraphics/debian/control
@@ -4,7 +4,7 @@ Priority: optional
Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
XSBC-Original-Maintainer: Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
Uploaders: Ana Beatriz Guerrero Lopez <ana@debian.org>, Francesco Pedrini <francesco.pedrini@gmail.com>, Josh Metzler <joshdeb@metzlers.org>, Sune Vuorela <debian@pusling.com>
-Build-Depends: imlib11-dev, cdbs (>= 0.4.39-0.1), debhelper (>= 5.0.31), autotools-dev, gawk, gettext, tdelibs14-trinity-dev, libexif-dev (>= 0.6.9-1), libfribidi-dev, freeglut3-dev, libgphoto2-2-dev, libopenexr-dev (>= 1.2.1), libpaper-dev, libpoppler-dev, libpoppler-private-dev, libsane-dev (>> 1.0.15), libtiff-dev, libtiff-tools, libusb-dev, sharutils, libxxf86vm-dev, chrpath [powerpc], cmake, libtool, libltdl-dev
+Build-Depends: imlib11-dev, cdbs (>= 0.4.39-0.1), debhelper (>= 5.0.31), autotools-dev, gawk, gettext, tdelibs14-trinity-dev, libexif-dev (>= 0.6.9-1), libfribidi-dev, freeglut3-dev, libgphoto2-6-dev | libgphoto2-2-dev, libopenexr-dev (>= 1.2.1), libpaper-dev, libpoppler-private-dev | libpoppler-dev (<< 0.18.4-3), libpoppler-dev, libsane-dev (>> 1.0.15), libtiff-dev, libtiff-tools, libusb-dev, sharutils, libxxf86vm-dev, chrpath [powerpc], cmake, libtool, libltdl-dev
Standards-Version: 3.8.4
Package: tdegraphics-trinity
diff --git a/ubuntu/raring/applications/kcpuload/debian/rules b/ubuntu/raring/applications/kcpuload/debian/rules
index 20eca167c..385c24313 100755
--- a/ubuntu/raring/applications/kcpuload/debian/rules
+++ b/ubuntu/raring/applications/kcpuload/debian/rules
@@ -45,11 +45,6 @@ ifeq ($(DEB_BUILD_GNU_TYPE),i386-linux)
#export CXXFLAGS=-O3 -march=i686 -ffast-math -finline-functions
endif
--include debian/debiandirs
-
-debian/debiandirs: admin/debianrules
- perl -w admin/debianrules echodirs > debian/debiandirs
-
configure: configure-stamp
configure-stamp:
dh_testdir
@@ -104,7 +99,7 @@ debian-clean:
clean:
dh_testdir
dh_testroot
- rm -f build-stamp configure-stamp debian/debiandirs
+ rm -f build-stamp configure-stamp
# Remove Debian specific patches
if test -f patch-stamp; then \
@@ -169,8 +164,6 @@ binary-common:
dh_testroot
dh_installchangelogs kcpuload/ChangeLog
dh_installdocs
- mkdir debian/kcpuload-trinity/opt/trinity/share/doc
- mv debian/kcpuload-trinity/usr/share/doc/tde debian/kcpuload-trinity/opt/trinity/share/doc/
rm -fr debian/kcpuload-trinity/usr/share/doc-base
dh_installexamples
dh_installmanpages
diff --git a/ubuntu/raring/applications/koffice/debian/control b/ubuntu/raring/applications/koffice/debian/control
index aa5d4cadb..6d2e73b8c 100644
--- a/ubuntu/raring/applications/koffice/debian/control
+++ b/ubuntu/raring/applications/koffice/debian/control
@@ -61,7 +61,7 @@ Architecture: any
Section: graphics
Replaces: karbon-kde3 (<< 4:14.0.0), karbon-trinity (<< 4:14.0.0)
Breaks: karbon-kde3 (<< 4:14.0.0), karbon-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Description: a vector graphics application for the KDE Office Suite
Karbon is a vector graphics application.
.
@@ -72,7 +72,7 @@ Architecture: any
Section: tde
Replaces: kchart-kde3 (<< 4:14.0.0), kchart-trinity (<< 4:14.0.0)
Breaks: kchart-kde3 (<< 4:14.0.0), kchart-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: a chart drawing program for the KDE Office Suite [Trinity]
KChart is a chart drawing application. It can be used to embed charts
@@ -85,7 +85,7 @@ Architecture: any
Section: tde
Replaces: kexi-kde3 (<< 4:14.0.0), kexi-trinity (<< 4:14.0.0)
Breaks: kexi-kde3 (<< 4:14.0.0), kexi-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Suggests: kexi-mdb-plugin-trinity
Description: integrated database environment for the KDE Office Suite [Trinity]
Kexi is an integrated data management application. It can be used for
@@ -107,7 +107,7 @@ Architecture: any
Section: tde
Replaces: kformula-kde3 (<< 4:14.0.0), kformula-trinity (<< 4:14.0.0)
Breaks: kformula-kde3 (<< 4:14.0.0), kformula-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: a formula editor for the KDE Office Suite [Trinity]
KFormula is a formula editor that provides the basic input facilities
@@ -124,7 +124,7 @@ Architecture: any
Section: graphics
Replaces: kivio-kde3 (<< 4:14.0.0), kivio-trinity (<< 4:14.0.0)
Breaks: kivio-kde3 (<< 4:14.0.0), kivio-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, kivio-data-trinity (>> 1:1.4.90.2-1), kivio-data-trinity (>> ${KDE-Version3}), kivio-data-trinity (<< ${KDE-Next-Version3}), koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, kivio-data-trinity (>> 1:1.4.90.2-1), kivio-data-trinity (>> ${KDE-Version3}~), kivio-data-trinity (<< ${KDE-Next-Version3}~), koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Description: a flowcharting program for the KDE Office Suite [Trinity]
Kivio is a flowcharting program that offers basic flowcharting abilities,
but with a twist. Objects are scriptable, and a backend plugin system
@@ -150,7 +150,7 @@ Architecture: any
Section: tde
Replaces: koshell-kde3 (<< 4:14.0.0), koshell-trinity (<< 4:14.0.0)
Breaks: koshell-kde3 (<< 4:14.0.0), koshell-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: koffice-trinity, khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: the KDE Office Suite workspace [Trinity]
The KOffice workspace is a desktop with easy one-click launchers for
@@ -163,7 +163,7 @@ Architecture: any
Section: tde
Replaces: kplato-kde3 (<< 4:14.0.0), kplato-trinity (<< 4:14.0.0)
Breaks: kplato-kde3 (<< 4:14.0.0), kplato-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: an integrated project management and planning tool [Trinity]
KPlato is a project management application, allowing for the planning and
@@ -177,7 +177,7 @@ Architecture: any
Section: tde
Replaces: kpresenter-kde3 (<< 4:14.0.0), kpresenter-trinity (<< 4:14.0.0)
Breaks: kpresenter-kde3 (<< 4:14.0.0), kpresenter-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, ${perl:Depends}, kpresenter-data-trinity (>> ${KDE-Version3}), kpresenter-data-trinity (<< ${KDE-Next-Version3}), koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, ${perl:Depends}, kpresenter-data-trinity (>> ${KDE-Version3}~), kpresenter-data-trinity (<< ${KDE-Next-Version3}~), koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: a presentation program for the KDE Office Suite [Trinity]
KPresenter is a fully-featured presentation program. Presentations can
@@ -204,7 +204,7 @@ Architecture: any
Section: tde
Replaces: krita-kde3 (<< 4:14.0.0), chalk-trinity (<< 4:14.0.0)
Breaks: krita-kde3 (<< 4:14.0.0), chalk-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, chalk-data-trinity (>> ${KDE-Version3}), chalk-data-trinity (<< ${KDE-Next-Version3}), koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, chalk-data-trinity (>> ${KDE-Version3}~), chalk-data-trinity (<< ${KDE-Next-Version3}~), koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: dcraw, khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: a pixel-based image manipulation program for the KDE Office Suite [Trinity]
Chalk is a painting and image editing application for KOffice. Chalk contains
@@ -230,7 +230,7 @@ Architecture: any
Section: tde
Replaces: kspread-kde3 (<< 4:14.0.0), kspread-trinity (<< 4:14.0.0)
Breaks: kspread-kde3 (<< 4:14.0.0), kspread-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: a spreadsheet for the KDE Office Suite [Trinity]
KSpread is a powerful spreadsheet application. It is scriptable and
@@ -244,7 +244,7 @@ Architecture: any
Section: tde
Replaces: kugar-kde3 (<< 4:14.0.0), kugar-trinity (<< 4:14.0.0)
Breaks: kugar-kde3 (<< 4:14.0.0), kugar-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: a business report maker for the KDE Office Suite [Trinity]
Kugar is a tool for generating business quality reports that can
@@ -260,7 +260,7 @@ Architecture: any
Section: tde
Replaces: kword-kde3 (<< 4:14.0.0), kword-trinity (<< 4:14.0.0)
Breaks: kword-kde3 (<< 4:14.0.0), kword-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, kword-data-trinity (>> ${KDE-Version3}), kword-data-trinity (<< ${KDE-Next-Version3}), koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, kword-data-trinity (>> ${KDE-Version3}~), kword-data-trinity (<< ${KDE-Next-Version3}~), koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: a word processor for the KDE Office Suite [Trinity]
KWord is a FrameMaker-like word processing and desktop publishing
@@ -288,7 +288,7 @@ Architecture: any
Section: tde
Replaces: kthesaurus-kde3 (<< 4:14.0.0), kthesaurus-trinity (<< 4:14.0.0)
Breaks: kthesaurus-kde3 (<< 4:14.0.0), kthesaurus-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-libs-trinity (<< ${KDE-Next-Version3}~)
Recommends: khelpcenter-trinity | koffice-trinity-doc-html (= ${source:Version})
Description: thesaurus for the KDE Office Suite [Trinity]
KThesaurus lists words related to a given term and offers a user interface
@@ -302,7 +302,7 @@ Architecture: any
Section: libs
Replaces: koffice-libs-kde3 (<< 4:14.0.0), koffice-libs-trinity (<< 4:14.0.0)
Breaks: koffice-libs-kde3 (<< 4:14.0.0), koffice-libs-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, koffice-data-trinity (>> ${KDE-Version3}), koffice-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, koffice-data-trinity (>> ${KDE-Version3}~), koffice-data-trinity (<< ${KDE-Next-Version3}~)
Recommends: latex-xft-fonts, ruby, python
Suggests: wordnet, texlive-base
Description: common libraries and binaries for the KDE Office Suite [Trinity]
diff --git a/ubuntu/raring/dependencies/arts/debian/patches/12_cleanup_artsc-config.diff b/ubuntu/raring/dependencies/arts/debian/patches/12_cleanup_artsc-config.diff
index 603ffdf37..57a8122f9 100644
--- a/ubuntu/raring/dependencies/arts/debian/patches/12_cleanup_artsc-config.diff
+++ b/ubuntu/raring/dependencies/arts/debian/patches/12_cleanup_artsc-config.diff
@@ -1,3 +1,5 @@
+Index: b/artsc/artsc-config.in
+===================================================================
--- a/artsc/artsc-config.in
+++ b/artsc/artsc-config.in
@@ -27,7 +27,7 @@
@@ -8,4 +10,4 @@
+ flags="$flags -L$libdir -lartsc"
;;
--cflags)
- flags="$flags -I$includedir/artsc @GLIB_CFLAGS@"
+ flags="$flags -I$includedir @GLIB_CFLAGS@"
diff --git a/ubuntu/raring/dependencies/arts/debian/rules b/ubuntu/raring/dependencies/arts/debian/rules
index 9c9730bda..1b4911297 100755
--- a/ubuntu/raring/dependencies/arts/debian/rules
+++ b/ubuntu/raring/dependencies/arts/debian/rules
@@ -41,6 +41,6 @@ DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
binary-predeb/libarts1-trinity-dev::
ifeq (linux,$(DEB_HOST_ARCH_OS))
- echo "libasound2-trinity-dev=libasound2-trinity-dev" >> debian/libarts1-dev.substvars
+ echo "libasound2-dev=libasound2-dev" >> debian/libarts1-trinity-dev.substvars
endif
diff --git a/ubuntu/raring/dependencies/libcaldav/debian/source/format b/ubuntu/raring/dependencies/libcaldav/debian/source/format
new file mode 100644
index 000000000..89ae9db8f
--- /dev/null
+++ b/ubuntu/raring/dependencies/libcaldav/debian/source/format
@@ -0,0 +1 @@
+3.0 (native)
diff --git a/ubuntu/raring/dependencies/libcaldav/debian/source/options b/ubuntu/raring/dependencies/libcaldav/debian/source/options
new file mode 100644
index 000000000..72f1f5450
--- /dev/null
+++ b/ubuntu/raring/dependencies/libcaldav/debian/source/options
@@ -0,0 +1,6 @@
+# Use xz instead of gzip
+compression = "xz"
+compression-level = 9
+
+# Don't run differences
+diff-ignore = .*
diff --git a/ubuntu/raring/dependencies/libcarddav/debian/source/format b/ubuntu/raring/dependencies/libcarddav/debian/source/format
new file mode 100644
index 000000000..89ae9db8f
--- /dev/null
+++ b/ubuntu/raring/dependencies/libcarddav/debian/source/format
@@ -0,0 +1 @@
+3.0 (native)
diff --git a/ubuntu/raring/dependencies/libcarddav/debian/source/options b/ubuntu/raring/dependencies/libcarddav/debian/source/options
new file mode 100644
index 000000000..72f1f5450
--- /dev/null
+++ b/ubuntu/raring/dependencies/libcarddav/debian/source/options
@@ -0,0 +1,6 @@
+# Use xz instead of gzip
+compression = "xz"
+compression-level = 9
+
+# Don't run differences
+diff-ignore = .*
diff --git a/ubuntu/raring/dependencies/qt3/debian/control b/ubuntu/raring/dependencies/qt3/debian/control
index 4be146e7d..7641cffbf 100644
--- a/ubuntu/raring/dependencies/qt3/debian/control
+++ b/ubuntu/raring/dependencies/qt3/debian/control
@@ -11,7 +11,7 @@ Build-Depends: debhelper (>= 5.0.31), quilt, cpio, libxext-dev (>= 4.3.0.dfsg.1-
libfreetype6-dev, libxft-dev, unixodbc-dev, uuid-dev, libglib2.0-dev,
libmysqlclient-dev, flex, libpq-dev, libaudio-dev, libcups2-dev,
libgl1-mesa-dev | libgl-dev, libglu1-mesa-dev | libglu-dev, libsqlite3-dev,
- firebird2.1-dev [i386 kfreebsd-i386 kfreebsd-amd64 knetbsd-i386 netbsd-i386 amd64 sparc powerpc] | firebird2-dev [i386 amd64]
+ firebird-dev | firebird2.1-dev [i386 kfreebsd-i386 kfreebsd-amd64 knetbsd-i386 netbsd-i386 amd64 sparc powerpc] | firebird2-dev [i386 amd64]
Section: libs
Priority: optional
Standards-Version: 3.8.4
diff --git a/ubuntu/raring/dependencies/qt3/debian/patches/06_disable_rpath.diff b/ubuntu/raring/dependencies/qt3/debian/patches/06_disable_rpath.diff
index 27fc1426c..a3d74ffce 100644
--- a/ubuntu/raring/dependencies/qt3/debian/patches/06_disable_rpath.diff
+++ b/ubuntu/raring/dependencies/qt3/debian/patches/06_disable_rpath.diff
@@ -2,25 +2,29 @@ author: Martin Loschwitz <madkiss@madkiss.org>
Disables the rpath settings in qmake.conf
+Index: b/mkspecs/linux-g++/qmake.conf
+===================================================================
--- a/mkspecs/linux-g++/qmake.conf
+++ b/mkspecs/linux-g++/qmake.conf
-@@ -55,7 +55,7 @@ QMAKE_LFLAGS_SHLIB = -shared
+@@ -55,7 +55,7 @@
QMAKE_LFLAGS_PLUGIN = $$QMAKE_LFLAGS_SHLIB
QMAKE_LFLAGS_SONAME = -Wl,-soname,
QMAKE_LFLAGS_THREAD =
-QMAKE_RPATH = -Wl,-rpath,
+QMAKE_RPATH =
- QMAKE_LIBS =
+ QMAKE_LIBS = -luuid
QMAKE_LIBS_DYNLOAD = -ldl
+Index: b/mkspecs/linux-g++-64/qmake.conf
+===================================================================
--- a/mkspecs/linux-g++-64/qmake.conf
+++ b/mkspecs/linux-g++-64/qmake.conf
-@@ -58,7 +58,7 @@ QMAKE_LFLAGS_SHLIB = -shared
+@@ -58,7 +58,7 @@
QMAKE_LFLAGS_PLUGIN = $$QMAKE_LFLAGS_SHLIB
QMAKE_LFLAGS_SONAME = -Wl,-soname,
QMAKE_LFLAGS_THREAD =
-QMAKE_RPATH = -Wl,-rpath,
+QMAKE_RPATH =
- QMAKE_LIBS =
+ QMAKE_LIBS = -luuid
QMAKE_LIBS_DYNLOAD = -ldl
diff --git a/ubuntu/raring/dependencies/tqt3/debian/control b/ubuntu/raring/dependencies/tqt3/debian/control
index b45983f80..1655a1357 100644
--- a/ubuntu/raring/dependencies/tqt3/debian/control
+++ b/ubuntu/raring/dependencies/tqt3/debian/control
@@ -11,7 +11,7 @@ Build-Depends: debhelper (>= 5.0.31), quilt, cpio, libxext-dev (>= 4.3.0.dfsg.1-
libfreetype6-dev, libxft-dev, unixodbc-dev, uuid-dev, libglib2.0-dev,
libmysqlclient-dev, flex, libpq-dev, libaudio-dev, libcups2-dev,
libgl1-mesa-dev | libgl-dev, libglu1-mesa-dev | libglu-dev, libsqlite3-dev,
- firebird2.1-dev [i386 kfreebsd-i386 kfreebsd-amd64 knetbsd-i386 netbsd-i386 amd64 sparc powerpc] | firebird2-dev [i386 amd64]
+ firebird-dev | firebird2.1-dev [i386 kfreebsd-i386 kfreebsd-amd64 knetbsd-i386 netbsd-i386 amd64 sparc powerpc] | firebird2-dev [i386 amd64]
Section: libs
Priority: optional
Standards-Version: 3.8.4
diff --git a/ubuntu/raring/dependencies/tqt3/debian/patches/06_disable_rpath.diff b/ubuntu/raring/dependencies/tqt3/debian/patches/06_disable_rpath.diff
index 27fc1426c..a3d74ffce 100644
--- a/ubuntu/raring/dependencies/tqt3/debian/patches/06_disable_rpath.diff
+++ b/ubuntu/raring/dependencies/tqt3/debian/patches/06_disable_rpath.diff
@@ -2,25 +2,29 @@ author: Martin Loschwitz <madkiss@madkiss.org>
Disables the rpath settings in qmake.conf
+Index: b/mkspecs/linux-g++/qmake.conf
+===================================================================
--- a/mkspecs/linux-g++/qmake.conf
+++ b/mkspecs/linux-g++/qmake.conf
-@@ -55,7 +55,7 @@ QMAKE_LFLAGS_SHLIB = -shared
+@@ -55,7 +55,7 @@
QMAKE_LFLAGS_PLUGIN = $$QMAKE_LFLAGS_SHLIB
QMAKE_LFLAGS_SONAME = -Wl,-soname,
QMAKE_LFLAGS_THREAD =
-QMAKE_RPATH = -Wl,-rpath,
+QMAKE_RPATH =
- QMAKE_LIBS =
+ QMAKE_LIBS = -luuid
QMAKE_LIBS_DYNLOAD = -ldl
+Index: b/mkspecs/linux-g++-64/qmake.conf
+===================================================================
--- a/mkspecs/linux-g++-64/qmake.conf
+++ b/mkspecs/linux-g++-64/qmake.conf
-@@ -58,7 +58,7 @@ QMAKE_LFLAGS_SHLIB = -shared
+@@ -58,7 +58,7 @@
QMAKE_LFLAGS_PLUGIN = $$QMAKE_LFLAGS_SHLIB
QMAKE_LFLAGS_SONAME = -Wl,-soname,
QMAKE_LFLAGS_THREAD =
-QMAKE_RPATH = -Wl,-rpath,
+QMAKE_RPATH =
- QMAKE_LIBS =
+ QMAKE_LIBS = -luuid
QMAKE_LIBS_DYNLOAD = -ldl
diff --git a/ubuntu/raring/libraries/python-trinity/debian/control b/ubuntu/raring/libraries/python-trinity/debian/control
index 0da4178e0..44606c723 100644
--- a/ubuntu/raring/libraries/python-trinity/debian/control
+++ b/ubuntu/raring/libraries/python-trinity/debian/control
@@ -4,17 +4,15 @@ Priority: optional
Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
XSBC-Original-Maintainer: Ricardo Javier Cardenes Medina <rcardenes@debian.org>
Uploaders: Torsten Marek <shlomme@debian.org>, Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
-Build-Depends: debhelper (>= 5.0.38), libtqtinterface-dev, python, python-all-dev, python-all-dbg, sip4 (>= 4.10), python-sip4-dev (>= 4.10), python-tqt-dev, tdelibs14-trinity-dev, python-support (>= 0.6) | python-dev (>= 2.6.6-3~), dpatch, python-sip4, python-sip4-dbg, python-sip4-dev
+Build-Depends: debhelper (>= 5.0.38), libtqtinterface-dev, python, python-all-dev, python-all-dbg, sip4 (>= 4.10), python-sip4-dev (>= 4.10), python-tqt-dev, tdelibs14-trinity-dev, python-sip4, python-sip4-dbg, python-sip4-dev
Standards-Version: 3.8.4
Homepage: http://www.riverbankcomputing.co.uk/pytde/index.php
-XS-Python-Version: all
Package: python-trinity-trinity
Architecture: any
Depends: ${shlibs:Depends}, ${python:Depends}, python-tqt
Replaces: python-kde3-kde3 (<< 4:14.0.0), python-trinity-trinity (<< 4:14.0.0)
Breaks: python-kde3-kde3 (<< 4:14.0.0), python-trinity-trinity (<< 4:14.0.0)
-XB-Python-Version: ${python:Versions}
Provides: ${python:Provides}
Conflicts: python-trinity-trinity
Description: Trinity bindings for Python [Trinity]
@@ -28,7 +26,6 @@ Architecture: any
Replaces: python-kde3-kde3-dbg (<< 4:14.0.0), python-trinity-trinity-dbg (<< 4:14.0.0)
Breaks: python-kde3-kde3-dbg (<< 4:14.0.0), python-trinity-trinity-dbg (<< 4:14.0.0)
Depends: python-trinity-trinity (= ${binary:Version}), python-dbg, python-tqt-dbg, ${shlibs:Depends}
-XB-Python-Version: ${python:Versions}
Description: Trinity bindings for Python (debug extensions) [Trinity]
Python binding module that provides wide access to the Trinity API,
also known as PyKDE. Using this, you'll get (for example) classes
@@ -42,7 +39,6 @@ Architecture: all
Replaces: python-kde3-kde3-dev (<< 4:14.0.0), python-trinity-trinity-dev (<< 4:14.0.0)
Breaks: python-kde3-kde3-dev (<< 4:14.0.0), python-trinity-trinity-dev (<< 4:14.0.0)
Depends: pytqt-tools, ${python:Depends}
-XB-Python-Version: ${python:Versions}
Description: Trinity bindings for Python - Development files and scripts [Trinity]
Development .sip files with definitions of PyKDE classes. They
are needed to build PyKDE, but also as building blocks of other
diff --git a/ubuntu/raring/libraries/python-trinity/debian/pycompat b/ubuntu/raring/libraries/python-trinity/debian/pycompat
deleted file mode 100644
index 0cfbf0888..000000000
--- a/ubuntu/raring/libraries/python-trinity/debian/pycompat
+++ /dev/null
@@ -1 +0,0 @@
-2
diff --git a/ubuntu/raring/libraries/python-trinity/debian/rules b/ubuntu/raring/libraries/python-trinity/debian/rules
index d4dac70f3..473caac7d 100755
--- a/ubuntu/raring/libraries/python-trinity/debian/rules
+++ b/ubuntu/raring/libraries/python-trinity/debian/rules
@@ -14,7 +14,6 @@ cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xine
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
-include /usr/share/dpatch/dpatch.make
# This has to be exported to make some magic below work.
export DH_OPTIONS
export QTDIR=/usr/share/qt3
@@ -31,8 +30,7 @@ endif
PYTHONS := $(shell pyversions -vr debian/control)
DBG_PYTHONS := $(shell pyversions -vd)
-DEB_PYTHON_SYSTEM = $(if $(wildcard /usr/bin/dh_python2),,pysupport)
-DH_PYTHON2 = $(if $(wildcard /usr/bin/dh_python2),dh_python2,dh_pysupport)
+DH_PYTHON2 = $(if $(wildcard /usr/bin/dh_python2),dh_python2,dh_python)
GCCVER := $(shell gcc --version | sed -n '/^gcc (GCC)/s/.*(GCC) \(...\).*/\1/p')
ifneq (,$(filter $(GCCVER),4.2 4.3))
@@ -45,7 +43,7 @@ endif
configure: $(PYTHONS:%=build-%/configure-stamp) $(DBG_PYTHONS:%=dbg-build-%/configure-stamp)
-build-%/configure-stamp: patch-stamp
+build-%/configure-stamp:
dh_testdir
mkdir -p build-$*
cd build-$* && python$* ../configure.py \
@@ -53,7 +51,7 @@ build-%/configure-stamp: patch-stamp
-v /opt/trinity/share/sip/trinity -j $(SPLIT)
touch $@
-dbg-build-%/configure-stamp: patch-stamp
+dbg-build-%/configure-stamp:
dh_testdir
mkdir -p dbg-build-$*
cd dbg-build-$* && python$*-dbg ../configure.py \
@@ -73,7 +71,7 @@ dbg-build-%/build-stamp: dbg-build-%/configure-stamp
$(MAKE) -C dbg-build-$*
touch $@
-clean: unpatch
+clean:
dh_testdir
dh_testroot
rm -f *-stamp
diff --git a/ubuntu/raring/tdebase/debian/control b/ubuntu/raring/tdebase/debian/control
index b2a891a78..748ea8bf5 100644
--- a/ubuntu/raring/tdebase/debian/control
+++ b/ubuntu/raring/tdebase/debian/control
@@ -88,7 +88,7 @@ Section: tde
Architecture: any
Replaces: kcontrol-kde3 (<< 4:14.0.0), kcontrol-trinity (<< 4:14.0.0)
Breaks: kcontrol-kde3 (<< 4:14.0.0), kcontrol-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdebase-data-trinity (>> ${KDE-Version3}), tdebase-data-trinity (<< ${KDE-Next-Version3}), usbutils
+Depends: ${shlibs:Depends}, tdebase-data-trinity (>> ${KDE-Version3}~), tdebase-data-trinity (<< ${KDE-Next-Version3}~), usbutils
Recommends: udev
Suggests: khelpcenter-trinity, ntpdate | ntp-simple
Conflicts: tdebase-libs-trinity (<< 4:3.0.0)
@@ -254,7 +254,7 @@ Section: tde
Architecture: any
Replaces: kdm-kde3 (<< 4:14.0.0), kdm-trinity (<< 4:14.0.0)
Breaks: kdm-kde3 (<< 4:14.0.0), kdm-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdebase-trinity-bin (= ${Source-Version}), tdebase-data-trinity (>> ${KDE-Version3}), tdebase-data-trinity (<< ${KDE-Next-Version3}), debconf (>= 1.2.9) | debconf-2.0, libpam-runtime (>= 0.76-14), xbase-clients
+Depends: ${shlibs:Depends}, tdebase-trinity-bin (= ${Source-Version}), tdebase-data-trinity (>> ${KDE-Version3}~), tdebase-data-trinity (<< ${KDE-Next-Version3}~), debconf (>= 1.2.9) | debconf-2.0, libpam-runtime (>= 0.76-14), xbase-clients
Recommends: logrotate, xserver-xorg
Suggests: khelpcenter-trinity, ksmserver-trinity (= ${Source-Version}), tdepasswd-trinity (= ${Source-Version}), menu
Provides: x-display-manager
@@ -313,7 +313,7 @@ Section: tde
Architecture: any
Replaces: kicker-kde3 (<< 4:14.0.0), kicker-trinity (<< 4:14.0.0)
Breaks: kicker-kde3 (<< 4:14.0.0), kicker-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdebase-data-trinity (>> ${KDE-Version3}), tdebase-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdebase-data-trinity (>> ${KDE-Version3}~), tdebase-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, kicker-applets-trinity, menu
Conflicts: tdebase-libs-trinity (<< 4:3.0.0)
Description: desktop panel for KDE
@@ -446,7 +446,7 @@ Section: tde
Architecture: any
Replaces: kpersonalizer-kde3 (<< 4:14.0.0), kpersonalizer-trinity (<< 4:14.0.0)
Breaks: kpersonalizer-kde3 (<< 4:14.0.0), kpersonalizer-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdebase-data-trinity (>> ${KDE-Version3}), tdebase-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdebase-data-trinity (>> ${KDE-Version3}~), tdebase-data-trinity (<< ${KDE-Next-Version3}~)
Description: installation personalizer for KDE
KDE Personalizer is the application that configures the KDE desktop for you.
It's a very useful wizard that allows you to quickly change the KDE desktop to
@@ -483,7 +483,7 @@ Section: tde
Architecture: any
Replaces: ksplash-kde3 (<< 4:14.0.0), ksplash-trinity (<< 4:14.0.0)
Breaks: ksplash-kde3 (<< 4:14.0.0), ksplash-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdebase-data-trinity (>> ${KDE-Version3}), tdebase-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdebase-data-trinity (>> ${KDE-Version3}~), tdebase-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity
Description: the KDE splash screen
This package includes the KDE Splash screen, which is seen when
@@ -540,7 +540,7 @@ Replaces: kwin-kde3 (<< 4:14.0.0), kwin-trinity (<< 4:14.0.0)
Breaks: kwin-kde3 (<< 4:14.0.0), kwin-trinity (<< 4:14.0.0)
Depends: ${shlibs:Depends}
Provides: x-window-manager
-Suggests: tdebase-trinity-bin (= ${Source-Version}), tdebase-data-trinity (>> ${KDE-Version3}), tdebase-data-trinity (<< ${KDE-Next-Version3}), kdesktop-trinity (= ${Source-Version}), kicker-trinity (= ${Source-Version}), kpager-trinity (= ${Source-Version}), kpersonalizer-trinity (= ${Source-Version}), ksmserver-trinity (= ${Source-Version}), ksplash-trinity (= ${Source-Version})
+Suggests: tdebase-trinity-bin (= ${Source-Version}), tdebase-data-trinity (>> ${KDE-Version3}~), tdebase-data-trinity (<< ${KDE-Next-Version3}~), kdesktop-trinity (= ${Source-Version}), kicker-trinity (= ${Source-Version}), kpager-trinity (= ${Source-Version}), kpersonalizer-trinity (= ${Source-Version}), ksmserver-trinity (= ${Source-Version}), ksplash-trinity (= ${Source-Version})
Conflicts: kde-window-manager-trinity (<< 7:3.5.0)
Description: the KDE window manager
This package contains the default X window manager for KDE.
diff --git a/ubuntu/raring/tdebindings/debian/control b/ubuntu/raring/tdebindings/debian/control
index 499a71208..77184243a 100644
--- a/ubuntu/raring/tdebindings/debian/control
+++ b/ubuntu/raring/tdebindings/debian/control
@@ -29,7 +29,7 @@ Architecture: all
Section: libs
Replaces: libdcop3-java-kde3 (<< 4:14.0.0), libdcop3-java-trinity (<< 4:14.0.0)
Breaks: libdcop3-java-kde3 (<< 4:14.0.0), libdcop3-java-trinity (<< 4:14.0.0)
-Depends: libdcop3-jni-trinity (>> ${KDE-Version3}), libdcop3-jni-trinity (<< ${KDE-Next-Version3}), gij | java1-runtime | java2-runtime
+Depends: libdcop3-jni-trinity (>> ${KDE-Version3}~), libdcop3-jni-trinity (<< ${KDE-Next-Version3}~), gij | java1-runtime | java2-runtime
Description: DCOP bindings for Java [Trinity]
This package contains the Java classes necessary to run Java programs
using the Java DCOP bindings. DCOP is the TDE Desktop COmmunications
@@ -56,7 +56,7 @@ Architecture: amd64 i386 ia64 powerpc s390 sparc
Section: libdevel
Replaces: libdcop3-java-kde3-dev (<< 4:14.0.0), libdcop3-java-trinity-dev (<< 4:14.0.0)
Breaks: libdcop3-java-kde3-dev (<< 4:14.0.0), libdcop3-java-trinity-dev (<< 4:14.0.0)
-Depends: libdcop3-java-trinity (>> ${KDE-Version3}), libdcop3-java-trinity (<< ${KDE-Next-Version3})
+Depends: libdcop3-java-trinity (>> ${KDE-Version3}~), libdcop3-java-trinity (<< ${KDE-Next-Version3}~)
Description: DCOP bindings for Java (dcopidl2java program) [Trinity]
This package contains the dcopidl2java program which generates Java
stubs from DCOP IDL files, necessary to do development with the DCOP Java
@@ -70,7 +70,7 @@ Architecture: all
Section: libs
Replaces: libqt3-java-kde3 (<< 4:14.0.0), libqt3-java-trinity (<< 4:14.0.0)
Breaks: libqt3-java-kde3 (<< 4:14.0.0), libqt3-java-trinity (<< 4:14.0.0)
-Depends: libqt3-jni-trinity (>> ${KDE-Version3}), libqt3-jni-trinity (<< ${KDE-Next-Version3}), gij | java1-runtime | java2-runtime
+Depends: libqt3-jni-trinity (>> ${KDE-Version3}~), libqt3-jni-trinity (<< ${KDE-Next-Version3}~), gij | java1-runtime | java2-runtime
Suggests: juic-trinity
Description: Java bindings for Qt [Trinity]
This package contains the Java classes necessary to run Java programs
@@ -100,7 +100,7 @@ Architecture: all
Section: libs
Replaces: libtrinity-java-kde3 (<< 4:14.0.0), libtrinity-java-trinity (<< 4:14.0.0)
Breaks: libtrinity-java-kde3 (<< 4:14.0.0), libtrinity-java-trinity (<< 4:14.0.0)
-Depends: libtrinity-jni-trinity (>> ${KDE-Version3}), libtrinity-jni-trinity (<< ${KDE-Next-Version3}), gij | java1-runtime | java2-runtime
+Depends: libtrinity-jni-trinity (>> ${KDE-Version3}~), libtrinity-jni-trinity (<< ${KDE-Next-Version3}~), gij | java1-runtime | java2-runtime
Description: tdelibs bindings for Java [Trinity]
This package contains the Java classes necessary to run Java programs
using the Java tdelibs bindings. TDE is the Trinity Desktop Environment, a
diff --git a/ubuntu/raring/tdeedu/debian/control b/ubuntu/raring/tdeedu/debian/control
index 602d933e5..f03b48025 100644
--- a/ubuntu/raring/tdeedu/debian/control
+++ b/ubuntu/raring/tdeedu/debian/control
@@ -74,7 +74,7 @@ Architecture: any
Section: games
Replaces: blinken-kde3 (<< 4:14.0.0), blinken-trinity (<< 4:14.0.0)
Breaks: blinken-kde3 (<< 4:14.0.0), blinken-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, ttf-sjfonts, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, ttf-sjfonts, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: Trinity version of the Simon Says electronic memory game
Blinken is based on an electronic game released in 1978, which
@@ -94,7 +94,7 @@ Architecture: any
Section: science
Replaces: kalzium-kde3 (<< 4:14.0.0), kalzium-trinity (<< 4:14.0.0)
Breaks: kalzium-kde3 (<< 4:14.0.0), kalzium-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, kalzium-data-trinity (>> ${KDE-Version3}), kalzium-data-trinity (<< ${KDE-Next-Version3}), tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, kalzium-data-trinity (>> ${KDE-Version3}~), kalzium-data-trinity (<< ${KDE-Next-Version3}~), tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: chemistry teaching tool for Trinity
Kalzium is a program which shows you the Periodic System of Elements
@@ -137,7 +137,7 @@ Architecture: any
Section: games
Replaces: kanagram-kde3 (<< 4:14.0.0), kanagram-trinity (<< 4:14.0.0)
Breaks: kanagram-kde3 (<< 4:14.0.0), kanagram-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: letter order game for Trinity
KAnagram is a game that is based on the word/letter puzzles that the
@@ -160,7 +160,7 @@ Architecture: any
Section: math
Replaces: kbruch-kde3 (<< 4:14.0.0), kbruch-trinity (<< 4:14.0.0)
Breaks: kbruch-kde3 (<< 4:14.0.0), kbruch-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: fraction calculation teaching tool for Trinity
KBruch is a small program to practice calculating with fractions.
@@ -175,7 +175,7 @@ Architecture: any
Section: tde
Replaces: keduca-kde3 (<< 4:14.0.0), keduca-trinity (<< 4:14.0.0)
Breaks: keduca-kde3 (<< 4:14.0.0), keduca-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: interactive form-based tests for Trinity
KEduca is a flash-card application which allows you to make
@@ -189,7 +189,7 @@ Architecture: any
Section: tde
Replaces: kgeography-kde3 (<< 4:14.0.0), kgeography-trinity (<< 4:14.0.0)
Breaks: kgeography-kde3 (<< 4:14.0.0), kgeography-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, kgeography-data-trinity (>> ${KDE-Version3}), kgeography-data-trinity (<< ${KDE-Next-Version3}), tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, kgeography-data-trinity (>> ${KDE-Version3}~), kgeography-data-trinity (<< ${KDE-Next-Version3}~), tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: Geography learning tool for Trinity
KGeography contains maps allowing you to learn various countries or
@@ -220,7 +220,7 @@ Architecture: any
Section: games
Replaces: khangman-kde3 (<< 4:14.0.0), khangman-trinity (<< 4:14.0.0)
Breaks: khangman-kde3 (<< 4:14.0.0), khangman-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, ttf-dustin, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, ttf-dustin, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: the classical hangman game for Trinity
KHangMan is a game based on the well known hangman game. It is aimed
@@ -240,7 +240,7 @@ Architecture: any
Section: math
Replaces: kig-kde3 (<< 4:14.0.0), kig-trinity (<< 4:14.0.0)
Breaks: kig-kde3 (<< 4:14.0.0), kig-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: interactive geometry program for KDE
Kig is an application for interactive geometry. It is intended to
@@ -268,7 +268,7 @@ Architecture: any
Section: tde
Replaces: kiten-kde3 (<< 4:14.0.0), kiten-trinity (<< 4:14.0.0)
Breaks: kiten-kde3 (<< 4:14.0.0), kiten-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3}), ttf-kochi-gothic | ttf-kochi-mincho
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~), ttf-kochi-gothic | ttf-kochi-mincho
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: Japanese reference/study tool for Trinity
Kiten is a Japanese reference and study tool for KDE. It is an
@@ -285,7 +285,7 @@ Architecture: any
Section: tde
Replaces: klatin-kde3 (<< 4:14.0.0), klatin-trinity (<< 4:14.0.0)
Breaks: klatin-kde3 (<< 4:14.0.0), klatin-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: application to help revise/teach Latin
KLatin is a program to help revise Latin. There are three "sections"
@@ -310,7 +310,7 @@ Architecture: any
Section: tde
Replaces: klettres-kde3 (<< 4:14.0.0), klettres-trinity (<< 4:14.0.0)
Breaks: klettres-kde3 (<< 4:14.0.0), klettres-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, klettres-data-trinity (>> ${KDE-Version3}), klettres-data-trinity (<< ${KDE-Next-Version3}), tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, klettres-data-trinity (>> ${KDE-Version3}~), klettres-data-trinity (<< ${KDE-Next-Version3}~), tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: foreign alphabet tutor for Trinity
KLettres is an application specially designed to help the user to
@@ -344,7 +344,7 @@ Architecture: any
Section: math
Replaces: kmplot-kde3 (<< 4:14.0.0), kmplot-trinity (<< 4:14.0.0)
Breaks: kmplot-kde3 (<< 4:14.0.0), kmplot-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: mathematical function plotter for Trinity
KmPlot is a mathematical function plotter for KDE. It has a powerful
@@ -368,7 +368,7 @@ Architecture: any
Section: math
Replaces: kpercentage-kde3 (<< 4:14.0.0), kpercentage-trinity (<< 4:14.0.0)
Breaks: kpercentage-kde3 (<< 4:14.0.0), kpercentage-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: percentage calculation teaching tool for Trinity
KPercentage is a small math application that will help pupils to
@@ -386,7 +386,7 @@ Architecture: any
Section: science
Replaces: kstars-kde3 (<< 4:14.0.0), kstars-trinity (<< 4:14.0.0)
Breaks: kstars-kde3 (<< 4:14.0.0), kstars-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, kstars-data-trinity (>> ${KDE-Version3}), kstars-data-trinity (<< ${KDE-Next-Version3}), tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3}), indi-trinity (= ${Source-Version})
+Depends: ${shlibs:Depends}, kstars-data-trinity (>> ${KDE-Version3}~), kstars-data-trinity (<< ${KDE-Next-Version3}~), tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~), indi-trinity (= ${Source-Version})
Suggests: konqueror-trinity, khelpcenter-trinity, tdeedu-trinity-doc-html
Description: desktop planetarium for Trinity
KStars is a graphical desktop planetarium for KDE. It depicts an
@@ -424,7 +424,7 @@ Architecture: any
Section: tde
Replaces: ktouch-kde3 (<< 4:14.0.0), ktouch-trinity (<< 4:14.0.0)
Breaks: ktouch-kde3 (<< 4:14.0.0), ktouch-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: touch typing tutor for Trinity
KTouch is a program for learning touch typing - it helps you learn to
@@ -444,7 +444,7 @@ Architecture: any
Section: devel
Replaces: kturtle-kde3 (<< 4:14.0.0), kturtle-trinity (<< 4:14.0.0)
Breaks: kturtle-kde3 (<< 4:14.0.0), kturtle-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: educational Logo programming environment
KTurtle is an educational programming environment using the Logo
@@ -472,7 +472,7 @@ Architecture: any
Section: tde
Replaces: kverbos-kde3 (<< 4:14.0.0), kverbos-trinity (<< 4:14.0.0)
Breaks: kverbos-kde3 (<< 4:14.0.0), kverbos-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: Spanish verb form study application for Trinity
Kverbos allows the user to learn the forms of Spanish verbs. The
@@ -491,7 +491,7 @@ Architecture: any
Section: tde
Replaces: kvoctrain-kde3 (<< 4:14.0.0), kvoctrain-trinity (<< 4:14.0.0)
Breaks: kvoctrain-kde3 (<< 4:14.0.0), kvoctrain-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, ${perl:Depends}, libwww-perl, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, ${perl:Depends}, libwww-perl, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: vocabulary trainer for Trinity
KVocTrain is a little utility to help you train your vocabulary when
@@ -517,7 +517,7 @@ Architecture: any
Section: tde
Replaces: kwordquiz-kde3 (<< 4:14.0.0), kwordquiz-trinity (<< 4:14.0.0)
Breaks: kwordquiz-kde3 (<< 4:14.0.0), kwordquiz-trinity (<< 4:14.0.0)
-Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}), tdeedu-data-trinity (<< ${KDE-Next-Version3})
+Depends: ${shlibs:Depends}, tdeedu-data-trinity (>> ${KDE-Version3}~), tdeedu-data-trinity (<< ${KDE-Next-Version3}~)
Suggests: khelpcenter-trinity, tdeedu-trinity-doc-html
Description: flashcard and vocabulary learning program for Trinity
KWordQuiz is a flashcard-based tool that helps you to master new
diff --git a/ubuntu/raring/tdegraphics/debian/control b/ubuntu/raring/tdegraphics/debian/control
index 4d9e8fb52..623d2dceb 100644
--- a/ubuntu/raring/tdegraphics/debian/control
+++ b/ubuntu/raring/tdegraphics/debian/control
@@ -4,7 +4,7 @@ Priority: optional
Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
XSBC-Original-Maintainer: Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
Uploaders: Ana Beatriz Guerrero Lopez <ana@debian.org>, Francesco Pedrini <francesco.pedrini@gmail.com>, Josh Metzler <joshdeb@metzlers.org>, Sune Vuorela <debian@pusling.com>
-Build-Depends: imlib11-dev, cdbs (>= 0.4.39-0.1), debhelper (>= 5.0.31), autotools-dev, gawk, gettext, tdelibs14-trinity-dev, libexif-dev (>= 0.6.9-1), libfribidi-dev, freeglut3-dev, libgphoto2-2-dev, libopenexr-dev (>= 1.2.1), libpaper-dev, libpoppler-dev, libpoppler-private-dev, libsane-dev (>> 1.0.15), libtiff-dev, libtiff-tools, libusb-dev, sharutils, libxxf86vm-dev, chrpath [powerpc], cmake, libtool, libltdl-dev
+Build-Depends: imlib11-dev, cdbs (>= 0.4.39-0.1), debhelper (>= 5.0.31), autotools-dev, gawk, gettext, tdelibs14-trinity-dev, libexif-dev (>= 0.6.9-1), libfribidi-dev, freeglut3-dev, libgphoto2-6-dev | libgphoto2-2-dev, libopenexr-dev (>= 1.2.1), libpaper-dev, libpoppler-private-dev | libpoppler-dev (<< 0.18.4-3), libpoppler-dev, libsane-dev (>> 1.0.15), libtiff-dev, libtiff-tools, libusb-dev, sharutils, libxxf86vm-dev, chrpath [powerpc], cmake, libtool, libltdl-dev
Standards-Version: 3.8.4
Package: tdegraphics-trinity