summaryrefslogtreecommitdiffstats
path: root/arch/PKGBUILD.template
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-09-20 17:08:32 +0200
committerTDE Gitea <gitea@mirror.git.trinitydesktop.org>2021-09-29 06:38:40 +0000
commit018f946ee70600993c60a74046f417ca05bdb41b (patch)
tree37829ad4f8af4005172148ee78ab38b67328cecb /arch/PKGBUILD.template
parent2bcda9ee7da7582ee0e550a71b9f865cac76dce2 (diff)
downloadtde-packaging-018f946ee70600993c60a74046f417ca05bdb41b.tar.gz
tde-packaging-018f946ee70600993c60a74046f417ca05bdb41b.zip
ArchLinux: Take a newer state of pkgbuilds from Michael Manley
Clean old long-term not maintained pkgbuilds. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'arch/PKGBUILD.template')
-rw-r--r--arch/PKGBUILD.template59
1 files changed, 59 insertions, 0 deletions
diff --git a/arch/PKGBUILD.template b/arch/PKGBUILD.template
new file mode 100644
index 000000000..0b84ae9d9
--- /dev/null
+++ b/arch/PKGBUILD.template
@@ -0,0 +1,59 @@
+# Maintainer: Michael Manley <mmanley@nasutek.com>
+# Contributor: David C. Rankin <drankinatty at gmail dot com>
+
+_mod=tdepowersave
+_cat=applications/
+_kdemod="${_mod/tde/kde}"
+pkgname="tde-$_mod"
+pkgver=14.0.5
+pkgrel=1
+pkgdesc="Trinity Desktop Enviroment $_cat$_mod"
+arch=('i686' 'x86_64')
+url="http://scm.trinitydesktop.org/scm/git/$_mod"
+license=('GPL')
+provides=("$_mod")
+groups=('tde-complete')
+depends=(
+ 'tde-tdelibs'
+)
+makedepends=(
+ 'autoconf'
+ 'cmake'
+ 'pkgconfig'
+)
+optdepends=()
+confilicts=("trinity-$_kdemod" "kdemod3-$_kdemod")
+replaces=("trinity-$_mod")
+options=('staticlibs' 'libtool' '!strip')
+install=
+
+source=("http://mirror.ppa.trinitydesktop.org/trinity/releases/R$pkgver/$_cat$_mod-R$pkgver.tar.bz2")
+
+build() {
+ cd "${srcdir}/${_cat}${_mod}"
+
+ msg "Setting PATH, CMAKE and Trinity Environment variables"
+ # Source the QT and TDE profile
+ [ "$QTDIR" = "" ] && . /etc/profile.d/tqt3.sh
+ [ "$TDEDIR" = "" ] && . /etc/profile.d/trinity.sh
+
+ msg "Creating out-of-source build directory: ${srcdir}/build"
+ mkdir -p "$srcdir/build"
+ cd "$srcdir/build"
+
+ msg "Starting cmake..."
+
+ cmake ${srcdir}/${_cat}${_mod} \
+ -DCMAKE_INSTALL_PREFIX=${TDEDIR} \
+ -DSYSCONF_INSTALL_DIR=${TDEDIR}/etc \
+ -DBUILD_ALL=ON \
+ -DWITH_GCC_VISIBILITY=ON
+
+ make $NUMJOBS
+}
+
+package() {
+ msg "Packaging - $pkgname-$pkgver"
+ cd "$srcdir/build"
+ make -j1 DESTDIR="$pkgdir" install
+}