summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/bibletime/debian/rules
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2019-04-03 22:56:40 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2019-04-03 22:56:40 +0900
commit11394aecd1f906fee2ebd2b90412aeba4651fbff (patch)
treebcf750380e6d9fc7dbe524e16bbe2afde25dcfa0 /debian/_base/applications/bibletime/debian/rules
parentd24bd898174453b586ac90f2ef7a60165fa26fde (diff)
downloadtde-packaging-11394aecd1f906fee2ebd2b90412aeba4651fbff.tar.gz
tde-packaging-11394aecd1f906fee2ebd2b90412aeba4651fbff.zip
DEB: use _base folder for a distro instead of specific distros (squeeze
and maverick). Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'debian/_base/applications/bibletime/debian/rules')
-rwxr-xr-xdebian/_base/applications/bibletime/debian/rules28
1 files changed, 28 insertions, 0 deletions
diff --git a/debian/_base/applications/bibletime/debian/rules b/debian/_base/applications/bibletime/debian/rules
new file mode 100755
index 000000000..eb2eab7e0
--- /dev/null
+++ b/debian/_base/applications/bibletime/debian/rules
@@ -0,0 +1,28 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/debian-qt-kde.mk
+include /usr/share/cdbs/1/class/autotools.mk
+#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+
+DEB_DH_INSTALL_SOURCEDIR := debian
+
+DEB_BUILDDIR = $(DEB_SRCDIR)
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+DEB_CMAKE_CUSTOM_FLAGS := -DKGTK_KDE3=true -DKGTK_QT3=true
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
+binary-install/bibletime-trinity::
+ chmod 644 debian/bibletime-trinity/opt/trinity/share/apps/bibletime/pics/*
+ chmod 644 debian/bibletime-trinity/opt/trinity/share/apps/bibletime/bibletimeui.rc
+ chmod 644 debian/bibletime-trinity/opt/trinity/share/apps/bibletime/tips