summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/internet/kftpgrabber/debian/rules
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2021-07-04 21:06:02 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2021-07-04 21:06:02 +0900
commitbd72eef4a4458f8d2e52609d7b6cf3efe12a0177 (patch)
treeb797d29ee85d482247cfecda13d1fb572e4c4d62 /debian/_base/applications/internet/kftpgrabber/debian/rules
parent5051f08d847e70346920d72e34da55558b89145c (diff)
downloadtde-packaging-bd72eef4a4458f8d2e52609d7b6cf3efe12a0177.tar.gz
tde-packaging-bd72eef4a4458f8d2e52609d7b6cf3efe12a0177.zip
Rearranged applications folder into sub categories.
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'debian/_base/applications/internet/kftpgrabber/debian/rules')
-rwxr-xr-xdebian/_base/applications/internet/kftpgrabber/debian/rules23
1 files changed, 23 insertions, 0 deletions
diff --git a/debian/_base/applications/internet/kftpgrabber/debian/rules b/debian/_base/applications/internet/kftpgrabber/debian/rules
new file mode 100755
index 000000000..8292bc38c
--- /dev/null
+++ b/debian/_base/applications/internet/kftpgrabber/debian/rules
@@ -0,0 +1,23 @@
+#!/usr/bin/make -f
+
+# Currently is not possible to build with --enable-final
+DEB_BUILD_OPTIONS += noopt
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/debian-tde.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+build/kftpgrabber-trinity::
+ /usr/bin/docbook2x-man debian/kftpgrabber.xml
+
+binary-install/kftpgrabber-trinity::
+ install -D -p -m644 debian/kftpgrabber-trinity.lintian-overrides \
+ debian/kftpgrabber-trinity/usr/share/lintian/overrides/kftpgrabber-trinity
+ mv debian/$(cdbs_curpkg)/usr/share/man debian/$(cdbs_curpkg)/opt/trinity/share/
+
+clean::
+ rm -f kftpgrabber.1