summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/kgtk-qt3/debian
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-04-04 03:02:11 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-04-04 16:10:05 +0200
commita92a915c5d3a438e4d8f7b538efeca6b81fcc4a5 (patch)
tree1026c3d6ecf34c4910f61be62e09761e34eb7318 /debian/_base/applications/kgtk-qt3/debian
parent166fcf9e56586808911b33205ab2aa1c035afe2e (diff)
downloadtde-packaging-a92a915c5d3a438e4d8f7b538efeca6b81fcc4a5.tar.gz
tde-packaging-a92a915c5d3a438e4d8f7b538efeca6b81fcc4a5.zip
DEB: Move DEB_DH_BUILDDEB_ARGS to common cdbs rules.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 3d0fe45a7b0b586d096644a3581df8307787eb3a)
Diffstat (limited to 'debian/_base/applications/kgtk-qt3/debian')
-rw-r--r--debian/_base/applications/kgtk-qt3/debian/cdbs/debian-tde.mk10
-rwxr-xr-xdebian/_base/applications/kgtk-qt3/debian/rules4
2 files changed, 10 insertions, 4 deletions
diff --git a/debian/_base/applications/kgtk-qt3/debian/cdbs/debian-tde.mk b/debian/_base/applications/kgtk-qt3/debian/cdbs/debian-tde.mk
index 641c6c6cc..5b4e8bfd7 100644
--- a/debian/_base/applications/kgtk-qt3/debian/cdbs/debian-tde.mk
+++ b/debian/_base/applications/kgtk-qt3/debian/cdbs/debian-tde.mk
@@ -75,6 +75,16 @@ DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+endif
+
ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
diff --git a/debian/_base/applications/kgtk-qt3/debian/rules b/debian/_base/applications/kgtk-qt3/debian/rules
index 6c50cfb9e..f1aa52d1c 100755
--- a/debian/_base/applications/kgtk-qt3/debian/rules
+++ b/debian/_base/applications/kgtk-qt3/debian/rules
@@ -32,10 +32,6 @@ DEB_CMAKE_EXTRA_FLAGS := \
-DCMAKE_SKIP_RPATH="OFF" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-
binary-install/kgtk-qt3-trinity::
mkdir -p $(CURDIR)/debian/kgtk-qt3-trinity/opt/trinity/share/kgtk/
cp -Rp $(CURDIR)/debian/preload $(CURDIR)/debian/kgtk-qt3-trinity/opt/trinity/share/kgtk/
-