summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/kima/debian/rules
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-06-29 12:51:05 +0200
committerSlávek Banko <slavek.banko@axis.cz>2019-06-29 12:51:05 +0200
commit93cb16b7a2ae2dc1daac2bf54efd7db89d97a420 (patch)
treee18a7664c2e24bbad4b5438074bd9460e9ad7866 /debian/_base/applications/kima/debian/rules
parentf2fcec0e0ad7cb99ae59fd0cd7af18ec66c99bec (diff)
downloadtde-packaging-93cb16b7a2ae2dc1daac2bf54efd7db89d97a420.tar.gz
tde-packaging-93cb16b7a2ae2dc1daac2bf54efd7db89d97a420.zip
DEB kima: Build nvidia support only for amd64 and i386.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'debian/_base/applications/kima/debian/rules')
-rwxr-xr-xdebian/_base/applications/kima/debian/rules5
1 files changed, 4 insertions, 1 deletions
diff --git a/debian/_base/applications/kima/debian/rules b/debian/_base/applications/kima/debian/rules
index cee2a3058..5598f7f9f 100755
--- a/debian/_base/applications/kima/debian/rules
+++ b/debian/_base/applications/kima/debian/rules
@@ -7,6 +7,8 @@ include debian/cdbs/debian-tde.mk
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
+WITH_NVCONTROL = $(if $(filter $(DEB_HOST_ARCH_CPU),amd64 i386),ON,OFF)
+
DEB_CMAKE_EXTRA_FLAGS := \
-DCMAKE_INSTALL_PREFIX="/opt/trinity" \
-DCONFIG_INSTALL_DIR="/etc/trinity" \
@@ -16,4 +18,5 @@ DEB_CMAKE_EXTRA_FLAGS := \
-DCMAKE_VERBOSE_MAKEFILE="ON" \
-DCMAKE_SKIP_RPATH="OFF" \
-DBUILD_ALL="ON" \
- -DWITH_ALL_OPTIONS="ON"
+ -DWITH_ALL_OPTIONS="ON" \
+ -DWITH_NVCONTROL="$(WITH_NVCONTROL)"