summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/tdeio/tdeio-appinfo/debian/rules
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2022-05-08 20:15:07 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2022-05-14 12:26:51 +0900
commita309888a4dfd7c47e305447f55f573c9b04a74fb (patch)
tree629d88164c655e9f03503aa330bdf06d953afc11 /debian/_base/applications/tdeio/tdeio-appinfo/debian/rules
parent7b6b219861a6a6ccde9211116a93d859e39c900f (diff)
downloadtde-packaging-a309888a4dfd7c47e305447f55f573c9b04a74fb.tar.gz
tde-packaging-a309888a4dfd7c47e305447f55f573c9b04a74fb.zip
DEB: added packaging files for tdeio-appinfo
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it> (cherry picked from commit 618071201258fd700c4d89313f9f6a6a595d35a3)
Diffstat (limited to 'debian/_base/applications/tdeio/tdeio-appinfo/debian/rules')
-rwxr-xr-xdebian/_base/applications/tdeio/tdeio-appinfo/debian/rules24
1 files changed, 24 insertions, 0 deletions
diff --git a/debian/_base/applications/tdeio/tdeio-appinfo/debian/rules b/debian/_base/applications/tdeio/tdeio-appinfo/debian/rules
new file mode 100755
index 000000000..16f2fa011
--- /dev/null
+++ b/debian/_base/applications/tdeio/tdeio-appinfo/debian/rules
@@ -0,0 +1,24 @@
+#!/usr/bin/make -f
+
+# Set LD_LIBRARY_PATH to the installed library directory to allow dh_shlibdeps to function
+# Also include the main Trinity path
+ifeq ("$(LD_LIBRARY_PATH)", "")
+LD_LIBRARY_PATH=debian/tmp/opt/trinity/lib
+else
+LD_LIBRARY_PATH += :debian/tmp/opt/trinity/lib
+endif
+export LD_LIBRARY_PATH
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+include debian/cdbs/debian-tde.mk
+
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DBUILD_ALL="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo