summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/themes
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2023-12-19 02:49:06 +0100
committerSlávek Banko <slavek.banko@axis.cz>2023-12-19 03:05:04 +0100
commit34145f8176dbda8170684ae8fcdea0787a904f66 (patch)
tree2433ae5b037017b35b7a1f3a3eb41e13816923fe /debian/_base/applications/themes
parentb73cc9eb4f7845482b7354719edb4e716f5d90c7 (diff)
downloadtde-packaging-34145f8176dbda8170684ae8fcdea0787a904f66.tar.gz
tde-packaging-34145f8176dbda8170684ae8fcdea0787a904f66.zip
DEB: Automatically add ldconfig trigger if the package contains plugins.
As a result, it is no longer necessary to enforce ldconfig in postinst and postrm scripts and this solves the problem with packages where the ldconfig was not called after installation, but it was needed. This resolves issue TDE/tdemultimedia#29. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'debian/_base/applications/themes')
-rw-r--r--debian/_base/applications/themes/gtk-qt-engine/debian/cdbs/debian-tde.mk5
-rw-r--r--debian/_base/applications/themes/gtk3-tqt-engine/debian/cdbs/debian-tde.mk5
-rw-r--r--debian/_base/applications/themes/kgtk-qt3/debian/cdbs/debian-tde.mk5
-rw-r--r--debian/_base/applications/themes/kgtk-qt3/debian/kgtk-qt3-trinity.lintian6
-rw-r--r--debian/_base/applications/themes/ksplash-engine-moodin/debian/cdbs/debian-tde.mk5
-rw-r--r--debian/_base/applications/themes/tde-style-baghira/debian/cdbs/debian-tde.mk5
-rw-r--r--debian/_base/applications/themes/tde-style-baghira/debian/tde-style-baghira-trinity.lintian2
-rw-r--r--debian/_base/applications/themes/tde-style-domino/debian/cdbs/debian-tde.mk5
-rw-r--r--debian/_base/applications/themes/tde-style-ia-ora/debian/cdbs/debian-tde.mk5
-rw-r--r--debian/_base/applications/themes/tde-style-lipstik/debian/cdbs/debian-tde.mk5
-rw-r--r--debian/_base/applications/themes/tde-style-qtcurve/debian/cdbs/debian-tde.mk5
-rw-r--r--debian/_base/applications/themes/tdmtheme/debian/cdbs/debian-tde.mk5
-rw-r--r--debian/_base/applications/themes/twin-style-crystal/debian/cdbs/debian-tde.mk5
-rw-r--r--debian/_base/applications/themes/twin-style-dekorator/debian/cdbs/debian-tde.mk5
-rw-r--r--debian/_base/applications/themes/twin-style-fahrenheit/debian/cdbs/debian-tde.mk5
-rw-r--r--debian/_base/applications/themes/twin-style-machbunt/debian/cdbs/debian-tde.mk5
-rw-r--r--debian/_base/applications/themes/twin-style-suse2/debian/cdbs/debian-tde.mk5
17 files changed, 75 insertions, 8 deletions
diff --git a/debian/_base/applications/themes/gtk-qt-engine/debian/cdbs/debian-tde.mk b/debian/_base/applications/themes/gtk-qt-engine/debian/cdbs/debian-tde.mk
index b031e6981..aba508624 100644
--- a/debian/_base/applications/themes/gtk-qt-engine/debian/cdbs/debian-tde.mk
+++ b/debian/_base/applications/themes/gtk-qt-engine/debian/cdbs/debian-tde.mk
@@ -202,6 +202,11 @@ $(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
install -p -D -m644 debian/$(cdbs_curpkg).presubj \
debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
fi
+ if test -d debian/$(cdbs_curpkg)/opt/trinity/lib && \
+ test $$(find debian/$(cdbs_curpkg)/opt/trinity/lib -name "*.so" | wc -l) -gt 0; then \
+ echo "# Triggers added by cdbs/debian-tde.mk" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ echo "activate-noawait ldconfig" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ fi
binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
set -e; \
diff --git a/debian/_base/applications/themes/gtk3-tqt-engine/debian/cdbs/debian-tde.mk b/debian/_base/applications/themes/gtk3-tqt-engine/debian/cdbs/debian-tde.mk
index b031e6981..aba508624 100644
--- a/debian/_base/applications/themes/gtk3-tqt-engine/debian/cdbs/debian-tde.mk
+++ b/debian/_base/applications/themes/gtk3-tqt-engine/debian/cdbs/debian-tde.mk
@@ -202,6 +202,11 @@ $(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
install -p -D -m644 debian/$(cdbs_curpkg).presubj \
debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
fi
+ if test -d debian/$(cdbs_curpkg)/opt/trinity/lib && \
+ test $$(find debian/$(cdbs_curpkg)/opt/trinity/lib -name "*.so" | wc -l) -gt 0; then \
+ echo "# Triggers added by cdbs/debian-tde.mk" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ echo "activate-noawait ldconfig" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ fi
binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
set -e; \
diff --git a/debian/_base/applications/themes/kgtk-qt3/debian/cdbs/debian-tde.mk b/debian/_base/applications/themes/kgtk-qt3/debian/cdbs/debian-tde.mk
index b031e6981..aba508624 100644
--- a/debian/_base/applications/themes/kgtk-qt3/debian/cdbs/debian-tde.mk
+++ b/debian/_base/applications/themes/kgtk-qt3/debian/cdbs/debian-tde.mk
@@ -202,6 +202,11 @@ $(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
install -p -D -m644 debian/$(cdbs_curpkg).presubj \
debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
fi
+ if test -d debian/$(cdbs_curpkg)/opt/trinity/lib && \
+ test $$(find debian/$(cdbs_curpkg)/opt/trinity/lib -name "*.so" | wc -l) -gt 0; then \
+ echo "# Triggers added by cdbs/debian-tde.mk" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ echo "activate-noawait ldconfig" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ fi
binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
set -e; \
diff --git a/debian/_base/applications/themes/kgtk-qt3/debian/kgtk-qt3-trinity.lintian b/debian/_base/applications/themes/kgtk-qt3/debian/kgtk-qt3-trinity.lintian
index f7e4ea7f5..794921e5e 100644
--- a/debian/_base/applications/themes/kgtk-qt3/debian/kgtk-qt3-trinity.lintian
+++ b/debian/_base/applications/themes/kgtk-qt3/debian/kgtk-qt3-trinity.lintian
@@ -1,8 +1,2 @@
kgtk-qt3-trinity: no-shlibs-control-file opt/trinity/lib/kgtk/libkgtk2.so
kgtk-qt3-trinity: no-shlibs-control-file opt/trinity/lib/kgtk/libkqt3.so
-
-kgtk-qt3-trinity: postinst-must-call-ldconfig opt/trinity/lib/kgtk/libkgtk2.so
-kgtk-qt3-trinity: postinst-must-call-ldconfig opt/trinity/lib/kgtk/libkqt3.so
-
-kgtk-qt3-trinity: postrm-should-call-ldconfig opt/trinity/lib/kgtk/libkgtk2.so
-kgtk-qt3-trinity: postrm-should-call-ldconfig opt/trinity/lib/kgtk/libkqt3.so
diff --git a/debian/_base/applications/themes/ksplash-engine-moodin/debian/cdbs/debian-tde.mk b/debian/_base/applications/themes/ksplash-engine-moodin/debian/cdbs/debian-tde.mk
index b031e6981..aba508624 100644
--- a/debian/_base/applications/themes/ksplash-engine-moodin/debian/cdbs/debian-tde.mk
+++ b/debian/_base/applications/themes/ksplash-engine-moodin/debian/cdbs/debian-tde.mk
@@ -202,6 +202,11 @@ $(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
install -p -D -m644 debian/$(cdbs_curpkg).presubj \
debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
fi
+ if test -d debian/$(cdbs_curpkg)/opt/trinity/lib && \
+ test $$(find debian/$(cdbs_curpkg)/opt/trinity/lib -name "*.so" | wc -l) -gt 0; then \
+ echo "# Triggers added by cdbs/debian-tde.mk" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ echo "activate-noawait ldconfig" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ fi
binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
set -e; \
diff --git a/debian/_base/applications/themes/tde-style-baghira/debian/cdbs/debian-tde.mk b/debian/_base/applications/themes/tde-style-baghira/debian/cdbs/debian-tde.mk
index b031e6981..aba508624 100644
--- a/debian/_base/applications/themes/tde-style-baghira/debian/cdbs/debian-tde.mk
+++ b/debian/_base/applications/themes/tde-style-baghira/debian/cdbs/debian-tde.mk
@@ -202,6 +202,11 @@ $(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
install -p -D -m644 debian/$(cdbs_curpkg).presubj \
debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
fi
+ if test -d debian/$(cdbs_curpkg)/opt/trinity/lib && \
+ test $$(find debian/$(cdbs_curpkg)/opt/trinity/lib -name "*.so" | wc -l) -gt 0; then \
+ echo "# Triggers added by cdbs/debian-tde.mk" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ echo "activate-noawait ldconfig" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ fi
binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
set -e; \
diff --git a/debian/_base/applications/themes/tde-style-baghira/debian/tde-style-baghira-trinity.lintian b/debian/_base/applications/themes/tde-style-baghira/debian/tde-style-baghira-trinity.lintian
index 475315ddc..b021de201 100644
--- a/debian/_base/applications/themes/tde-style-baghira/debian/tde-style-baghira-trinity.lintian
+++ b/debian/_base/applications/themes/tde-style-baghira/debian/tde-style-baghira-trinity.lintian
@@ -1,6 +1,4 @@
tde-style-baghira-trinity: no-shlibs-control-file opt/trinity/lib/libbaghirastarter.so
tde-style-baghira-trinity: no-shlibs-control-file opt/trinity/lib/usermanager_panelapplet.so
-tde-style-baghira-trinity: postinst-must-call-ldconfig opt/trinity/lib/libbaghirastarter.so
-tde-style-baghira-trinity: postrm-should-call-ldconfig opt/trinity/lib/libbaghirastarter.so
tde-style-baghira-trinity: several-sonames-in-same-package usermanager_panelapplet.so libbaghirastarter.so
tde-style-baghira-trinity: package-name-doesnt-match-sonames usermanager-panelapplet libbaghirastarter
diff --git a/debian/_base/applications/themes/tde-style-domino/debian/cdbs/debian-tde.mk b/debian/_base/applications/themes/tde-style-domino/debian/cdbs/debian-tde.mk
index b031e6981..aba508624 100644
--- a/debian/_base/applications/themes/tde-style-domino/debian/cdbs/debian-tde.mk
+++ b/debian/_base/applications/themes/tde-style-domino/debian/cdbs/debian-tde.mk
@@ -202,6 +202,11 @@ $(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
install -p -D -m644 debian/$(cdbs_curpkg).presubj \
debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
fi
+ if test -d debian/$(cdbs_curpkg)/opt/trinity/lib && \
+ test $$(find debian/$(cdbs_curpkg)/opt/trinity/lib -name "*.so" | wc -l) -gt 0; then \
+ echo "# Triggers added by cdbs/debian-tde.mk" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ echo "activate-noawait ldconfig" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ fi
binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
set -e; \
diff --git a/debian/_base/applications/themes/tde-style-ia-ora/debian/cdbs/debian-tde.mk b/debian/_base/applications/themes/tde-style-ia-ora/debian/cdbs/debian-tde.mk
index b031e6981..aba508624 100644
--- a/debian/_base/applications/themes/tde-style-ia-ora/debian/cdbs/debian-tde.mk
+++ b/debian/_base/applications/themes/tde-style-ia-ora/debian/cdbs/debian-tde.mk
@@ -202,6 +202,11 @@ $(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
install -p -D -m644 debian/$(cdbs_curpkg).presubj \
debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
fi
+ if test -d debian/$(cdbs_curpkg)/opt/trinity/lib && \
+ test $$(find debian/$(cdbs_curpkg)/opt/trinity/lib -name "*.so" | wc -l) -gt 0; then \
+ echo "# Triggers added by cdbs/debian-tde.mk" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ echo "activate-noawait ldconfig" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ fi
binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
set -e; \
diff --git a/debian/_base/applications/themes/tde-style-lipstik/debian/cdbs/debian-tde.mk b/debian/_base/applications/themes/tde-style-lipstik/debian/cdbs/debian-tde.mk
index b031e6981..aba508624 100644
--- a/debian/_base/applications/themes/tde-style-lipstik/debian/cdbs/debian-tde.mk
+++ b/debian/_base/applications/themes/tde-style-lipstik/debian/cdbs/debian-tde.mk
@@ -202,6 +202,11 @@ $(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
install -p -D -m644 debian/$(cdbs_curpkg).presubj \
debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
fi
+ if test -d debian/$(cdbs_curpkg)/opt/trinity/lib && \
+ test $$(find debian/$(cdbs_curpkg)/opt/trinity/lib -name "*.so" | wc -l) -gt 0; then \
+ echo "# Triggers added by cdbs/debian-tde.mk" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ echo "activate-noawait ldconfig" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ fi
binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
set -e; \
diff --git a/debian/_base/applications/themes/tde-style-qtcurve/debian/cdbs/debian-tde.mk b/debian/_base/applications/themes/tde-style-qtcurve/debian/cdbs/debian-tde.mk
index b031e6981..aba508624 100644
--- a/debian/_base/applications/themes/tde-style-qtcurve/debian/cdbs/debian-tde.mk
+++ b/debian/_base/applications/themes/tde-style-qtcurve/debian/cdbs/debian-tde.mk
@@ -202,6 +202,11 @@ $(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
install -p -D -m644 debian/$(cdbs_curpkg).presubj \
debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
fi
+ if test -d debian/$(cdbs_curpkg)/opt/trinity/lib && \
+ test $$(find debian/$(cdbs_curpkg)/opt/trinity/lib -name "*.so" | wc -l) -gt 0; then \
+ echo "# Triggers added by cdbs/debian-tde.mk" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ echo "activate-noawait ldconfig" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ fi
binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
set -e; \
diff --git a/debian/_base/applications/themes/tdmtheme/debian/cdbs/debian-tde.mk b/debian/_base/applications/themes/tdmtheme/debian/cdbs/debian-tde.mk
index b031e6981..aba508624 100644
--- a/debian/_base/applications/themes/tdmtheme/debian/cdbs/debian-tde.mk
+++ b/debian/_base/applications/themes/tdmtheme/debian/cdbs/debian-tde.mk
@@ -202,6 +202,11 @@ $(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
install -p -D -m644 debian/$(cdbs_curpkg).presubj \
debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
fi
+ if test -d debian/$(cdbs_curpkg)/opt/trinity/lib && \
+ test $$(find debian/$(cdbs_curpkg)/opt/trinity/lib -name "*.so" | wc -l) -gt 0; then \
+ echo "# Triggers added by cdbs/debian-tde.mk" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ echo "activate-noawait ldconfig" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ fi
binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
set -e; \
diff --git a/debian/_base/applications/themes/twin-style-crystal/debian/cdbs/debian-tde.mk b/debian/_base/applications/themes/twin-style-crystal/debian/cdbs/debian-tde.mk
index b031e6981..aba508624 100644
--- a/debian/_base/applications/themes/twin-style-crystal/debian/cdbs/debian-tde.mk
+++ b/debian/_base/applications/themes/twin-style-crystal/debian/cdbs/debian-tde.mk
@@ -202,6 +202,11 @@ $(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
install -p -D -m644 debian/$(cdbs_curpkg).presubj \
debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
fi
+ if test -d debian/$(cdbs_curpkg)/opt/trinity/lib && \
+ test $$(find debian/$(cdbs_curpkg)/opt/trinity/lib -name "*.so" | wc -l) -gt 0; then \
+ echo "# Triggers added by cdbs/debian-tde.mk" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ echo "activate-noawait ldconfig" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ fi
binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
set -e; \
diff --git a/debian/_base/applications/themes/twin-style-dekorator/debian/cdbs/debian-tde.mk b/debian/_base/applications/themes/twin-style-dekorator/debian/cdbs/debian-tde.mk
index b031e6981..aba508624 100644
--- a/debian/_base/applications/themes/twin-style-dekorator/debian/cdbs/debian-tde.mk
+++ b/debian/_base/applications/themes/twin-style-dekorator/debian/cdbs/debian-tde.mk
@@ -202,6 +202,11 @@ $(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
install -p -D -m644 debian/$(cdbs_curpkg).presubj \
debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
fi
+ if test -d debian/$(cdbs_curpkg)/opt/trinity/lib && \
+ test $$(find debian/$(cdbs_curpkg)/opt/trinity/lib -name "*.so" | wc -l) -gt 0; then \
+ echo "# Triggers added by cdbs/debian-tde.mk" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ echo "activate-noawait ldconfig" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ fi
binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
set -e; \
diff --git a/debian/_base/applications/themes/twin-style-fahrenheit/debian/cdbs/debian-tde.mk b/debian/_base/applications/themes/twin-style-fahrenheit/debian/cdbs/debian-tde.mk
index b031e6981..aba508624 100644
--- a/debian/_base/applications/themes/twin-style-fahrenheit/debian/cdbs/debian-tde.mk
+++ b/debian/_base/applications/themes/twin-style-fahrenheit/debian/cdbs/debian-tde.mk
@@ -202,6 +202,11 @@ $(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
install -p -D -m644 debian/$(cdbs_curpkg).presubj \
debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
fi
+ if test -d debian/$(cdbs_curpkg)/opt/trinity/lib && \
+ test $$(find debian/$(cdbs_curpkg)/opt/trinity/lib -name "*.so" | wc -l) -gt 0; then \
+ echo "# Triggers added by cdbs/debian-tde.mk" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ echo "activate-noawait ldconfig" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ fi
binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
set -e; \
diff --git a/debian/_base/applications/themes/twin-style-machbunt/debian/cdbs/debian-tde.mk b/debian/_base/applications/themes/twin-style-machbunt/debian/cdbs/debian-tde.mk
index b031e6981..aba508624 100644
--- a/debian/_base/applications/themes/twin-style-machbunt/debian/cdbs/debian-tde.mk
+++ b/debian/_base/applications/themes/twin-style-machbunt/debian/cdbs/debian-tde.mk
@@ -202,6 +202,11 @@ $(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
install -p -D -m644 debian/$(cdbs_curpkg).presubj \
debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
fi
+ if test -d debian/$(cdbs_curpkg)/opt/trinity/lib && \
+ test $$(find debian/$(cdbs_curpkg)/opt/trinity/lib -name "*.so" | wc -l) -gt 0; then \
+ echo "# Triggers added by cdbs/debian-tde.mk" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ echo "activate-noawait ldconfig" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ fi
binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
set -e; \
diff --git a/debian/_base/applications/themes/twin-style-suse2/debian/cdbs/debian-tde.mk b/debian/_base/applications/themes/twin-style-suse2/debian/cdbs/debian-tde.mk
index b031e6981..aba508624 100644
--- a/debian/_base/applications/themes/twin-style-suse2/debian/cdbs/debian-tde.mk
+++ b/debian/_base/applications/themes/twin-style-suse2/debian/cdbs/debian-tde.mk
@@ -202,6 +202,11 @@ $(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
install -p -D -m644 debian/$(cdbs_curpkg).presubj \
debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
fi
+ if test -d debian/$(cdbs_curpkg)/opt/trinity/lib && \
+ test $$(find debian/$(cdbs_curpkg)/opt/trinity/lib -name "*.so" | wc -l) -gt 0; then \
+ echo "# Triggers added by cdbs/debian-tde.mk" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ echo "activate-noawait ldconfig" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ fi
binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
set -e; \