summaryrefslogtreecommitdiffstats
path: root/debian/_base/dependencies/tqca/debian/rules
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-01-11 16:54:54 +0100
committerSlávek Banko <slavek.banko@axis.cz>2020-01-11 16:56:08 +0100
commit74168d176bfa4d05bbd9f7efdedb7881aad64d31 (patch)
tree035400ac28a1dbdd4e22ff1e4b652919fc35b92f /debian/_base/dependencies/tqca/debian/rules
parent0dfbc5f7c11b4f228cd5176fba06c1098d3c4691 (diff)
downloadtde-packaging-74168d176bfa4d05bbd9f7efdedb7881aad64d31.tar.gz
tde-packaging-74168d176bfa4d05bbd9f7efdedb7881aad64d31.zip
DEB tqca: Add packaging files as a standalone libtqca shared library.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 9a2614f8965f0157618dfc9a89f14f7cab278c51)
Diffstat (limited to 'debian/_base/dependencies/tqca/debian/rules')
-rwxr-xr-xdebian/_base/dependencies/tqca/debian/rules21
1 files changed, 21 insertions, 0 deletions
diff --git a/debian/_base/dependencies/tqca/debian/rules b/debian/_base/dependencies/tqca/debian/rules
new file mode 100755
index 000000000..5d7f84feb
--- /dev/null
+++ b/debian/_base/dependencies/tqca/debian/rules
@@ -0,0 +1,21 @@
+#! /usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+include debian/cdbs/debian-tde.mk
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
+ifdef DEB_HOST_MULTIARCH
+ CMAKE_INSTALL_LIBDIR = lib/$(DEB_HOST_MULTIARCH)
+else
+ CMAKE_INSTALL_LIBDIR = lib
+endif
+
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_LIBDIR=$(CMAKE_INSTALL_LIBDIR) \
+ -DWITH_ALL_OPTIONS="ON"