summaryrefslogtreecommitdiffstats
path: root/debian/_base
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2024-03-08 01:52:03 +0100
committerSlávek Banko <slavek.banko@axis.cz>2024-03-08 01:52:03 +0100
commit6b317407df9dd017ce6673a4c3249b59dbc15a0d (patch)
tree7d0a1f0e02cbda9b3c04df41aa4e217f42e0fa87 /debian/_base
parent8f8ece8a19cdb9b913e205c417cc7805354a8890 (diff)
downloadtde-packaging-6b317407df9dd017ce6673a4c3249b59dbc15a0d.tar.gz
tde-packaging-6b317407df9dd017ce6673a4c3249b59dbc15a0d.zip
DEB libcaldav: Change the library package name in case of incompatible ABI for 64-bit time_t.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'debian/_base')
-rwxr-xr-xdebian/_base/dependencies/libcaldav/debian/rules44
1 files changed, 44 insertions, 0 deletions
diff --git a/debian/_base/dependencies/libcaldav/debian/rules b/debian/_base/dependencies/libcaldav/debian/rules
index e898aa6d2..9b371a62d 100755
--- a/debian/_base/dependencies/libcaldav/debian/rules
+++ b/debian/_base/dependencies/libcaldav/debian/rules
@@ -4,6 +4,14 @@ include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/cmake.mk
include debian/cdbs/debian-tde.mk
+DEB_TIME64_API = $(shell echo | cc $(dpkg-buildflags --get CPPFLAGS) -dM -E -x c++ - | grep -q "_TIME_BITS 64" && echo true || false)
+ifeq ($(DEB_TIME64_API),true)
+DEB_TIME64_SUFFIX = 0t64
+else
+DEB_TIME64_SUFFIX =
+endif
+
+
ifdef DEB_HOST_MULTIARCH
CMAKE_INSTALL_LIBDIR = lib/$(DEB_HOST_MULTIARCH)
else
@@ -18,3 +26,39 @@ DEB_CMAKE_EXTRA_FLAGS := \
-DCMAKE_INSTALL_LIBDIR=$(CMAKE_INSTALL_LIBDIR) \
-DWITH_ALL_OPTIONS="ON" \
-DBUILD_ALL="ON"
+
+post-patches::
+ dh_testdir
+ifeq ($(DEB_TIME64_API),true)
+ # update library package name for TIME64 ABI
+ ls -d debian/* | \
+ grep -E "/libcaldav\." | \
+ grep -v "\.t64$$" | \
+ while read a; do \
+ [ -d $$a ] || [ -f $$a.t64 ] || \
+ (cp -a $$a debian/libcaldav$(DEB_TIME64_SUFFIX).$${a##*.} && mv $$a $$a.t64); \
+ done
+ [ -f debian/control.t64 ] || \
+ sed -i.t64 \
+ -e "s/^Package: \\(libcaldav\\)$$/Package: \\1$(DEB_TIME64_SUFFIX)\\nReplaces: \\1\\nBreaks: \\1/" \
+ -e "s/\\(libcaldav\\) (=/\\1$(DEB_TIME64_SUFFIX) (=/" \
+ debian/control
+endif
+
+clean::
+ dh_testdir
+ dh_clean
+
+ifeq ($(DEB_TIME64_API),true)
+ # revert library package name for TIME64 ABI
+ ls -d debian/* | \
+ grep -E "\.t64$$" | \
+ while read a; do \
+ mv $$a $${a%.t64}; \
+ done
+ ls -d debian/* | \
+ grep -E "/libcaldav$(DEB_TIME64_SUFFIX)\." | \
+ xargs -r rm
+ [ ! -f debian/control.t64 ] || \
+ mv debian/control.t64 debian/control
+endif