summaryrefslogtreecommitdiffstats
path: root/debian/lenny/applications/kbiff/debian/rules
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2013-07-04 19:05:01 +0200
committerSlávek Banko <slavek.banko@axis.cz>2013-07-04 19:05:01 +0200
commit87dc0649077ea66ac593b3397b84c4144bbe12f8 (patch)
treef7b5b5ece49de221121fc13b1e023cbef32e4f08 /debian/lenny/applications/kbiff/debian/rules
parente164b04fd3c45cf4c4ee47f1efadfc8bbc920bbc (diff)
downloadtde-packaging-87dc0649077ea66ac593b3397b84c4144bbe12f8.tar.gz
tde-packaging-87dc0649077ea66ac593b3397b84c4144bbe12f8.zip
Add packaging files for kbiff on Debian and Ubuntu
Diffstat (limited to 'debian/lenny/applications/kbiff/debian/rules')
-rwxr-xr-xdebian/lenny/applications/kbiff/debian/rules38
1 files changed, 38 insertions, 0 deletions
diff --git a/debian/lenny/applications/kbiff/debian/rules b/debian/lenny/applications/kbiff/debian/rules
new file mode 100755
index 000000000..39a274279
--- /dev/null
+++ b/debian/lenny/applications/kbiff/debian/rules
@@ -0,0 +1,38 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# GNU copyright 1997 to 1999 by Joey Hess.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/kde.mk
+
+post-patches:: debian/stamp-bootstrap
+
+debian/stamp-bootstrap:
+ dh_testdir
+
+ # Regenerate build system
+ ! [ -f /usr/share/libtool/ltmain.sh ] || \
+ cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
+ ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
+ cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+
+ autoreconf --install && automake -f && \
+ $(MAKE) -f admin/Makefile.common && \
+ touch debian/stamp-bootstrap
+
+clean::
+ dh_testdir
+ rm -f debian/stamp-bootstrap