summaryrefslogtreecommitdiffstats
path: root/debian/lenny/applications/ksquirrel/debian/rules
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2012-07-31 18:29:20 +0200
committerSlávek Banko <slavek.banko@axis.cz>2012-07-31 18:29:20 +0200
commita3737a550655ca25724dbb28e504dd412c3cf0d0 (patch)
tree6bbb18e93b00d8cb2d1cc063cde75937e665cbd6 /debian/lenny/applications/ksquirrel/debian/rules
parent3ce3ef7494319fe3151bfee72c09af679830058a (diff)
downloadtde-packaging-a3737a550655ca25724dbb28e504dd412c3cf0d0.tar.gz
tde-packaging-a3737a550655ca25724dbb28e504dd412c3cf0d0.zip
Removed former way of managing patches for ksquirrel on Debian and Ubuntu
Diffstat (limited to 'debian/lenny/applications/ksquirrel/debian/rules')
-rwxr-xr-xdebian/lenny/applications/ksquirrel/debian/rules24
1 files changed, 2 insertions, 22 deletions
diff --git a/debian/lenny/applications/ksquirrel/debian/rules b/debian/lenny/applications/ksquirrel/debian/rules
index 8f8161523..797fc4a08 100755
--- a/debian/lenny/applications/ksquirrel/debian/rules
+++ b/debian/lenny/applications/ksquirrel/debian/rules
@@ -22,7 +22,7 @@ DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-config.status: patch configure
+config.status: configure
dh_testdir
# Add here commands to configure the package.
ifneq "$(wildcard /usr/share/misc/config.sub)" ""
@@ -54,37 +54,17 @@ build-stamp: config.status
touch $@
-clean: clean-patched unpatch
-
-clean-patched:
+clean:
dh_testdir
dh_testroot
rm -f build-stamp
- ! [ -f /usr/share/libtool/ltmain.sh ] || \
- cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
- ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
- cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
- cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-
- make -f admin/Makefile.common cvs
-
# Add here commands to clean up after the build process.
[ ! -f Makefile ] || $(MAKE) distclean
rm -f config.sub config.guess
dh_clean
-patch: patch-stamp
-
-patch-stamp:
- dpatch apply-all
- dpatch cat-all >patch-stamp
-
-unpatch:
- dpatch deapply-all
- rm -rf patch-stamp debian/patched
-
install: build
dh_testdir
dh_testroot