summaryrefslogtreecommitdiffstats
path: root/debian/lenny/applications/tde-style-qtcurve/debian/rules
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-11-24 20:08:05 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-11-24 20:08:05 -0600
commit65a3fe0c81c103ee83cd326cf05a3b6ce18f2b4d (patch)
tree9d5ab60a1abb554fa88138cd64c6122198947ac5 /debian/lenny/applications/tde-style-qtcurve/debian/rules
parent26cead648c6fa5b047caf9ff6badaffca17de97d (diff)
downloadtde-packaging-65a3fe0c81c103ee83cd326cf05a3b6ce18f2b4d.tar.gz
tde-packaging-65a3fe0c81c103ee83cd326cf05a3b6ce18f2b4d.zip
Fix tde-style-qtcurve on Debian and Ubuntu
Diffstat (limited to 'debian/lenny/applications/tde-style-qtcurve/debian/rules')
-rwxr-xr-xdebian/lenny/applications/tde-style-qtcurve/debian/rules128
1 files changed, 17 insertions, 111 deletions
diff --git a/debian/lenny/applications/tde-style-qtcurve/debian/rules b/debian/lenny/applications/tde-style-qtcurve/debian/rules
index 3d090390b..8041bcf1e 100755
--- a/debian/lenny/applications/tde-style-qtcurve/debian/rules
+++ b/debian/lenny/applications/tde-style-qtcurve/debian/rules
@@ -1,120 +1,26 @@
#!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/kde
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-
-cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
-
-# These are used for cross-compiling and for saving the configure script
-# from having to guess our platform (since we know it already)
-DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-
-
-CFLAGS = -Wall -g
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -O0
+# Set LD_LIBRARY_PATH to the installed library directory to allow dh_shlibdeps to function
+# Also include the main Trinity path
+ifeq ("$(LD_LIBRARY_PATH)", "")
+LD_LIBRARY_PATH=debian/tmp/opt/trinity/lib
else
- CFLAGS += -O2
-endif
-
-config.status: CMakeLists.txt config.h.cmake
- dh_testdir
- # Add here commands to configure the package.
-
-ifneq "$(wildcard /usr/share/misc/config.sub)" ""
- cp -f /usr/share/misc/config.sub config.sub
-endif
-ifneq "$(wildcard /usr/share/misc/config.guess)" ""
- cp -f /usr/share/misc/config.guess config.guess
+LD_LIBRARY_PATH += :debian/tmp/opt/trinity/lib
endif
- mkdir build
- cd build; env PATH=/opt/trinity/bin:$(PATH) CMAKE_LIBRARY_PATH=/opt/trinity/lib CMAKE_INCLUDE_PATH=/opt/trinity/include/kde cmake -DKDE3PREFIX=/opt/trinity ..
- touch config.status
-
-build: build-stamp
-
-build-stamp: config.status
- dh_testdir
-
- # Add here commands to compile the package.
- cd build; env PATH=/opt/trinity/bin:$(PATH) CMAKE_LIBRARY_PATH=/opt/trinity/lib CMAKE_INCLUDE_PATH=/opt/trinity/include/kde $(MAKE)
- #docbook-to-man debian/tde-style-qtcurve.sgml > tde-style-qtcurve.1
-
- touch $@
-
-clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp
-
- # Add here commands to clean up after the build process.
- rm -rf build
- rm -f config.sub config.guess
- rm -f config.status
-
- dh_clean
-
-install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
-
- # Add here commands to install the package into debian/tde-style-qtcurve-trinity.
- cd build; env PATH=/opt/trinity/bin:$(PATH) CMAKE_LIBRARY_PATH=/opt/trinity/lib CMAKE_INCLUDE_PATH=/opt/trinity/include/kde $(MAKE) DESTDIR=$(CURDIR)/debian/tde-style-qtcurve-trinity install
-
+export LD_LIBRARY_PATH
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+include /usr/share/cdbs/1/rules/simple-patchsys.mk
+include /usr/share/cdbs/1/rules/utils.mk
+include debian/cdbs/debian-qt-kde.mk
-# Build architecture-dependent files here.
-binary-arch: build install
- dh_testdir
- dh_testroot
- dh_installchangelogs ChangeLog
- dh_installdocs
- dh_installexamples
-# dh_install
-# dh_installmenu
-# dh_installdebconf
-# dh_installlogrotate
-# dh_installemacsen
-# dh_installpam
-# dh_installmime
-# dh_python
-# dh_installinit
-# dh_installcron
-# dh_installinfo
- dh_installman
- dh_link
- dh_strip
- dh_compress
- dh_fixperms
-# dh_perl
-# dh_makeshlibs
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
+DEB_KDE_APIDOX := yes
-get-orig-source:
- debian/scan-version get-orig-source
+CXXFLAGS := -DSMB_CTX_FLAG_USE_KERBEROS -DSMB_CTX_FLAG_FALLBACK_AFTER_KERBEROS -g -Wall $(DEB_OPT_FLAG)
+DEB_CMAKE_EXTRA_FLAGS := -DLIB_SUFFIX="" -DCMAKE_INSTALL_PREFIX="/opt/trinity" -DCONFIG_INSTALL_DIR="/etc/trinity" -DSYSCONF_INSTALL_DIR="/etc/trinity" -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" -DCMAKE_LIBRARY_PATH="/opt/trinity/lib" -DCMAKE_INCLUDE_PATH="/opt/trinity/include/" -DAUTODETECT_QT_DIRS="ON" -DCMAKE_VERBOSE_MAKEFILE="ON" -DBUILD_ALL="ON" -DCMAKE_SKIP_RPATH="OFF"
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install
+# Honour "parallel=N" option of DEB_BUILD_OPTIONS. Comment out to
+# never build in parallel, regardless of DEB_BUILD_OPTIONS.
+DEB_BUILD_PARALLEL = true \ No newline at end of file